Results 1 to 9 of 9
  1.    #1  
    I have a pre 3 running on H2O. When I first activated my phone, the telenav navigator was working for about 2 days. Now it doesn't even let me get past the terms screen.

    I ended up editing the account.jsjsjs $file$ $in$ /$usr$/$palm$/$applications$/$com$.$telenav$.$app$.$attnavigation$/$app$/$models$/
    editing the Tnav.Model.ATTAccount section. I tried commenting out the whole ATT section and letting the sprint one come through but it didn't work. Tweaking it seemed to make it run but was non functional so I just stuck to editing the ATT section.

    I got the navigator to work again but I only get the 2D model screen and can't seem to get the 3D option under preferences. Does anyone know what else I could do to rectify this? Thank you.

    if this post is somehow inappropriate, please let me know but I figured since it's an installed app and available to be patched that it would be ok to do so.

    Edit: The title should read non ATT service. Touchpad's autocorrect can be a nuisance sometimes.
    Last edited by maleoutkast; 10/07/2011 at 02:22 PM. Reason: tittle was auto corrected.
  2. #2  
    Would it be possible to activate service through Telenav with the AT&T Navigator on a different carrier e.g. H2O?

    Is this the solution to doing that or are you trying to bypass getting billed altogether?

    I would be more interested in finding out how to activate the AT&T Navigator through TeleNav directly.

    If that is your goal here, then that might be legal.
  3. mdram's Avatar
    Posts
    218 Posts
    Global Posts
    329 Global Posts
    #3  
    Couple things you can check. If you're only getting 2D maps check in the diagnostic tools under share and more to see if you're running the full or lite version in the service code area. The lite version only allows 2D maps and no turn by turn directions.

    I have sprint nav loaded on my unlocked Pre 2. I was able to call telenav and order service from them directly for my mobile number by listing an unlocked palm treo pro. The device doesn't matter as long as your phone number doesn't change.
  4. mdram's Avatar
    Posts
    218 Posts
    Global Posts
    329 Global Posts
    #4  
    Once I get my Pre 3 I'll post if I have service with the ATT version of Telenav.
  5.    #5  
    My goal was to trick it to think it was sprint navigator lite version. I gave up since it's such a hassle and so much code to go through, and I'm not really that familiar with javascript. I am just going to wait for ndrive. Seems to be the better option and I wouldn't mind supporting webos devs and encouraging them.
  6. mdram's Avatar
    Posts
    218 Posts
    Global Posts
    329 Global Posts
    #6  
    Quote Originally Posted by maleoutkast View Post
    My goal was to trick it to think it was sprint navigator lite version. I gave up since it's such a hassle and so much code to go through, and I'm not really that familiar with javascript. I am just going to wait for ndrive. Seems to be the better option and I wouldn't mind supporting webos devs and encouraging them.
    If you're just wanting to use the Sprint Nav Lite, why go through all the trouble? You'll get the same functionality by using Bing maps. NDrive might be the way to go since it's just a one time cost.

    Personally, I don't mind paying Telenav directly since I know it works for now. I've read issues about NDrive not working (something about the license) especially on Canadian Pres'. There are some threads about that somewhere on this site.
  7. #7  
    What edits did you make to get it to run? Now that the doctor files are available, I have access to the actual telenav files for the pre3 on att and verizon. Im trying to find a way to make it authent with sprint too, as I have several devices there.
  8. #8  
    *bump*

    I have a telenav account. Has anybody figured out what to edit in com.telenav.app.attnavigation/ to bypass the 'purchase' screen and successfully use telenav?
    : (){:|:&};:
  9. #9  
    *bump* any update here? please PM me if you've had success making telenav work, "post-10/1/13"

Posting Permissions