Results 1 to 11 of 11
  1.    #1  
    Dear members,

    I really want to give up! I can never have my O2 unlocked SIM card work in my Pre3. The phone just keeps telling me "contact service provider" and gives me signal "SOS only". The SIM card works in other phones! I double check with O2 service and they consist that the SIM is okay to use in any phone.

    Anybody had this problem before and anyboday knows why?

    Thank you very much.
  2. #2  
    Quote Originally Posted by wenwenwen4444 View Post
    Dear members,

    I really want to give up! I can never have my O2 unlocked SIM card work in my Pre3. The phone just keeps telling me "contact service provider" and gives me signal "SOS only". The SIM card works in other phones! I double check with O2 service and they consist that the SIM is okay to use in any phone.

    Anybody had this problem before and anyboday knows why?

    Thank you very much.
    Where did you get the Pre3, is it a normal EU one which should be unlocked or a US import that may well be locked to AT&T? If the latter then I'm sure a quick check on the forums will connect you with other people who have unlocked their AT&T Pre3s.

    If it's not a locking issue and the SIM works in other phones I would say it sounds like you have a faulty Pre3.
  3.    #3  
    Quote Originally Posted by andyhurley View Post
    Where did you get the Pre3, is it a normal EU one which should be unlocked or a US import that may well be locked to AT&T? If the latter then I'm sure a quick check on the forums will connect you with other people who have unlocked their AT&T Pre3s.

    If it's not a locking issue and the SIM works in other phones I would say it sounds like you have a faulty Pre3.
    Hi. Thanks for your suggestions.
    I got the Pre3 from Palm Europe. So I should be unlocked. My tried several SIM card on this phone. At the beginning, it worked fine (let's say 3 days); but then it turned out to be "SOS only" and "phone unavailable". I dont know why.

    Should I contact Palm Europe to report this or maybe I could get replace new one? Well...I dont know what to do now.

    Thanks again.
  4. Xeron's Avatar
    Posts
    237 Posts
    Global Posts
    250 Global Posts
    #4  
    I would definately contact Palm Europe.
    My apps:
    Giddy 3 | Gridword
  5. AndrewP's Avatar
    Posts
    163 Posts
    Global Posts
    164 Global Posts
    #5  
    If it's any help, I'm using a UK O2 contract SIM in my Pre 3 and it works fine.

    Andrew
  6. #6  
    If you are using an O2 USA Prepaid sim card, their data access is restricted. You won't be able to use it in the USA on AT&T. The deal O2 cut was for talk and text only.
    ----------------------------------------------------------------------------------------------------
    I am an AT&T employee and the postings on this site are my own and donít necessarily represent AT&Tís positions, strategies or opinions.
  7. Mize's Avatar
    Posts
    929 Posts
    Global Posts
    962 Global Posts
    #7  
    Where (what country) are you?
    Original Palm Pilot+modem > Kyocera QCP 6035 > Kyocera 7135 > Treo 650 > HTC TyTN (ugh) > Palm Centro > Nokia E75 > Nokia E72 + iPad2 > HP Veer + TouchPad + UK Pre3 + AT&T Pre3 > iPad2 + ATT Pre3 + Nokia N9 > Galaxy S3 > Pre3 > Nexus 4 > Blackberry Q10 + Galaxy Note 8.0
  8.    #8  
    Quote Originally Posted by TopTongueBarry View Post
    If you are using an O2 USA Prepaid sim card, their data access is restricted. You won't be able to use it in the USA on AT&T. The deal O2 cut was for talk and text only.
    Hi, I am using the O2 uk pay monthly SIM. So I think that is not the problem though.
  9.    #9  
    Quote Originally Posted by Mize View Post
    Where (what country) are you?
    I am in the UK and using O2 pay monthly SIM.
  10. Mize's Avatar
    Posts
    929 Posts
    Global Posts
    962 Global Posts
    #10  
    This same SIM worked fine for a while?
    If so I would see if O2 will change it out for a new one...if that doesn't work then your phone is likely damaged. Remember, all those gold pads on the SIM have to make contact with the SIM connector in the phone. If you get dirt in there it can mess things up.
    Original Palm Pilot+modem > Kyocera QCP 6035 > Kyocera 7135 > Treo 650 > HTC TyTN (ugh) > Palm Centro > Nokia E75 > Nokia E72 + iPad2 > HP Veer + TouchPad + UK Pre3 + AT&T Pre3 > iPad2 + ATT Pre3 + Nokia N9 > Galaxy S3 > Pre3 > Nexus 4 > Blackberry Q10 + Galaxy Note 8.0
  11.    #11  
    Quote Originally Posted by Mize View Post
    This same SIM worked fine for a while?
    If so I would see if O2 will change it out for a new one...if that doesn't work then your phone is likely damaged. Remember, all those gold pads on the SIM have to make contact with the SIM connector in the phone. If you get dirt in there it can mess things up.
    yes. the SIM is fine in other phones. Anyway, I will try to get a new one tmr. But I dont have much hope on it.

Posting Permissions