Results 1 to 8 of 8
  1.    #1  
    Hi,

    Today i moved to a new carrier in Spain (mundo-R). Sadly, this carrier doesn't seem to recognize ussd codes to query the status of certain phone settings.

    Every 30 minutes or so, my phone tries to query the status of Caller ID, Divert calls and Call waiting.

    As far as I know, this is due to phone settings, which is (obviously) trying to query the status of those settings to be able to tell me whether those settings are on or off.

    I'm not sure if I can convince this carrier to handle or enable those USSD codes, but until then, I'm getting a bit stressed when my phone app wakes just to dial a non valid USSD code and say "can't connect to *#31#, Retry/OK". It doesn't matter if i'm in the middle of a call, or using another app, it just tries to dial and get the error.

    So, is there an option to force my Pre3 not to dial those USSD codes? a fake answer, or just disabling the automatic dial would work.

    I like my HP Pre3, but right now i have 2 options... change once more to Vodafone carrier, or sell my new Pre3 and keep my old N900.

    Thanks in advance.
  2.    #2  
    After doing some research, going to a store of my carrier and explaining my problem to them, i found out that mundo-R does recognize and use all ussd codes.

    We tried with some nokia (S40) phones and dialing *#21# with my SIM card displayed the "divert calls not active" message. But, dialing with the Pre3 gave an error.

    Trying with other spanish carriers (Movistar, Orange and Vodafone) Pre3 works perfectly.

    Is there any problem with virtual carriers? (that is, a carrier which doesn't own a network and hires it to a big carrier)

    Has anyone found the same problem with virtual carriers?

    Does the Pre, Pre2, Pixi or Veer have the same problem?
  3. pretoo's Avatar
    Posts
    85 Posts
    Global Posts
    92 Global Posts
    #3  
    Quote Originally Posted by jgvaldecasas View Post
    After doing some research, going to a store of my carrier and explaining my problem to them, i found out that mundo-R does recognize and use all ussd codes.

    We tried with some nokia (S40) phones and dialing *#21# with my SIM card displayed the "divert calls not active" message. But, dialing with the Pre3 gave an error.

    Trying with other spanish carriers (Movistar, Orange and Vodafone) Pre3 works perfectly.

    Is there any problem with virtual carriers? (that is, a carrier which doesn't own a network and hires it to a big carrier)

    Has anyone found the same problem with virtual carriers?

    Does the Pre, Pre2, Pixi or Veer have the same problem?
    Hi,

    I was using (for a brief moment - used to activate my Pre-)Play carrier in Poland.
    It is also a virtual carrier (based on Plus GSM infrastructure).
    I have not noticed any problems.
    But it was on Pre-.

    Now I'm using Orange and all (excepr MMS)works just fine.

    Sorry I couldn't help.

    -pretoo-
  4.    #4  
    Thanks Pretoo.

    Orange should work OK. At least in Spain it does, as I've tested it. Also during 3 days I used my Pre3 with Vodafone, and worked flawlessly.

    Did you try to enter to Phone Settings in your Pre-? Maybe it's a bug with WebOS 2.2

    I can't understand why USSD codes can work with some phones and not with others, using all of them the same carrier.
  5.    #5  
    the post was duplicated... editing and removing duplicated post. Sorry
    Last edited by jgvaldecasas; 10/07/2011 at 04:55 AM. Reason: duplicated post.
  6. pretoo's Avatar
    Posts
    85 Posts
    Global Posts
    92 Global Posts
    #6  
    When I was on Pre- (Play - virtual carrier)I did nothing and everything was fine.
    I didn't check MMS becouse I've use virtual carrier just to activate it (no manual internet seetings needed), then I switch to Orange where i had to do manual input of internet setting. It worked.
    Second time (after doctoring my Pre-)I've activated it with Orange (manual settings on failed connection).

    Now I'm on Pre3 [Orange].
    No USSD codes error.
    I used Impostash to activate my Pre3 so I didn't use virtual carrier SIM.
    I can't tell is there a bug in webOS 2.2 since I don't use VC SIM.

    Hope someone could help you with this since I can't.

    My only concern related to Phone app/carrier is to force MMS to work.

    PS

    Did you tried to turn Restricted Dialling on (PUK2 needed in my case) and add USSD to Restricted Dialling List?

    -pretoo-

    PS2

    Have you experienced a issue with MMS when using Orange (didn't send, didn't recieve)?

    -p-
  7.    #7  
    Pretoo,

    I haven't tried to add those USSD codes to restricted dialling list. Might be a workaround.

    I haven't tried MMS. I think that i've sent just 5 or 6 MMS in my life... and not since i can send mails (nearly everyone i would send an MMS has internet on their smartphones, so it's cheaper to send a mail than a MMS).
  8.    #8  
    Yesterday i had the chance to test the Pre3 with another virtual carrier, Simyo, and it worked perfectly. So it seems to be a problem with Pre3 and my carrier, maybe also other virtual carriers, but not with all of them.

    Is anyone interested in an AZERTY european Pre3?

Posting Permissions