Results 1 to 15 of 15
Like Tree1Likes
  • 1 Post By checkmate
  1.    #1  
    Anyone have issues with not getting Captive Portal notifications? I can't log in to my free wife hotspots as they require authentication. I've removed all my patches but no luck. I'm on webOS v2.2. Any help would be appreciated.

    -- Sent from my Palm Pre3 using Forums
  2. #2  
    Actually just tried it a couple of hours ago, and it just popped up. First time I saw that feature, as I came from a Pre-.
  3. #3  
    Did you try just opening a web page? Most captive portals will show you the sign in at that point.
  4. #4  
    Quote Originally Posted by davidra View Post
    Did you try just opening a web page? Most captive portals will show you the sign in at that point.
    That doesn't seem to work on the pre3, at least in my experience. And you can't be cunning and try and connect to the wifi DNS server, because the browser decides to use your 3G connection, so it instead looks for, whatever, 192.168.0.* on the whole internet, not inside the wlan.

    I've only had the problem once: I was faffing around on the captive portal of a BTOpenzone, and it evidently decided to recognise my phone, without giving me internet access, so the portal notification stopped turning up. I found it worked again after a day or so.

    But yeah it would be great to have an 'open local captive portal' option, rather than relying on the notification coming up.
  5.    #5  
    Quote Originally Posted by davidra View Post
    Did you try just opening a web page? Most captive portals will show you the sign in at that point.
    No can't even log in cos it won't get into the log in page
  6.    #6  
    Quote Originally Posted by jester3397 View Post
    Actually just tried it a couple of hours ago, and it just popped up. First time I saw that feature, as I came from a Pre-.
    Did u turn on wifi? Or did it pop up on it's own?
  7. BBooDad's Avatar
    Posts
    406 Posts
    Global Posts
    541 Global Posts
    #7  
    Could be worse - on my Pre2 last night, despite being connected to our home wifi, the bloody thing kept buzzing me that there was a captive portal available (our guest wifi portal). I finally turned off wifi because of it.
  8. #8  
    Quote Originally Posted by BBooDoc View Post
    Could be worse - on my Pre2 last night, despite being connected to our home wifi, the bloody thing kept buzzing me that there was a captive portal available (our guest wifi portal). I finally turned off wifi because of it.
    Mine too. I was at my campus and it kept popping up but when I click on it, it takes me to the Palm homepage and then says "connected" but it actually isn't because I need to enter my user id and password. Annoying!
    The Original Owner of the AT&T Pre3
  9. #9  
    Quote Originally Posted by BBooDoc View Post
    Could be worse - on my Pre2 last night, despite being connected to our home wifi, the bloody thing kept buzzing me that there was a captive portal available (our guest wifi portal). I finally turned off wifi because of it.
    Yeah, I get this a lot. It doesn't seem to have a way to prioritize connections and will randomly connect to, e.g. BTFON even when it has a password for the local hub.

    The same used to happen with 2.1 hacked onto my Pre- so it's not a new problem.
  10. #10  
    Quote Originally Posted by ajedi72 View Post
    Anyone have issues with not getting Captive Portal notifications? I can't log in to my free wife hotspots as they require authentication. I've removed all my patches but no luck. I'm on webOS v2.2. Any help would be appreciated.
    Works fine for me been using my Pre3 off and on at my company which has captive portal and it picks it up every time. Only issue is I think I can't dismiss the notification, I tried once yesterday and it came right back up. Didn't bother to try a 2nd time.

    I'm not sure how it would detect whether or not there is a captive portal. If you try to access a web page shouldn't the wifi infrastructure the location has automatically redirect you to a web page to authenticate ? I've logged on to lots of wifi hotspots mainly in hotels over the years without devices that have any explicit support for "captive portals" and never had an issue.
  11. #11  
    I can't get the notification neither, I don't know why.
    It worked fine, but now it just doesn't work. I have been waiting for 2 days to see if it will appear or not...
  12. #12  
    try turning the wifi off, then back on as that seems to help me. otherwise you may want to do a restart.
  13. #13  
    I can't log in to my free wife hotspots
    Wow, I'd love to visit one of these hotspots and bag me a free wife!

    I randomly get the captive portal notification at home, maybe once every 2 months. Why on earth does it suddenly crop up for no reason?
    HP Pre 3 (UK)
    fxspec06 likes this.
  14. #14  
    Quote Originally Posted by checkmate View Post
    I randomly get the captive portal notification at home, maybe once every 2 months. Why on earth does it suddenly crop up for no reason?
    Now I have this problem with my guest wifi.
    Had the same wifi for almost a year & now it suddenly became a "Captive Portal" that makes my phone door bell all the time.

    Very annoying
  15. #15  
    There is a patch in Preware that prevents the captive portal notification.

    -- Sent from my Palm Pre3 using Forums
    PDA Lineage: Palm Pilot, Palm V, Palm Tungsten, Treo 650 (Cingular), Treo 750 (AT&T), Treo Pro GSM (unlocked), Pre Plus (AT&T), Pre 2 GSM (unlocked), Pre 3 16GB (AT&T Branded) and Touchpad 32 GB

Posting Permissions