Page 2 of 2 FirstFirst 12
Results 21 to 29 of 29
Like Tree5Likes
  1. ijip's Avatar
    Posts
    885 Posts
    Global Posts
    960 Global Posts
    #21  
    the latest for phones, but may not support enyo.... =(
  2. #22  
    Quote Originally Posted by EvilKell View Post
    webOS 1.4.5 = Mojo 1.0 SDK = Pre/Pixi/Pre+/Pixi+
    webOS 2.1/2.2 = Mojo 2.0 SDK = Pre 2, Veer & Pre3
    webOS 3.0 = Enyo SDK = TouchPad, Pre 2, Veer & Pre3

    No webOS 1.x device will EVER run a webOS 2.x or webOS 3.x application, regardless of the development environment the application was coded in (Mojo or Enyo). They are entirely incompatible. That's step one.

    The webOS 2.0 Mojo based SDK can be used to code for phones or the TouchPad, though the TouchPad will run the applications in emulator mode only.

    There are no Enyo SDKs available for phones. Period. However, Palm's developer page indicates the webOS 3.0 Enyo based SDK should be used with the emulator image from webOS 2.1.

    https://developer.palm.com/content/a...3.0.0-643.html



    The main problem I'm seeing is that I don't know if webOS 2.x devices can handle Enyo coded apps, but you would certainly think they should... Who knows though. It's a huge problem that HP is not making things clear.
    They definitely can, and to think not would be ignorance.

    I have enyo on my Pre 2, and it runs great. Scrolling does not work, but enyo itself runs great.
    Neo Enyo 2.0 Twitter App: NOW AVAILABLE | WON REVIEW
    clearview - clear card app for HP TOUCHPAD
    Wild'n Video Poker - AVAILABLE FOR ALL WEBOS DEVICES! | follow for latest updates - @fxspec06

  3. Targon's Avatar
    Posts
    502 Posts
    Global Posts
    716 Global Posts
    #23  
    Quote Originally Posted by YankBoy View Post
    Wow, so after reading all the responses, I'm more confused than I was at the start. So will the Pre3 release with the latest version of WebOS or not?
    The exact version of WebOS isn't the issue. At release, the Pre 3 will come with the latest version of WebOS 2.x, and the Touchpad has WebOS 3.x. Just because the version numbers are different between phones and tablets does not mean that one is "newer" than the other, both are being developed at the same time, with a convergence at some point in the future.

    Think about it like Microsoft Windows, you had the Windows 95/98/98SE/ME line, and then you had the Windows NT/2000 lines. Windows XP brought the two different lines together, so both consumers and corporations would run the same OS with different features. For WebOS, we have 2.x for phones, and 3.x for tablets.

    The confusion comes from what "framework" the Pre 3 will support at launch, since that would affect if the same apps would run on both, or if we need two different versions, one for phones and the other for tablets. That is the whole Mojo/Enyo discussion, and that is more a technical discussion for those who actually care about such things.
  4.    #24  
    Quote Originally Posted by Targon View Post
    The exact version of WebOS isn't the issue. At release, the Pre 3 will come with the latest version of WebOS 2.x, and the Touchpad has WebOS 3.x. Just because the version numbers are different between phones and tablets does not mean that one is "newer" than the other, both are being developed at the same time, with a convergence at some point in the future.

    Think about it like Microsoft Windows, you had the Windows 95/98/98SE/ME line, and then you had the Windows NT/2000 lines. Windows XP brought the two different lines together, so both consumers and corporations would run the same OS with different features. For WebOS, we have 2.x for phones, and 3.x for tablets.

    The confusion comes from what "framework" the Pre 3 will support at launch, since that would affect if the same apps would run on both, or if we need two different versions, one for phones and the other for tablets. That is the whole Mojo/Enyo discussion, and that is more a technical discussion for those who actually care about such things.
    I just don't want to buy a Pre 3 and be looking over at a TP and seeing all the apps/functionality it has that my Pre 3 doesn't.
  5. Targon's Avatar
    Posts
    502 Posts
    Global Posts
    716 Global Posts
    #25  
    Quote Originally Posted by YankBoy View Post
    I just don't want to buy a Pre 3 and be looking over at a TP and seeing all the apps/functionality it has that my Pre 3 doesn't.
    That is SUPPOSED to be a part of Enyo being on the Pre 3. Right now, there is no release dates officially announced, and HP isn't even talking about the Pre 3...it's like the people working on that project all dropped dead and HP not wanting to say anything.
  6. #26  
    Quote Originally Posted by Targon View Post
    ...it's like the people working on that project all dropped dead and HP not wanting to say anything.
    Soviet-style transparency.
  7. #27  
    Quote Originally Posted by YankBoy View Post
    I just don't want to buy a Pre 3 and be looking over at a TP and seeing all the apps/functionality it has that my Pre 3 doesn't.
    Like what exactly? What kind of apps / functionality are you missing on the Pre 2 right now? I'd love to know. Because from what I understand, from a developer standpoint, the missing apps and functionality is because of a small circle of developers trying to fill holes by themselves. The framework is great, but without developers, it doesn't mean crap.
    Neo Enyo 2.0 Twitter App: NOW AVAILABLE | WON REVIEW
    clearview - clear card app for HP TOUCHPAD
    Wild'n Video Poker - AVAILABLE FOR ALL WEBOS DEVICES! | follow for latest updates - @fxspec06

  8. #28  
    Hi all,

    MY Answer is YES, but NOT for the reasons that you may think.....all software, (apps) and hardware truly is outdated the minute you open the package!

    take care,

    Jay
    Please Support Research into Fibromyalgia, Chronic Pain and Spinal Injuries. If You Suffer from These, Consider Joining or Better Yet Forming a Support Group. No One Should Suffer from the Burden of Chronic Pain, Jay M. S. Founder, Leesburg Fibromyalgia/Resources Group
  9. Targon's Avatar
    Posts
    502 Posts
    Global Posts
    716 Global Posts
    #29  
    Quote Originally Posted by fxspec06 View Post
    Like what exactly? What kind of apps / functionality are you missing on the Pre 2 right now? I'd love to know. Because from what I understand, from a developer standpoint, the missing apps and functionality is because of a small circle of developers trying to fill holes by themselves. The framework is great, but without developers, it doesn't mean crap.
    I think the concern is that if 3.0 is what all developers will program for from now on, then a phone that comes with 1.x or 2.x won't get new software versions.
Page 2 of 2 FirstFirst 12

Posting Permissions