Results 1 to 17 of 17
  1. redmist's Avatar
    Posts
    674 Posts
    Global Posts
    679 Global Posts
       #1  
    Or do they all have to be re-written?
  2. #2  
    they will work
  3. #3  
    This isn't android we're talking about here.
  4. #4  
    Why wouldn't they? Maybe some developers who thought the 480x320 screen dimensions will stay forever will have problems with their apps not scaling properly, but nevertheless most apps should still work. They are written using Javascript+HTML+CSS after all...
  5. #5  
    I believe that one of the genius points of webOS simple scalability. I don't know exactly how it works, but I thought mojo sdk was supposed to scale automatically
  6. redmist's Avatar
    Posts
    674 Posts
    Global Posts
    679 Global Posts
       #6  
    Well the reason I ask is because I see people saying the hardware is finished but they are still waiting for Enyo to be finished as the platform will fail without apps.

    Maybe I'm confused. Why dont they just release the Pre3 now?

    -- Sent from my Palm Pre using Forums
    Pilot 5000 > Pre > Pre2 > Pre3 > Galaxy Nexus
    TouchPad > Galaxy Tab 8.9
  7. #7  
    i have a pixi and i have boughed apps for around 50 euro. What will happen to them if i upgrade to a pre3? I dont believe i can take them with me (or could amy upgrader use his pixi apps on a pre plus?)
  8. #8  
    Quote Originally Posted by DirkGently View Post
    i have a pixi and i have boughed apps for around 50 euro. What will happen to them if i upgrade to a pre3? I dont believe i can take them with me (or could amy upgrader use his pixi apps on a pre plus?)
    your purchased apps should work fine on a Pre3.
  9. #9  
    Quote Originally Posted by DirkGently View Post
    i have a pixi and i have boughed apps for around 50 euro. What will happen to them if i upgrade to a pre3? I dont believe i can take them with me (or could amy upgrader use his pixi apps on a pre plus?)
    You have to understand that the apps you buy aren't actually associated with your device, but with your profile. So no matter what you do with your phone, your apps are safe. There might be some problems with Pixi-specific apps you may have, but things should generally just work. Get your Pre 3, plop in your profile information, and watch as everything syncs back to you
  10. #10  
    Quote Originally Posted by GodShapedHole View Post
    You have to understand that the apps you buy aren't actually associated with your device, but with your profile. So no matter what you do with your phone, your apps are safe. There might be some problems with Pixi-specific apps you may have, but things should generally just work. Get your Pre 3, plop in your profile information, and watch as everything syncs back to you
    One single great feature with Palm/HP phones.
  11. #11  
    I think they're thinking Pixi users will go the way of the Veer, and Pre users towards the Pre3. Which will help with Pixi apps being ported easier. But I think there'll be some problems with the apps scaling to different resolutions at first, but either Palm/HP will fix these problems or the developers will have to update them manually.
  12. #12  
    Quote Originally Posted by RedMist View Post
    Well the reason I ask is because I see people saying the hardware is finished but they are still waiting for Enyo to be finished as the platform will fail without apps.

    Maybe I'm confused. Why dont they just release the Pre3 now?

    -- Sent from my Palm Pre using Forums
    Uhm, you confused the Pre 3 with the TouchPad. The Pre 3 is still not finished and fully optimized and that's why the Veer was faster and some apps didn't show properly. In the other hand, the TouchPad is at least in hardware terms* finished, but the lack of apps and optimization is making the delay to June.
  13. #13  
    They will work the same as ever on the Pre3 because it runs 2.x. Once it is upgraded to 3.0 it will run exactly the same but behind the scenes there will be a mojo emulator that will be taking care of running it. Just to clarify, it will not be in a emulator and will run as a normal app would. Just the new Enyo framework will include a Mojo engine to run it.
    "Life is Hard... it's harder if your stupid"
    - John Wayne
  14. #14  
    The only Problem is that some APIs have changed, some 1.4.5 apps wont run without problems on 2.X (Calender access, MusicDB etc)
  15. #15  
    A better question is what will happen to those 1.4.5 Palm profiles of Pixi and Pre users?
  16. #16  
    Quote Originally Posted by Sonic-NKT View Post
    The only Problem is that some APIs have changed, some 1.4.5 apps wont run without problems on 2.X (Calender access, MusicDB etc)
    Sense it will be an underlying emulator, it is possible to reroute the API calls to those of the newer framework. There will be no purpose of what they are doing if it is going to be like the Classic emulator.
    "Life is Hard... it's harder if your stupid"
    - John Wayne
  17. mosdl's Avatar
    Posts
    781 Posts
    Global Posts
    787 Global Posts
    #17  
    One of my app logs shows what looks like a Pre3, so they are testing webos apps on it
    Apps: MyQ for Netflix (Phone/TouchPad), Giantbomb (Phone), Excavate (Reddit/Digg clients for TouchPad)

Posting Permissions