webOS Nation Forums >  webOS Developer Forums >  gregstoll.com > Gauth - can't make it work :-(
Gauth - can't make it work :-(
  Reply
 
Thread Tools Display Modes
Old 05/04/2011, 05:26 AM   #1 (permalink)
Member
 
Posts: 69
Hi; I've just tried setting up 2-factor auth with GAuth, but at the "verify" step I always get told "The code is incorrect. Try again."

This is a Palm Pre, GSM version, WebOS 1.4.5, on O2 in the UK.
It's a google apps domain.

Any ideas?!
Thanks
swaldman is offline   Reply With Quote
Old 05/04/2011, 11:04 AM   #2 (permalink)
Member
 
gregstoll's Avatar
 
Posts: 108
Hmm - are you using version 1.0.2 of GAuth? 1.0.1 and earlier has a serious bug that caused about half of all results to be wrong.

If you are using 1.0.2, I'll try to look into this. I haven't tried it for a google apps domain so it's possible the algorithm is different...
__________________
My apps: FlightPredictor, LJ for WebOS (LiveJournal client), We the People, Private Browser, GAuth (Google two-factor authenticator), BoardGameGeek, PasswordHash
gregstoll is offline   Reply With Quote
Old 05/04/2011, 11:25 AM   #3 (permalink)
Member
 
Posts: 69
1.0.2 I'm afraid.
Re making sure the time is right - I should double-check what time zone gmail is set to... only I can't find where to do that...?!
swaldman is offline   Reply With Quote
Old 05/09/2011, 03:21 PM   #4 (permalink)
Member
 
Posts: 31
I was just unable to enter the right code briefly, after successfully doing so several days ago. Google help suggested I make sure the time on my device was the same as on my computer. Sure enough, today my Palm has drifted about six minutes into the future and after syncing it back to our time, everything was working again.

So swaldman, if you haven't solved this already, maybe you could try temporarily setting the clock on your Pre to show the time that's on your computer. Or you're saying you did that already? I haven't fiddled with any time zone settings, though I know I have them setup correctly for Google Calendar. Can't find where you could setup time zone for your Google Account.

Greg, thanks a lot for this app!
__________________
Want to get the best Android Apps on your webOS device? Tell HP we need OpenMobile ACL!
Sign the petition today at http://www.ipetitions.com/petition/a...apps-on-webos/
domicius is offline   Reply With Quote
Old 05/09/2011, 05:10 PM   #5 (permalink)
Member
 
gregstoll's Avatar
 
Posts: 108
Thanks domicius! Maybe I should add a description of time sync problem in the app somehow...
__________________
My apps: FlightPredictor, LJ for WebOS (LiveJournal client), We the People, Private Browser, GAuth (Google two-factor authenticator), BoardGameGeek, PasswordHash
gregstoll is offline   Reply With Quote
Old 05/10/2011, 02:16 PM   #6 (permalink)
Member
 
Posts: 69
Just tried tweaking the time back and forward a minute or two, to no avail.

Frankly, this wouldn't be a workable solution anyway - the Pre's clock drifts very badly, so if it was necessary to turn off network time setting I'd need to correct the time every day!

I think, for now, I give up on 2-factor auth.
But thank you for the app, and for the effort.
swaldman is offline   Reply With Quote
Old 05/10/2011, 04:01 PM   #7 (permalink)
Member
 
gregstoll's Avatar
 
Posts: 108
Sorry for the trouble :-(

Unfortunately, the need to have the time the same on the phone as the server is really a key to the whole two-factor scheme, which leads to problems like this...
__________________
My apps: FlightPredictor, LJ for WebOS (LiveJournal client), We the People, Private Browser, GAuth (Google two-factor authenticator), BoardGameGeek, PasswordHash
gregstoll is offline   Reply With Quote
Old 05/10/2011, 05:51 PM   #8 (permalink)
Member
 
Posts: 69
Quote:
Originally Posted by gregstoll View Post
Sorry for the trouble :-(

Ach, not your fault! :-)
THanks again.
swaldman is offline   Reply With Quote
Old 11/06/2011, 11:43 AM   #9 (permalink)
Member
 
Posts: 6
I'm having this exact same problem with GAuth 1.1.0. The server will just tell me the code is wrong, and give me a tip: "codes are time-dependent, blah blah".

I'm in Sweden, on a pre2 (webos version 2.1.0).

Could this be a problem with DST or something?
frost is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0