I dont' know if you can answer these questions
or not, but I figured you could direct me where to find the answers if you can't

1.The thing I don't like about the 300 is the browser (Blazer 2.0) won't allow you to view pages like the regular Yahoo. It says because you can't view Java Script. Can you suggest anything I can do to remedy this situation?

2. Can I upgrade the Palm 3.5 to anything higher? If so how high can I go?

3. Can I beam directly from a palm software download site to my Treo? I have Verichat and when an update comes thru it beams it directly. Is
there a site that will allow me to beam software directly when I locate it online?

Thanks.