I bought an unbranded Treo 600 and inserted my sim in to it using the local Suncom affiliate. As expected it works fine as a phone but data needs some more settings to work. Has anyone successfully set up data on this or a similar network? I found this post on pdaphonehome.com's forums and replied to it but got no reponse.

I'd like to get data working but don't know how. I used these setting and it tried to connect but I get this error:

Service Connection Progress:
Error: GPRS
connection not available. check
your settings in network preferences
and/or try again later.
(0x7143)


I've setup the info as described below. Anyone have suggestions?

-Steve

*********************************************************
Post from other board
*********************************************************
Hey, happy to read all of your comments

I just bought my treo from handspring and plugged in my Suncom sim. The phone works great, I love it.

I called up suncom and got the connect info:
ip: 066.150.237.195
APN: mobileinternet
connection: GPRS
username: none
Password: none

The phone will get a connection (the two green arrows next to the tower icon) however the browser can't load a web page (even google and yahoo and suncom).

The browser will only give me a "sending" message then an error message stating:"the page download could not be completed...".
So I called up suncom and handspring and several soft resets and a few hard resets later I'm still where I started.

Out of frustration I took my brothers' T-mobile card and plugged it in there and out pops a preset connection that works flawlessly. I then tried buying into a independant ISP dial-up and tried connecting via ISDN. Alas! suncom does not support ISDN yet (they're working on it). SO I tried ising the "wireless dial-up" function and that also did not work.

I referred all this to Handspring and their solution was to send me a new phone. However, I don't beleive that'll solve the problem and its on its way. In the mean time... has anyone successfully set up a suncom GPRS connection on the treo 600? Or any other treo for that matter?