I neeeeed it !!!
I updated yet my firmware by the beta release 1.07, but my phone still crash when speaking or dialing !!

I need 1.08 or superior, when will be finally available ???

Hs are crazy ! T600 does not work at all with a specifical kind of SIM and they KNOW IT VERY WELL !!!!