Results 1 to 4 of 4
  1. grabbit97's Avatar
    Posts
    19 Posts
    Global Posts
    22 Global Posts
       #1  
    HELLO
    I have a problem with my TREO 90 which I have had for just 2 days... going to call Handspring in the AM.
    I used it and all of a sudden the screen BACKLIT went OFF, and I cant' turn it on... have no idea what happened..
    Tried a HARD RESET and SOFT RESET.. nothing...
    anyone else have this PROBLEM.. please advise.
    Thanks
    GRABBIT
  2. #2  
    Sounds like you've fallen victim of the backlight failure HS identified awhile back. Give them a call and they will replace it for you.

    http://support.handspring.com/esuppo...sType=RESEARCH
    T750 w/Cingular
    Black Jawbone
  3. grabbit97's Avatar
    Posts
    19 Posts
    Global Posts
    22 Global Posts
       #3  
    I am planning on calling them in the MORNING.. hope that they will replace it.. it's maddening to have this happen after having the thing for 2 days. GRRRRRRRRR
    Anyone else you know had this problem?
    Thanks
    Grabbit
  4. #4  
    There were a number of these and 270's that were failing several months ago. If you search the forum you'll find lots of threads that indicate this issue. I'm suprised to hear that it's still happening though! I just talked to someone else on friday who's 270's backlight just failed as well!

    http://discussion.treocentral.com/tc...klight+failure


    They will replace it for you without question. I know it's frustrating to have something like this occur right after you bought it!
    Last edited by millerhifi; 03/30/2003 at 11:16 PM.
    T750 w/Cingular
    Black Jawbone

Posting Permissions