Results 1 to 6 of 6
  1.    #1  
    Hello,

    if your treo doesn't transmit your Caller ID, enter these Codes into the dialing screen and make the call:

    #31# : Activates the transmission of your ID
    *31# : Deactivates the transmission of your Caller ID

    I verified this with a treo 270 and T-Mobile (T-D1) in Germany. I've got no idea if this works with other GSM-Providers too, but it's worth a try...

    CU

    voidhawk
  2. #2  
    Hey voidhawk. That's good info. I believe that if a GSM network supports codes such as the ones found on this page (http://home.swipnet.se/OsbyMikro/gsmkode.htm ), the codes are universal, i.e. they're applicable to all GSM networks that accept 'em. Hmm, I don't know if there are any GSM networks that don't accept the codes; taking a random guess, I'd posit that those codes would be in the spec for the network, but what do I know. (answer = absolutely nothing beyond wild speculation)

    I also found this on the Handspring website:
    http://support.handspring.com/esuppo...sType=RESEARCH. These are the same codes that do the same things, so I'm assuming that GSM codes are universal.

    But I could be wrong.

    Wireless telephony is, like, TOTALLY cool, dude. Wish I knew more about it.
  3. #3  
    There's an easier way (well, one that doesn't involve codes, anyway).

    In the phone app, go to the options menu, then the "Call Preferences." There will be a checkbox to block outgoing caller ID.
  4.    #4  
    Hi,

    in Preferences you can block CLID, but I disabled blocking and it still wasn't being transmitted. So I used the code. Works fine

    @KRamsauer: thanks for the link, it looks pretty complete
  5. #5  
    Quote Originally Posted by KRamsauer
    There's an easier way (well, one that doesn't involve codes, anyway).

    In the phone app, go to the options menu, then the "Call Preferences." There will be a checkbox to block outgoing caller ID.
    You can block outgoing caller ID if you are on your native network for the GSM Treo 600, but if you are "roaming" the blocking does not work. I have a Cingular GSM (replacement from Palm for a broken ATT 600 sent for repairs). While on ATT's network, the outgoing call blocking by Call Preference is fine, but if I roam onto, say, Cingular's network it starts revealing my phone number. Any method to correct this short of entering some code request before any individual call? Jim R.
  6. #6  
    Quote Originally Posted by voidhawk
    Hello,

    if your treo doesn't transmit your Caller ID, enter these Codes into the dialing screen and make the call:

    #31# : Activates the transmission of your ID
    *31# : Deactivates the transmission of your Caller ID

    I verified this with a treo 270 and T-Mobile (T-D1) in Germany. I've got no idea if this works with other GSM-Providers too, but it's worth a try...

    CU

    voidhawk
    I think that you make a mistake:

    *31# : Activates the transmission of your ID
    #31# : Deactivates the transmission of your Caller ID

Posting Permissions