Page 2 of 2 FirstFirst 12
Results 21 to 25 of 25
  1.    #21  
    I am supposed to receive a call from a HS product control specialist today. Of course, I'll report what he/she tells me.
  2. #22  
    I agree with you Trey. I have a replacement unit and will be putting it through its paces to see if I have the echo problem on this one as I did on the last. If so it is going back. I will just buy a Voicestream phone and use Ureach.com to get my emails read to me untill their is a product out their with the form and function of the Treo but with out the problems.

    Will keep all posted. This is a very big issue for users and for HS.
  3. #23  
    I just want to reiterate, not everyone is having this "echo" problem.

    I'm not, anyway, and I exclusively use the built-in speaker and not the earpiece. I'm not sure that it IS a "very big issue", sounds like a couple of isolated problems so far, a few defective units.

    Originally posted by murphysj
    I agree with you Trey. I have a replacement unit and will be putting it through its paces to see if I have the echo problem on this one as I did on the last. If so it is going back. I will just buy a Voicestream phone and use Ureach.com to get my emails read to me untill their is a product out their with the form and function of the Treo but with out the problems.

    Will keep all posted. This is a very big issue for users and for HS.
  4.    #24  
    Hyperenough, I am very glad that you are not experiencing any problems. I, too, hope that this is not a big problem, just a few defective units.

    However, I think it is quite a coincidence that my replacement unit has the problem just as bad as my orginal Treo. And others have posted the same result when getting a replacement unit.

    I'm not trying to start a fire, I'd just like for me, and everyone else experiencing problems, to have Treos that work as well as yours does.
  5. #25  
    Trey - so how did it work out for you and the echo?
Page 2 of 2 FirstFirst 12

Posting Permissions