Results 1 to 7 of 7
  1.    #1  
    I work in a university with lots of old, very solid buildings. As a result of this, I'm often in buuildings where my Treo gets no service. The little LED blinks red under these circumstances, as it should.

    The problem I'm having is that when I leave one of these buildings for an area where I have service, the Treo takes a long time - sometimes up to two minutes - to realize that it has service. During that time, I'm not notified of SMS messages, and can't recieve or make phone calls. If I power it down and back up, it will do the "network search" and be back online much more quicly than if I just leave it to its own devices.

    I'm guessing this is by design; by checking the network status less often, battery life can be enhanced. I find it quite annoying, though, since I go in and out of service areas so often.


    Does anyone else notice this behavior? Anything I can do about it?
  2. #2  
    I've noticed it too. I agree that it's not so much a bug as it is an intentional design. Just power down wireless and power it up again, i guess.
  3. #3  
    Same here. It's kinda of a hassle if you ask me. Also I notice that if you forward a phone to your Treo the forwarded call goes directly to voicemail even if the treo has a good signal.
  4. #4  
    This is a common sort of behaviour with GSM phones too; if I'm in and out of the tube all day, the battery life drops right down.

    Usually, the best way to get the phone to look for a network right away is to try to call something; when I hope out of the tube, I hit the speed dial for Voicemail on my Nokia, then hang up when the signal strength appears again.

    Nigel.
  5.    #5  
    Originally posted by nwhitfield

    Usually, the best way to get the phone to look for a network right away is to try to call something; when I hope out of the tube, I hit the speed dial for Voicemail on my Nokia, then hang up when the signal strength appears again.

    Nigel.
    I wish it worked that way on the Treo. If I try to dial a number, I'll get an error that it can't fnd the network. It seems that the only way to speed it up is to turn wireless mode off and back on.

    It's kinda frustrating, because I often leave a building where I can't get service and walk for about two minutes to get to another building where there's no service; It would be nice if the Treo would tell me if I have any voicemail during the short jaunt without me having to manually intervene. Oh well.
  6. #6  
    I encountered this problem frequently on a recent train trip from SF to Denver as we went in and out of coverage areas. What I found somewhat faster was to use the "Select Network" command from the options menu in the Phone app. It seemed to sort of "wake up" the phone to actively "sniff" for a provider. It seemed marginally faster than a power off/on solution - which sometimes failed to ever find a network provider. This was especially true when roaming from Cingular to Voicestream areas.

    I should also point out that my business partner also has a Treo and sometimes his would show a strong signal and automatically pick up the new provider, while mine would simply continue to blink red while I sat right next to him.

    Go figger.
  7. #7  
    This is standard for cell phones. It sucks a lot of power to search for networks, so once one isn't found for a while, they commonly go into a sleep mode and only search once every few minutes. I'm sure trying anything cell related will force it to search again. If you didn't have this sleep delay, your battery would die in like 2 hours while you were in those buildings!

Posting Permissions