Results 1 to 8 of 8
  1. edmc's Avatar
    Posts
    120 Posts
    Global Posts
    128 Global Posts
       #1  
    [Appologies for the re-/cross-post - the Treo600-only forum hasn't responded at all and I thought this issue likely broader than just the Treo600...]

    It seems T-Mobile has disabled a nice feature of going straight into voicemail when dialing "XXX-YYY-9999" where "XXX" is your cell's area code and "YYY" is your cell's prefix. It now behaves as if you are not calling from your phone or are calling from out of the area.

    There are two work-arounds: the 805- number (I believe it's "Message", but not sure). The other is to dial your cell's number itself.

    My problem is that I can't use the '1' QuickKey. And I can't edit the first Favorite that T-Mobile has called "Voicemail" and setup to dial "XXX-YYY-9999" using the QuickKey '1'. It's the only Favorite not editable.

    Is there any way to make this Favorite editable so that I can fix it?

    T-Mobile will tell you to create a different Favorite (with a different Quick Key of course) to work-around the problem - but I was hoping someone here would know how to fix the broken favorite.

    [Note: I've verified that this problem also appears on a Verizon Treo650]
  2. #2  
    I am not sure I understand your problem. I have a unbrandedb 650 with TMobilem. I can use 1 to go to voice mail just fine.

    Actual I use "123" more because I don't need to depress 1 and wait.
  3. edmc's Avatar
    Posts
    120 Posts
    Global Posts
    128 Global Posts
       #3  
    Quote Originally Posted by whatever7
    I am not sure I understand your problem. I have a unbrandedb 650 with TMobilem. I can use 1 to go to voice mail just fine.

    Actual I use "123" more because I don't need to depress 1 and wait.
    If you go to your Favorites Page, you will likely see the first entry (upper left on page 1) is titled "Voicemail". Try to edit that Favorite Button. I expect you'll see that it is not as editable as every other Favorite Button. Specifically, while you may be able to add "Extra Digits", you won't be able to modify the Type, Label, Number, nor Quick Key.

    Why is this important, you may ask? When you get a new voicemail message, for instance, my Treo pops up a message where I can select either "OK" or "Listen". If I select "Listen", it will use this-and-only-this Favorite Button to dial Voicemail.

    Unfortunately, T-Mobile treats this call the same whether in the area or out of the area and I am required to enter those "Extra Digits" (either manually or by affixing them to the "1" Quick Key).

    Adding an "alternate" Quick Key/Favorite Button avoids this step nicely - except for this particular pop-up.

    What I'd like to do is modify the Number dialed when the "1"/"Voicemail" favorite is selected.

    Now I could just add those "Extra Digits", but this wasn't the right thing to do before T-Mobile made this change...

    I have a work-around - but I just thought somebody out there would know how to enable editing this Favorite Button... I wouldn't be surprised if that requires unlocking my phone (which I have not done yet).
  4. #4  
    I can get to my TMO voicemail on my unlocked GSM 650 by either:
    Pressing and holding the 1 key
    Pressing the Voicemail favorite key
    Dialing 123.

    I'm not sure, but I think that the number for voicemail is stored on your SIM card. You could go to a TMO store and get them to reprogram the card.

    I did find a way to edit the non-editable favorite buttons, but I don't remember how. Do a search and you should find the way.
  5. edmc's Avatar
    Posts
    120 Posts
    Global Posts
    128 Global Posts
       #5  
    I appreciate those trying to help. Perhaps I need to state the problem more clearly. The SIM card - or whatever - has hard-coded the number dialed as "XXX-YYY-9999". Try it with your T-Mobile's Area Code and Prefix with the "9999" suffix. You will get to your T-Mobile VoiceMail Acct. Granted there are other ways - it's just that T-Mobile has apparently hard-coded this particular way to QuickKey "1". And, as I said earlier, the behavior is not optimal as of late given that one now needs to also enter the password.

    The simple "work-around" is to code the "Extra Digits" for my voicemail account into that QuickKey/Favorite. Unfortunately, I'd prefer not to as this leave my VM password quite vulnerable should my Treo get lost or stolen...
  6. #6  
    When I press 1, my unbranded 650 dials +18056377243 for voice mail. Maybe its time for you to move out of the Treo600 slum.
  7. #7  
    I applaud your careful explanation of the issues. Here is a thought aimed at finding an actual solution.

    I forget what the search is but I found out how to edit the speed buttons. Bill Gamble had the key post and it involves FileZ.

    Maybe this same thing that let me DELETE the hard coded speed buttons will let you EDIT (using FileZ) the Voicemail button so you can change away from the -9999 setup to one that actually works as you want it to work.
  8. edmc's Avatar
    Posts
    120 Posts
    Global Posts
    128 Global Posts
       #8  
    Thanks for the FileZ/Bill Gamble reference. I believe I found the particular posting you were thinking of:

    http://discussion.treocentral.com/sh...ighlight=FileZ

    I downloaded FileZ 5.3.2 and quickly found the PhoneFavoritesDB file indicated in BG's post. I found the entry (it was #0 in my case) and
    was, indeed, able to edit the phone number to include my 4 digit suffix
    rather than the "9999" suffix...

    And it worked... once... Now, every time I modify it, the Phone App (when
    it next runs) takes the time to replace the 4 digit suffix with "9999"

    Later posts indicated that, although one might be able to edit the entry, you
    actually need to delete the record and edit a new/replacement one. Sure
    enough, this worked like a charm. Several oddities, however. First, it seems
    to restrict what I can type into the phone number for the Speed Dial.
    Second, it won't let me make the QuickKey a "1" as it had been. It's an "e"
    instead (which is, of course, the same key).

    It now works as I used to have it. I can QuickKey Voicemail just as I always
    have and it will go straight there - and not prompt me for my password as
    if I was calling from out of the area or from another phone.

    The only remaining thing to check was what happens when the pop-up
    is displayed telling me someone left a voicemail message. Would the
    pop-op invoke my new/improved voicemail? I'm sorry to say the answer
    is no Fortunately, it didn't revert my new/improved QuickKey...

    But I have a passable solution. I just need to not use the pop-up to
    "Listen" to my voicemail...

    Thanks, again, for the pointer to FileZ/Bill Gamble's post...

Posting Permissions