http://discuss.treocentral.com/newth...read&f=35#Need HELP! I purchased an unlocked GSM Treo 600 from a T-Mobile dealer. The phone had originally been programmed for the Orange France network and had Orange firmware installed. It was unlocked, however, and worked fine with my both my T-Mobile SIM card and a Cingular SIM card.

Yesterday I wanted to upgrade my Treo's capabilities to use MVoice, and to do that, I needed to download the Treo Updater. I installed an updater for Orange UK (Treo600-1.12-OUK) that I found on a Google search. I don't know if the phone would have worked with this updater or not, because, a few minutes later, I found the Palm site with the T-Mobile updater and installed that over the earlier updater. When I went to turn on the phone then I got a message advising me that "Your phone cannot be used with this SIM card" and that I could make emergency calls only.

I tried to find and delete the Orange firmware, but it doesn't appear on a list of software using either the INFO or DELETE options. As a last resort, I deleted the T-Mobile firmware (which for some reason DID show up on a list of s/w using the DELETE option) but this didn't cure the problem.

Any help would be most appreciated. I am a new Treo owner and new to this board. http://discuss.treocentral.com/newth...ewthread&f=35#