Page 13 of 15 FirstFirst ... 389101112131415 LastLast
Results 241 to 260 of 300
Like Tree20Likes
  1.    #241  
    Quote Originally Posted by Darkmagister View Post
    yes i don't know wich version i have now of npm i've instelled yesterday ... with the install.sh script on the npm site

    but with the "last" version of npm and 0.6.6 nodejs i have the dir node_modules and it's work

    previous when i had installed the npm from repo the npm install hc-server create the dir node_libraries/hc-server and inside this i have index.jsjsjs
    and with this version if i launch it i receive the previous error.

    so now still using the self compiled version of nodejs and the npm manually installed ... thats work ...
    maybe in the future i go back to the repo version

    thanks
    Ok so now I understood I can confirm that the debian versions are not working at the moment since I am running Debian myself so I am also using the self compiled version. Hopefully Debian updates its node/npm packages at some point since its something in Debian packages that is causing the trouble.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  2.    #242  
    Quote Originally Posted by michote View Post
    Pulseaudio is now shown as ONLINE but it doesn't work
    If I use the slider it will always jump back to the current Volume level and nothing changes. Also the Mute toggle flips back without effect.

    I also have some simmilar issue with MPD. the mute toggle always flips back but it works. But I can only unmute using the volume-slider.

    I enabled the dbus plugin in totem but it still crashes. Maybe its still the bug ...
    Its also shows unknown Video playing.
    I updated my ubuntu and now I can also enable the dbus service plugin but yes Totem seems to be very crashy so its a bug in the Totem version of Ubuntu 11.10. Hopefullly they will fix it soon. I fixed the MPD problem so its fixed in next release, but then for the pulseaudio I would need you to do some experimenting with the control script and tell me if its working when you use it manually and then lets work that problem from there.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  3. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #243  
    Quote Originally Posted by sconix View Post
    I updated my ubuntu and now I can also enable the dbus service plugin but yes Totem seems to be very crashy so its a bug in the Totem version of Ubuntu 11.10. Hopefullly they will fix it soon. I fixed the MPD problem so its fixed in next release, but then for the pulseaudio I would need you to do some experimenting with the control script and tell me if its working when you use it manually and then lets work that problem from there.
    sorry had to do some other stuff.
    ./data/bin/pulseaudio-control.sh output volume 10
    doesn't give any output but work as expected: Volume is at 10%
    (HC reports 9. Exept 50 and 100 it always report one less than I set.
    eg 10 -> HC: 9, 20 -> HC 19)

    I also set debug to true, but I didn't got any other output than the normal "executing ... command"
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  4.    #244  
    Quote Originally Posted by michote View Post
    sorry had to do some other stuff.
    ./data/bin/pulseaudio-control.sh output volume 10
    doesn't give any output but work as expected: Volume is at 10%
    (HC reports 9. Exept 50 and 100 it always report one less than I set.
    eg 10 -> HC: 9, 20 -> HC 19)

    I also set debug to true, but I didn't got any other output than the normal "executing ... command"
    Sorry this is my fault, forgot to add the fix for the script executing for the commands, I only added for status script So with next version it will work for sure
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  5. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #245  
    Glad to hear

    By the way, what would be the best way to start hc-server systemwide at startup?
    ( My homeserver isn't running all the time, but I'd like to control mpd from my tp without starting the hc-server manually)
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  6.    #246  
    Quote Originally Posted by michote View Post
    Glad to hear

    By the way, what would be the best way to start hc-server systemwide at startup?
    ( My homeserver isn't running all the time, but I'd like to control mpd from my tp without starting the hc-server manually)
    I am not sure about Ubuntu, at least at some point it was possible to add program to be run after login in preferences-session-startup applications. If its not anymore then I guess you need to google about it, there should be some way to add apps/commands to be started after login.

    I will need to test/see at some point myself as well since for 1.0 I would like to add automatic installation into the server so it gets automatically added into startup if user wants.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  7.    #247  
    Version 0.7.9 will be out later today, it brings again few small fixes here and there. The main change is addition of progress bar for quicktime and fixing the status report "flickering" if server gets offline and then back online (added timeout for the server calls).

    The next 0.8.0 release should happen on Monday and it will be the first public release, it will bring mainly working touchpad surveillance and hopefully working osx mouse / keyboard (if I can get it to work decently).

    Then the 0.8.x releases will be feature releases where I hope to broaden the supported controllers at least for Windows side. And then 0.9.0 will come with auto discovery of servers and will act as a release candidate for 1.0.0 for phones. I will start the work on fine tuning HC for touchpad usage at this point and hopefully get this thing into App Catalog within this month (well at least submitted).
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  8.    #248  
    Version 0.7.9 is out now so enjoy. Now is the time to let me know if you have any problems, the next release will go into public feed.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  9. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #249  
    I'm getting:
    Code:
    node.jsjsjs:$134$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
            ^
    $Error$: $Cannot$ $find$ $module$ '../$misc$/$mpd$-$pre$-$release$'
        $at$ $Function$.$_resolveFilename$ ($module$.$js$:$317$:$11$)
        $at$ $Function$.$_load$ ($module$.$js$:$262$:$25$)
        $at$ $require$ ($module$.$js$:$346$:$19$)
        $at$ /$home$/$micha$/.$node_libraries$/.$npm$/$hc$-$server$/$0$.$7$.$9$/$package$/$lib$/$app$/$mpd$.$js$:$52$:$5$
        $at$ $ChildProcess$.$exithandler$ ($child_process$.$js$:$100$:$7$)
        $at$ $ChildProcess$.$emit$ ($events$.$js$:$67$:$17$)
        $at$ $Socket$.&$lt$;$anonymous$&$gt$; ($child_process$.$js$:$179$:$12$)
        $at$ $Socket$.$emit$ ($events$.$js$:$64$:$17$)
        $at$ $Array$.&$lt$;$anonymous$&$gt$; ($net$.$js$:$831$:$12$)
        $at$ $EventEmitter$.$_tickCallback$ ($node$.$js$:$126$:$26$)
    on my server.

    PA is finally working

    I also got it (0.7.8) working systemwide , by adding:
    Code:
    sleep 7
    /usr/bin/node /home/<user>/.node_libraries/hc-server &
    to /etc/rc.local
    without sleep it won't start for me.
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  10.    #250  
    Quote Originally Posted by michote View Post
    I'm getting:
    Code:
    node.jsjsjs:$134$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
            ^
    $Error$: $Cannot$ $find$ $module$ '../$misc$/$mpd$-$pre$-$release$'
        $at$ $Function$.$_resolveFilename$ ($module$.$js$:$317$:$11$)
        $at$ $Function$.$_load$ ($module$.$js$:$262$:$25$)
        $at$ $require$ ($module$.$js$:$346$:$19$)
        $at$ /$home$/$micha$/.$node_libraries$/.$npm$/$hc$-$server$/$0$.$7$.$9$/$package$/$lib$/$app$/$mpd$.$js$:$52$:$5$
        $at$ $ChildProcess$.$exithandler$ ($child_process$.$js$:$100$:$7$)
        $at$ $ChildProcess$.$emit$ ($events$.$js$:$67$:$17$)
        $at$ $Socket$.&$lt$;$anonymous$&$gt$; ($child_process$.$js$:$179$:$12$)
        $at$ $Socket$.$emit$ ($events$.$js$:$64$:$17$)
        $at$ $Array$.&$lt$;$anonymous$&$gt$; ($net$.$js$:$831$:$12$)
        $at$ $EventEmitter$.$_tickCallback$ ($node$.$js$:$126$:$26$)
    on my server.

    PA is finally working

    I also got it (0.7.8) working systemwide , by adding:
    Code:
    sleep 7
    /usr/bin/node /home/<user>/.node_libraries/hc-server &
    to /etc/rc.local
    without sleep it won't start for me.
    There is now 0.8.0 server out there which fixes the mpd problem I released the mpd library I was using so its not anymore included, just forgot to update the library loading.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  11. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #251  
    Quote Originally Posted by sconix View Post
    There is now 0.8.0 server out there which fixes the mpd problem I released the mpd library I was using so its not anymore included, just forgot to update the library loading.
    works now, thanks!
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  12.    #252  
    Quote Originally Posted by michote View Post
    works now, thanks!
    Good I noticed that the media center layout is broken, will be fixed in 0.8.0. Other than that I guess the current features are working rather well.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  13. #253  
    OK, well reading through the thred, I see I'm the only one with this problem. I'm hoping someone might be able to point me in the right direction. Running node.jsjsjs $on$ $Windows$ ($XP$ $SP3$), $clean$ $install$ $of$ $node$.$js$ $using$ $the$ $node$.$js$ $msi$ $from$ $the$ $node$.$js$ $website$. $installing$ $hc$-$server$ $goes$ $ok$ ($I$ $think$):
    Code:
    C:\Program Files\nodejs>npm install hc-server
    hc-server@0.8.0 ./node_modules/hc-server
    ├── mpd@0.0.1
    ├── applescript@0.2.1
    ├── x11@0.0.4
    ├── connect-form@0.2.1 (formidable@1.0.8)
    └── express@2.5.2
    However when I try to run hc-server, I get:
    Code:
    C:\Program Files\nodejs\node_modules\hc-server>node hc-server.jsjsjs
    
    $node$.$js$:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $Cannot$ $find$ $module$ '$connect$-$form$'
        $at$ $Function$.$_resolveFilename$ ($module$.$js$:$334$:$11$)
        $at$ $Function$.$_load$ ($module$.$js$:$279$:$25$)
        $at$ $Module$.$require$ ($module$.$js$:$357$:$17$)
        $at$ $require$ ($module$.$js$:$368$:$17$)
        $at$ $Object$.&$lt$;$anonymous$&$gt$; ($C$:\$Program$ $Files$\$nodejs$\$node_modules$\$hc$-$server$\$hc$-$server$.$js$:$46$:$12$)
        $at$ $Module$.$_compile$ ($module$.$js$:$432$:$26$)
        $at$ $Object$..$js$ ($module$.$js$:$450$:$10$)
        $at$ $Module$.$load$ ($module$.$js$:$351$:$31$)
        $at$ $Function$.$_load$ ($module$.$js$:$310$:$12$)
        $at$ $Array$.$0$ ($module$.$js$:$470$:$10$)
    connect-form is there under "node_modules". I've tried removing the bundled connect-form and installing is separately (npm install connect-form"), but I get the same error. node.jsjsjs $is$ $obviously$ $looking$ $in$ $the$ $right$ $place$, $because$ $if$ $I$ $rename$ $say$ $express$ ($under$ $the$ $node_modules$ $branch$), $to$ $expres_$, $and$ $try$ $to$ $run$ $hc$-$server$ $I$ $get$ $the$ $expected$ $error$ $saying$ $it$ $can$'$t$ $find$ $module$ '$express$'.

    So I'm stumped...can some kind soul point out where I'm being a stupid e-whip?

    Thanx
  14.    #254  
    Quote Originally Posted by cmcrae1 View Post
    OK, well reading through the thred, I see I'm the only one with this problem. I'm hoping someone might be able to point me in the right direction. Running node.jsjsjs $on$ $Windows$ ($XP$ $SP3$), $clean$ $install$ $of$ $node$.$js$ $using$ $the$ $node$.$js$ $msi$ $from$ $the$ $node$.$js$ $website$. $installing$ $hc$-$server$ $goes$ $ok$ ($I$ $think$):
    Code:
    C:\Program Files\nodejs>npm install hc-server
    hc-server@0.8.0 ./node_modules/hc-server
    ├── mpd@0.0.1
    ├── applescript@0.2.1
    ├── x11@0.0.4
    ├── connect-form@0.2.1 (formidable@1.0.8)
    └── express@2.5.2
    However when I try to run hc-server, I get:
    Code:
    C:\Program Files\nodejs\node_modules\hc-server>node hc-server.jsjsjs
    
    $node$.$js$:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $Cannot$ $find$ $module$ '$connect$-$form$'
        $at$ $Function$.$_resolveFilename$ ($module$.$js$:$334$:$11$)
        $at$ $Function$.$_load$ ($module$.$js$:$279$:$25$)
        $at$ $Module$.$require$ ($module$.$js$:$357$:$17$)
        $at$ $require$ ($module$.$js$:$368$:$17$)
        $at$ $Object$.&$lt$;$anonymous$&$gt$; ($C$:\$Program$ $Files$\$nodejs$\$node_modules$\$hc$-$server$\$hc$-$server$.$js$:$46$:$12$)
        $at$ $Module$.$_compile$ ($module$.$js$:$432$:$26$)
        $at$ $Object$..$js$ ($module$.$js$:$450$:$10$)
        $at$ $Module$.$load$ ($module$.$js$:$351$:$31$)
        $at$ $Function$.$_load$ ($module$.$js$:$310$:$12$)
        $at$ $Array$.$0$ ($module$.$js$:$470$:$10$)
    connect-form is there under "node_modules". I've tried removing the bundled connect-form and installing is separately (npm install connect-form"), but I get the same error. node.jsjsjs $is$ $obviously$ $looking$ $in$ $the$ $right$ $place$, $because$ $if$ $I$ $rename$ $say$ $express$ ($under$ $the$ $node_modules$ $branch$), $to$ $expres_$, $and$ $try$ $to$ $run$ $hc$-$server$ $I$ $get$ $the$ $expected$ $error$ $saying$ $it$ $can$'$t$ $find$ $module$ '$express$'.

    So I'm stumped...can some kind soul point out where I'm being a stupid e-whip?

    Thanx
    Not sure why you are installing the server on Windows, if for future or development sake then ok, but at the moment there is no supported apps on Windows. The 0.8.x releases will bring support for Windows apps though so its not long before there should be some need for the server on Windows At the moment only VLC can be controlled on Windows and it wont need the hc-server, just so that you know the current situation.

    Then about the error, it does seem bit odd, I am about to start testing the server on Windows during next week so then I know more, but I already tested this problem and found a solution. It seems that the connect-form has invalid package.json info which the new npm don't seem to know how to handle. So to get the server running on Windows with the latest nodejs you need to edit the node_modules/connect-form/package.json and change the "main" line from "./index.jsjsjs&$quot$; $to$ &$quot$;./$lib$/$connect$-$form$&$quot$;. $Then$ $it$ $will$ $work$, $but$ $as$ $said$ $at$ $the$ $moment$ $you$ $wont$ $get$ $much$ $use$ $of$ $the$ $server$ $on$ $windows$, $but$ $during$ $next$ $week$ $you$ $should$
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  15. #255  
    Not sure why you are installing the server on Windows, if for future or development sake then ok, but at the moment there is no supported apps on Windows.
    Thank you for your quick reply. Yes, I am developing a c-bus module.

    So to get the server running on Windows with the latest nodejs you need to edit the node_modules/connect-form/package.json and change the "main" line from "./index.jsjsjs&$quot$; $to$ &$quot$;./$lib$/$connect$-$form$&$quot$;. $Then$ $it$ $will$ $work$.
    I assume you meant "./lib/connect-form.jsjsjs&$quot$; ...yes it is all good now, thank you for the tip.

    Cheers,

    -- Chris
  16.    #256  
    Quote Originally Posted by cmcrae1 View Post
    Thank you for your quick reply. Yes, I am developing a c-bus module.



    I assume you meant "./lib/connect-form.jsjsjs&$quot$; ...yes it is all good now, thank you for the tip.

    Cheers,

    -- Chris
    Ah cool, if you need different controller UI that is currently supported on the app side, just let me know and I will add one / required changes. Or if you need any help at all don't be afraid to bug me, can send email to scorpio.iix at gmail.com if any questions.

    And actually both will work for the package.json
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  17.    #257  
    So time to start talk about the first public release, which will be 0.8.1 (0.8.0 is skipped).

    The things it will bring for sure:

    - Couple small fixes

    - Fix for the media center controller UI

    - Re-enabled the Cisco IP Camera support

    - Changes for input support in Linux, now the modifier key and mouse buttons states will be correct even if controlling from multiple devices at the same time. Also closing the controller will reset the button / modifier states in case of something goes wrong.

    - User/password authentication possibility for the server side so you can open the port in you firewall for outside world as well if you like

    - Keyboard support for OS X (mouse will come later, it seems that I might need to code some handy helper app, unless somebody can suggest a good "mouse server" for OSX).

    The things it might bring:

    - Working touchpad surveillance mode for touchpad (the phone side works already, i.e. you can view latest screencap if any taked with touchpad which obviously can not be without this being finished)

    After the first public release I will start to look into Windows apps and adding support at least for couple of them.
    Last edited by sconix; 12/18/2011 at 06:10 PM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  18. #258  
    Code:
    node.jsjsjs:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $connect$ $Unknown$ $system$ $errno$ $110$
        $at$ $errnoException$ ($net$.$js$:$614$:$11$)
        $at$ $Object$.$afterConnect$ [$as$ $oncomplete$] ($net$.$js$:$605$:$18$)
  19.    #259  
    Quote Originally Posted by groogh View Post
    Code:
    node.jsjsjs:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $connect$ $Unknown$ $system$ $errno$ $110$
        $at$ $errnoException$ ($net$.$js$:$614$:$11$)
        $at$ $Object$.$afterConnect$ [$as$ $oncomplete$] ($net$.$js$:$605$:$18$)
    Would need to know, what you are trying to do and on what platform / node.jsjsjs / $npm$ $version$.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  20.    #260  
    New release should show up soon in the public Preware feed (0.8.1). And new server (0.8.1) is already available. There should be at least one more release before Christmas break, but at least couple more before years end.

    The server brings support for authentication and port configuration so should allow even usage over untrusted network if somebody has need for such.

    From the client app I had to leave out couple extensions since I did not had time to properly finish them but they will be enabled in next release most likely. The 0.8.x releases will bring few finishing touches and support for some Windows apps.
    Last edited by sconix; 12/19/2011 at 06:28 PM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.

Posting Permissions