Page 12 of 15 FirstFirst ... 2789101112131415 LastLast
Results 221 to 240 of 300
Like Tree20Likes
  1.    #221  
    Quote Originally Posted by michote View Post
    found it now, it's in .node_libraries/.npm/hc-server/active/package/data/bin
    hard to find, beeing tired

    Anyway, I don't get any output from this skript.
    Maybe you forgot the status parameter from the script being tired and all? Since I think there should be some output, I think it fails to get the status for some reason.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  2. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #222  
    yep. sorry. The output is:

    50,false,52,false
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  3.    #223  
    Quote Originally Posted by michote View Post
    yep. sorry. The output is:

    50,false,52,false
    Ok the script works then, well let me know how the 0.7.7 works, at least I fixed the input bugs etc.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  4. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #224  
    Quote Originally Posted by sconix View Post
    Ok the script works then, well let me know how the 0.7.7 works, at least I fixed the input bugs etc.
    Input works fine now. PA still shows unknown...
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  5.    #225  
    Quote Originally Posted by michote View Post
    Input works fine now. PA still shows unknown...
    Hmm, is there any output on the server when it queries the status for sound?

    You could add the following line into the ./lib/sys/sound.jsjsjs $after$ $line$ $140$ $which$ $is$ $after$ $the$ $line$:
    if(error !== null) {

    Add after that: console.log("DEBUG: " + error);

    Then you should see the error and can tell me what it is, since thats the only place where server sends unknown status for pulseaudio.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  6. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #226  
    Quote Originally Posted by sconix View Post
    Hmm, is there any output on the server when it queries the status for sound?

    You could add the following line into the ./lib/sys/sound.jsjsjs $after$ $line$ $140$ $which$ $is$ $after$ $the$ $line$:
    if(error !== null) {

    Add after that: console.log("DEBUG: " + error);

    Then you should see the error and can tell me what it is, since thats the only place where server sends unknown status for pulseaudio.
    after adding the line I get:
    Code:
    Executing sound command: status
    DEBUG: Error: Command failed: /bin/sh: ./data/bin/pulseaudio-control.sh: not found
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  7.    #227  
    Quote Originally Posted by michote View Post
    after adding the line I get:
    Code:
    Executing sound command: status
    DEBUG: Error: Command failed: /bin/sh: ./data/bin/pulseaudio-control.sh: not found
    So it seems that the installation is somewhat different or that the service is executed in some other directory. I will need to come up with proper way to call those scripts. This should be fixed in tonight release then. Thanks for the info.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
    ka1 likes this.
  8.    #228  
    New version 0.7.8 should be out later today, it should bring cleanups / fixes and hopefully playlist / media library browser for VLC. At least the pulseaudio should be now fixed for all, or at least the path issue should be resolved that has troubled few users.

    And for those who wonder the current status, here is how I see things:

    * Status Info: for showing 1-wire status info (ready for 1.0 for phones)
    - Surveillance: support for video/snapshots
    - System Input: system mouse and keyboard controls
    * System Sound: master sound and speaker controls (ready for 1.0 for phones)
    * Media Center: media boxes with d-pad controls (ready for 1.0 for phones)
    * Music Player: music player applications (ready for 1.0 for phones)
    * Video Player: video player applications (ready for 1.0 for phones)

    Next I plan to address the Video Player extension / modules, and then the system input and surveillance. Then I will release 0.8.0 and then I start adding support for few Windows apps. And as you can see first I will release 1.0 for phones and then start adding tweaks and changes to make the app more useful / prettier on Touchpad.

    Those who are using the media center controllers please let me know if its missing something or something is not working properly, since otherwise I consider it to be 1.0.0 ready as well. And of course this goes to everything if you think something that is really a must to have please tell me so I can consider it for 1.0.0. I want the 1.0.0 be rather feature rich and specially very usable.

    EDIT: Having bit of trouble with VLC playlist/media library integration so release will go tomorrow...

    EDIT2: So next release will bring next/prev controls, seek bar, playlist and media library views for VLC once I get all of them to work

    EDIT3: So totem support is also gaining some extra features in the next release.
    Last edited by sconix; 12/15/2011 at 06:38 PM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  9.    #229  
    New release should soon show up in the feed, the version 0.7.8 brings new controls for VLC and Totem (need to have the dbus-service plugin enabled). Also the server side went through a big cleanup process so if I broke something let me know

    Please let me know if you think something is missing from music/video players or from media center controllers. I consider them to be ready for 1.0.0 now unless somebody raises concern about missing functionality.

    If all goes well during this weekend I should have 0.8.0 ready by Monday and it will go into public feed.

    EDIT: Quicktime should be getting progress bar on next release, that I forgot to add into this release.
    Last edited by sconix; 12/15/2011 at 07:06 PM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  10. #230  
    hi, i had problems with my debian, i had installed all the packages from repo:
    nodejs 0.4.12-1
    npm 0.2.19-1
    and first thing i don't have the directory node_modules/ but .node_libraries/
    anyway i've tried to launch it but it doesn't work (version 0.7.8):

    node .node_libraries/.npm/hc-server/0.7.8/package/hc-server.jsjsjs

    node.jsjsjs:$134$
    throw e; // process.nextTick error, or 'error' event on first tick
    ^
    TypeError: Cannot read property 'merge' of undefined
    at Object.<anonymous> (/home/dm/.node_libraries/.npm/express/2.5.2/package/lib/view.jsjsjs:$20$:$18$)
    at Module._compile (module.jsjsjs:$411$:$26$)
    at Object..jsjsjs ($module$.$js$:$417$:$10$)
    at Module.load (module.jsjsjs:$343$:$31$)
    at Function._load (module.jsjsjs:$302$:$12$)
    at require (module.jsjsjs:$355$:$19$)
    at Object.<anonymous> (/home/dm/.node_libraries/.npm/express/2.5.2/package/lib/http.jsjsjs:$16$:$12$)
    at Module._compile (module.jsjsjs:$411$:$26$)
    at Object..jsjsjs ($module$.$js$:$417$:$10$)
    at Module.load (module.jsjsjs:$343$:$31$)

    so i've tried to compile the last nodejs 0.6.6 and same with npm now i've the node_modules dir and it's work ...
    but i'm prefering to using the repo package, so it's something that can be fixed or i have to use this nodejs version ?

    and by the way, how i can enable the auto discover ... ?

    thanks
    Federico Pietta "Darkmagister"
    http://www.darkmagister.org
    http://www.wosp.it
    Linux Registered User: #425709

    public gpg key: gpg --keyserver pgp.mit.edu --recv-key 1B20570B
  11. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #231  
    Quote Originally Posted by Darkmagister View Post
    hi, i had problems with my debian, i had installed all the packages from repo:
    nodejs 0.4.12-1
    npm 0.2.19-1
    and first thing i don't have the directory node_modules/ but .node_libraries/
    anyway i've tried to launch it but it doesn't work (version 0.7.8):

    node .node_libraries/.npm/hc-server/0.7.8/package/hc-server.jsjsjs
    Have you tried to launch it with node .node_libraries/hc-server
    I'm using Ubuntu, with the same version of npm from apt and it's working fine.
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  12.    #232  
    Quote Originally Posted by Darkmagister View Post
    hi, i had problems with my debian, i had installed all the packages from repo:
    nodejs 0.4.12-1
    npm 0.2.19-1
    and first thing i don't have the directory node_modules/ but .node_libraries/
    anyway i've tried to launch it but it doesn't work (version 0.7.8):

    node .node_libraries/.npm/hc-server/0.7.8/package/hc-server.jsjsjs

    node.jsjsjs:$134$
    throw e; // process.nextTick error, or 'error' event on first tick
    ^
    TypeError: Cannot read property 'merge' of undefined
    at Object.<anonymous> (/home/dm/.node_libraries/.npm/express/2.5.2/package/lib/view.jsjsjs:$20$:$18$)
    at Module._compile (module.jsjsjs:$411$:$26$)
    at Object..jsjsjs ($module$.$js$:$417$:$10$)
    at Module.load (module.jsjsjs:$343$:$31$)
    at Function._load (module.jsjsjs:$302$:$12$)
    at require (module.jsjsjs:$355$:$19$)
    at Object.<anonymous> (/home/dm/.node_libraries/.npm/express/2.5.2/package/lib/http.jsjsjs:$16$:$12$)
    at Module._compile (module.jsjsjs:$411$:$26$)
    at Object..jsjsjs ($module$.$js$:$417$:$10$)
    at Module.load (module.jsjsjs:$343$:$31$)

    so i've tried to compile the last nodejs 0.6.6 and same with npm now i've the node_modules dir and it's work ...
    but i'm prefering to using the repo package, so it's something that can be fixed or i have to use this nodejs version ?

    and by the way, how i can enable the auto discover ... ?

    thanks
    I was also unable to get the debian versions to work so I build the 0.6.x version as well. Had the exact same error with the express. So I guess that the latest express does not play nice with the older node.jsjsjs. $Which$ $is$ $too$ $bad$ $since$ $the$ $auto$ $discover$ $does$ $not$ $work$ $with$ $node$.$js$ $0$.$6$.$x$ $yet$ $since$ $its$ $missing$ $the$ $support$ $for$ $that$ Well the auto discover is not ready yet anyway, I will hide the options for next version, they should be visible only once they are implemented Should be in 0.9 when the auto discover will be working in HC but I have to see if I can go around the limitation in node 0.6.x.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  13. #233  
    Quote Originally Posted by michote View Post
    Have you tried to launch it with node .node_libraries/hc-server
    I'm using Ubuntu, with the same version of npm from apt and it's working fine.
    no but
    on .node_libraries/hc-server/ i don't have hc-server.jsjsjs $but$ $idex$.$js$ ... $but$ $trying$ $now$ $with$ $nodejs$ $0$.$6$.$6$ $i$ $receive$ $the$ $same$ $error$ ... $as$ $before$ ... $so$ $maybe$ $it$'$s$ $npm$ $problem$ ... $i$ $don$'$t$ $know$

    here the error:
    node hc-server/index.jsjsjs

    node.jsjsjs:$201$
    throw e; // process.nextTick error, or 'error' event on first tick
    ^
    Error: require.paths is removed. Use node_modules folders, or the NODE_PATH environment variable instead.
    at Function.<anonymous> (module.jsjsjs:$376$:$11$)
    at Object.<anonymous> (/home/dm/.node_libraries/hc-server@0.7.8/index.jsjsjs:$4$:$21$)
    at Module._compile (module.jsjsjs:$432$:$26$)
    at Object..jsjsjs ($module$.$js$:$450$:$10$)
    at Module.load (module.jsjsjs:$351$:$31$)
    at Function._load (module.jsjsjs:$310$:$12$)
    at Array.0 (module.jsjsjs:$470$:$10$)
    at EventEmitter._tickCallback (node.jsjsjs:$192$:$40$)

    it's the first time that i use nodejs or npm so i don't know
    Federico Pietta "Darkmagister"
    http://www.darkmagister.org
    http://www.wosp.it
    Linux Registered User: #425709

    public gpg key: gpg --keyserver pgp.mit.edu --recv-key 1B20570B
  14. #234  
    Quote Originally Posted by sconix View Post
    I was also unable to get the debian versions to work so I build the 0.6.x version as well. Had the exact same error with the express. So I guess that the latest express does not play nice with the older node.jsjsjs. $Which$ $is$ $too$ $bad$ $since$ $the$ $auto$ $discover$ $does$ $not$ $work$ $with$ $node$.$js$ $0$.$6$.$x$ $yet$ $since$ $its$ $missing$ $the$ $support$ $for$ $that$ Well the auto discover is not ready yet anyway, I will hide the options for next version, they should be visible only once they are implemented Should be in 0.9 when the auto discover will be working in HC but I have to see if I can go around the limitation in node 0.6.x.
    ok but as i've write right 2 minutes ago i've tryed with nodejs 0.6.6 to use the hc-server installed with the npm of the repo and doesn't work, i don't know how the npm or nodejs work so i don't know if it's normal or not

    ok for the auto discover
    Federico Pietta "Darkmagister"
    http://www.darkmagister.org
    http://www.wosp.it
    Linux Registered User: #425709

    public gpg key: gpg --keyserver pgp.mit.edu --recv-key 1B20570B
  15.    #235  
    Quote Originally Posted by Darkmagister View Post
    no but
    on .node_libraries/hc-server/ i don't have hc-server.jsjsjs $but$ $idex$.$js$ ... $but$ $trying$ $now$ $with$ $nodejs$ $0$.$6$.$6$ $i$ $receive$ $the$ $same$ $error$ ... $as$ $before$ ... $so$ $maybe$ $it$'$s$ $npm$ $problem$ ... $i$ $don$'$t$ $know$

    here the error:
    node hc-server/index.jsjsjs

    node.jsjsjs:$201$
    throw e; // process.nextTick error, or 'error' event on first tick
    ^
    Error: require.paths is removed. Use node_modules folders, or the NODE_PATH environment variable instead.
    at Function.<anonymous> (module.jsjsjs:$376$:$11$)
    at Object.<anonymous> (/home/dm/.node_libraries/hc-server@0.7.8/index.jsjsjs:$4$:$21$)
    at Module._compile (module.jsjsjs:$432$:$26$)
    at Object..jsjsjs ($module$.$js$:$450$:$10$)
    at Module.load (module.jsjsjs:$351$:$31$)
    at Function._load (module.jsjsjs:$310$:$12$)
    at Array.0 (module.jsjsjs:$470$:$10$)
    at EventEmitter._tickCallback (node.jsjsjs:$192$:$40$)

    it's the first time that i use nodejs or npm so i don't know
    If you are still using the npm that comes with Debian then thats the problem its very old and its giving the headaches. If you build the 0.6.x node.jsjsjs $it$ $comes$ $with$ $latest$ $npm$ $which$ $works$ $nicely$, $just$ $be$ $sure$ $to$ $use$ $them$ $from$ $correct$ $path$ $since$ $if$ $you$ $compiled$ $0$.$6$.$x$ $its$ $most$ $likely$ $installed$ $in$ /$usr$/$local$/$bin$.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  16. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #236  
    Quote Originally Posted by sconix View Post
    New release should soon show up in the feed, the version 0.7.8 brings new controls for VLC and Totem (need to have the dbus-service plugin enabled). Also the server side went through a big cleanup process so if I broke something let me know
    Pulseaudio is now shown as ONLINE but it doesn't work
    If I use the slider it will always jump back to the current Volume level and nothing changes. Also the Mute toggle flips back without effect.

    I also have some simmilar issue with MPD. the mute toggle always flips back but it works. But I can only unmute using the volume-slider.

    I enabled the dbus plugin in totem but it still crashes. Maybe its still the bug ...
    Its also shows unknown Video playing.
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  17.    #237  
    Quote Originally Posted by michote View Post
    Pulseaudio is now shown as ONLINE but it doesn't work
    If I use the slider it will always jump back to the current Volume level and nothing changes. Also the Mute toggle flips back without effect.

    I also have some simmilar issue with MPD. the mute toggle always flips back but it works. But I can only unmute using the volume-slider.

    I enabled the dbus plugin in totem but it still crashes. Maybe its still the bug ...
    Its also shows unknown Video playing.
    Can you enable debug (set it to true) in lib/sys/sound.jsjsjs $and$ $lib$/$app$/$totem$.$js$ $and$ $send$ $me$ $the$ $servers$ $output$ $if$ $any$ $available$. $I$ $will$ $test$ $the$ $MPD$, $it$ $might$ $be$ $a$ $bug$. $Also$ $try$ $the$ $pulseaudio$ $script$ $again$ $manually$ $by$: ./$data$/$bin$/$pulseaudio$-$control$.$sh$ $output$ $volume$ $10$

    And tell me if it works that way, so I know is it the service or the script. I will also test all of these in the latest ubuntu which I did not do before the release.

    EDIT: at least pulse is working for me with the Ubuntu 11.10 so its most likely the script that has problems for you, will have to try to figure that what is wrong.

    EDIT2: I cannot even turn on the plugin in Ubuntu, its giving me error, trying to update its packages now to see if there is an update for totem, but I am guessing there is bug in the totem in Ubuntu 11.10...

    EDIT3: the MPD mute is bug in HC for sure will fix it for next release...
    Last edited by sconix; 12/16/2011 at 04:09 AM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  18. #238  
    Quote Originally Posted by sconix View Post
    If you are still using the npm that comes with Debian then thats the problem its very old and its giving the headaches. If you build the 0.6.x node.jsjsjs $it$ $comes$ $with$ $latest$ $npm$ $which$ $works$ $nicely$, $just$ $be$ $sure$ $to$ $use$ $them$ $from$ $correct$ $path$ $since$ $if$ $you$ $compiled$ $0$.$6$.$x$ $its$ $most$ $likely$ $installed$ $in$ /$usr$/$local$/$bin$.

    no i receive this error using nodejs 0.6.6 compiled ... with the hc-downloaded with npm of the repo ... if i use nodejs on the hc-server download with the npm installed manually it's work
    Federico Pietta "Darkmagister"
    http://www.darkmagister.org
    http://www.wosp.it
    Linux Registered User: #425709

    public gpg key: gpg --keyserver pgp.mit.edu --recv-key 1B20570B
  19.    #239  
    Quote Originally Posted by Darkmagister View Post
    no i receive this error using nodejs 0.6.6 compiled ... with the hc-downloaded with npm of the repo ... if i use nodejs on the hc-server download with the npm installed manually it's work
    Not sure if I understood correctly So if you install hc-server with somewhat new npm (1.x version, not 0.2.x that comes with debian) then you will get node_modules directory in the dir you are when you issue the npm install hc-server. Then if you go into the node_modules/hc-server directory and execute: node hc-server.jsjsjs $it$ $should$ $work$ $just$ $fine$. $There$ $should$ $not$ $be$ $no$ $index$.$js$ $etc$.

    With Ubuntu it works even with npm 0.2.x and nodejs 0.4.x so its something in Debian versions that is giving problems.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  20. #240  
    Quote Originally Posted by sconix View Post
    Not sure if I understood correctly So if you install hc-server with somewhat new npm (1.x version, not 0.2.x that comes with debian) then you will get node_modules directory in the dir you are when you issue the npm install hc-server. Then if you go into the node_modules/hc-server directory and execute: node hc-server.jsjsjs $it$ $should$ $work$ $just$ $fine$. $There$ $should$ $not$ $be$ $no$ $index$.$js$ $etc$.

    With Ubuntu it works even with npm 0.2.x and nodejs 0.4.x so its something in Debian versions that is giving problems.

    yes i don't know wich version i have now of npm i've instelled yesterday ... with the install.sh script on the npm site

    but with the "last" version of npm and 0.6.6 nodejs i have the dir node_modules and it's work

    previous when i had installed the npm from repo the npm install hc-server create the dir node_libraries/hc-server and inside this i have index.jsjsjs
    and with this version if i launch it i receive the previous error.

    so now still using the self compiled version of nodejs and the npm manually installed ... thats work ...
    maybe in the future i go back to the repo version

    thanks
    Federico Pietta "Darkmagister"
    http://www.darkmagister.org
    http://www.wosp.it
    Linux Registered User: #425709

    public gpg key: gpg --keyserver pgp.mit.edu --recv-key 1B20570B

Posting Permissions