Page 11 of 15 FirstFirst ... 6789101112131415 LastLast
Results 201 to 220 of 300
Like Tree20Likes
  1.    #201  
    Quote Originally Posted by eliasp View Post
    Just found another issue:
    PulseAudio control silently fails as 'bc' isn't installed.

    I'm just trying to come up with a better way to calculate the values without using 'bc'.
    The next release does not have the bc dependency anymore. Now can you give an example of an system that has system wide pulseaudio setup? I would need one to test and verify that everything works also in such a system.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  2.    #202  
    Version 0.7.6 will be out later today with the following changes and maybe more (will update this post if I get something else done before the release):

    - No more bc application needed for pulseaudio control

    - Fixed MPD search when searched with multiple words

    - Made rhythmbox status be precise (now it knows weather rhythmbox is playing or paused)

    - Fixed Banshee status showing to be correct always (i.e. playing/paused is now correctly shown)

    - Added possibility to "close" controllers (to put them in sort of off state) which also closes the application if the module supports it (i.e. not all apps can be closed, such as MPD).

    - Made the available controllers list dynamic with new configuration method for adding servers (only manual adding works for now, the discovering of servers/devices is coming bit later)

    EDIT: The new version (both client and server) should show up real soon, just pushed it out...
    Last edited by sconix; 12/13/2011 at 10:32 AM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  3. #203  
    Don't know why ... :/
    Code:
    $ node ./hc-server.jsjsjs
    $Home$ $Control$ $server$: $starting$
    $Loading$ $sys$ $module$: $Surveillance$
    
    $node$.$js$:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $listen$ $EADDRINUSE$
        $at$ $errnoException$ ($net$.$js$:$614$:$11$)
        $at$ $Array$.$0$ ($net$.$js$:$704$:$26$)
        $at$ $EventEmitter$.$_tickCallback$ ($node$.$js$:$192$:$40$)
  4.    #204  
    Quote Originally Posted by groogh View Post
    Don't know why ... :/
    Code:
    $ node ./hc-server.jsjsjs
    $Home$ $Control$ $server$: $starting$
    $Loading$ $sys$ $module$: $Surveillance$
    
    $node$.$js$:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $listen$ $EADDRINUSE$
        $at$ $errnoException$ ($net$.$js$:$614$:$11$)
        $at$ $Array$.$0$ ($net$.$js$:$704$:$26$)
        $at$ $EventEmitter$.$_tickCallback$ ($node$.$js$:$192$:$40$)
    Something is using the ports that are set by default. So you need to edit the hc-server.jsjsjs $and$ $change$ $either$ $the$ $discovery$ $port$ ($80$) $or$ $the$ $http$ $service$ $port$ ($3000$). $I$ $guess$ $I$ $need$ $to$ $make$ $them$ $settable$ $from$ $command$ $line$ $as$ $well$ $for$ $the$ $next$ $release$.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  5. #205  
    Changed both, works. Thank you

    What do I need for the X11 Input (Linux x64)? It's offline. Ad Pulseaudio "Unknown" ...

    And (after some time):
    Code:
    Reading 1-wire sensors
    
    node.jsjsjs:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $connect$ $Unknown$ $system$ $errno$ $110$
        $at$ $errnoException$ ($net$.$js$:$614$:$11$)
        $at$ $Object$.$afterConnect$ [$as$ $oncomplete$] ($net$.$js$:$605$:$18$)
  6.    #206  
    Quote Originally Posted by groogh View Post
    Changed both, works. Thank you

    What do I need for the X11 Input (Linux x64)? It's offline. Ad Pulseaudio "Unknown" ...

    And (after some time):
    Code:
    Reading 1-wire sensors
    
    node.jsjsjs:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $connect$ $Unknown$ $system$ $errno$ $110$
        $at$ $errnoException$ ($net$.$js$:$614$:$11$)
        $at$ $Object$.$afterConnect$ [$as$ $oncomplete$] ($net$.$js$:$605$:$18$)
    What is your distribution? Did you have those controllers setup before the 0.7.6 release or you set them up with this release (in other words does the server output show those as loaded or not)?

    Since the input should work out of the box and the pulseaudio works if you have session based distribution, but if the pulseaudio is run as system wide instance then it most likely wont work atm. I am looking for information about distribution that uses it as system wide so I can test and adjust HC accordingly to work with system instance as well.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  7. #207  
    I'm using Arch. Pulse is starting system-wide, so thats ok. I've added the Input in Version 0.7.5. Since this Version it won't work anyore. Added it in 0.7.6, too. I think it's a problem with my configuration
  8.    #208  
    Quote Originally Posted by groogh View Post
    I'm using Arch. Pulse is starting system-wide, so thats ok. I've added the Input in Version 0.7.5. Since this Version it won't work anyore. Added it in 0.7.6, too. I think it's a problem with my configuration
    Ok, so the pulse is because of that, but that should change in upcoming versions, at least I am trying to make it work with system wide instance as well.

    I just asked since with 0.7.6 you get only list of controller that the server reports that are supported so as long as it shows in the list of available controllers it should work. Does the server output anything if you try to move the mouse for example? Anyway I will install arch in virtualbox so I can test with it.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  9. #209  
    Quote Originally Posted by sconix View Post
    Ok, so the pulse is because of that, but that should change in upcoming versions, at least I am trying to make it work with system wide instance as well.

    I just asked since with 0.7.6 you get only list of controller that the server reports that are supported so as long as it shows in the list of available controllers it should work. Does the server output anything if you try to move the mouse for example? Anyway I will install arch in virtualbox so I can test with it.
    Yep, there's output (sorry for my english):
    Code:
    Executing input command: status
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing sound command: status
    Executing input command: mouse
    Reading 1-wire sensors
    
    node.jsjsjs:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $connect$ $Unknown$ $system$ $errno$ $110$
        $at$ $errnoException$ ($net$.$js$:$614$:$11$)
        $at$ $Object$.$afterConnect$ [$as$ $oncomplete$] ($net$.$js$:$605$:$18$)
    But the cursor didn't move.
  10.    #210  
    Quote Originally Posted by groogh View Post
    Yep, there's output (sorry for my english):
    Code:
    Executing input command: status
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing input command: mouse
    Executing sound command: status
    Executing input command: mouse
    Reading 1-wire sensors
    
    node.jsjsjs:$201$
            $throw$ $e$; // $process$.$nextTick$ $error$, $or$ '$error$' $event$ $on$ $first$ $tick$
                  ^
    $Error$: $connect$ $Unknown$ $system$ $errno$ $110$
        $at$ $errnoException$ ($net$.$js$:$614$:$11$)
        $at$ $Object$.$afterConnect$ [$as$ $oncomplete$] ($net$.$js$:$605$:$18$)
    But the cursor didn't move.
    Ok so the problem is with the x11 node library, I will see if I can reproduce and then fix it. I have only tested on Ubuntu and Debian and on both it is working.

    EDIT: Seems that arch is not just click and install type of thing so can not test it right now at least. Do you know if you have the XTest extension installed / enabled in your X? At least it is needed.
    Last edited by sconix; 12/13/2011 at 01:31 PM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  11. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #211  
    Finally got my homeserver ready and I'M back testing
    Now I've Running the HC-Server on a Ubuntu Oneiric-Server and a -Netbook.
    Auto detect is very nice. I only ran into problems adding too servers in HC.
    Neither on my TP nor on my Veer I was able to control to server. If I add a new Server the other disapears with all its controllers

    Also Input is shown as OFFLINE (do I need an extra package for it, di a fresh install on my netbook) and Pulseaudio as UNKNOWN. (All Controller where newly created with HC 0.7.6)
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  12.    #212  
    Quote Originally Posted by michote View Post
    Finally got my homeserver ready and I'M back testing
    Now I've Running the HC-Server on a Ubuntu Oneiric-Server and a -Netbook.
    Auto detect is very nice. I only ran into problems adding too servers in HC.
    Neither on my TP nor on my Veer I was able to control to server. If I add a new Server the other disapears with all its controllers

    Also Input is shown as OFFLINE (do I need an extra package for it, di a fresh install on my netbook) and Pulseaudio as UNKNOWN. (All Controller where newly created with HC 0.7.6)
    Hmm I tested adding of two servers and it worked well. The controls should only disappear if the server does not reply when the app is started. The added controllers will never disappear but the available controllers show up according to which servers reply when HC is started. So do you have both server online when you started HC? If yes then can you describe more the way you added the two servers so I can test and see if there is a bug since for me it is working even right now, have two servers and controllers from both are showing up and for those that offer same controller I can select the server.

    Odd you are the second user to report that input shows as offline and pulseaudio unknown. I have hc-server running on Ubuntu Oneiric Desktop and the pulseaudio shows up as online, but maybe the server uses the system wide pulseaudio. I will install the server version and see how it is, I need to get a system wide pulseaudio anyway so I can fix HC to work with system wide pulseaudio as well.

    For the input I think the netbook edition might be the blame here, anyway I will install it as well and see why it is and can I make it work.

    Or is the pulseaudio offline on the netboot edition as well or on the server edition or both? Just so that I know what to test on what edition, so far I only tested the desktop.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  13. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #213  
    Quote Originally Posted by sconix View Post
    Hmm I tested adding of two servers and it worked well. The controls should only disappear if the server does not reply when the app is started. The added controllers will never disappear but the available controllers show up according to which servers reply when HC is started. So do you have both server online when you started HC? If yes then can you describe more the way you added the two servers so I can test and see if there is a bug since for me it is working even right now, have two servers and controllers from both are showing up and for those that offer same controller I can select the server.
    I just tested again with a new install on my TP (remove lunarestart install HC). I add the 1. Server (Ubuntu Server) using the menu with Ip:Port and add a Controller (MPD), which work as it should. Then I trie to add my netbbok the same way. if I try to add a new controller there are no other controller (like totem which works on my Veer with only the netbook as server added) and no other server. When I hit cancel the MPD from the first server disappears. When I try to readd this MPD controller It doesn#t show up anymore (Add menu works fine, but when I click ok nothing appears).

    Quote Originally Posted by sconix View Post
    Odd you are the second user to report that input shows as offline and pulseaudio unknown. I have hc-server running on Ubuntu Oneiric Desktop and the pulseaudio shows up as online, but maybe the server uses the system wide pulseaudio. I will install the server version and see how it is, I need to get a system wide pulseaudio anyway so I can fix HC to work with system wide pulseaudio as well.
    I don't have pulseaudio running on the server, its on the netbook.

    Quote Originally Posted by sconix View Post
    For the input I think the netbook edition might be the blame here, anyway I will install it as well and see why it is and can I make it work.
    I'm using standard Ubuntu Desktop Version 32bit.

    Quote Originally Posted by sconix View Post
    Or is the pulseaudio offline on the netboot edition as well or on the server edition or both? Just so that I know what to test on what edition, so far I only tested the desktop.
    only on the netbook
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  14.    #214  
    Quote Originally Posted by michote View Post
    I just tested again with a new install on my TP (remove lunarestart install HC). I add the 1. Server (Ubuntu Server) using the menu with Ip:Port and add a Controller (MPD), which work as it should. Then I trie to add my netbbok the same way. if I try to add a new controller there are no other controller (like totem which works on my Veer with only the netbook as server added) and no other server. When I hit cancel the MPD from the first server disappears. When I try to readd this MPD controller It doesn#t show up anymore (Add menu works fine, but when I click ok nothing appears).


    I don't have pulseaudio running on the server, its on the netbook.


    I'm using standard Ubuntu Desktop Version 32bit.


    only on the netbook
    Ok so you are using the normal desktop version of Ubuntu, well then its odd since its working for me with 11.10. The pulseaudio I mean, I just noticed that the input is broken, I must have broken it since its showing offline for me as well. So I have to look into that, but the pulseaudio should work for Ubuntu Desktop 11.10.

    About the server / controllers problem then there has to be some error in the code since the already added controllers can only disappear if some error aborts Home Control startup. I will test on clean install the two servers and hopefully I find the bug if not I will bug you an ask you to provide me more info.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  15. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #215  
    Quote Originally Posted by sconix View Post
    Ok so you are using the normal desktop version of Ubuntu, well then its odd since its working for me with 11.10. The pulseaudio I mean, I just noticed that the input is broken, I must have broken it since its showing offline for me as well. So I have to look into that, but the pulseaudio should work for Ubuntu Desktop 11.10.
    Which command does the server use to control PA?

    Quote Originally Posted by sconix View Post
    About the server / controllers problem then there has to be some error in the code since the already added controllers can only disappear if some error aborts Home Control startup. I will test on clean install the two servers and hopefully I find the bug if not I will bug you an ask you to provide me more info.
    No problem, but will go to sleep soon
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  16.    #216  
    Quote Originally Posted by michote View Post
    Which command does the server use to control PA?


    No problem, but will go to sleep soon
    BTW what node.jsjsjs $version$ $you$ $have$? $Maybe$ $that$ $is$ $effecting$ $the$ $pulseaudio$ $since$ $I$ $am$ $not$ $running$ $the$ $version$ $that$ $one$ $can$ $get$ $by$ $installing$ $apt$-$get$.

    I just tested with clean configuration and I can not get the disappearance of the controls / servers happen. So can you do the configuration again and after the "error" send the /var/log/messages to me.

    Then for the pulseaudio can you try executing the script and send me the output if it spits anything out by running the following command in the server directory:
    ./data/bin/pulseaudio-control.sh status
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  17. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #217  
    Quote Originally Posted by sconix View Post
    BTW what node.jsjsjs $version$ $you$ $have$? $Maybe$ $that$ $is$ $effecting$ $the$ $pulseaudio$ $since$ $I$ $am$ $not$ $running$ $the$ $version$ $that$ $one$ $can$ $get$ $by$ $installing$ $apt$-$get$.

    I just tested with clean configuration and I can not get the disappearance of the controls / servers happen. So can you do the configuration again and after the "error" send the /var/log/messages to me.

    Then for the pulseaudio can you try executing the script and send me the output if it spits anything out by running the following command in the server directory:
    ./data/bin/pulseaudio-control.sh status
    Strange. Now, that I want to log it it diappered. Couldn't reproduce the problem either on TP or Veer. But the Problem was there at least two time on the TP before. Really sorry about bugging you with it.

    I installed nodejs with apt-get, as well. And the npm install hc-server which installed it in ~/.node_libraries/hc-server. Running the PA command there gives me an error, that the file doesn't exist.
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  18.    #218  
    Quote Originally Posted by michote View Post
    Strange. Now, that I want to log it it diappered. Couldn't reproduce the problem either on TP or Veer. But the Problem was there at least two time on the TP before. Really sorry about bugging you with it.

    I installed nodejs with apt-get, as well. And the npm install hc-server which installed it in ~/.node_libraries/hc-server. Running the PA command there gives me an error, that the file doesn't exist.
    For the configuration I think there is some corner case that is causing a problem, well if you see it happen again please take the messages log and send it to me.

    For the PA well if the file is missing then its the fault, I just installed the hc-server with npm and the file is there for me. Can you check once more is there the data directory at least it should be in the same dir where the hc-server.jsjsjs $file$ $is$ $so$ $you$ $know$ $you$ $are$ $in$ $right$ $directory$. $Then$ $under$ $the$ $data$ $dir$ $should$ $be$ $bin$ $dir$ $and$ $under$ $that$ $the$ $pulseaudio$-$control$.$sh$ $file$. $If$ $its$ $really$ $missing$ $then$ $try$ $installing$ $the$ $hc$-$server$ $again$.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  19. michote's Avatar
    Posts
    183 Posts
    Global Posts
    196 Global Posts
    #219  
    found it now, it's in .node_libraries/.npm/hc-server/active/package/data/bin
    hard to find, beeing tired

    Anyway, I don't get any output from this skript.
    Touchpad 32GB and Veer | my app MySongBook | my Dark Glass Theme | apps involved in: OrganizeMe!, ReadOnTouch
  20.    #220  
    Quote Originally Posted by michote View Post
    found it now, it's in .node_libraries/.npm/hc-server/active/package/data/bin
    hard to find, beeing tired

    Anyway, I don't get any output from this skript.
    Ok so then the script is not working for you, I will study the matter and will have questions for you tomorrow

    Will release an updated server either tonight or tomorrow that fixes the input problem and couple other bugs.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.

Posting Permissions