Page 10 of 15 FirstFirst ... 56789101112131415 LastLast
Results 181 to 200 of 300
Like Tree20Likes
  1.    #181  
    Quote Originally Posted by bluenote View Post
    Don't see the seek bar in itunes.
    Command executions seems much slower than before, if it happens.
    Quote Originally Posted by eliasp View Post
    Running now 0.7.5 (server/client) on TP, using nodejs 0.6.3 and mpd 0.16.5.

    It is not possible to add a track of the search result list to the playlist by using "Play Song Now".
    The resulting output of hc-server is:
    Code:
    Executing mpd command: library/select
    Executing mpd command: playqueue/list
    Got mpd error: Got invalid hello msg from mpd: OK
    Using "Add Song To Queue" works.

    Further issues:
    • The seek bar is not visible. When implementing/fixing the seek bar, pay attention to playback of streams where a seekbar cannot be provided, so the seekbar should be shown/hidden depending on the type of played track.
    • When having a large playlist, it is very cumbersome to clear it. It would be nice to have something like Remove all tracks from queue or Clear queue


    Thanks a lot for all your work - HC is definitely now my favourite app on the TP.
    Quote Originally Posted by bluenote View Post
    I saw in itunes play song now but did not see add song to queue.
    edit: agreed this is a top app, it goes beyond the devices to affect our living space.
    The seek bar is not visible on phone, you need to tap the song name when playing to get it (it will get visible on bigger screens once I get to that, but for now its always hidden by default, to fit everything on a Veer screen). And currently the seekbar is provided always, and yes I need to add the disabling if the song wont allow seeking.

    Ok I will add clear queue, there is actually the support in server but the option is just missing from the menu of the app. iTunes does not have a queue, thats why add to queue is not in iTunes.

    Well its nice if you already think that HC is nice on the TP, my priority first is to make it to 1.0.0 version so that the app is usable on phone screen. Then I will start to add changes so that the app takes better usage of the large screen on TP for example. So version 1.1.0 should be much better on TP and should be still ready during this month.

    There is no changes that could effect the command execution, it always only depends on the network delay. Which usually should be almost instant on local network, at least it is on mine. For iTunes it seems that there is small delay, which might be caused either by applescript being slow as hell (which I doubt) or that the node.jsjsjs $applescript$ $implementation$ $could$ $use$ $some$ $improvements$.

    Not sure why you are getting that error on MPD when adding tracks, I will need to see if I can get that version to test with, with 0.15.12 its working.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  2. #182  
    Hey Sconix,

    I was trying to download the latest server v0.7.5 but it seems like http://e-lnx.org/homecontrol/ isn't coming up! Yet your main domain is working....wanted to test with my upgraded node.jsjsjs $to$ $version$ $0$.$6$.$4$

    CaliMark
    Mark Reed
  3. #183  
    Quote Originally Posted by sconix View Post
    Not sure why you are getting that error on MPD when adding tracks, I will need to see if I can get that version to test with, with 0.15.12 its working.
    If you add some more debug output (and possibly a configuration option to optionally enable this debug output) I could try to provide more information about this issue.

    I'll also take a look into the PulseAudio issues as soon as possible, which are currently are:
    • The PulseAudio script relies on 'bc' as where most of the calculations can simply be done using bash builtins
    • The PulseAudio script uses pacmd which doesn't work when running PulseAudio in system-wide mode, which might be relatively often the case for media servers


    I remember having seen some more PulseAudio issues, can't remember them at the moment, but I'm sure I'll remember as soon as I'm working on PulseAudio again
  4. #184  
    Quote Originally Posted by CaliMark View Post
    Hey Sconix,

    I was trying to download the latest server v0.7.5 but it seems like http://e-lnx.org/homecontrol/ isn't coming up! Yet your main domain is working....wanted to test with my upgraded node.jsjsjs $to$ $version$ $0$.$6$.$4$

    CaliMark
    Mark Reed
    hc-server is now available through the npm repository and not anymore through the URL above.

    Use 'npm install hc-server' to install it. See also npm - Node Package Manager

    EDIT: @sconix: The package description in the Preware feed still states, one needs to download the server application from the old URL. Please change that and add a note about npm.
    Last edited by eliasp; 12/02/2011 at 02:08 AM. Reason: Added note about package descriptions.
  5. #185  
    Quote Originally Posted by eliasp View Post
    hc-server is now available through the npm repository and not anymore through the URL above.

    Use 'npm install hc-server' to install it. See also npm - Node Package Manager

    EDIT: @sconix: The package description in the Preware feed still states, one needs to download the server application from the old URL. Please change that and add a note about npm.
    Cool thanks! Now have latest version running on node.jsjsjs $v0$.$6$.$4$...$I$ $will$ $read$ $up$ $a$ $bit$ $but$ $how$ $to$ $you$ $do$ $upgrades$ $when$ $using$ $NPM$ $install$ $method$?

    Thanks,
    CaliMark
    Mark Reed
  6. #186  
    Quote Originally Posted by CaliMark View Post
    Cool thanks! Now have latest version running on node.jsjsjs $v0$.$6$.$4$...$I$ $will$ $read$ $up$ $a$ $bit$ $but$ $how$ $to$ $you$ $do$ $upgrades$ $when$ $using$ $NPM$ $install$ $method$?
    Simply use
    Code:
    npm update hc-server
    EDIT: I'd also strongly recommend to install the node packages into a local prefix, to prevent them from messing with your system files by creating a file ~/.npmrc with content like this:
    Code:
    prefix = /home/your-username/.npm/
    Last edited by eliasp; 12/02/2011 at 02:24 AM. Reason: Added note about local prefix
  7. #187  
    Another issue I've found in the search (MPD):

    When searching for "tubular", it lists me a lot of matches for "Tubular Bells" by "Mike Oldfield".

    When searching for "tubular bells", no matches are listed at all.
    This is the same for any other "single word"/"multi word" search term.

    See also attached screenshots.
    Attached Images Attached Images
    Last edited by eliasp; 12/02/2011 at 02:47 AM. Reason: Added notice about the issue also being valid for any other multi-word searchterm.
  8.    #188  
    Quote Originally Posted by eliasp View Post
    If you add some more debug output (and possibly a configuration option to optionally enable this debug output) I could try to provide more information about this issue.

    I'll also take a look into the PulseAudio issues as soon as possible, which are currently are:
    • The PulseAudio script relies on 'bc' as where most of the calculations can simply be done using bash builtins
    • The PulseAudio script uses pacmd which doesn't work when running PulseAudio in system-wide mode, which might be relatively often the case for media servers


    I remember having seen some more PulseAudio issues, can't remember them at the moment, but I'm sure I'll remember as soon as I'm working on PulseAudio again
    I work through the modules one by one, now the music player stuff starts to be ready I move to next. The pulse stuff will come, but if you can take look it would be nice.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  9.    #189  
    Quote Originally Posted by eliasp View Post
    Another issue I've found in the search (MPD):

    When searching for "tubular", it lists me a lot of matches for "Tubular Bells" by "Mike Oldfield".

    When searching for "tubular bells", no matches are listed at all.
    This is the same for any other "single word"/"multi word" search term.

    See also attached screenshots.
    I will look into the mpd search and do some more searxh testing on itunes as well.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  10. #190  
    My experience again trying 0.7.5 on itunes on TouchPad after rebooting:

    Saw the seeker when pressing the song title, thanks, very cool.
    Very very useful to have the time written above the seeker.

    Pressed the FF button 10 deliberate times and the new time displayed instantly, nice!

    Unfortunately, the time and seeker goes away in a second or two even without pressing any buttons.

    One nice thing: when I went to mac and picked playlist (touchpad disconnected at this point), the app on touchpad displayed the playlist when I reran the server command without me having to toss the app away and restart it.

    Took several minutes to display artist search results at first. Afterwards did about 4 artist searches and was instant (had to press enter on keyboard and then magnifying glass on app box and displayed songs by the artist). Played a few songs from the searches. On the last search a bunch of songs displayed that did not pertain to the artist and no longer reverted back to my initial playlist. I picked one of the new songs and App read offline (see error below) and indeed, was disconnected.


    net.jsjsjs:$739$
    return getsockname(this.fd);
    ^
    TypeError: Bad file descriptor argument
    at Socket.address (net.jsjsjs:$739$:$10$)
    at /Users/tigger/node_modules/hc-server/lib/app/itunes.jsjsjs:$364$:$50$
    at ChildProcess.<anonymous> (/Users/tigger/node_modules/hc-server/node_modules/applescript/lib/applescript.jsjsjs:$53$:$5$)
    at ChildProcess.emit (events.jsjsjs:$67$:$17$)
    at ChildProcess.onexit (child_process.jsjsjs:$192$:$12$)

    Edit: Reconnected server, did a search in app and returned results instantly. Picked a song and disconnected.
    Then reconnected server, did a search and got instant results, this time picked a song and worked fine.

    This time, tried moving seeker bar instead of pressing FF and works! thanks!!
    Last edited by bluenote; 12/02/2011 at 07:39 AM.
  11.    #191  
    Quote Originally Posted by bluenote View Post
    My experience again trying 0.7.5 on itunes on TouchPad after rebooting:

    Saw the seeker when pressing the song title, thanks, very cool.
    Very very useful to have the time written above the seeker.

    Pressed the FF button 10 deliberate times and the new time displayed instantly, nice!

    Unfortunately, the time and seeker goes away in a second or two even without pressing any buttons.

    One nice thing: when I went to mac and picked playlist (touchpad disconnected at this point), the app on touchpad displayed the playlist when I reran the server command without me having to toss the app away and restart it.

    Took several minutes to display artist search results at first. Afterwards did about 4 artist searches and was instant (had to press enter on keyboard and then magnifying glass on app box and displayed songs by the artist). Played a few songs from the searches. On the last search a bunch of songs displayed that did not pertain to the artist and no longer reverted back to my initial playlist. I picked one of the new songs and App read offline (see error below) and indeed, was disconnected.


    net.jsjsjs:$739$
    return getsockname(this.fd);
    ^
    TypeError: Bad file descriptor argument
    at Socket.address (net.jsjsjs:$739$:$10$)
    at /Users/tigger/node_modules/hc-server/lib/app/itunes.jsjsjs:$364$:$50$
    at ChildProcess.<anonymous> (/Users/tigger/node_modules/hc-server/node_modules/applescript/lib/applescript.jsjsjs:$53$:$5$)
    at ChildProcess.emit (events.jsjsjs:$67$:$17$)
    at ChildProcess.onexit (child_process.jsjsjs:$192$:$12$)

    Edit: Reconnected server, did a search in app and returned results instantly. Picked a song and disconnected.
    Then reconnected server, did a search and got instant results, this time picked a song and worked fine.

    This time, tried moving seeker bar instead of pressing FF and works! thanks!!
    Yes the seaker bar only shows for 5 secs if its not dragged. I can add that every fwd/bwd key press will also extend the time shown.

    I have seen that net error, but arent yet sure where tbat bug is, i.e. Node,node applescript or hc-server.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  12.    #192  
    Bad news, I just had a hardware failure, my system harddrive does not work anymore so I can not boot my dev PC I try to recover from this asap, but not sure where I find the money, new hd seems to take 100e which I can by but not sure if I have money for food then. Its not fun to be jobless when you get surprises like this. Hopefully I get the PC up and running during the weekend. Now if ever donations are appreciated...

    The good news, no data/code loss, the data disk seems to be working and its only the system disk.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  13. #193  
    Sorry for your loss--I will donate a few more dollars.

    Still getting app going offline when Mac screen display dims in preparation for sleep.
    Also temp rises 50 degrees + F on Mac.
    When I close terminal, I get this message:

    Closing this window will terminate the running processes: login, bash, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript, osascript.
  14. #194  
    Thats always a major pain. Hope you have a recent OS partition image.
  15.    #195  
    I should be back in business later today so expect a new release tomorrow evening (if all goes well)
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  16. #196  
    glad you recovered
  17.    #197  
    Quote Originally Posted by bluenote View Post
    glad you recovered
    Thanks, I had urgent work related things coming my way so not sure if I can push out the next release before the weekends trip that I have, but next week I am again in full speed with this app
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  18. #198  
    Quote Originally Posted by sconix View Post
    Thanks, I had urgent work related things coming my way so not sure if I can push out the next release before the weekends trip that I have, but next week I am again in full speed with this app
    we all wish you luck with the work stuff
  19. #199  
    So I saw this in the Preware feed and thought it could be cool. I downloaded node.jsjsjs $and$ $npm$, $got$ $this$ $running$, $and$ $tried$ $it$ $out$. $It$'$s$ $very$ $cool$. $In$ $no$ $time$ $at$ $all$ $I$ $had$ $Pulseaudio$ $and$ $Banshee$ $controllers$ $set$ $up$ $and$ $could$ $play$ $music$ $and$ $adjust$ $volume$ $from$ $anywhere$ $in$ $the$ $house$.

    I haven't done any extensive testing but there are a few things I noticed right away. First, it does a nice job of displaying the current status. Controllers are offline when the server isn't running and came online right away once it's started. Volume levels were accurate for Pulseaudio, and Banshee showed "Closed" when it wasn't running and "Paused" when it was. The only exception here is that Banshee displays "Paused" even if music is playing. Not a huge problem since I can hear the music and clearly it's not paused. Second, once Banshee is opened, it stays open. You can close it but it's going to pop back open a few seconds later when the server does the status check. Perhaps there could be an option on the controller to close Banshee and stop the status check until restarted? Stopping the server with an interrupt (SIGINT) stopped the server and killed all the child processes nicely, closing Banshee. Next I ran the server in the background and redirected the output to /dev/null. This worked just fine, but when I killed the background process it orphaned off the processes to monitor the Banshee status and left Banshee open. Is the SIGTERM trapped differently than SIGINT? Again, minor issues.

    This is a very nicely done app, albeit one only for advanced users at this point. I'm really looking forward to trying more of the features out and seeing where it goes!
    Nick
  20.    #200  
    Quote Originally Posted by Nick31 View Post
    So I saw this in the Preware feed and thought it could be cool. I downloaded node.jsjsjs $and$ $npm$, $got$ $this$ $running$, $and$ $tried$ $it$ $out$. $It$'$s$ $very$ $cool$. $In$ $no$ $time$ $at$ $all$ $I$ $had$ $Pulseaudio$ $and$ $Banshee$ $controllers$ $set$ $up$ $and$ $could$ $play$ $music$ $and$ $adjust$ $volume$ $from$ $anywhere$ $in$ $the$ $house$.

    I haven't done any extensive testing but there are a few things I noticed right away. First, it does a nice job of displaying the current status. Controllers are offline when the server isn't running and came online right away once it's started. Volume levels were accurate for Pulseaudio, and Banshee showed "Closed" when it wasn't running and "Paused" when it was. The only exception here is that Banshee displays "Paused" even if music is playing. Not a huge problem since I can hear the music and clearly it's not paused. Second, once Banshee is opened, it stays open. You can close it but it's going to pop back open a few seconds later when the server does the status check. Perhaps there could be an option on the controller to close Banshee and stop the status check until restarted? Stopping the server with an interrupt (SIGINT) stopped the server and killed all the child processes nicely, closing Banshee. Next I ran the server in the background and redirected the output to /dev/null. This worked just fine, but when I killed the background process it orphaned off the processes to monitor the Banshee status and left Banshee open. Is the SIGTERM trapped differently than SIGINT? Again, minor issues.

    This is a very nicely done app, albeit one only for advanced users at this point. I'm really looking forward to trying more of the features out and seeing where it goes!
    Sometimes it seems that the "status" can get somehow weird when the server is closed and started again without re-starting the app. I haven't yet figured out why, but this is not on top of my list of things to fix since it might be even an Enyo bug.

    The application should be only started when you click the controller in the app, not on status checks. I will test that and if it acts like you say I will fix the bug. I will check/test all the things you mentioned to see how it is and fix if there is somethign to be fixed.

    During the week that is about to begin there should be again many releases that should take the app again many steps closer to be releasable to the public.

    EDIT: About the next release which should be out on Tuesday, it should come with couple bug fixes and change to how the controllers are configure. The server's will be added through menu entry (later version will also automatically discover the servers) and then you get list of configured servers to pick from when adding a controller so the list of supported controllers will get to be dynamic i.e. only stuff that is reported to be supported by the server is shown. This should be the last bigger change while going towards 1.0.0.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.

Posting Permissions