Page 43 of 56 FirstFirst ... 33383940414243444546474853 ... LastLast
Results 841 to 860 of 1104
Like Tree24Likes
  1.    #841  
    Quote Originally Posted by aziza0 View Post
    I'm having the same issue after updated to 2.4.2 version (wifi SSID trigger isn't working). Is there any option how to download older version (preferably 2.3.9)?

    Anyway thanks for the best app!
    There has not been any changes to wifi trigger after 2.0.0. So if it worked before and not now then its something else. Coincidence etc. If something is not working please send problem report. You are first one to report problems with wifi trigger.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  2. #842  
    It's strange. When I installed 2.4.2 wifi SSID trigger was not working (tried to reinstall several times - same issue). Then I installed 2.3.9 and everything is working well on Pre2. I will upgrade to 2.4.2 again and try to send you report.
  3.    #843  
    Quote Originally Posted by aziza0 View Post
    It's strange. When I installed 2.4.2 wifi SSID trigger was not working (tried to reinstall several times - same issue). Then I installed 2.3.9 and everything is working well on Pre2. I will upgrade to 2.4.2 again and try to send you report.
    Please do since I can not fix something that I am not seeing so I need the logs to have a clue what could be going on.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  4. Kratus's Avatar
    Posts
    522 Posts
    Global Posts
    536 Global Posts
    #844  
    There has not been any changes to wifi trigger after 2.0.0. So if it worked before and not now then its something else. Coincidence etc. If something is not working please send problem report. You are first one to report problems with wifi trigger.
    I already reported a wifi SSID trigger problem too.
    Since I switched from pre2 to pre3, I can't say if it is related to webOS 2.2 or to MS, but the trigger is definitely broken. It works the very first time after device restart, and after that it does not work anymore. I sent you 2 logs a couple of days ago.


    -- Envoyé depuis mon HP TouchPad avec Communities
    "I disapprove of what you say, but I will defend to the death your right to say it".
    Voltaire, french writer and Philosopher, 1694-1778

    French translator of UberCalendar, sconix's advanced patches, Twithibition, AuctionMate, Communities, Headlines 2, OrganizeMe!, Homebrew Google Maps, and many other webOS apps.
  5.    #845  
    Quote Originally Posted by Kratus View Post
    I already reported a wifi SSID trigger problem too.
    Since I switched from pre2 to pre3, I can't say if it is related to webOS 2.2 or to MS, but the trigger is definitely broken. It works the very first time after device restart, and after that it does not work anymore. I sent you 2 logs a couple of days ago.


    -- Envoyé depuis mon HP TouchPad avec Communities
    Oh I have missed your report then, I saw one and later same person saying that it works now. Well anyway it seems that there is some problem with the trigger, and it might be pre3 (webOS 2.2) related. I will release an update during this weekend.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  6. Kratus's Avatar
    Posts
    522 Posts
    Global Posts
    536 Global Posts
    #846  
    Oh I have missed your report then, I saw one and later same person saying that it works now. Well anyway it seems that there is some problem with the trigger, and it might be pre3 (webOS 2.2) related. I will release an update during this weekend.
    Thanks.
    Remember I sent you two logs, if it can help...


    -- Envoyé depuis mon HP TouchPad avec Communities
    "I disapprove of what you say, but I will defend to the death your right to say it".
    Voltaire, french writer and Philosopher, 1694-1778

    French translator of UberCalendar, sconix's advanced patches, Twithibition, AuctionMate, Communities, Headlines 2, OrganizeMe!, Homebrew Google Maps, and many other webOS apps.
  7.    #847  
    Quote Originally Posted by Kratus View Post
    Thanks.
    Remember I sent you two logs, if it can help...


    -- Envoyé depuis mon HP TouchPad avec Communities
    I do remember I was supposed to look into this during the weekend but was busy elsewhere. I will push "last" updates to the system prefs patches tomorrow morning and after that I will look into the MS wifi trigger problem and hopefully release fix tomorrow evening.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  8. Kratus's Avatar
    Posts
    522 Posts
    Global Posts
    536 Global Posts
    #848  
    Thanks!
    "I disapprove of what you say, but I will defend to the death your right to say it".
    Voltaire, french writer and Philosopher, 1694-1778

    French translator of UberCalendar, sconix's advanced patches, Twithibition, AuctionMate, Communities, Headlines 2, OrganizeMe!, Homebrew Google Maps, and many other webOS apps.
  9.    #849  
    So I have studied the wifi ssid trigger problem. Unfortunately I can not fix it. The problem is only related to Pre3 i.e. webOS 2.2. For some reason webOS 2.2.0 reports wifi connection in two phase, first notification about wifi being connected and then a second one with wifi being connected to a certain ssid (in webOS 2.1.x this happens with one call). This causes the problem, since I haven't found a way how I can make the JSJSJS $service$ $process$ $one$ $call$ $at$ $a$ $time$ ($i$.$e$. $make$ $a$ $trigger$ $queue$) $instead$ $of$ $processing$ $the$ $calls$ $as$ $they$ $arrive$. $So$ $when$ $those$ $two$ $notification$ $arrive$ $almost$ $at$ $the$ $same$ $time$ $MS$ $gets$ $confused$ $and$ $I$ $can$ $not$ $do$ $anything$ $about$ $that$. $Hence$ $the$ $trigger$ $might$ $work$ $after$ $boot$ $since$ $device$ $is$ $working$ $bit$ $faster$ $and$ $MS$ $has$ $time$ $to$ $process$ $those$ $calls$ $as$ $they$ $arrive$, $but$ $not$ $when$ $device$ $is$ $busy$ ($processing$ $something$).

    So it might be a webOS 2.2 bug or just that Pre3 is faster and hence it sends notification about wifi connection before it gets a read on about ssid. So until I figure out how to make JSJSJS $services$ $have$ $a$ $process$ $queue$ $I$ $can$ $not$ $make$ $this$ $work$ $fully$ $for$ $everyone$. $For$ $example$ $with$ $my$ $network$ $and$ $current$ $condition$ $of$ $my$ $Pre3$ $this$ $happens$ $only$ $one$ $times$ $out$ $of$ $ten$. $I$.$e$. $in$ $other$ $occasions$ $the$ $wifi$ $status$ $is$ $reported$ $with$ $one$ $call$ $and$ $not$ $two$.

    I will continue to look into the JSJSJS $services$ $if$ $there$ $is$ $a$ $way$ $to$ $make$ $the$ $queue$ $work$, $since$ $I$ $really$ $want$ $it$ $in$ $since$ $the$ $problem$ $also$ $exists$ $for$ $people$ $that$ $use$ $lots$ $of$ $triggers$ $that$ $some$ $of$ $the$ $trigger$ $calls$ $might$ $get$ $ignored$ $due$ $to$ $MS$ $not$ $being$ $able$ $to$ $process$ $triggers$ $that$ $arrive$ $almost$ $at$ $the$ $same$ $time$. $If$ $there$ $is$ $a$ $JS$ $service$ $guru$ $that$ $knows$ $a$ $way$ $to$ $do$ $this$ $please$ $let$ $me$ $know$

    EDIT: and the reason why those <2.4.0 versions might work bit better is that with those version I ignored wifi calls with changed ssid (i.e. trigger did not work when switching networks) but also with those older versions the trigger might get ignored some times since it still wakes MS for processing two triggers but MS ignores the other due to not being intrest to it so the processing is bit faster. But again even with the older version its not 100% sure it works always since the same problem still exists, i.e. MS is woken up to process same trigger twice.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  10. #850  
    Quote Originally Posted by sconix View Post
    So I have studied the wifi ssid trigger problem.
    Let's see if I've undestood correctly your very detailed explanation.

    webOS 2.2.0 reports wifi connection in two phase, first notification about wifi being connected and then a second one with wifi being connected to a certain ssid
    That's different from older versions, and it indeed might cause issues with applications. But it's not bad in itself, I'd say it's simply better, more complete.

    when those two notification arrive almost at the same time MS gets confused
    Aha.

    make JSJSJS $services$ $have$ $a$ $process$ $queue$
    Sounds like quite a bit of work, for something that was alright until now. Not appealing.

    What about if you split your WiFi triggers in two? One for simple connection, and a separate one for connection to specific SSID. If you think that's horrid, I think the same, though.

    some of the trigger calls might get ignored due to MS not being able to process triggers that arrive almost at the same time.
    So the chance that applications can miss events really exists. It's a bad general situation, and surely the solution would be a lower layer (JSJSJS $service$) $that$ $enqueues$ $events$, $to$ $assure$ $not$ $a$ $single$ $one$ $is$ $missed$ $by$ &$quot$;$distracted$&$quot$; $applications$. $If$ $you$ $manage$ $to$ $do$ $it$, $you$'$ll$ $be$ $a$ $proud$ $programmer$!
  11.    #851  
    Quote Originally Posted by jcmarcos View Post
    Let's see if I've undestood correctly your very detailed explanation.



    That's different from older versions, and it indeed might cause issues with applications. But it's not bad in itself, I'd say it's simply better, more complete.



    Aha.



    Sounds like quite a bit of work, for something that was alright until now. Not appealing.

    What about if you split your WiFi triggers in two? One for simple connection, and a separate one for connection to specific SSID. If you think that's horrid, I think the same, though.



    So the chance that applications can miss events really exists. It's a bad general situation, and surely the solution would be a lower layer (JSJSJS $service$) $that$ $enqueues$ $events$, $to$ $assure$ $not$ $a$ $single$ $one$ $is$ $missed$ $by$ &$quot$;$distracted$&$quot$; $applications$. $If$ $you$ $manage$ $to$ $do$ $it$, $you$'$ll$ $be$ $a$ $proud$ $programmer$!
    Yes its not like the webOS 2.2.0 is working wrongly. In a way its better now as you said, but worse for MS. Splitting the trigger wont help, since I can not sign in to only connection notifications or connectiong with ssid notifications. Its the same activity that notifies MS.

    And its not that the applications (or services in this case) miss the events, they don't actually miss anything. Its the fact that the commands that services receive are processed separately. I still believe that there is a way to synchronize the service somehow its just that I don't yet know how, and all services I have seen don't need such a thing.

    But actually now thanks to Rod I think I know how to make this work perfectly. I actually think this will work, as the end result we would have a MS service thats 100% reliable So keep your fingers crossed that this works. I actually tried this couple months a go, but did not get it to work back then, but now I see what I did wrong. Its always good to learn new things Too bad this was buried so deep in the documentation that I was only able to find it now when someone told me about such thing existing.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  12. #852  
    Quote Originally Posted by sconix View Post
    Splitting the trigger wont help, since I can not sign in to only connection notifications or connectiong with ssid notifications.
    Oh. Well, it was a crude idea anyway.

    I still believe that there is a way to synchronize the service somehow its just that I don't yet know how, and all services I have seen don't need such a thing.
    Sure, it's not an easy task. I was thinking that, even if you queue events in the service, perhaps there's not a way of knowing if the application has acknowledged it.

    now thanks to Rod I think I know how to make this work perfectly.
    Woohoo! Would you share some juicy details here, or is it too technical/boring?
  13.    #853  
    Quote Originally Posted by jcmarcos View Post
    Oh. Well, it was a crude idea anyway.



    Sure, it's not an easy task. I was thinking that, even if you queue events in the service, perhaps there's not a way of knowing if the application has acknowledged it.



    Woohoo! Would you share some juicy details here, or is it too technical/boring?
    Well its not, its more like too obvious that I might be embarrassed by the fact not knowing about it Well lets see first if this works before I share the fix.

    EDIT: yes it works, so there should be new release if not today then tomorrow that has perfectly working service Its nice to know that services can have global data across the command assistants and in addition a service assistant. Now I can make MS process requests one by one so no more race conditions etc. This should mean that now on triggers work every time. And I can finally implement the trigger delays back
    Last edited by sconix; 09/19/2011 at 10:33 AM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  14.    #854  
    I just finished implementing the queue for MS and so far it looks to work perfectly. But since this is quite big change I will release this first into beta feed later today. I hope someone of you who have the SSID wifi trigger problem could test this beta version (2.4.5) and report back to me if it works. When I have heard couple success stories I will push it into stable feed.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  15. Kratus's Avatar
    Posts
    522 Posts
    Global Posts
    536 Global Posts
    #855  
    And I can finally implement the trigger delays back
    That sounds great!



    -- Envoyé depuis mon HP TouchPad avec Communities
    "I disapprove of what you say, but I will defend to the death your right to say it".
    Voltaire, french writer and Philosopher, 1694-1778

    French translator of UberCalendar, sconix's advanced patches, Twithibition, AuctionMate, Communities, Headlines 2, OrganizeMe!, Homebrew Google Maps, and many other webOS apps.
  16.    #856  
    So anyone with the SSID trigger not working tried the beta version?
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  17. chris42's Avatar
    Posts
    170 Posts
    Global Posts
    171 Global Posts
    #857  
    Sorry for the dumb question: Where do I get the beta? Do I need to uninstall the old stuff?
  18. Kratus's Avatar
    Posts
    522 Posts
    Global Posts
    536 Global Posts
    #858  
    Quote Originally Posted by chris42 View Post
    Sorry for the dumb question: Where do I get the beta? Do I need to uninstall the old stuff?
    You have to enable the beta feeds in preware.
    See directions here:
    Testing Feeds - WebOS Internals
    "I disapprove of what you say, but I will defend to the death your right to say it".
    Voltaire, french writer and Philosopher, 1694-1778

    French translator of UberCalendar, sconix's advanced patches, Twithibition, AuctionMate, Communities, Headlines 2, OrganizeMe!, Homebrew Google Maps, and many other webOS apps.
  19.    #859  
    Quote Originally Posted by chris42 View Post
    Sorry for the dumb question: Where do I get the beta? Do I need to uninstall the old stuff?
    See here how to enable beta feed. So no need to uninstall, it shows as an update when feed is enabled.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  20. Kratus's Avatar
    Posts
    522 Posts
    Global Posts
    536 Global Posts
    #860  
    Quote Originally Posted by sconix View Post
    So anyone with the SSID trigger not working tried the beta version?
    I installed v2.4.6 from the beta feed this morning.
    I already sent you logs.

    After just a few hours of real life testing, at home and at work, it does not work better.After device restart, it works well the first time, but WiFi SSID triggers do not work after that, or very rarely.
    I have to return to work now, but I'll try to send you some more logs and some more details this evening.

    Thank you for your work.
    "I disapprove of what you say, but I will defend to the death your right to say it".
    Voltaire, french writer and Philosopher, 1694-1778

    French translator of UberCalendar, sconix's advanced patches, Twithibition, AuctionMate, Communities, Headlines 2, OrganizeMe!, Homebrew Google Maps, and many other webOS apps.

Posting Permissions