Page 25 of 56 FirstFirst ... 15202122232425262728293035 ... LastLast
Results 481 to 500 of 1104
Like Tree24Likes
  1.    #481  
    Quote Originally Posted by Zahid View Post
    Sconix -
    I was never able to get the above to work. Now I've just upgraded from 2.2.something to 3.2.2, and (as recommended) I exported all my modes before doing so. After the upgrade, I tried to import them, and again it doesn't work--though the symptom is different this time. It appears my Google Docs login works, because it takes me to a scene with a header reading "Import All Modes", but the scene is otherwise blank.

    I've attached screen shots (though I doubt they'll be helpful!) Any idea what's going on here?
    The instructions says that export modes after upgrading since the new MS can not import modes exported by older versions, which you are trying. The configuration stays when upgrading so there is no need to export modes before upgrading. So if you export the modes from the 2.3.2 you will be able to import them as well. Let me know if you are not able to import modes exported with this version, but I gave this new export/import routine quite much testing so it should work.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  2. #482  
    Sconix I am running 2.3.2 and for some reason mode switcher won't fire the GPS. I haven't had any issues with previous builds just the latest one. I have a mode for my gps dependent and data apps. It will fire up the data but gps never comes on.
  3.    #483  
    Quote Originally Posted by mamouton View Post
    Sconix I am running 2.3.2 and for some reason mode switcher won't fire the GPS. I haven't had any issues with previous builds just the latest one. I have a mode for my gps dependent and data apps. It will fire up the data but gps never comes on.
    Well there has been no changes to the settings applying mechanism, so its just the WebOS radio problem bug that is causing the problem. I would like to this happening to me so that I could see if there is anything I can do to go around this problem in WebOS. Since based on what I have seen with the radio's API it is possible that the service is informing MS that the radio setting is already on even if it isn't. If this is the case then I could add extra toggling into MS to fix the state. But since it is not happening to me I can not. You could send me logs (problem report) though from the mode change so I could see if the log tells anything.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  4. #484  
    Quote Originally Posted by sconix View Post
    MS wont apply settings that are same in previous mode and the mode being switched to. This is due to making MS as optimal as possible regarding the amount of system requests needed on mode change. And also partly so that manual changes to settings carry on between modes. But there is a way to override this, just go extensions from app menu of MS and select application extension. From there you can set per extension if they should always apply the settings even they are the same in the previous and new mode.
    Ok, that worked but I have to set the Default mode screen brightness lower than all of my modes to make the modes change screen brightness.

    I have three modes 5%, 50%, 100% brightness. I set the default to minimum and they all work. If I set default to 30%, the 5 % mode does not change the brightness to lower than 30% but both the 50% and 100% modes change brightness.

    Thanks!
  5. #485  
    Log sent.
  6.    #486  
    Quote Originally Posted by gsparks2 View Post
    Ok, that worked but I have to set the Default mode screen brightness lower than all of my modes to make the modes change screen brightness.

    I have three modes 5%, 50%, 100% brightness. I set the default to minimum and they all work. If I set default to 30%, the 5 % mode does not change the brightness to lower than 30% but both the 50% and 100% modes change brightness.

    Thanks!
    That does not make any sense, it should not matter what the brightness is in default mode. At least it works for me no matter what I set the brightness to. Have you tried reboot or checked from the screenlock app that it really does not change the setting? This just seems even too weird to be a WebOS bug.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  7.    #487  
    Quote Originally Posted by mamouton View Post
    Log sent.
    Haven't received any email, are you sure the email was sent.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  8. #488  
    Quote Originally Posted by sconix View Post
    That does not make any sense, it should not matter what the brightness is in default mode. At least it works for me no matter what I set the brightness to. Have you tried reboot or checked from the screenlock app that it really does not change the setting? This just seems even too weird to be a WebOS bug.
    RESOLVED: I had my 5% mode brightness setting set to Default although the slider was at minimum. I changed the drop down from Default to Minimum and all works consistently now. I apologize for wasting your brain cells on this.
    Last edited by gsparks2; 05/30/2011 at 08:06 AM. Reason: spelling
  9.    #489  
    Quote Originally Posted by gsparks2 View Post
    RESOLVED: I had my 5% mode brightness setting set to Default although the slider was at minimum. I changed the drop down from Default to Minimum and all works consistently now. I apologize for wasting your brain cells on this.
    No worries, glad that you got it sorted out. The slider usage is bit wonky, I have thought about fixing the slider widget so that I could do what I want, but decided to wait and see how its in enyo.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  10. carrel's Avatar
    Posts
    425 Posts
    Global Posts
    426 Global Posts
    #490  
    Quote Originally Posted by mamouton View Post
    Sconix I am running 2.3.2 and for some reason mode switcher won't fire the GPS. I haven't had any issues with previous builds just the latest one. I have a mode for my gps dependent and data apps. It will fire up the data but gps never comes on.
    I am having this problem on my Pre- and I think I have found a way to reliably reproduce it.

    In my default mode under connection settings, I have Phone, Data, WiFi and GPS enabled and I have bluetooth disabled. Now I create a very simple new mode called "Test". The mode type is normal and for automation I select "By Selection". In Settings, I only set connection settings and I set Phone and Data enabled and WiFi, Bluetooth and GPS disabled. Now I exit MS, wait a bit and then go to the Mode Menu. It says I am using default mode, so I enable the Test mode. WiFi does turn off, but GPS does not. I disable, re-enable as much as I like and the behavior is consistent.

    Now I go back into MS and I edit my "Test" mode so that Phone, Data and WiFi are enabled, and Bluetooth and GPS are disabled. I exit MS, wait a bit and then manually select my Test mode. This time the GPS does go off. The behavior is consistent. I can disable/re-enable and it does the same thing. I can also go back and edit the mode the way it was in the previous paragraph and I get the behavior from the previous paragraph.

    I'm not sure if changing the WiFi state is preventing the GPS state from changing or if the fact that the Bluetooth state is not changing (it is off in both the default and Test modes, and it is located between WiFi and GPS) is causing MS to think it is done, or if I am just guessing wildly ;-) .

    Thanks!!!

    Dave
  11.    #491  
    Quote Originally Posted by carrel View Post
    I am having this problem on my Pre- and I think I have found a way to reliably reproduce it.

    In my default mode under connection settings, I have Phone, Data, WiFi and GPS enabled and I have bluetooth disabled. Now I create a very simple new mode called "Test". The mode type is normal and for automation I select "By Selection". In Settings, I only set connection settings and I set Phone and Data enabled and WiFi, Bluetooth and GPS disabled. Now I exit MS, wait a bit and then go to the Mode Menu. It says I am using default mode, so I enable the Test mode. WiFi does turn off, but GPS does not. I disable, re-enable as much as I like and the behavior is consistent.

    Now I go back into MS and I edit my "Test" mode so that Phone, Data and WiFi are enabled, and Bluetooth and GPS are disabled. I exit MS, wait a bit and then manually select my Test mode. This time the GPS does go off. The behavior is consistent. I can disable/re-enable and it does the same thing. I can also go back and edit the mode the way it was in the previous paragraph and I get the behavior from the previous paragraph.

    I'm not sure if changing the WiFi state is preventing the GPS state from changing or if the fact that the Bluetooth state is not changing (it is off in both the default and Test modes, and it is located between WiFi and GPS) is causing MS to think it is done, or if I am just guessing wildly ;-) .

    Thanks!!!

    Dave
    Well I have suspected that it might be the fact that other radio states are changed at the same time that causes the problem. But now when you described that it actually might be that the errors I have seen about the wifi/bt state already being what MS is requesting that could actually cause the chain to abort (i.e. the gps state would not be set at all). I will try something for 2.3.3 testing release. Please try that versions once out (should be tomorrow) and let me know does it work any better.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  12. #492  
    log resent. I am not sure what happened.
  13. chris42's Avatar
    Posts
    170 Posts
    Global Posts
    171 Global Posts
    #493  
    Hi Sconix,
    I send you logs on a not triggered battery trigger. It actually never fired until the battery was completely depleted.
    Got the E-Mail?

    Thanks
    Chris
  14.    #494  
    Quote Originally Posted by chris42 View Post
    Hi Sconix,
    I send you logs on a not triggered battery trigger. It actually never fired until the battery was completely depleted.
    Got the E-Mail?

    Thanks
    Chris
    Yes I did, and I just now figured out why battery trigger is sometimes skipped or at least why its not on time. I will release updated system prefs patch that fixes the battery trigger (hopefully).
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  15. #495  
    I just started using MS and I really am enjoying it... except for one thing that is making me nutso.

    For whatever reason, it keeps kicking my screen on. I can turn my screen off, put the phone down, and within 30 seconds it turns back on. It doesn't actually DO anything, though. It just sits there with the screen on. During the day it's not so much of a problem (besides battery drain), but now I have a night light I don't want.

    I really don't want to uninstall MS, but this is making me crazy.
  16.    #496  
    Quote Originally Posted by katefields View Post
    I just started using MS and I really am enjoying it... except for one thing that is making me nutso.

    For whatever reason, it keeps kicking my screen on. I can turn my screen off, put the phone down, and within 30 seconds it turns back on. It doesn't actually DO anything, though. It just sits there with the screen on. During the day it's not so much of a problem (besides battery drain), but now I have a night light I don't want.

    I really don't want to uninstall MS, but this is making me crazy.
    Well I can say 100% certainty that its not MS doing that. There just ain't such code in MS that could turn on the screen. The only way is if your modes use banner notification then screen is turned on momentarily when mode changes other than that it just cannot be MS. So you should look for the reason somewhere else.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  17. #497  
    Using MS v2.3.2 here, getting the "Unknown Service Error! Mode Switcher service not responding." popup alert repeatedly. I have uninstalled and reinstalled, both actions via Preware, and rebooted twice (per the Wiki) - still have issue. Also tried the three commands manually in the Wiki - still have issue. Tried another couple of reboots after the manual commands - still have issue. Please advise. Thanks!
  18. #498  
    I got it! It was actually a setting in MS.

    I went to Mode Configuration view, tapped "Settings" and in the Preferences box there is a setting for "Behavior". For "On Charger" I had it set to "Always On". I switched it to "Turn Off" and tested it. The screen stayed off!

    So I went back, set it back to "Always On" and did a test. Within 7 seconds the screen turned on.

    Sorry for posting before I played around a little. But maybe that can help someone else.
  19.    #499  
    Quote Originally Posted by SilvrDrgn View Post
    Using MS v2.3.2 here, getting the "Unknown Service Error! Mode Switcher service not responding." popup alert repeatedly. I have uninstalled and reinstalled, both actions via Preware, and rebooted twice (per the Wiki) - still have issue. Also tried the three commands manually in the Wiki - still have issue. Tried another couple of reboots after the manual commands - still have issue. Please advise. Thanks!
    Please send problem report right after you get the popup. Also tell me in what situations you get it.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  20.    #500  
    Quote Originally Posted by katefields View Post
    I got it! It was actually a setting in MS.

    I went to Mode Configuration view, tapped "Settings" and in the Preferences box there is a setting for "Behavior". For "On Charger" I had it set to "Always On". I switched it to "Turn Off" and tested it. The screen stayed off!

    So I went back, set it back to "Always On" and did a test. Within 7 seconds the screen turned on.

    Sorry for posting before I played around a little. But maybe that can help someone else.
    I see you have MS 1.x, it has its own thread. Anyway good that you got it solved since I have ended support for that version quite long time a go.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.

Posting Permissions