Page 54 of 66 FirstFirst ... 444495051525354555657585964 ... LastLast
Results 1,061 to 1,080 of 1313
Like Tree1Likes
  1. #1061  
    Sanjay:

    What are your settings for ts removal?

    Nevermind: oak.. You beat me to it
    _______________________________________________________________________________________
    Patches Added to Preware: Fixed Keyboard Brightness 25, Fixed Keyboard Brightness 50, & Fixed Keyboard Brightness 100.
    @webOSdealer : A Day In My Life, #MaskAppeal Video - Enjoy
  2. #1062  
    Quote Originally Posted by webOSdealer View Post
    Sanjay:

    What are your settings for ts removal?

    Nevermind: oak.. You beat me to it


    Here is the response again in case it is missed from being the last post before the thread jumped to a new page...

    Quote Originally Posted by Sanjay View Post
    I have been facing a problem since v1.45.89 (could be since the previous version but not sure), but I waited for the problem to reoccur a few times before I reported it. Even though in 'Preferences' under 'Automation' I have the 'Speakerphone' set to 'Only Manually', the phone switches to the speakerphone when I answer the phone. This happens only sometimes and not always, although I am not sure but it seems to happen when I answer the phone by taking it off the touchstone.

    The normal/default webOS action when picking up the phone from a TS during or getting a call will answer the call.

    In the Phone Preferences, what do you have the ON TS REMOVAL setting set to? Change it to Do Nothing to over-ride the default webOS behavior.

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  3. #1063  
    Quote Originally Posted by oakridge outdoors View Post
    Quote Originally Posted by Sanjay View Post
    I have been facing a problem since v1.45.89 (could be since the previous version but not sure), but I waited for the problem to reoccur a few times before I reported it. Even though in 'Preferences' under 'Automation' I have the 'Speakerphone' set to 'Only Manually', the phone switches to the speakerphone when I answer the phone. This happens only sometimes and not always, although I am not sure but it seems to happen when I answer the phone by taking it off the touchstone.
    The normal/default webOS action when picking up the phone from a TS during or getting a call will answer the call.

    In the Phone Preferences, what do you have the ON TS REMOVAL setting set to? Change it to Do Nothing to over-ride the default webOS behavior.
    If you were to read my post more carefully, you will realize that you have misunderstood the problem. I know that the default webOS action when picking up the phone from a TS, is to answer the call. I don't have a problem with that, infact that is how I want it to be and which is why I have in the 'Phone app' in 'Preferences' under 'Automation' set the 'On TS Removal' to 'Answer Call'. The problem is, when the phone rings with the phone on the TS and I pick up the phone to answer it, the phone answers with the speakerphone on, which is not what I want. I would like the phone to answer with the regular front speaker and not the speakerphone. Which is why in 'Preferences' under 'Automation' I have the 'Speakerphone' set to 'Only Manually'. I hope I have been able to make myself clearer this time.

    PS: The problem only occours sometimes and not always.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  4. #1064  
    Quote Originally Posted by Sanjay View Post
    If you were to read my post more carefully, you will realize that you have misunderstood the problem. I know that the default webOS action when picking up the phone from a TS, is to answer the call. I don't have a problem with that, infact that is how I want it to be and which is why I have in the 'Phone app' in 'Preferences' under 'Automation' set the 'On TS Removal' to 'Answer Call'. The problem is, when the phone rings with the phone on the TS and I pick up the phone to answer it, the phone answers with the speakerphone on, which is not what I want. I would like the phone to answer with the regular front speaker and not the speakerphone. Which is why in 'Preferences' under 'Automation' I have the 'Speakerphone' set to 'Only Manually'. I hope I have been able to make myself clearer this time.

    PS: The problem only occours sometimes and not always.
    Sanjay:

    This happens to me when I click the the screen to answer the call and then lift the phone off ts to talk.

    I believe this is because by default if you answer the phone while on a TS, it defaults to speaker.

    If the answering process and the removal happen in the wrong order, the wrong reaction can be set into place... Hence speaker sometimes and sometimes not.
    Last edited by webOSdealer; 10/22/2010 at 02:58 PM.
    _______________________________________________________________________________________
    Patches Added to Preware: Fixed Keyboard Brightness 25, Fixed Keyboard Brightness 50, & Fixed Keyboard Brightness 100.
    @webOSdealer : A Day In My Life, #MaskAppeal Video - Enjoy
  5. #1065  
    Quote Originally Posted by Sanjay View Post
    If you were to read my post more carefully, you will realize that you have misunderstood the problem. I know that the default webOS action when picking up the phone from a TS, is to answer the call. I don't have a problem with that, infact that is how I want it to be and which is why I have in the 'Phone app' in 'Preferences' under 'Automation' set the 'On TS Removal' to 'Answer Call'. The problem is, when the phone rings with the phone on the TS and I pick up the phone to answer it, the phone answers with the speakerphone on, which is not what I want. I would like the phone to answer with the regular front speaker and not the speakerphone. Which is why in 'Preferences' under 'Automation' I have the 'Speakerphone' set to 'Only Manually'. I hope I have been able to make myself clearer this time.

    PS: The problem only occours sometimes and not always.
    Until you clarified in your follow-up post exactly what you were wanting to happen, I understood and responded to your original post as it was posted.

    The problem is, when the phone rings with the phone on the TS and I pick up the phone to answer it, the phone answers with the speakerphone on, which is not what I want.
    When you say "pick up the phone", do you mean:

    Physically lift the phone off of the TS to answer or You answer ("pick up") the call while the phone is on the TS, then lift it from the TS?

    Physically lifting the phone from the TS to answer a call should not put the phone into speakerphone mode. If that is what is happening to you, then you have some other issue going on.

    If you are answering the call while on the TS, then lifting it from TS, the phone should answer in speakerphone mode while still on the TS, then flip to the ear speaker (after a short delay) after being taken off of the TS.
    Last edited by oakridge outdoors; 10/22/2010 at 02:44 PM. Reason: trying to clarify my questions to get clarification from poster so that better help can be provided.

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  6. #1066  
    Quote Originally Posted by webOSdealer View Post
    Sanjay:

    This happens to me when I click the the screen to answer the call and then lift the phone off ts to talk.

    I believe this is because by default if you answer the phone while on a TS, it defaults to speaker.

    If the answering process and the removal happen in the wrong order, the wrong reaction can be set into place... Hence speaker sometimes and sometimes not.
    Well you beat me to it this time around. I guess I ended up saying the same thing, just not as condensed.

    Happy Friday!

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  7. #1067  
    Quote Originally Posted by oakridge outdoors View Post
    Well you beat me to it this time around. I guess I ended up saying the same thing, just not as condensed.

    Happy Friday!
    Anytime. ; ) been using Forums Beta App to reply from work so not as quick as you most of the time.
    _______________________________________________________________________________________
    Patches Added to Preware: Fixed Keyboard Brightness 25, Fixed Keyboard Brightness 50, & Fixed Keyboard Brightness 100.
    @webOSdealer : A Day In My Life, #MaskAppeal Video - Enjoy
  8. #1068  
    Quote Originally Posted by webOSdealer View Post
    Anytime. ; ) been using Forums Beta App to reply from work so not as quick as you most of the time.
    I have not messed with that much, but have it to look at later. Being in front of a computer all day has some benefits (not sure if being on the forums all day counts as one though...)

    For more information on Sconix's (@therealsconix/@modeswitcher) webOS collective work... visit here.

    "Those convinced against their will are of the same opinion still." - Dale Carnegie
  9. mad_cow's Avatar
    Posts
    24 Posts
    Global Posts
    29 Global Posts
    #1069  
    Quote Originally Posted by tobias funke View Post
    According to the wiki: no.

    Someone posted an unsupported workaround in the messaging plugin thread. Use at your own risk.
    found nothing.
  10. #1070  
    We should do this! Its a text message privacy patch.
    Then we should put an on and off feature in the texting preferences.

    http://forums.precentral.net/webos-p...e-privacy.html
  11. #1071  
    Quote Originally Posted by sconix View Post
    Not sure if any of the disabling part of the system sound patches are compatible. I would think that the phone keypad remove patch is. I just disable all system sounds, never liked the idea of phone making sounds. Maybe in future there is toggle to disable part of the system sounds.
    Thanks Sconix. There is a patch that disables the sound on the keypad and it does not conflict with yours. It took care of my issue.


    "How art thou, thou globby bottle of cheap, stinking chip oil? Come and get one in the yarbles, if ya have any yarbles, you eunuch jelly thou!"
  12.    #1072  
    Quote Originally Posted by Sanjay View Post
    If you were to read my post more carefully, you will realize that you have misunderstood the problem. I know that the default webOS action when picking up the phone from a TS, is to answer the call. I don't have a problem with that, infact that is how I want it to be and which is why I have in the 'Phone app' in 'Preferences' under 'Automation' set the 'On TS Removal' to 'Answer Call'. The problem is, when the phone rings with the phone on the TS and I pick up the phone to answer it, the phone answers with the speakerphone on, which is not what I want. I would like the phone to answer with the regular front speaker and not the speakerphone. Which is why in 'Preferences' under 'Automation' I have the 'Speakerphone' set to 'Only Manually'. I hope I have been able to make myself clearer this time.

    PS: The problem only occours sometimes and not always.
    I am pretty sure that this patch should not effect to this, since if you have the speakerphone setting set to manual the switch to speakerphone should not happen because of the patch. Since even if the setting would not be read properly the default action is not to use the proximity thing. But I will still look into this to be sure.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  13. #1073  
    Quote Originally Posted by Sanjay View Post
    I know that the default webOS action when picking up the phone from a TS, is to answer the call. I don't have a problem with that, infact that is how I want it to be and which is why I have in the 'Phone app' in 'Preferences' under 'Automation' set the 'On TS Removal' to 'Answer Call'. The problem is, when the phone rings with the phone on the TS and I pick up the phone to answer it, the phone answers with the speakerphone on, which is not what I want.
    Quote Originally Posted by oakridge outdoors View Post
    When you say "pick up the phone", do you mean:

    Physically lift the phone off of the TS to answer or You answer ("pick up") the call while the phone is on the TS, then lift it from the TS?
    I thought I was clear enough in stating "pick up the phone to answer it", that I was referring to "physically lifting the phone off of the TS to answer" the call. Please excuse me if the English is not clear enough, it is but a second language for me.
    Quote Originally Posted by webOSdealer View Post
    This happens to me when I click the the screen to answer the call and then lift the phone off ts to talk.

    I believe this is because by default if you answer the phone while on a TS, it defaults to speaker.
    Quote Originally Posted by oakridge outdoors View Post
    Physically lifting the phone from the TS to answer a call should not put the phone into speakerphone mode. If that is what is happening to you, then you have some other issue going on.

    If you are answering the call while on the TS, then lifting it from TS, the phone should answer in speakerphone mode while still on the TS, then flip to the ear speaker (after a short delay) after being taken off of the TS.
    I am familiar with the standard/default functioning of webOS regarding this. My problem is that, inspite of my wanting it to, the phone is not behaving as per it's standard/default behaviour.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  14. #1074  
    Quote Originally Posted by sconix View Post
    I am pretty sure that this patch should not effect to this, since if you have the speakerphone setting set to manual the switch to speakerphone should not happen because of the patch. Since even if the setting would not be read properly the default action is not to use the proximity thing. But I will still look into this to be sure.
    I understand your aprehensions but please bear with mine. I have had the very same set of patches and programs on my phone from before ACSP. When you first added the ability to set 'Speakerphone' = 'Using Proximity' in the phone 'Preferences' under 'Automation'. I had selected that. But then I personally found the feature to be a little buggy or shall I say not very refined and encountered the speakerphone coming on at times that I did not like. So I switched the 'Speakerphone' to 'Manually only' to get back the standard/default webOS functionality. But apparently for some reason, upon 'lifting the phone off of the TS to answer an incoming call', at times the phone seems to behave as it would if I had set the 'Speakerphone' to 'Using Proximity'. I think I have noticed this problem only after the last update (v1.45.89) or at the most from after the previous update. As mentioned before, the problem is not consistent and occurs only once in a while. Thank you for patience and efforts.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  15.    #1075  
    Quote Originally Posted by Sanjay View Post
    I understand your aprehensions but please bear with mine. I have had the very same set of patches and programs on my phone from before ACSP. When you first added the ability to set 'Speakerphone' = 'Using Proximity' in the phone 'Preferences' under 'Automation'. I had selected that. But then I personally found the feature to be a little buggy or shall I say not very refined and encountered the speakerphone coming on at times that I did not like. So I switched the 'Speakerphone' to 'Manually only' to get back the standard/default webOS functionality. But apparently for some reason, upon 'lifting the phone off of the TS to answer an incoming call', at times the phone seems to behave as it would if I had set the 'Speakerphone' to 'Using Proximity'. I think I have noticed this problem only after the last update (v1.45.89) or at the most from after the previous update. As mentioned before, the problem is not consistent and occurs only once in a while. Thank you for patience and efforts.
    Yes, but its still possible that the bug is in Palm's code. For example the touchstone option that I have added is only in a function that is executed only in a specific situation that phone has been on TS and is removed and when answered it still checks if the phone is off TS before executing the speakerphon switch. So that part of my patch cannot be the reason since that function should not be even called and if it is then its a error in Palm's code. So that one is out of the questions when it comes to this patch. Then the seconds place in the patch that could effect to this is the proximity speakerphone code. That code is inside one if sentence which requires the setting to be set to proximity so that the new code would be used and if this would be the case you would see in your preferences that the option is enabled. So this part of the patch is also out of the question. The third and the last part that could have anything to do with this is the handling of connecting the TS again after answering. This is also Palm's code and the function is only called if the phone has been out of the TS and then connected back. So there just isn't code in this patch that will execute speakerphone switch without being inside of Palm code.

    So my guess is that your disconnection from TS is not "clean" and the phone receives TS disconnect/connect/disconnect event which then executes the speakerphone switch. The charger connection reporting is not exact and something like that could very easily happen. So my guess is that your phone when it does the speakerphone on answer is under a small load for some reason and these charger events wont get correctly executed (fast enough) so that it has time to actually execute the connect event in the middle.

    So I am 99% sure that this problem comes from that so the problem lies in the Palm's code that does not take it properly into consideration that these events would happen this way.

    I am all in to fix all problems weather its error in my code or Palm, but since the 2.0 is so close let see if it fixes this problem. If not please do report this again and I will try to find and fix it.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  16. #1076  
    Quote Originally Posted by sconix View Post
    So my guess is that your disconnection from TS is not "clean" and the phone receives TS disconnect/connect/disconnect event which then executes the speakerphone switch. The charger connection reporting is not exact and something like that could very easily happen. So my guess is that your phone when it does the speakerphone on answer is under a small load for some reason and these charger events wont get correctly executed (fast enough) so that it has time to actually execute the connect event in the middle.

    So I am 99% sure that this problem comes from that so the problem lies in the Palm's code that does not take it properly into consideration that these events would happen this way.

    I am all in to fix all problems weather its error in my code or Palm, but since the 2.0 is so close let see if it fixes this problem. If not please do report this again and I will try to find and fix it.
    Thanks for the very detailed explanation. I shall try and keep a more watchful tab on this issue and in case I have any more pertinent information I shall get back to you. Thanks once again. You are by far the most helpful programmers/patchers I have had the privilege of interacting with.
    Pre3 (AT&T meta-doctored to ROW) webOS 2.2.4 build 3175
    TouchPad WiFi (32GB) - webOS 3.0.5 build 86
    App Catalog (US) - Vodafone (India)

    Treo 180 > 270 > 600 > 650 > 680 > Pre+ > Pre2 > Pre+ > Pre3 & tPad
  17. elryon's Avatar
    Posts
    715 Posts
    Global Posts
    720 Global Posts
    #1077  
    Sonix, I'm not sure if it's been mentioned here, but I have gotten emails about the blocked caller function not working when your on a call and the setting is to hangup. I have created a small patch to 'patch' your patch, lol. Please feel free to use the mod in your next update. Love the patch by the way.
    Attached Files Attached Files
    Avatar on Left Patch
    Call Rejecter Patch
    Make your messanger look like the iphone's
    SMS tone per Contact
    No Alert During call

    Thanks are always appreciated or for a really big Thanks you can always:
    (it can go a long way to convince my fiancee that this is worth my time)

    Please feel free to PM for more direct assistance.
  18.    #1078  
    Quote Originally Posted by elryon View Post
    Sonix, I'm not sure if it's been mentioned here, but I have gotten emails about the blocked caller function not working when your on a call and the setting is to hangup. I have created a small patch to 'patch' your patch, lol. Please feel free to use the mod in your next update. Love the patch by the way.
    Thanks, I will add this to next version/release. The only reason why I did not yet add this by myself was that here if you are in a call the other caller anyway gets a busy signal so no way for me to test.
    Last edited by sconix; 10/24/2010 at 11:04 AM.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  19. #1079  
    I'm getting a lot more "No Lines Free" messages since adding your patch. This is whether the call I am concerned with is incoming or outgoing. Could this be related to the blocked call issue stated above? In fact sometimes I can't simply add a call for normal conferencing. I blame the carrier usually, but this has never happened before.
  20.    #1080  
    Quote Originally Posted by copasetic View Post
    I'm getting a lot more "No Lines Free" messages since adding your patch. This is whether the call I am concerned with is incoming or outgoing. Could this be related to the blocked call issue stated above? In fact sometimes I can't simply add a call for normal conferencing. I blame the carrier usually, but this has never happened before.
    At least I don't see a way how this patch could effect on the available lines thing. So I am 99% sure that its not this patch causing it and most likely not any of the patches and you blame for carrier is probably right.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.

Posting Permissions