Page 48 of 63 FirstFirst ... 38434445464748495051525358 ... LastLast
Results 941 to 960 of 1246
Like Tree2Likes
  1. #941  
    Quote Originally Posted by notcalvin View Post
    Is there any chance of creating a mode that shuts down mode switcher? It could be triggered by launching Sprint Navigation?

    Does the Disable Mode Triggers option allow Sprint Navigation to function properly?
    Well the only issue I see with a mode that shuts down mode switcher is that then it isn't running, so then it would just go to the default mode or something? Plus then I'd have to re-enable it manually, which kinda defeats the purpose. I could just disable it manually and then re-enable it.

    Good question though about the disable Mode Triggers option. I will test it to see if it makes a difference. That would be easy to toggle whenever I need to use navigation..... I'll test it hopefully later today.
  2. #942  
    What about the option to "block other modes". If I have my car mode set to block other modes, then does that disable the GPS checking since those modes can't start anyway? I'll also test that theory, since I only use sprint navigation in my car.....
  3. #943  
    Quote Originally Posted by cvendra View Post
    I was trying to switch on all radios on device restart. So I created 2 profiles. 1 with radios off and default profile with radios on. I have selected default profile on startup. However on restart, the radios are all off but when I switch modes and back to default, the radios turn on. Can anyone help me on this?
    Default Mode Settings - Misc - On Startup -- be sure it is set to 'Default Mode'
  4. #944  
    Just sort of relaying my experiences here setting up Mode Switcher.

    Firstly, really a great app, well done sconix.

    In my default mode, I had it turn off airplane mode, and I found that often I would have my system menu 'locked up' with the message 'turning off airplane mode' even though it had never been turned on. So I fixed that be setting default for that value to 'Do Not Set'.

    I also found that if I was inside and lost my GPS lock on a GPS triggered mode, it would revert to default mode. I fixed that by making two modes that were modifier modes instead of normal modes, one that would switch to roam only withing 500 meters of a GPS location, and another that would turn off roaming when 'not within' 1000 meters of a location. That seems to be working pretty well.
  5. #945  
    Quote Originally Posted by sconix View Post
    What do you mean optional triggers to close modes? If you mean possibility to set different triggers for starting the mode and for closing then I am not thinking of that at least currently. The groupped functionality is more simpler code wise and should provide the same end result. The groupped triggers works exactly the same way than none groupped ones so if a groupped triggers wont close/start the mode its still one of the triggers giving false info so setting them for only closing or starting would not change anything.
    I used to have a mod mode in which an app in focus triggered turning my bluetooth on. Then I would close the app or minimize or something. Bt would stay on until I turned it off manually later. Now, when I minimize the trigger app, it sometimes turns the mode, and bt, off. Which is how it's supposed to work from what I've read, which works for me for another mode of mine. I think a close trigger that would keep the mode on until the close trigger happened might be useful.

    edit: nevermind I think I found the problem
    Last edited by patricksmangan; 11/12/2010 at 04:16 PM.
  6. #946  
    is there any possibility to turn of the localized version and keep english?
  7. cvendra's Avatar
    Posts
    123 Posts
    Global Posts
    498 Global Posts
    #947  
    Quote Originally Posted by palmuse View Post
    Default Mode Settings - Misc - On Startup -- be sure it is set to 'Default Mode'
    yes, that is selected. But still does not work.
  8. #948  
    Quote Originally Posted by cvendra View Post
    yes, that is selected. But still does not work.
    Sorry, I missed that in your original post.

    I guess I am not sure what could cause that issue.

    Edit: What triggers your radios off mode? Is it possible that it is being triggered after a reset?
    Last edited by palmuse; 11/12/2010 at 10:20 PM.
  9. #949  
    Quote Originally Posted by patricksmangan View Post
    I used to have a mod mode in which an app in focus triggered turning my bluetooth on. Then I would close the app or minimize or something. Bt would stay on until I turned it off manually later. Now, when I minimize the trigger app, it sometimes turns the mode, and bt, off. Which is how it's supposed to work from what I've read, which works for me for another mode of mine. I think a close trigger that would keep the mode on until the close trigger happened might be useful.

    edit: nevermind I think I found the problem
    If you feel like you learned something, please post it so we can benefit from your effort.

    But just a related thought, if you are doing something simple like turning bluetooth on and off you might try using a modifier mode - turn on bluetooth when triggered by abc app, turn off bluetooth when triggered by gps location
  10. #950  
    Quote Originally Posted by palmuse View Post
    Sorry, I missed that in your original post.

    I guess I am not sure what could cause that issue.

    Edit: What triggers your radios off mode? Is it possible that it is being triggered after a reset?
    Something I've found useful when troubleshooting is to change the trigger from something inconvenient like a gps location or a restart to something easy like silent mode on or calculator app launch.

    another suggestion is, if you are doing something complicated, add one feature at a time - on trigger at a time, one setting at a time...
  11. #951  
    Quote Originally Posted by notcalvin View Post
    If you feel like you learned something, please post it so we can benefit from your effort.

    But just a related thought, if you are doing something simple like turning bluetooth on and off you might try using a modifier mode - turn on bluetooth when triggered by abc app, turn off bluetooth when triggered by gps location
    I still think there should be the ability to close modes with a close trigger. All I learned was that another mode of mine was turning off bluetooth when it should have been set to default/do not set, lol.

    right, I think all my modes are modifier modes.

    another thought was to trigger bt on with any audio app/videos. It'd be a pain in the **** to figure out every app that could do that. Could ms eventually have audio media playback as a trigger?the volume rocker only affects media volume when something is playing. How/whatever is making that happen, could that be used as a trigger?
    Last edited by patricksmangan; 11/13/2010 at 09:19 AM.
  12. #952  
    Quote Originally Posted by cvendra View Post
    yes, that is selected. But still does not work.
    I have a somewhat similar setup, but in misc, I have on start up set to "active mode." so unless my phone is in a state (like charging) that will trigger another mode, it'll start on default mode. You should give that a try.
    Quote Originally Posted by palmuse View Post
    Edit: What triggers your radios off mode? Is it possible that it is being triggered after a reset?
    that might be it too.
  13. nxg125's Avatar
    Posts
    48 Posts
    Global Posts
    53 Global Posts
    #953  
    I'm just getting started with Mode Switcher. (I've read through some but not all of the thread so far, apologies if my question has already been answered.)

    To start with, I'd like to set a night mode, where all system sounds are muted. I would, however, like to leave my ringer at normal volume. I figure if I get a call in the middle of the night it's probably something important and I want to be sure I hear it.

    My default mode has all email settings configured per account. My night mode is a normal mode. For Sounds, Ringer is default, System is minimum, and Media is minimum. For email, Alert is vibrate.

    I have found that I'm still hearing my per-account notification alert when I get an email in night mode. Does it sound like I'm setting things up properly, or am I misunderstanding what the different settings mean?
  14.    #954  
    Quote Originally Posted by nxg125 View Post
    I'm just getting started with Mode Switcher. (I've read through some but not all of the thread so far, apologies if my question has already been answered.)

    To start with, I'd like to set a night mode, where all system sounds are muted. I would, however, like to leave my ringer at normal volume. I figure if I get a call in the middle of the night it's probably something important and I want to be sure I hear it.

    My default mode has all email settings configured per account. My night mode is a normal mode. For Sounds, Ringer is default, System is minimum, and Media is minimum. For email, Alert is vibrate.

    I have found that I'm still hearing my per-account notification alert when I get an email in night mode. Does it sound like I'm setting things up properly, or am I misunderstanding what the different settings mean?
    Are you sure that you are using per account email alert configuration? The global email alert configuration is broken, but no one has reported problems with the per account one. I am trying to get 1.1.0 out with the fixed email global alert configuration quite soon.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  15. nxg125's Avatar
    Posts
    48 Posts
    Global Posts
    53 Global Posts
    #955  
    Quote Originally Posted by sconix View Post
    Are you sure that you are using per account email alert configuration? The global email alert configuration is broken, but no one has reported problems with the per account one. I am trying to get 1.1.0 out with the fixed email global alert configuration quite soon.
    OK, I think I have it working now. In my default mode, I went through and made sure the per-account settings were correct (and they were.) In my night mode, I had been using a global configuration set to vibrate. Once I went through and set each account to vibrate, it works as expected. Thanks!
  16. #956  
    sry if this idea has all ready surfaced.

    it would be cool if you could export individual modes as patch files. I'm still fighting with Ms off and on to get it to work the way I want it. Sometimes the triggers seem to just not work, so I've given up for right now, lol. I'm wondering if a mode would be more consistent in behaviour if I could install it as a patch.

    I'll work with ms more later, but I'm giving I a break right now. Don't want to make too much work for either of us.
  17. #957  
    Quote Originally Posted by patricksmangan View Post
    sry if this idea has all ready surfaced.

    it would be cool if you could export individual modes as patch files. I'm still fighting with Ms off and on to get it to work the way I want it. Sometimes the triggers seem to just not work, so I've given up for right now, lol. I'm wondering if a mode would be more consistent in behaviour if I could install it as a patch.

    I'll work with ms more later, but I'm giving I a break right now. Don't want to make too much work for either of us.
    It is probably a good idea to give it a rest. A good idea for troublesome modes is to try one trigger at a time for a while. Get the one working how you like and then add the next piece of the puzzle. I find that I tend to make too many changes at a time.
  18.    #958  
    Quote Originally Posted by patricksmangan View Post
    sry if this idea has all ready surfaced.

    it would be cool if you could export individual modes as patch files. I'm still fighting with Ms off and on to get it to work the way I want it. Sometimes the triggers seem to just not work, so I've given up for right now, lol. I'm wondering if a mode would be more consistent in behaviour if I could install it as a patch.

    I'll work with ms more later, but I'm giving I a break right now. Don't want to make too much work for either of us.
    The converting a mode into patch would not help. The main problem is that some of the request provided by WebOS needed for some triggers are just not that certain. So it does not have a effect whether the request are made by MS or by some system entity. Not sure if you have state changing for BT / Wifi in your modes, if you do then that might be the cause of modes not changing so its not usually fault of the triggers itself.

    WebOS 2.0 has lots of changes regarding this and I am pretty sure everything works much better in WebOS 2.0. But as far as I know the only uncertain trigger should be GPS trigger others should work rather reliably at least they have never failed for me. The only one failed for me is the battery trigger, but that turned out to be fault of the battery which was in such a bad shape that caused the webOS to skip the battery level drops sometimes.
    Developer of Mode Switcher app & Advanced System Menus / System Prefs / Launcher Configuration patches
    - If you like my app or the patches and wish to donate, then use this link. Even small donations are appreciated and will motivate the further development of the Mode Switcher and my patches. For list of all my WebOS related work see here.
  19. Evansgw
    Evansgw's Avatar
    #959  
    Hey Sconix, loving the app and all the other work you are doing.

    I am having trouble with the GPS trigger, I have GPS enabled in default, with other radios off (except phone, so that I can save battery when I am not at home or work, commuting etc).

    The GPS is to Trigger work or Home mode, I've set each location but the trigger doesnt seem to be firing. Any suggestions?

    Also, with the silent switch trigger (for my meeting mode), which one is switch on and which is switch off? I have two triggers (required: All Unique) for time (8-5) and Silent Switch state. The switch is currently off, i.e. the phone isn't in silent, yet at 8 this morning the mode wanted to switch... I must be doing something wrong...
  20. mjsmiley's Avatar
    Posts
    89 Posts
    Global Posts
    101 Global Posts
    #960  
    I love this app. I have a scenerio that I think it could support if the developer is interested in adding a few more functions. When I'm at home, my phone will link up with my Airave and wifi, at that very moment my GPS warps me 5 or more cities away. If I disable "Google Services" under the preferences of the "Location Services" app, I get warped back home.
    I would need a Location Services Mode Switcher setting of: Enable/Disable "Google Services" and then I could maybe make a mode that sets Google Services to off when I'm home. I think a good trigger would be for it to detect what Wifi its mating too, and if its a predesignated one, it triggers the mode.
    I'd like the ability to turn "Google Services" on once I leave the house because it does get my location faster and it seems to be more accurate. But once I get home, it needs to off or I'm virtually teleported away.

    If this is already possible, sorry for the post, any advice would be appreciated. Otherwise, I'll be rooting for this sort of functionality in future updates. Take care.

Posting Permissions