Page 7 of 58 FirstFirst ... 234567891011121757 ... LastLast
Results 121 to 140 of 1151
Like Tree1Likes
  1. #121  
    Quote Originally Posted by orsapps View Post
    The only lag I noticed (as Sconix mentioned) is when moving between the first and last pages where the effect/animation is not present.

    Otherwise moving about the launcher is smooth and fast for me. Just my observation.
    Do you have Quick Launch set to hide when pulling up the Launcher?
    If you found my post useful then please sign up for a Dropbox Account, I could use the extra 250mb of storage.

    HOW TO: Zip/Unzip via Pre/Pixi using Terminal
    HOW TO: Modify DTMF audio (webOS 1.4.5 or earlier)
    Palm Pre wallpapers
  2. #122  
    I could be crazy, but I think I too noticed the lag while bring up the launcher. I had wrapping turned on, just turned it off to see if it makes any difference. I have quick launch bar set to always visible. I have 5 pages. I noticed the lag when running at 720 mhz and 500 mhz.

    Love the patches, thanks!
  3. #123  
    Quote Originally Posted by NachoB View Post
    Do you have Quick Launch set to hide when pulling up the Launcher?
    Yes.

    Here is how I have things:

    App Launcher
    Wrapping Enabled
    Show Page Names

    Quick Launch Bar
    Hide In Launcher

    I have 6 pages in all right now.

    When I swipe the launcher to open, it opens right away.
    When I swipe the launcher to closed, it closes right away.
    When I swipe from page to page, it goes right away.

    The only slight lag I see is when going between the pages where the page wrapping happens. (not an issue for me)

    I checked for the issue running at varying speeds as well.
    This is just my experience.
  4. Zahid's Avatar
    Posts
    109 Posts
    Global Posts
    117 Global Posts
    #124  
    I have the exact same setup as Orsapps and I get the same behavior but I wouldn't call it a lag. It takes about the same time as any other transition, but there's no animation so it feels slower. I'd equate it to the 1.4 launcher behavior, where Palm added animation to launching an app to make it feel faster.
  5. #125  
    How and where can i find the previous version
  6.    #126  
    Quote Originally Posted by nulsul View Post
    I could be crazy, but I think I too noticed the lag while bring up the launcher. I had wrapping turned on, just turned it off to see if it makes any difference. I have quick launch bar set to always visible. I have 5 pages. I noticed the lag when running at 720 mhz and 500 mhz.

    Love the patches, thanks!
    I will look through the code and compare to the 1.4.1-4 that was said to be smooth to see if there is something that could cause it. It is possible that I have forgot to remove some old code and it for example does something twice that causes a bit lag. I will fine tune the app launcher patch during tonight which means that today menu patch has to wait one more day, but I am getting it done as soon as possible so hopefully those waiting for that can wait one more day. And I also added configuration for the resetting page position and setting default page so expect those in the next release of the app launcher patch which should happen tonight. Which hopefully is the final release this time
  7.    #127  
    Quote Originally Posted by buddytammy View Post
    How and where can i find the previous version
    All packages including old versions are in Index of /webos/local/patches
  8. #128  
    Quote Originally Posted by sconix View Post
    All packages including old versions are in Index of /webos/local/patches
    hey thanks. i just want to test the last one to this one on my pre. you ROCK
  9. #129  
    Where do I download the launcher edit patch? I cannot find it in preware ><
  10.    #130  
    Quote Originally Posted by Addyc View Post
    Where do I download the launcher edit patch? I cannot find it in preware ><
    It is in my personal feed until it is ready when I submit it to the WebOS internals feed. I posted information about adding my feed somewhere quite beginning of this thread if I remember correctly.
  11.    #131  
    Quote Originally Posted by buddytammy View Post
    hey thanks. i just want to test the last one to this one on my pre. you ROCK
    If you are testing the lag then I hope that the tonight release should perform better at least I found quite much of old left over code which caused few things called twice for no reason therefore most likely having small effect on performance.
  12. #132  
    Nevermind I found it, sorry.

    I cannot think straight. too much work.

    Exhaustion.
  13. #133  
    Any word on getting the Today menu available for AT&T 1.4.2? Preware says not available.
  14.    #134  
    Quote Originally Posted by TreoAide View Post
    Any word on getting the Today menu available for AT&T 1.4.2? Preware says not available.
    I would like to test the patch myself before releasing it so I have been waiting for 1.4.2 O2 version, but if it does not show up soon then I guess I need to find a guinea pig. Anyway I am very busy currently finishing the patches so haven't though about updating to 1.4.2 yet. But once these are ready and if it still seems that no common version insight then I will update them to 1.4.2.
  15.    #135  
    New release of app launcher patch available. To avoid any problems please toggle the new configuration options couple times since I did not add any code to detect which exist in previous config so the uninitialized variables might cause a small problem for users updating the patch. Toggling them will set them to the correct value.

    Changes:

    - Now it is possible to set the page position resetting to enabled or disabled. And it actually should now work

    - Cleaned up a lot, please let me know if it there is still noticeable lag since I don't see it so hard to know when it is eliminated.

    - Added possibility to set default page (the page that is shown when app launcher is started). Just select Set As Default Page from the menu. When unset then the last active page is always used.

    - Fixed a tiny bug in renaming and in showing the menu when more than 6 pages.

    Todo:

    - When wrapping is enabled there might still be some page skipping. Will try to address this tomorrow.

    - When deleting the last page and adding it again the page might stay on the current page and not change to the new page. Will fix this tomorrow.

    - The limit for 6 pages still exists and will try to get rid of this tomorrow.
  16. #136  
    Quote Originally Posted by sconix View Post
    New release of app launcher patch available. To avoid any problems please toggle the new configuration options couple times since I did not add any code to detect which exist in previous config so the uninitialized variables might cause a small problem for users updating the patch. Toggling them will set them to the correct value.

    Changes:

    - Now it is possible to set the page position resetting to enabled or disabled. And it actually should now work

    - Cleaned up a lot, please let me know if it there is still noticeable lag since I don't see it so hard to know when it is eliminated.

    - Added possibility to set default page (the page that is shown when app launcher is started). Just select Set As Default Page from the menu. When unset then the last active page is always used.

    - Fixed a tiny bug in renaming and in showing the menu when more than 6 pages.

    Todo:

    - When wrapping is enabled there might still be some page skipping. Will try to address this tomorrow.

    - When deleting the last page and adding it again the page might stay on the current page and not change to the new page. Will fix this tomorrow.

    - The limit for 6 pages still exists and will try to get rid of this tomorrow.
    Sconix,

    Thanks for the update.

    Here are some more of my observations... I apologize if your sick of them.

    - Resetting to the top of the page works perfectly! Thank you!

    - Setting the default page works, however, it doesn't follow the page if the page is moved. It seems the patch is remembering what page position was marked and not the actual page. Make sense? IMHO, would be better to have the page marked as default follow the page if it is moved much like the other patch that implements this feature.

    Otherwise, great work!
    As I said before, I really like the way you have implemented the features from a number of launcher bar patches into one patch. Very clever and intuitive UI design.

    Another donation on its way very soon.

    Best Regards!
  17. rlopin's Avatar
    Posts
    441 Posts
    Global Posts
    443 Global Posts
    #137  
    Hi Sconix,

    I am facing install and uninstall issues after trying to apply a series of patches:

    1. Removed hide quick launch bar (by Jason Robitaille)
    2. Installed system menu initial framework (by sconix)
    3. Installed system menu today menu (by sconix)
    4. Installed Hide Quick Launch Bar in Launcher Remix (by sconix)
    5. Removed reset scroll position (by IMgrant)
    6. Removed reset to first page (by IMgrant)
    7. Removed show wifi ssid (by Rod Whitby)
    8. Tried to install Add Edit Launcher Pages and Quick Launch Options (by Janne Julkunen) - FAILED TO INSTALL
    9. Tried to remove Wrap Pages (by iclarkjr,dbspooner) - FAILED TO REMOVE


    Now the Wrap Pages patch no longer works. I am unable to uninstall it.
    I am unable to install the Add Edit launcher Pages and Quick Launch Options patch.

    IPKG Log
    For#8:

    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    43 12380 43 5377 0 0 6011 0 0:00:02 --:--:-- 0:00:02 11202
    100 12380 100 12380 0 0 12836 0 --:--:-- --:--:-- --:--:-- 22509
    install
    ** Message: serviceResponse Handling: 2, {"returnValue":true , "ticket":2, "subscribed":true}
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"STARTING" }
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"CREATE_TMP" }
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"VERIFYING" }
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"IPKG_INSTALL" }
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.e-lnx.wee.patches.app-launcher-add-edit-options.postinst 2>&1
    Reversed (or previously applied) patch detected! Assume -R? [n]
    Apply anyway? [n]
    5 out of 5 hunks ignored -- saving rejects to file usr/lib/luna/system/luna-applauncher/app/controllers/global-search-assistant.jsjsjs.$rej$
    2 out of 3 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-applauncher/app/controllers/reorder-controller.jsjsjs.$rej$
    Reversed (or previously applied) patch detected! Assume -R? [n]
    Apply anyway? [n]
    13 out of 13 hunks ignored -- saving rejects to file usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs.$rej$
    remove
    Removing package org.e-lnx.wee.patches.app-launcher-add-edit-options from root...
    (offline root mode: not running org.e-lnx.wee.patches.app-launcher-add-edit-options.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.

    IPKG Log
    For#9:

    failed
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.app-launcher-wrap-pages.prerm 2>&1
    1 out of 4 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-applauncher/app/controllers/launcher-assistant.jsjsjs.$rej$

    Reject Files

    I am unable to find any of the 3 .rej files mentioned in the above IPKG logs on the device. I browsed for them using internalz as well as the terminal app.

    The only file names I find in the mentioned directory (usr/lib/luna/system/luna-applauncher/app/controllers/) are:
    • reorder-controller.jsjsjs
    • reorder-controller.jsjsjs.$webosinternals$.$orig$
    • global-search-assistant.jsjsjs
    • global-search-assistant.jsjsjs.$webosinternals$.$orig$
    • launcher-assistant.jsjsjs
    • launcher-assistant.jsjsjs.$webosinternals$.$orig$


    I am stumped as to what to do next. I have already tried full reboots. Your guidance would be greatly appreciated.
    Phones>Ericsson->iPaq->Treo700w>>PalmPre & TouchPad<<PC<-Amiga<-C64<-Vic20<-PET<Computers
  18. #138  
    hi sconix,
    regarding app launcher patch, this may be unchangeable with the cleanup you just did, but up to the last version (1.4.1.1-5 works, -6 doesn't) this patch played well with the 'launcher page selection tabs' patch. with the -6 version there is a conflict in the launcher-assistant.jsjsjs $file$ $apparently$. $these$ $two$ $patches$ $are$ $great$ $together$, $but$ $as$ $usual$ $your$'$s$ $wins$ $out$ $in$ $a$ $head$ $to$ $head$.
    might there be any chance of them playing nice again or did the last clean-up changes make this impossible?
    Ev
    Last edited by everette13; 05/26/2010 at 12:15 AM.
  19.    #139  
    Quote Originally Posted by orsapps View Post
    Sconix,

    Thanks for the update.

    Here are some more of my observations... I apologize if your sick of them.

    - Resetting to the top of the page works perfectly! Thank you!

    - Setting the default page works, however, it doesn't follow the page if the page is moved. It seems the patch is remembering what page position was marked and not the actual page. Make sense? IMHO, would be better to have the page marked as default follow the page if it is moved much like the other patch that implements this feature.

    Otherwise, great work!
    As I said before, I really like the way you have implemented the features from a number of launcher bar patches into one patch. Very clever and intuitive UI design.

    Another donation on its way very soon.

    Best Regards!
    Thanks and I like to have feedback so thanks about that too. It is actually supposed to follow the page even when moved the default page setting I mean. It seems that this slipped my testing so will fix it for next release.
  20.    #140  
    Quote Originally Posted by everette13 View Post
    hi sconix,
    regarding app launcher patch, this may be unchangeable with the cleanup you just did, but up to the last version (1.4.1.1-5 works, -6 doesn't) this patch played well with the 'launcher page selection tabs' patch. with the -6 version there is a conflict in the launcher-assistant.jsjsjs $file$ $apparently$. $these$ $two$ $patches$ $are$ $great$ $together$, $but$ $as$ $usual$ $your$'$s$ $wins$ $out$ $in$ $a$ $head$ $to$ $head$.
    might there be any chance of them playing nice again or did the last clean-up changes make this impossible?
    Ev
    Actually I have thought that the tabs patch wont work in any way with my patch. I'll see if I can change my patch a bit so that it still works with it.
Page 7 of 58 FirstFirst ... 234567891011121757 ... LastLast

Posting Permissions