Page 28 of 58 FirstFirst ... 18232425262728293031323338 ... LastLast
Results 541 to 560 of 1151
Like Tree1Likes
  1. #541  
    Ok so that means I need to unistall them all and reinstall? Are the 1.4.1 patches in Preware I noticed the ones for 1.4.5 and didn't want to be without them.
  2.    #542  
    Quote Originally Posted by mamouton View Post
    Ok so that means I need to unistall them all and reinstall? Are the 1.4.1 patches in Preware I noticed the ones for 1.4.5 and didn't want to be without them.
    Yes the 1.4.1 versions in Preware feed are now equal to 1.4.5 versions that I have. So everything is updated now. And yes manual uninstall and reinstall from Preware feed will do the trick.
  3. mckay25's Avatar
    Posts
    75 Posts
    Global Posts
    76 Global Posts
    #543  
    Quote Originally Posted by sconix View Post
    The 1.4.1 versions are now also available in Preware.
    What about the device menu patch? The one with all the settings in the menu and the flashlight?
  4.    #544  
    Quote Originally Posted by mckay View Post
    What about the device menu patch? The one with all the settings in the menu and the flashlight?
    Yes even that, everything updated for 1.4.1 too so enjoy
  5. Speebs's Avatar
    Posts
    297 Posts
    Global Posts
    403 Global Posts
    #545  
    I'm sorry if this has been covered, but for those of us who have accidentally installed the 1.4.5 versions from your testing feed when only running OS 1.4.1 and are get ipkg errors when trying to uninstall... is there a solution? Or do we have to run EPR/doctor? I can't seem to uninstall the framework or install the Today menu or Mode menu.
  6.    #546  
    Quote Originally Posted by Speebs View Post
    I'm sorry if this has been covered, but for those of us who have accidentally installed the 1.4.5 versions from your testing feed when only running OS 1.4.1 and are get ipkg errors when trying to uninstall... is there a solution? Or do we have to run EPR/doctor? I can't seem to uninstall the framework or install the Today menu or Mode menu.
    It does not matter the version I mean if you have been able to installed them you should be able to uninstall them. Just remember the order, first uninstall the menus patches then the framework. And if you have installed something after installing those patches they may have changed the files so that my patches wont uninstall and in that case you need to uninstall those too so my patches can uninstall.
  7. Speebs's Avatar
    Posts
    297 Posts
    Global Posts
    403 Global Posts
    #547  
    Quote Originally Posted by sconix View Post
    It does not matter the version I mean if you have been able to installed them you should be able to uninstall them. Just remember the order, first uninstall the menus patches then the framework. And if you have installed something after installing those patches they may have changed the files so that my patches wont uninstall and in that case you need to uninstall those too so my patches can uninstall.
    Hmm. I haven't installed any patches that should conflict with yours, but I'm unable to install the "System menus initial framework" patch (or any top bar patches), and I'm unable to UNinstall "Device menu system menus mod" and "Add support for system menus". Looks like I will have to run EPR.

    Here's all that comes up in the IPKG log:

    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.e-lnx.wee.patches.top-bar-system-device-menu.prerm 2>&1
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    1 out of 13 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs.$rej$


    I'm not really sure what to do with that.
  8. #548  
    Quote Originally Posted by Speebs View Post
    I'm sorry if this has been covered, but for those of us who have accidentally installed the 1.4.5 versions from your testing feed when only running OS 1.4.1 and are get ipkg errors when trying to uninstall... is there a solution? Or do we have to run EPR/doctor? I can't seem to uninstall the framework or install the Today menu or Mode menu.
    Running EPR then reinstalling everything via Preware's Saved Package List solved EVERTHING for me! Thanks to Preware, Doctoring should not be necessary in this case!
  9.    #549  
    Quote Originally Posted by Speebs View Post
    Hmm. I haven't installed any patches that should conflict with yours, but I'm unable to install the "System menus initial framework" patch (or any top bar patches), and I'm unable to UNinstall "Device menu system menus mod" and "Add support for system menus". Looks like I will have to run EPR.

    Here's all that comes up in the IPKG log:

    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.e-lnx.wee.patches.top-bar-system-device-menu.prerm 2>&1
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    Check for md5sum in /usr/lib/ipkg/info
    1 out of 13 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs.$rej$


    I'm not really sure what to do with that.
    Something has changed that file for some reason so that the patch cannot be reversed. I hope you get everything back to working again. At least now with using Preware feed only there should not be issues like these anymore at least not that often since you cannot get "wrong" versions of the patches.
  10. Speebs's Avatar
    Posts
    297 Posts
    Global Posts
    403 Global Posts
    #550  
    Quote Originally Posted by sjamie View Post
    Running EPR then reinstalling everything via Preware's Saved Package List solved EVERTHING for me! Thanks to Preware, Doctoring should not be necessary in this case!
    Quote Originally Posted by sconix View Post
    Something has changed that file for some reason so that the patch cannot be reversed. I hope you get everything back to working again. At least now with using Preware feed only there should not be issues like these anymore at least not that often since you cannot get "wrong" versions of the patches.
    I tried using WebOS Repair Utility to just restore the file usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs $and$ $now$ $I$ $have$ $no$ $device$ $menu$ $at$ $all$! $lol$. $But$ $it$ $allowed$ $me$ $to$ $uninstall$ $the$ $2$ $patches$ $I$ $couldn$'$t$ $uninstall$. $I$'$m$ $restarting$ $now$ $to$ $see$ $if$ $I$ $can$ $install$ $the$ $1$.$4$.$1$ $patches$.

    What's odd is that restoring the original file seemed to break the "just charge by default" patch. I'm reinstalling that one too.

    EDIT: Is it possible that the "date as carrier string" and "battery percentage" and "am/pm indicator in top bar" caused the conflict? I never had any issues with these when your patches were installed along with them, but I see that they were all removed after restoring the original file. I should have thought of that before!
    Last edited by Speebs; 07/26/2010 at 08:29 PM.
  11. #551  
    Thought I would pass this along for those not on this Twitter thing....

    Twitter / WebOS Internals: App Launcher / Advanced Co ...

    Great work Sconix!
  12. #552  
    Well repair utility is supposed to repair files back to factory condition..... so running that should technically *fix* patches, that would probably be why just charge by default was gone.
  13. Speebs's Avatar
    Posts
    297 Posts
    Global Posts
    403 Global Posts
    #553  
    Quote Originally Posted by OldSkoolVWLover View Post
    Well repair utility is supposed to repair files back to factory condition..... so running that should technically *fix* patches, that would probably be why just charge by default was gone.
    I didn't run the full repair though, I just replaced the stock file "usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs&$quot$;. $That$'$s$ $it$.
  14. #554  
    Quote Originally Posted by sconix View Post
    The 1.4.1 versions are now also available in Preware.
    Should I be seeing these in Preware now or will they show up later? I just refreshed all feeds but did not find the newly updated 1.4.1 patches; I only see the old ones created in May.

    I do have the new System Framework patch.
  15. #555  
    Uhh, nevermind... They *miraculously* just appeared!
  16. #556  
    Quote Originally Posted by sjamie View Post
    Uhh, nevermind... They *miraculously* just appeared!
    Our package feeds have caching enabled, so that our servers don't die when everyone hammers them after a webOS release.

    You can use shift-reload in the right directory on ipkg.preware.org/feeds to force a reload of the cache. Otherwise wait up to 1 hour (I think).

    -- Rod
    Last edited by rwhitby; 07/26/2010 at 09:52 PM.
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. mckay25's Avatar
    Posts
    75 Posts
    Global Posts
    76 Global Posts
    #557  
    Quote Originally Posted by sconix View Post
    Yes even that, everything updated for 1.4.1 too so enjoy
    whoo hoo! It's all good! You are awsome Sconix.
  18. #558  
    Sconix, since I ran EPR and turned off your feeds, I can no longer access your Advanced launcher patch for 1.4.5. Although I am running on 1.4.1, the 1.4.5 version of that patch worked well and fixed the QL problem. Can you post the ipk or tell me another way to access that patch?

    Even when I turn your feeds back on, I cannot access the 1.4.5 version of the Advanced Launcher patch.
  19. Speebs's Avatar
    Posts
    297 Posts
    Global Posts
    403 Global Posts
    #559  
    Quote Originally Posted by sjamie View Post
    Sconix, since I ran EPR and turned off your feeds, I can no longer access your Advanced launcher patch for 1.4.5. Although I am running on 1.4.1, the 1.4.5 version of that patch worked well and fixed the QL problem. Can you post the ipk or tell me another way to access that patch?

    Even when I turn your feeds back on, I cannot access the 1.4.5 version of the Advanced Launcher patch.
    I was having the same problem with the quicklaunch bar not disappearing when a card was minimized (the problem was happening with version 1.4.5 of the patch so I don't think it's version-related). After running EPR tonight and installing the 1.4.1 version (1.4.1-31) it is working as intended. Have you tried 1.4.1-31 yet?
  20. #560  
    Nevermind... It looks like you updated the 1.4.1 version of the Launcher patch so the QL stays hidden! Sconix, your awesomeness is quite overwhelming!

    Speebs, it looks like we posted nearly at the same time! Yes, the new version is working properly!

Posting Permissions