Page 20 of 58 FirstFirst ... 10151617181920212223242530 ... LastLast
Results 381 to 400 of 1151
Like Tree1Likes
  1.    #381  
    Quote Originally Posted by mrchedda View Post
    I'm trying to install the "Device Menu Remix with Flashlight" and getting an error. Only certain patches give me errors, NOT ALL.

    I've provided the ipkg log below. If someone could explain what the error is and what I need to do to resolve and successfully install this patch it'd be greatly appreciated. Thanks in advance!!



    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 7064 100 7064 0 0 28457 0 --:--:-- --:--:-- --:--:-- 83105
    install
    ** Message: serviceResponse Handling: 2, {"returnValue":true , "ticket":1, "subscribed":true}
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"STARTING" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"CREATE_TMP" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"VERIFYING" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"IPKG_INSTALL" }
    ** Message: serviceResponse Handling: 2, { "ticket":1 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.top-bar-device-menu-remix-with-flashlight.postinst 2>&1
    1 out of 8 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/devicemenu-assistant.jsjsjs.$rej$
    remove
    Removing package org.webosinternals.patches.top-bar-device-menu-remix-with-flashlight from root...
    (offline root mode: not running org.webosinternals.patches.top-bar-device-menu-remix-with-flashlight.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.
    download
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed
    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 7064 100 7064 0 0 54107 0 --:--:-- --:--:-- --:--:-- 101k
    install
    ** Message: serviceResponse Handling: 2, {"returnValue":true , "ticket":2, "subscribed":true}
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"STARTING" }
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"CREATE_TMP" }
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"VERIFYING" }
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"IPKG_INSTALL" }
    ** Message: serviceResponse Handling: 2, { "ticket":2 , "status":"SUCCESS" }
    mkdir-prerm
    Nothing Interesting.
    install-prerm
    Nothing Interesting.
    postinst
    -1: Unable to run command: IPKG_OFFLINE_ROOT=/media/cryptofs/apps /bin/sh /media/cryptofs/apps/usr/lib/ipkg/info/org.webosinternals.patches.top-bar-device-menu-remix-with-flashlight.postinst 2>&1
    1 out of 8 hunks FAILED -- saving rejects to file usr/lib/luna/system/luna-systemui/app/controllers/devicemenu-assistant.jsjsjs.$rej$
    remove
    Removing package org.webosinternals.patches.top-bar-device-menu-remix-with-flashlight from root...
    (offline root mode: not running org.webosinternals.patches.top-bar-device-menu-remix-with-flashlight.prerm)
    delete
    Nothing Interesting.
    failed
    Nothing Interesting.
    Even though that patch is not related in any way to my patches, these errors always means that you have some other patch installed that is conflicting with the patch that you are trying to install. My patch tries to bring all the features that those small separate patches will add for device menu which in a way will make the situation better since you only need one patch instead of many which may conflict with each other.
  2.    #382  
    Quote Originally Posted by mespiff View Post
    well this leads to the only question i have left

    When ? lol
    Most likely on Sunday But these patches will most likely be on my testing feed already tonight, but one thing to remember if somebody goes already installing these that the mode menu patch wont work properly with current version of mode switcher. And hence I only release these on my stable feed when next release of MS is ready which I hope is at the latest on this Sunday.
  3.    #383  
    Quote Originally Posted by HaPe View Post
    Sconix,

    Do you change some of the HTML files? If yes we should try to make this part of the patches also available for the Europe Pres where we also need to patch the lang specific HTML files.

    HaPe
    Yes, and the plan is to make the patch so that it patches all related land stuff, but most likely not the next release. First I want to see that everything works for everyone then I can "finalize" the patch.
  4. hape's Avatar
    Posts
    556 Posts
    Global Posts
    578 Global Posts
    #384  
    Quote Originally Posted by sconix View Post
    Yes, and the plan is to make the patch so that it patches all related land stuff, but most likely not the next release. First I want to see that everything works for everyone then I can "finalize" the patch.
    Fully with you. Give me a ping if I can help you for the localization.

    HaPe
  5. #385  
    Quote Originally Posted by sconix View Post
    Even though that patch is not related in any way to my patches, these errors always means that you have some other patch installed that is conflicting with the patch that you are trying to install. My patch tries to bring all the features that those small separate patches will add for device menu which in a way will make the situation better since you only need one patch instead of many which may conflict with each other.
    The only problem with that is... I don't have any other device menu patches installed. This worked for me flawlessly a week ago but I'm reinstalling because I have replacement device, so I'm installing from scratch. I also get these "hunk" errors when trying to install: UberCalendar, iPhone Icons, as well as others. Anything else that may help? Thanks.
  6. #386  
    Sconix: Can you tell me what files to replace with their originals so the Mode Menu for Top Bar and Today Menu for Top Bar can be reinstalled? Both of these patches are installed, but are shown incorrectly in my Saved Package list.

    thanks
    Scott
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  7.    #387  
    Quote Originally Posted by swieder View Post
    Sconix: Can you tell me what files to replace with their originals so the Mode Menu for Top Bar and Today Menu for Top Bar can be reinstalled? Both of these patches are installed, but are shown incorrectly in my Saved Package list.

    thanks
    Scott
    Its bit hard to tell, of course I can give list that those patches modifies, but if you have some other patch installed that modifies the same files then you will get in trouble when replacing. I would also like to think that there is a better way to recover than that.
  8.    #388  
    Quote Originally Posted by mrchedda View Post
    The only problem with that is... I don't have any other device menu patches installed. This worked for me flawlessly a week ago but I'm reinstalling because I have replacement device, so I'm installing from scratch. I also get these "hunk" errors when trying to install: UberCalendar, iPhone Icons, as well as others. Anything else that may help? Thanks.
    If those patches are for the same version than your phone installation and you are sure that the patches should not conflict (some times even the installation order with some patches matter that will they install together without any problems) then it must be that your phone had modified files already when you got it. Then doctoring is always the best way to reset the device.
  9. #389  
    Quote Originally Posted by sconix View Post
    Its bit hard to tell, of course I can give list that those patches modifies, but if you have some other patch installed that modifies the same files then you will get in trouble when replacing. I would also like to think that there is a better way to recover than that.
    I am willing to try it. I dont think i have other patches that touch the same files as your patches. It would be easier to try it compared to doctoring.
    Pilot 5K->Palm IIIc->Tungsten T/T2->Treo 650/680 -> Pre+ (1.4.5 & Uberkernel)
  10.    #390  
    Quote Originally Posted by swieder View Post
    I am willing to try it. I dont think i have other patches that touch the same files as your patches. It would be easier to try it compared to doctoring.
    The common system menus patch will modify following files:

    /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs
    /usr/lib/luna/system/luna-systemui/app/views/bar/bar-scene.html
    /usr/palm/frameworks/mojo/submissions/338/stylesheets/global-menus.css
    /usr/lib/luna/system/luna-systemui/stylesheets/systemui.css
    /etc/palm/persistentWindows.conf

    Mode menu patch:

    /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs
    /usr/lib/luna/system/luna-systemui/sources.json

    Today menu patch:

    /usr/lib/luna/system/luna-systemui/app/controllers/bar-assistant.jsjsjs
    /usr/lib/luna/system/luna-systemui/sources.json
    /usr/lib/luna/system/luna-systemui/stylesheets/systemui.css

    Then there was those additional files which you remove safely after resetting those files.
  11. #391  
    Quote Originally Posted by sconix View Post
    If those patches are for the same version than your phone installation and you are sure that the patches should not conflict (some times even the installation order with some patches matter that will they install together without any problems) then it must be that your phone had modified files already when you got it. Then doctoring is always the best way to reset the device.
    I have no clue what you're talking about. If those patches are for the same version of my phone? what does that mean? Do you mean to say "If those patches are compatible with the WebOS version I'm running?

    No, the previous phone I had (which successfully installed this patch before) was NOT running any preware or anything. The previous owner has NO clue on how to do these kinds of things, I know him personally. The update that was on the phone when I purchased the phone was the webos 1.4.1.1. done over the air.

    I don't mean to sound like an A-Hole, but thanks for the speculation, I need someone who can READ the error log and tell me what's wrong so I can successfully install patches. This doesn't only happen w/ this patch, it happens to several patches. I am running the latest update of Thunderchief. Thanks.
    Last edited by mrchedda; 07/16/2010 at 01:01 AM.
  12. #392  
    I need someone who can READ the error log and tell me what's wrong so I can successfully install patches.
    Dude, relax.
    The guy tries to help you and you give him grief...
    It's a phone.
    I wonder how you get over something that actually matters.

    You're not even asking in the right place.
    Why don't you try asking him for help in his native language, and see how far you get. Oh wait, you can't because you only speak a-hole?

    Good luck getting help.

    Take a deep breath, Dr. your phone, and start fresh.
    or
    Get something more your speed, like a Razr.
    Last edited by Mannyman; 07/16/2010 at 01:58 AM. Reason: Really what a jerk.
    APP & Patch Makers Get on the:webOS Developers Map
    My Apps: Presentation Controller (for PowerPoint and Open Office Impress), PC Display Master ,Handheld X-Ray H.E. (Halloween Edition), Text Morpher ⓦⓘⓣⓗ ⓑⓤⓑⓑⓛⓔ ⓣⓔⓧⓣ plus Ŧεẍṫ ℉яεαḱεя
  13. #393  
    As Mannyman says time to relax.
    Time to appreciate the joy that gives me the generous work of sconix.
    Time to thank sconix.
    Time to donate too.
  14.    #394  
    Quote Originally Posted by mrchedda View Post
    I have no clue what you're talking about. If those patches are for the same version of my phone? what does that mean? Do you mean to say "If those patches are compatible with the WebOS version I'm running?

    No, the previous phone I had (which successfully installed this patch before) was NOT running any preware or anything. The previous owner has NO clue on how to do these kinds of things, I know him personally. The update that was on the phone when I purchased the phone was the webos 1.4.1.1. done over the air.

    I don't mean to sound like an A-Hole, but thanks for the speculation, I need someone who can READ the error log and tell me what's wrong so I can successfully install patches. This doesn't only happen w/ this patch, it happens to several patches. I am running the latest update of Thunderchief. Thanks.
    Well sorry if English is not my native language and for trying to help you even if your question is not even remotely in the right thread (none of the patches you have mentioned are not mine and hence this is completely wrong thread). And I did it since I happen to know what I am talking about. There is no way to read the error more better since the patches are not exact on their reporting what is wrong. Without digging more closely on what patches you have and to those specific patches that does not install to see what files do they modify etc. (quite time consuming) it is impossible to say what is the real culprit. The general reason are what I told you, you either have patch that conflicts (you denied this) so I went to next reason, the version of patches is not for the WebOS version you have installed (which you now denied) so the only reason could be that something else has modified those files that are giving problems and one reason for that could be that the files was modified already before you got the phone (for some odd reason). And since finding the reason takes more time than doctoring specially if you don't understand how patches work so therefore I suggested doctoring.
  15.    #395  
    I will release the new system menu patches to the stable feed in couple hours so people can start testing them and giving feedback. I decided to add one more menu that has not been in any of the existing device menu patches which at least I could see useful if I would not happen to have a mode that changes those settings when I need. SO hence the slight delay.

    JUST remember that the mode menu patch does not work properly with the current MS version only with the next version that should be out quite soon.
  16. #396  
    Quote Originally Posted by mrchedda View Post
    I have no clue what you're talking about. If those patches are for the same version of my phone? what does that mean? Do you mean to say "If those patches are compatible with the WebOS version I'm running?

    No, the previous phone I had (which successfully installed this patch before) was NOT running any preware or anything. The previous owner has NO clue on how to do these kinds of things, I know him personally. The update that was on the phone when I purchased the phone was the webos 1.4.1.1. done over the air.

    I don't mean to sound like an A-Hole, but thanks for the speculation, I need someone who can READ the error log and tell me what's wrong so I can successfully install patches. This doesn't only happen w/ this patch, it happens to several patches. I am running the latest update of Thunderchief. Thanks.
    i was going to try to help you untill i read this post
    -------------------------------------------------------------------
    Rob Chilcott

    Twitter @robchilcott
    pre2
    " I am only a stupid electrician after all"

    My house is a webOS house
    My pre 2, Touchpad 32g
    Wife Pixi, touchpad 32gb
    Daughter -- my old pre+
    of course my 16 year old son has and droid incredible but i think i remeber finding him on the porch
  17. Zahid's Avatar
    Posts
    109 Posts
    Global Posts
    117 Global Posts
    #397  
    Quote Originally Posted by sconix View Post
    I will release the new system menu patches to the stable feed in couple hours so people can start testing them and giving feedback. I decided to add one more menu that has not been in any of the existing device menu patches which at least I could see useful if I would not happen to have a mode that changes those settings when I need. SO hence the slight delay.
    Do these menus work independently? I'd like to download the new Today and Device menus, but keep the old Mode menu so it will still work with my current Mode Switcher version.

    Also, I assume I'd want to uninstall all my old individual Device Menu patches?
  18.    #398  
    Quote Originally Posted by Zahid View Post
    Do these menus work independently? I'd like to download the new Today and Device menus, but keep the old Mode menu so it will still work with my current Mode Switcher version.

    Also, I assume I'd want to uninstall all my old individual Device Menu patches?
    Yes and no. When there is changes to the framework patch that the menu patches dependent to then no. Which is the case now so all menu patches have to be the same version. Normally there is no changes to the framework patch, but the editing needed a slight change to that patch. But the new MS should come in couple days, but if you can't live without mode menu then don't update just yet.

    And yes the old individual Device Menu patches need to be uninstalled so that mine patch wont conflict. I am still trying to fix one weird bug in the patch and once I find where the fault is I will put the new version into my feed.
  19.    #399  
    Finally found the bug. Kinda frustrating to find out that it was in palm's code and not mine since I spend first couple hours only finding the reason from my code. The bug was kinda obvious when I started to watch already existing device menu code so it seems that the bug was just brought up by my additions. Oh well now the patches are ready and in the feed in couple minutes.
  20.    #400  
    I did not test every single toggle in the new menu patches so please report any misbehaving. I also had to leave out (at least for now) the security menu item which I would have liked to have for setting quickly screen lock on/off, but it seems that even that text field can be a menu item the key presses cannot be registered when menu is open. The text fields would be needed for quickly giving the pin/password for the unlocking. So for now that feature is out.

Posting Permissions