Page 10 of 58 FirstFirst ... 5678910111213141520 ... LastLast
Results 181 to 200 of 1151
Like Tree1Likes
  1. #181  
    Maybe put in an option to turn on/off animation for page wrapping?

    edit:
    Dunno if it was intentional but I now have a very neat scrolling through the launcher. It is smooth, almost like browsing a web page. The pages don't click (I can sometimes get them to click). If I'm on a half page I can still launch the app. It is VERY neat, but causes some lag. I like it. (I have wrapping turned off)

    2nd edit:
    after playing with it some more, if you bring up the launcher (after having it closed/minimized), if you flick it will smoothly scroll through all your pages. If you don't flick it will "click" and stay "clicked" until you bring up the launcher again.
    Last edited by nulsul; 05/27/2010 at 06:37 AM.
  2.    #182  
    Quote Originally Posted by nulsul View Post
    Maybe put in an option to turn on/off animation for page wrapping?

    edit:
    Dunno if it was intentional but I now have a very neat scrolling through the launcher. It is smooth, almost like browsing a web page. The pages don't click (I can sometimes get them to click). If I'm on a half page I can still launch the app. It is VERY neat, but causes some lag. I like it. (I have wrapping turned off)

    2nd edit:
    after playing with it some more, if you bring up the launcher (after having it closed/minimized), if you flick it will smoothly scroll through all your pages. If you don't flick it will "click" and stay "clicked" until you bring up the launcher again.
    The wrapping is a hack since mojo scroller element wont support it and the animation to be on or off would not work since I am already currently fighting to get it work one of those ways (both have introduced some problems). The pages should still snap on their positions. Can you toggle the wrap setting on/off couple times and leave it disabled. Since at least with wrapping off the snapping should not go away (i.e. it should not be possible that the snapping is lost since the page changing is not touched at all when wrapping is off). And you do have the latest -10 release?
  3. #183  
    Quote Originally Posted by cdonehew View Post
    Do you have Wifi turned on &/or other top bar patches installed (specifically the ringer switch icon or GPS on top bar)? The reason I ask is because the "today" menu patch creates a tap-able area on the top bar where the clock is. This new tab-able area causes icons to be hidden behind the clock if you have alot of icons on your top bar (I have wifi on and the ringer switch icon and when I leave an area where there is no wifi my bluetooth icon is hidden and if I also have the ringer switch to vibrate by Ev icon is also hidden).

    As far as how to get the icons back, you said that you have uninstalled the "Today" menu patch, have you also uninstalled the "initial framework" patch? I would bet that with both of these patches uninstalled your icons will reappear. However, I am not a programmer so I could be completely wrong.
    Thank you! It was the "System Menu Initial Framework" patch that I didn't know was still on it. Problem solved.

    I love the idea of this patch but if it covers up my top bar icons then I can't use it. I have to know whether my BT headset is connected or not by looking at the phone.
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  4.    #184  
    Quote Originally Posted by Homie View Post
    Thank you! It was the "System Menu Initial Framework" patch that I didn't know was still on it. Problem solved.

    I love the idea of this patch but if it covers up my top bar icons then I can't use it. I have to know whether my BT headset is connected or not by looking at the phone.
    The latest test version from my feed should not cover the icons anymore since it does not touch the size of the icon area.
  5. #185  
    Quote Originally Posted by sconix View Post
    The latest test version from my feed should not cover the icons anymore since it does not touch the size of the icon area.
    Great! Should I find it or wait till a final version is pushed to Preware? It needs to be very stable for me as I work on my phone all day.

    Thanks!
    Palms and more Palms till the 700p ruined it for me. Blackberry and now the Pre. Sprint customer since 1994! They had 1 tower in town.
  6. #186  
    Quote Originally Posted by sconix View Post
    The wrapping is a hack since mojo scroller element wont support it and the animation to be on or off would not work since I am already currently fighting to get it work one of those ways (both have introduced some problems). The pages should still snap on their positions. Can you toggle the wrap setting on/off couple times and leave it disabled. Since at least with wrapping off the snapping should not go away (i.e. it should not be possible that the snapping is lost since the page changing is not touched at all when wrapping is off). And you do have the latest -10 release?
    Wrapping is off, and have toggled it on/off several times. I do have the latest -10 release. I did do 2 complete device restarts. Still doing it (but I'm not complaining)
  7.    #187  
    Quote Originally Posted by nulsul View Post
    Wrapping is off, and have toggled it on/off several times. I do have the latest -10 release. I did do 2 complete device restarts. Still doing it (but I'm not complaining)
    Ok, I will check if I can find a reason for this.
  8.    #188  
    Quote Originally Posted by Homie View Post
    Great! Should I find it or wait till a final version is pushed to Preware? It needs to be very stable for me as I work on my phone all day.

    Thanks!
    The info about my feed is on the first page of this thread, and it should be stable. At least today menu wont hold any hacks like the app launcher patch that are causing the problems. The hacks are always a bit harder to get right...

    Of course the releases in my feed are not that well tested, but if bugs are reported I always fix them right away.
  9. #189  
    Quote Originally Posted by sconix View Post
    Of course the releases in my feed are not that well tested, but if bugs are reported I always fix them right away.
    Yes you do and we appreciate it!

    I hope others are able to donate to the ongoing development of your patches and MS. IMHO, they are right up there with some of the other more well known Homebrew apps and patches in usefulness and adding "missing" functionality to webOS.

    Great work as always!
    Regards
  10. #190  
    Quote Originally Posted by nulsul View Post
    Wrapping is off, and have toggled it on/off several times. I do have the latest -10 release. I did do 2 complete device restarts. Still doing it (but I'm not complaining)
    I'm having the same issue. The "Enable Position Reset" menu item (which I presume is the setting to "freeze" launcher pages as you horizontally scroll) has unpredictable behavior, and the setting doesn't seem to stick. Sometimes with that option enabled, pages scroll without stopping, and other times they stop at each page.

    UPDATE: Seems to be working OK now . . . go figure.
  11. allonon's Avatar
    Posts
    372 Posts
    Global Posts
    373 Global Posts
    #191  
    Quote Originally Posted by sconix View Post
    Can you toggle the page wrapping couple times and then leave it disabled and see if it still does that? Since the page changing routing is not touched when wrapping is off and therefore it should work always when wrapping off.
    I've tried turning wrapping on and off a couple of times. As long as wrapping is on Page names are fine. Turn it off, leave the launcher and come back and I get "Launcher Page NaN"
  12.    #192  
    Quote Originally Posted by allonon View Post
    I've tried turning wrapping on and off a couple of times. As long as wrapping is on Page names are fine. Turn it off, leave the launcher and come back and I get "Launcher Page NaN"
    This is really strange since the page names are stored so if they are right at some point they should not get like that. Specially strange since the page names are not reloaded at any point, only when Luna starts.

    At least I found bug in storing the page names when adding new pages / deleting pages. That is fixed in next release, but I don't get how the page number can change. Well at least the tonight release will have some other bug fixes as well and I will go through the whole added code to see if I have missed something so hopefully the next version works.

    EDIT: Actually I might now know where this comes from. Please try the next version that should be out tonight and report back.

    EDIT2: There is another possibility, have you toggled the new set default page couple times after updating? If not then it is causing the problem since the variable is uninitialized.

    EDIT3: I will add resetting of app/quick launcher settings for next release so these wierd problems should go away since I think that many of them are from the problem that I added those settings later on.
    Last edited by sconix; 05/27/2010 at 02:15 PM.
  13.    #193  
    New app launcher patch release available. It most likely wont fix all problems, but at least lets me know which problems are real and which from the configuration problem. So please test this and report any problems.

    So this patch resets the app launcher / quick launch settings so don't be alarmed.

    Changes:

    - jump to page shows 8 pages at once.

    - fixed bug concerning page names not saved when adding / deleting pages (caused all sorts of funny things).
  14. allonon's Avatar
    Posts
    372 Posts
    Global Posts
    373 Global Posts
    #194  
    Much better for me. Thanks!

    Page names are read properly. Page swipes stop on each page appropriately
  15. #195  
    When Renaming a page , one must type a character before being able to delete the old name.
    Is this by design?
    APP & Patch Makers Get on the:webOS Developers Map
    My Apps: Presentation Controller (for PowerPoint and Open Office Impress), PC Display Master ,Handheld X-Ray H.E. (Halloween Edition), Text Morpher ⓦⓘⓣⓗ ⓑⓤⓑⓑⓛⓔ ⓣⓔⓧⓣ plus Ŧεẍṫ ℉яεαḱεя
  16.    #196  
    Quote Originally Posted by Mannyman View Post
    When Renaming a page , one must type a character before being able to delete the old name.
    Is this by design?
    At least I can delete it right away. It is a normal text widget so theres nothing that I could do differently with it.
  17. #197  
    Quote Originally Posted by allonon View Post
    Page swipes stop on each page appropriately
    Not with Page Wrapping enabled.
  18.    #198  
    Quote Originally Posted by Ubuntite View Post
    Not with Page Wrapping enabled.
    For me this is very rare with wrapping enabled. Maybe under load it might not be that way. I think the only way to get the wrapping to work is to remove the animation (just like in the other wrap patch). I just took this old behavior back for now since it at least works for some people, but the new none animation wrapping had still some problems with the other features that I need to solve before putting it back.
  19. #199  
    Quote Originally Posted by sconix View Post
    At least I can delete it right away. It is a normal text widget so theres nothing that I could do differently with it.
    I just tried again and could not duplicate the issue.

    No, I'm not drunk.
    Last edited by Mannyman; 05/27/2010 at 07:00 PM. Reason: Ok, maybe a little drunk.
    APP & Patch Makers Get on the:webOS Developers Map
    My Apps: Presentation Controller (for PowerPoint and Open Office Impress), PC Display Master ,Handheld X-Ray H.E. (Halloween Edition), Text Morpher ⓦⓘⓣⓗ ⓑⓤⓑⓑⓛⓔ ⓣⓔⓧⓣ plus Ŧεẍṫ ℉яεαḱεя
  20. allonon's Avatar
    Posts
    372 Posts
    Global Posts
    373 Global Posts
    #200  
    Quote Originally Posted by Ubuntite View Post
    Not with Page Wrapping enabled.
    it is for me. I tried both page wrap enabled and disabled

Posting Permissions