Page 1 of 4 1234 LastLast
Results 1 to 20 of 66
Like Tree4Likes
  1.    #1  
    SysToolsMgr v1.0.5

    Homebrew's favourite "odds and ends" service is back with webOS 2.x support!



    All the standard system functions are still here and available for homebrew developers to harness. System functions like listing running apps and running processes, controling flashlight LED, getting CPU info, getting memory info, and much more.


    If you'd like to help support SysToolsMgr's development, please consider a donation.



    An updated v1.0.0 API specsheet is attached to this post.


    SOURCE: systoolsmgr-service - Project Hosting on Google Code

    P|C Homebrew Gallery: SysToolsMgr Service | PreCentral.net | The #1 Palm Pre and Pixi Community


    Note: SysToolsMgr 1.0.0 requires Homebrew JS Service Framework.


    Change Log
    v1.0.5 - October 11, 2011
    - Now support Pre3's led flash, thanks to mpx

    v1.0.2 - June 1, 2011
    - Fixed the clock theme list updater for webOS 1.4.5 devices

    v1.0.0 - March 4, 2011
    - Completely re-written into a Node.jsjsjs $service$ $for$ $webOS$ $2$.$x$
    - Redesigned frontend app
    - Now stays as an icon in the launcher, rather than being hidden
    - Can now be completely removed via orange+tap uninstall method
    Attached Files Attached Files
    Last edited by Jason Robitaille; 10/11/2011 at 02:38 PM.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
    apollowing likes this.
  2. #2  
    Geeze...

    I'm really running out of excuses now not to Meta-Doctor my Pre Minus...

    Thank you, Jason!


    M.
  3. #3  
    Does this mean the NDA has been lifted? (asking because last i heard the LED Flashlight function was waiting for that).

    Thanks!
  4.    #4  
    Quote Originally Posted by NickVTPre View Post
    Does this mean the NDA has been lifted? (asking because last i heard the LED Flashlight function was waiting for that).

    Thanks!
    NDA is not lifted, but I got permission from Palm for the releases
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  5. #5  
    Hello,

    thanks for that great tool!

    I updated my Pre- to webOS 2.1 and installed the SysToolsMgr but when I start the app it says: "Service not running" and restart the device and reinstall SysToolsMgr. I've done that twice but still no result.

    I use a german version of webOS. Can this be the problem?

    Thanks,
    Torsten
  6. #6  
    Quote Originally Posted by totow View Post
    Hello,

    thanks for that great tool!

    I updated my Pre- to webOS 2.1 and installed the SysToolsMgr but when I start the app it says: "Service not running" and restart the device and reinstall SysToolsMgr. I've done that twice but still no result.

    I use a german version of webOS. Can this be the problem?

    Thanks,
    Torsten
    If you used Preware to install JSJSJS $Service$ $Framework$ $and$ $SysToolsMgr$ $try$ $this$.
    De-install all services with Preware. Do a Device Restart. Connect with USB (charging) in Developer Mode. Using WebOS Quick Install 4.04 install JSJSJS $Service$ $Framework$, $FileMgr$ $Service$, $SysToolsMgr$ $Service$. $Eject$ $Pre$-. $Then$ $Device$ $Restart$ $and$ $all$ $services$ $running$.
    Spanish translator of Outline Tracker, UberCalendar, sconix's advanced patches, and other MIA webOS apps. HP Pre 3 and HP TouchPad 64 GB (Espaņol_Espaņa, es_es)
  7. #7  
    yeah i tried a few times using preware and it never worked. quick install works perfect. i dont know what the issue is. just remove everything from preware and then restart, add everything through qi. good to go.
  8. #8  
    Works for me too!
    Thanks a lot!
  9. #9  
    Quote Originally Posted by graffix31 View Post
    yeah i tried a few times using preware and it never worked. quick install works perfect. i dont know what the issue is. just remove everything from preware and then restart, add everything through qi. good to go.
    The only issue I have ever had with Jason's software is that his post-install routine is to restart the "Java Service" which cuts network connectivity (making it impossible to successfully "install all" from the saved package list in Preware) the first time you try. Once that list gets past his services/apps, everything's fine.

    I have no explanation why you guys are having problems since I just did all this yesterday afternoon, exclusively via Preware, without any issues.


    M.
  10.    #10  
    Quote Originally Posted by Xanadu73 View Post
    The only issue I have ever had with Jason's software is that his post-install routine is to restart the "Java Service" which cuts network connectivity (making it impossible to successfully "install all" from the saved package list in Preware) the first time you try. Once that list gets past his services/apps, everything's fine.

    I have no explanation why you guys are having problems since I just did all this yesterday afternoon, exclusively via Preware, without any issues.


    M.
    Do note: for webOS 2.x, there is no more java. SysToolsMgr is recoded in Node.jsjsjs $for$ $that$. $So$ $no$ $more$ $java$ $restarts$ $for$ $webOS$ $2$.$x$ $users$
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  11. #11  
    no kidding. when i was running them through preware that didnt work after the install it said that java needed to be reset. even though i hit yes nothing happened. when installing through quick install i did not get the prompt and everything loaded fine.
  12. #12  
    Quote Originally Posted by Jason Robitaille View Post
    Do note: for webOS 2.x, there is no more java. SysToolsMgr is recoded in Node.jsjsjs $for$ $that$. $So$ $no$ $more$ $java$ $restarts$ $for$ $webOS$ $2$.$x$ $users$


    Understood. That's why I put it in quotes. I guess I should've said that. Thank you!


    M.
  13.    #13  
    Quote Originally Posted by Xanadu73 View Post


    Understood. That's why I put it in quotes. I guess I should've said that. Thank you!


    M.
    Oh, my mistake, i misread your original post.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  14. #14  
    how do you use SysToolsMgr 1.00?
  15.    #15  
    Quote Originally Posted by luxdelux007 View Post
    how do you use SysToolsMgr 1.00?
    SysToolsMgr is essentially a library of functions that other apps and patches can use; the frontend app merely shows the changelog and service status.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  16. #16  
    After updating both SysToolsMgr Service and Homebrew JSJSJS $Service$ $Framework$ $to$ $1$.$0$.$1$ $on$ $my$ $2$.$1$.$0$ $MetaDoctor$ $PreMinus$, $the$ $music$ $player$ $stays$ $silent$. $Any$ $audio$ $streaming$ $doesn$'$t$ $work$ ($DrPodder$, $Music$ $Player$, $UberRadio$). $I$ $don$'$t$ $know$ $if$ $this$ $is$ $just$ $a$ $coincidence$ $or$ $if$ $there$ $is$ $a$ $causative$ $coherence$. $Restarting$ $audio$ $service$ $doesn$'$t$ $change$ $anything$, $just$ $as$ $rebooting$ $the$ $device$.

    Lumberjack log "musicplayer"

    Lumberjack log "everything" from start of muisc player to start of lumberjack
    Last edited by ZehHa; 04/07/2011 at 09:39 AM.
  17.    #17  
    Quote Originally Posted by ZehHa View Post
    After updating both SysToolsMgr Service and Homebrew JSJSJS $Service$ $Framework$ $to$ $1$.$0$.$1$ $on$ $my$ $2$.$1$.$0$ $MetaDoctor$ $PreMinus$, $the$ $music$ $player$ $stays$ $silent$. $Any$ $audio$ $streaming$ $doesn$'$t$ $work$ ($DrPodder$, $Music$ $Player$, $UberRadio$). $I$ $don$'$t$ $know$ $if$ $this$ $is$ $just$ $a$ $coincidence$ $or$ $if$ $there$ $is$ $a$ $causative$ $coherence$. $Restarting$ $audio$ $service$ $doesn$'$t$ $change$ $anything$, $just$ $as$ $rebooting$ $the$ $device$.

    Lumberjack log will follow later.
    Extremely doubtful it's related. None of my software interact with or do anything at all related to the music API; in fact, both SysToolsMgr and Homebrew JSJSJS $Service$ $Framework$ $are$ $standalone$ $and$ $no$ $music$ $software$ $access$ $them$, afaikafaikafaik.

    There is a known unrelated webOS 2.x system bug that could explain the issue: http://forums.precentral.net/hedami/...yer-remix.html
    Last edited by Jason Robitaille; 04/07/2011 at 09:23 AM.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  18. #18  
    Quote Originally Posted by ZehHa View Post
    After updating both SysToolsMgr Service and Homebrew JSJSJS $Service$ $Framework$ $to$ $1$.$0$.$1$ $on$ $my$ $2$.$1$.$0$ $MetaDoctor$ $PreMinus$, $the$ $music$ $player$ $stays$ $silent$. $Any$ $audio$ $streaming$ $doesn$'$t$ $work$ ($DrPodder$, $Music$ $Player$, $UberRadio$). $I$ $don$'$t$ $know$ $if$ $this$ $is$ $just$ $a$ $coincidence$ $or$ $if$ $there$ $is$ $a$ $causative$ $coherence$. $Restarting$ $audio$ $service$ $doesn$'$t$ $change$ $anything$, $just$ $as$ $rebooting$ $the$ $device$.

    Lumberjack log will follow later.
    I would try raising the volume. Seriously, it happened to me once! :blush:
  19. #19  
    Quote Originally Posted by ApplePie View Post
    I would try raising the volume. Seriously, it happened to me once! :blush:
    Tried this first. Didn't change anything.

    @Jason: Thanks for your reply. The Lumberjack log shows that "file:///usr/palm/applications/com.palm.app.musicplayer/framework_config.json" is missing now. Don't know how this could disappear. Besides normal usage, like peeking into my calendar, looking up a couple of addresses, and browsing the web, I just loaded the two updates mentioned above.

    Looks like my Pre needs the doctor again.
  20. #20  
    Quote Originally Posted by ZehHa View Post
    The Lumberjack log shows that "file:///usr/palm/applications/com.palm.app.musicplayer/framework_config.json" is missing now.

    I don't have that on mine, nor is it in the Doctor. Ignore it.


    M.
Page 1 of 4 1234 LastLast

Posting Permissions