Page 2 of 18 FirstFirst 1234567 12 ... LastLast
Results 21 to 40 of 360
Like Tree2Likes
  1. #21  
    Quote Originally Posted by mangotrance View Post
    Installation worked,the options are available in the settings,but no flash is showing.Still the "missing plugin"-logo.
    Yeah I was concerned about that. When I figured out how to get Flash working, my first step was to package all the files up into ipkgs. It didn't work. Got the same issues with the files being present on the device, but still had a "plugin missing" icon like you.

    Not to denigrate Jason's work here because it's definitely a lot more user-friendly than my manual method, but has anyone successfully installed and used Flash with the files posted in this thread?
  2. #22  
    OK, the installation via ipk wont work... the files are not on the device even when it looks good (in WEBOSQI, root filesystem mounted rw). I copied the files manually, the "missing plugin" logo is gone but it doesn't work anyway. There is an "empty window" instead of the missing-plugin logo.
  3. #23  
    Quote Originally Posted by EdCates View Post
    I can't even get the Ipk Packager to Package the Ipk. Very odd. I click the "Create IPK" button and nothing happens.

    I'm running 64-bit Fedora 14, if that helps at all.
    Make sure you select the 'Flash Plugin' folder that is inside the 'Flash Plugin Container' folder.
  4. SashoDikov
    SashoDikov's Avatar
    #24  
    Hi, ipk didn't install with WOQI so i executed "mount -o remount, rw /" on my terminal. After IPK and patch installed as advertised but no flash.

    I ended up following Leathal's instructions step by step from http://forums.precentral.net/webos-i...etadoctor.html by manually sending every file with WOQI and commenting the preferences-assistant.jsjsjs $after$ $which$ &$quot$;$mount$ -$o$ $remount$, $ro$ /&$quot$; ($i$ $think$ $this$ $is$ $redundant$ $since$ $it$ $is$ $read$ $only$ $by$ $default$ $after$ $reboot$) $and$ $i$ $haz$ $flashes$ $now$

    I think the problem is not including the FlashMiniAdapterData:

    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-noplay.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-play.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-unknown.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-scrim.png
    /usr/lib/BrowserServerPlugins/FlashMiniPlugin.so

    now i need to figure out how disable all the flash adds I'm seeing
    Last edited by SashoDikov; 02/24/2011 at 09:05 AM.
  5. #25  
    If all that's needed is the MiniAdapterData files, can't that just be included into Jason's the packager as well? Or perhaps a second container can be created to install the MiniAdapter information, and a second .ipk be generated for that portion...
  6. #26  
    Does a Sym link need to be created from the /usr/lib/BrowserPlugins directory to flashplayer.so in the BrowserServerPlugins directory?
  7.    #27  
    Quote Originally Posted by SashoDikov View Post
    Hi, ipk didn't install with WOQI so i executed "mount -o remount, rw /" on my terminal. After IPK and patched installed as advertised but no flash.

    I ended up following Leathal's instructions step by step from http://forums.precentral.net/webos-i...etadoctor.html by manually sending every file with WOQI and commenting the preferences-assistant.jsjsjs $after$ $which$ &$quot$;$mount$ -$o$ $remount$, $ro$ /&$quot$; ($i$ $think$ $this$ $is$ $redundant$ $since$ $it$ $is$ $read$ $only$ $by$ $default$ $after$ $reboot$) $and$ $i$ $haz$ $flashes$ $now$

    I think the problem is not including the FlashMiniAdapterData:

    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-noplay.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-play.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-unknown.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-scrim.png
    /usr/lib/BrowserServerPlugins/FlashMiniPlugin.so

    now i need to figure out how disable all the flash adds I'm seeing
    yea, I purposefully left that out as the webOSDoctor for 2.1.0 contained it already, though a different version. As stated in post#1, it is an untested method.

    As we speak, I'm updating the zip and instructions, to accommodate the change
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  8. mgmft's Avatar
    Posts
    199 Posts
    Global Posts
    230 Global Posts
    #28  
    Quote Originally Posted by mangotrance View Post
    Installation worked,the options are available in the settings,but no flash is showing.Still the "missing plugin"-logo.
    Same for me
  9. SashoDikov
    SashoDikov's Avatar
    #29  
    Quote Originally Posted by Jason Robitaille View Post
    As stated in post#1, it is an untested method.
    i wasn't accusing you, hopefully i contributed to your fix

    Shall i guess that the patch is essentially modifying the preferences file and the script puts the files in root dir, even though IPK Packager shows "/media/cryptof/apps/" ?

    also note that uninstall of the IPK will require write-enabled remounted filesystem for people who want to remove it
    Last edited by SashoDikov; 02/24/2011 at 09:33 AM.
  10. mgmft's Avatar
    Posts
    199 Posts
    Global Posts
    230 Global Posts
    #30  
    Quote Originally Posted by SashoDikov View Post
    ...

    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-noplay.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-play.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-icon-unknown.png
    /usr/lib/BrowserServerPlugins/FlashMiniAdapterData/plugin-scrim.png
    /usr/lib/BrowserServerPlugins/FlashMiniPlugin.so
    Installing these additionally helps! But on a Pre - with 500 MHz Flash is of no use IMHO. That`s probably the cause, why it`s not included.
  11.    #31  
    Quote Originally Posted by SashoDikov View Post
    i wasn't accusing you, hopefully i contributed to your fix

    Shall i guess that the patch is essentially modifying the preferences file and the script puts the files in root dir, even though IPK Packager shows "/media/cryptof/apps/" ?

    also note that uninstall of the IPK will require write-enabled remounted filesystem for people who want to remove it
    yea, I realize ya weren't accusing me. Ya helped validate a concern/theory

    And yep, that's how the package works. The fixed zip is coming soon and will include a md5sum check on /usr/lib/BrowserServerPlugins/FlashMiniPlugin.so to check if it should backup or whatnot.

    And about the remounting, looking over it actually found a bug in WOSQI (fixed with 4.04). Upcoming updated zip will also include proper remounting.


    EDIT: New zip uploaded. I've also added /usr/lib/BrowserServerPlugins/FlashMiniPlugin.so to the instructions. I left out the other image files as they're identical to the ones already included in 2.1.0.
    Last edited by Jason Robitaille; 02/24/2011 at 10:28 AM.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  12. #32  
    Ok, so i downloaded and followed instructions. I am getting an error message when I try to install the Flashplugin.ipk:

    Unclean FlashMiniPlugin.so or invalid webOS version: line 14
  13.    #33  
    Quote Originally Posted by arkieboy View Post
    Ok, so i downloaded and followed instructions. I am getting an error message when I try to install the Flashplugin.ipk:

    Unclean FlashMiniPlugin.so or invalid webOS version: line 14
    have you previously replaced FlashMiniPlugin.so? or is it the stock webos 2.1.0 one?
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  14. #34  
    It is from the Verizon doctor. I downloaded it from the link you provided in the first post.

    Yep, I bet I know the issue. I did use another file by that name from another 2.1.0 doctor, (yes, I am in the Dev program and obtained that file legally...)

    Tried a reboot and it still will not install.
    Last edited by arkieboy; 02/24/2011 at 11:35 AM. Reason: add info
  15. #35  
    Quote Originally Posted by arkieboy View Post
    Ok, so i downloaded and followed instructions. I am getting an error message when I try to install the Flashplugin.ipk:

    Unclean FlashMiniPlugin.so or invalid webOS version: line 14
    You're installing on 2.1, right?
    Just remember: If I helped you, press the thanks button!

    Owner of: Pre Sprint, Pre Telcel, Pre Plus AT&T, Pre 2 Unlocked, Pixi Plus AT&T, and 2 TouchPads (my Pre3 was stolen so it won't appear again here).
    Needs: Veer (anyone?)
    Apps: Subnet Calculator, FreeCam, PhotoFun, NuttyPad (work in progress)
    HomeBrew: meta-doctor and Messaging Plugins collaborator
    Twitter: @cesarneg
  16. #36  
    Quote Originally Posted by arkieboy View Post
    It is from the Verizon doctor. I downloaded it from the link you provided in the first post.

    Yep, I bet I know the issue. I did use another file by that name from another 2.1.0 doctor, (yes, I am in the Dev program and obtained that file legally...)
    I'm getting the same problem from the verizon doctor. I'm not in the dev program so chances of me having it from another 2.1.0 doctor are slim to none.
    Treo 680 -> Palm Pre Plus
    WebOS is next to godliness
  17. #37  
    I had the same problem described by arkieboy. The compare between MD5_CURRENT and MD5_210 in the postinst file seems to always return false. However I noticed when I echo the current they appear visually identical.

    This was also my first attempt, no files previously copied.
  18. #38  
    Quote Originally Posted by NuttyBunny View Post
    You're installing on 2.1, right?
    Yes, created with the AT&T meta-script
  19.    #39  
    Quote Originally Posted by alex.dobeck View Post
    I had the same problem described by arkieboy. The compare between MD5_CURRENT and MD5_210 in the postinst file seems to always return false. However I noticed when I echo the current they appear visually identical.

    This was also my first attempt, no files previously copied.
    Ooo, I've figured it out. Just uploaded an updated zip. Should work now.

    Note: do not install with palm-install. Only use WOSQI, Internalz or Preware for install/uninstall.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  20. #40  
    Quote Originally Posted by Jason Robitaille View Post
    oo, duh, I've figured it out. uploading a fixed package
    Yep, forcing the true statement to occur fixed it and it seems to be working just fine after that.

    Thanks Jason.
Page 2 of 18 FirstFirst 1234567 12 ... LastLast

Posting Permissions