Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 61
  1. #21  
    Quote Originally Posted by TBH View Post
    You install it with Preware, and that's the way you uninstall it, too.
    Select the service in Preware -> Installed Packages -> Service and tap "remove".
    Thanks for the quick reply.
    Unfortunately I don't have Preware installed and used WebOSQuickinstall to install the SysToolsMgr-Package. Is there any way to uninstall without first installing Preware?

    Best Regards

    Richard
  2. TBH
    TBH is offline
    TBH's Avatar
    Posts
    47 Posts
    #22  
    Oh sorry, didn't think of using WOSQI ;-) Of course you can uninstall it, I suggest reading http://www.precentral.net/how-add-ho...hes-and-themes, there is a section called Removing Apps, Patches, and Themes (you have to scroll down a little bit ;-) )
    Regards,
    Tobi
  3. #23  
    Quote Originally Posted by TBH View Post
    Oh sorry, didn't think of using WOSQI ;-) Of course you can uninstall it, I suggest reading http://www.precentral.net/how-add-ho...hes-and-themes, there is a section called Removing Apps, Patches, and Themes (you have to scroll down a little bit ;-) )
    Regards,
    Tobi
    Oh, OK! Very easy! Thanks very much. I did't take a look at the "Device Management" section in WOSQI...

    Got my Pre for a week now and as you see I'm still a novice in the Homebrew area.

    Thanks!

    Richard
  4. #24  
    Quote Originally Posted by TBH View Post
    You install it with Preware, and that's the way you uninstall it, too.
    Select the service in Preware -> Installed Packages -> Service and tap "remove".
    Tried that, but it failed.

    I had already removed Brightness in Device Menu, then removed LED Torch and then did a reset.

    Following that I tried to remove STM. It asked and ran the removal script, but failed ? ErrorGenericMethodException.

    As far as I know, I've not installed anything else that might use STM ?

    EDIT I did another Pre Reset and then tried again and it removed OK
    Last edited by ChasT; 01/06/2010 at 02:13 PM.
    Thought of the day :
    No sense being pessimistic, it probably wouldn't work anyway
  5. swmrbkrrnr's Avatar
    Posts
    7 Posts
    Global Posts
    11 Global Posts
    #25  
    Quote Originally Posted by Jason Robitaille View Post
    Interesting idea, PM me with details on your bash-script


    Think of SysToolsMgr like a software library. Just stays quietly in the background until it's used by an app like LED Torch
    Thanks! I uninstalled them both then installed the sys mgr first then the torch and it worked. Last time I installed the torch before i knew i needed the sys mgr but now i am all good. This is super cool and much better than the app in the catalog becuase it projects the lightness. Oddly enough (or maybe not) I use the flashlight a lot so I don't wake my wife up when I go to bed it is a great app. Thanks again
  6. #26  
    Amazing app, Mr Robitaille! But then again this is only one of many youve shot out since launch!

    BTW, the link in preware that says you need SysToolsManager brings you to the precentral download link instead of automatically getting it or linking to the preware services area. Not sure if that was supposed to be the case as it gave me an ipk open error. After I did that, I just downloaded the service from preware then installed LED torch...works as expected.

    Its just awesome that you and the team think of these things! Thanks again!
  7. AMR-1's Avatar
    Posts
    258 Posts
    Global Posts
    261 Global Posts
    #27  
    JR: my brain is newbin and I can't for the life of me figure out how to kill a service from inside a code snippet. I found refs to webosinternals.service.shell to run shell commands which would work great but has been removed/not recommended for security reasons. egaudet pointed me at upstart in AppAssistant.jsjsjs $found$ $in$ $DOOM$ $but$ $I$ $can$'$t$ $get$ $all$ $the$ $parts$ $where$ $they$ $are$ $supposta$ $be$ $to$ $make$ $it$ $work$.
    Basically I need to (with a button tap) kill a service and chmod it to -x so it stops the service and it won't start on a reboot.

    Could this functionality be added to SysToolsMgr?
    Last edited by amrcc; 01/09/2010 at 02:26 PM.
  8. #28  
    I cannot get flahlight to work even after installing system manager. Any advice? It's drivin me nuts!
  9.    #29  
    The service has been updated:

    v0.2.2 - February 7, 2010
    - Much-improved flashlight functions
    - Added multithreaded strobe LED functionality
    - Added ntp time sync function (by request)
    - Fixed issue affecting commandline stdout/stderr reporting


    It'll take a bit of time before the PreCentral homebrew gallery entry gets updated. So in the meantime, you can download the ipk from the GoogleCode project page
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  10. #30  
    jason,

    Once again you are a god. just installed it and like always it worked first time perfectly. Thanks again for making it so easy for the regular guy.
  11. #31  
    Wow! Awesome work, Jay. Had to do 5-6 full resets to get my page back, lol, but finally all is good. Not sure what the issue was...
    If "If's" and "But's" were candy and nuts we'd all have a Merry Christmas!


  12. #32  
    The update is now available in Preware, as well.
    Blaize, Mistress of Verbosity



    Be nice until it's time to not be nice.--Dalton, "Roadhouse"
  13. #33  
    Is there a way to get the two files linked together in preware for the update? Some programs when installed or updated indicate that there is another that needs to be also. I updated the LED program and found it not to work. Then looked for the service update and updated it. Now all is fine.

    By the way. Great job ..... again!
  14. #34  
    Should one wait until WebOs gets updated to 1.4 before installing the files for LED Torch and SysToolsMgr so as not to have to uninstall it for the up grade. By the way am so new to all of this (only had the Pre for a few weeks) I want to Thank every one for any help I get here.
  15. #35  
    all patches have AUPT (search for the thread) & do not have to be removed prior to an update. LED Torch is an app, however, and apps never have to be removed prior to an update. Good luck, and keep on Hombrewing. It's addictive. :grin
    Blaize, Mistress of Verbosity



    Be nice until it's time to not be nice.--Dalton, "Roadhouse"
  16. #36  
    I followed the instructions and intalled myflashlight,system tools and the flashlight video patch and I still dont see anything in the video recording app to turn it on..
    Help a guy thats down and out on his luck..
  17.    #37  
    Quote Originally Posted by upperking View Post
    I followed the instructions and intalled myflashlight,system tools and the flashlight video patch and I still dont see anything in the video recording app to turn it on..
    well, first off, I gotta say, MyFlashlight has nothing to do with my stuff. That's a completely separate app that I maintained for a while but no longer. LED Torch is my version of the MyFlaslight app, used mainly to highlight the flashligh api in SysToolsMgr

    Anyway, back on topic, sounds like the patch installed bad; not surprising for today. See http://forums.precentral.net/canuck-...ml#post2261826
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  18. #38  
    Nevermind, sometimes I speak before I think, or search

    GOT IT!

    its AWESOME!

    but Jason, (he who is young enough to be my grandson) we have come to expect NOTHING less that awesomeness from you!

    Once again THANK YOU THANK YOU THANK YOU!

    I may have to send yet another donation to you.. , you are well worth it!
    Last edited by dianehelen; 02/28/2010 at 12:34 PM.
    I have always been a "Phone" person. My love of "Phones" started at an early age. Avatar to the left, is circa 1952, see the sparkle in my lil toddler eyes
    Cell History: Bag Phone, Brick Phone, Various Micro Tacs, Treo's, Centro, the PRE!


    I Pre

  19. #39  
    I've been trying to install the LED patch for the video camera, and it says I need SysToolsMgr Service to function. However, when I try to install SysTools Preware says the file could not be found, and there was an installation error. Do I have to install through quick install?
  20. #40  
    Once I knew I needed SysToolsMgr, I tried to install it via WebOS QuickInstall and got a Java error message regarding the file ca.canucksoftware.systoolsmgr_0.2.3_all.ipk. I downloaded the file HERE, copied it to the path given in the error message, and tried again from WebOS QuickInstall. This time the install worked and now so does LED Torch. Of course, that all sounds a lot easier than it seemed while I was trying to figure it out. For instance, I thought the path it was indicating was the same path where I installed WebOS QuickInstall, but it turns out that file structure and files were duplicated under "Program Files (x86)" and that is where I had to put the download. Being my first homebrew app didn't help matters, I'm sure. Still, directions do need to be written for people who DON"T already know what they are doing. I hope this helps someone figure this out faster than I did.
Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions