Page 124 of 165 FirstFirst ... 2474114119120121122123124125126127128129134 ... LastLast
Results 2,461 to 2,480 of 3299
Like Tree11Likes
  1. #2461  
    Quote Originally Posted by rmackay View Post
    Thank you for the response. How do I break a theme into multiple packages and how would that affect Preware's and WOSQI's from being able to uninstall/revert to default?
    I can only speak for how Preware will operate, cause WebOS Quick Install is a closed source program so even though I'm personally able to decompile it to determine it's operation (and do so at various times to diagnose compatibility issues), I'm not sure whether Jason would be happy if I talked about it's internal operation in public, so will respect his choice of licensing.

    Preware installs, updates, and removes sets of dependent packages correctly.

    In the CONTROL/control file of the master package, you add a Depends: header which contains a comma-separated list of the package IDs of all the other packages that it depends on.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  2.    #2462  
    I'd like to point out WOSQI doesn't use the ipk theme format Preware uses, thus shouldn't be limited by /var memory like Preware would during installation.

    I recently made a change to how I close novacom streams in WebOS Repair Utility that led to MUCH more reliable usage. I'll be adding this to my upcoming 2.91 which should in turn get WOSQI theming upto a reliable stand.
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  3. rmackay's Avatar
    Posts
    190 Posts
    Global Posts
    192 Global Posts
    #2463  
    Quote Originally Posted by Jason Robitaille View Post
    I'd like to point out WOSQI doesn't use the ipk theme format Preware uses, thus shouldn't be limited by /var memory like Preware would during installation.

    I recently made a change to how I close novacom streams in WebOS Repair Utility that led to MUCH more reliable usage. I'll be adding this to my upcoming 2.91 which should in turn get WOSQI theming upto a reliable stand.
    Jason - you have my email if you want me to help test with my themes that seem to be the ones to measure with in terms of resource limits (per Rod). I am up all hours, so just call or text (my tel is in my emails) if you have a ver for me to try for you.

    Robert
  4. #2464  
    Same issue here.....Themer ran once and I thought all was well, but not all of the icons from the theme installed (i'm thinking maybe because of the firewall at work). But now when I try to run Themer to Uninstall it never starts.

    I've tried to install the same theme again and get the errors listed below.

    Quote Originally Posted by rmackay View Post
    Hi Jason,

    I sent email, but will also post here...

    With 2.9, I am having install problems with large themes (8+ mb). I had no problems with 2.82 and 1.2.1.

    Here are the symptoms...

    Choose the theme (Zip file version) and install begins. After a few minutes, I will get the following (note however, the file mentioned differs everytime):

    ERROR 5:
    Command: put file://var/usr/plam/applications/com.palm.app.musicplayerremix/icon.png
    Reply:No data to read from socket

    Again, the file differs everytime, so it is not the file. I have been trying all night to install a theme and have had it work only once. Seems random but perhaps it is somekind of time limit on the socket?

    When I press OK, the message goes away, and within seconds I get...

    ERROR 19:
    Connection refused: connect

    When I press OK, the message goes away, and immediately I get...

    ERROR 5:
    Connection refused: connect

    Then from here, I keep getting Errors 19 and 5 alternating until I give up and close WOSQI via the task manager.

    I upgraded to the latest 32bit and 64bit Java 6 Update 17 to see that would fix the problem, but it did not.

    Help!

    Robert
  5. #2465  
    Quote Originally Posted by Jason Robitaille View Post
    I'd like to point out WOSQI doesn't use the ipk theme format Preware uses, thus shouldn't be limited by /var memory like Preware would during installation.

    I recently made a change to how I close novacom streams in WebOS Repair Utility that led to MUCH more reliable usage. I'll be adding this to my upcoming 2.91 which should in turn get WOSQI theming upto a reliable stand.
    Excellent. Perhaps once we work out the maximum size of package that can be installed OTA, we might just put a limit in the autobuilder to exclude individual packages from the feeds that are larger than that size ... then the huge themes will just need to be installed via WOSQI.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  6.    #2466  
    Quote Originally Posted by rmackay View Post
    Jason - you have my email if you want me to help test with my themes that seem to be the ones to measure with in terms of resource limits (per Rod). I am up all hours, so just call or text (my tel is in my emails) if you have a ver for me to try for you.

    Robert
    my pre should be arrive any day now and I'll have 2.91 ready soon, so I'll probably send out a beta to ya soon
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  7. rmackay's Avatar
    Posts
    190 Posts
    Global Posts
    192 Global Posts
    #2467  
    Quote Originally Posted by rwhitby View Post
    Excellent. Perhaps once we work out the maximum size of package that can be installed OTA, we might just put a limit in the autobuilder to exclude individual packages from the feeds that are larger than that size ... then the huge themes will just need to be installed via WOSQI.

    -- Rod
    Rod - what about the notion you stated in a prior post about breaking the theme into like a part A and part B. How would I go about doing that?
  8. rmackay's Avatar
    Posts
    190 Posts
    Global Posts
    192 Global Posts
    #2468  
    Quote Originally Posted by rwhitby View Post
    Excellent. Perhaps once we work out the maximum size of package that can be installed OTA, we might just put a limit in the autobuilder to exclude individual packages from the feeds that are larger than that size ... then the huge themes will just need to be installed via WOSQI.

    -- Rod
    Also, in figuring out the max size, please help the theme devs know/understand what the size restrictions are... is it number of files, KB of files, KB of the entire package, or what? Otherwise theme devs will be clueless on how to get their themes below whatever this limit is comprised of.

    Thank you! Robert
  9. rmackay's Avatar
    Posts
    190 Posts
    Global Posts
    192 Global Posts
    #2469  
    Quote Originally Posted by rwhitby View Post
    I can only speak for how Preware will operate, cause WebOS Quick Install is a closed source program so even though I'm personally able to decompile it to determine it's operation (and do so at various times to diagnose compatibility issues), I'm not sure whether Jason would be happy if I talked about it's internal operation in public, so will respect his choice of licensing.

    Preware installs, updates, and removes sets of dependent packages correctly.

    In the CONTROL/control file of the master package, you add a Depends: header which contains a comma-separated list of the package IDs of all the other packages that it depends on.

    -- Rod
    Just saw this... sorry. Rats - the problem is that I do not know how to make packages. Whatever "packages" are being put in Preware feeds, are being created by the host site (precentral, prethemer, etc.) based off a theme ZIP file that I upload to them.

    Guess this would be a cool feature for Jason's Theme Builder app - to let the theme dev manually, or perhaps TB do it automatically, break a large theme into parts and put together again in a dependent package like you are suggesting.
  10.    #2470  
    Quote Originally Posted by rmackay View Post
    Also, in figuring out the max size, please help the theme devs know/understand what the size restrictions are... is it number of files, KB of files, KB of the entire package, or what? Otherwise theme devs will be clueless on how to get their themes below whatever this limit is comprised of.
    One restriction I know of currently is the well-know /var memory limit issue. ipk themes temporarily load into /var before being transferred to their destinations. So if you at the app limit, you may need to uninstall a lot of apps to install an 8mb+ theme

    Quote Originally Posted by rmackay View Post
    Just saw this... sorry. Rats - the problem is that I do not know how to make packages. Whatever "packages" are being put in Preware feeds, are being created by the host site (precentral, prethemer, etc.) based off a theme ZIP file that I upload to them.

    Guess this would be a cool feature for Jason's Theme Builder app - to let the theme dev manually, or perhaps TB do it automatically, break a large theme into parts and put together again in a dependent package like you are suggesting.
    Currently Rod has a WebOS-Internals script that auto-builds zip themes into the ipks on the PreCentral. It'd probably be easiest to alter the script to split into multiple ipks depending on size, but I'm not sure how Rod made the script (pretty sure it's in python and I'm not familiar with that language). As for integrating ipk building into ThemeBuilder, I'm not sure how to do that cross-platform in java and have no real desire to at the moment given how many other things have higher priority for me (especially given PreThemer and PreCentral Theme Gallery zip uploads are automatically made available in ipk format for Preware anyway).
    If you've liked my software, please consider to towards future development.

    Developer of many apps such as: WebOS Quick Install, WebOS Theme Builder, Ipk Packager, Unified Diff Creator, Internalz Pro, ComicShelf HD, LED Torch, over 70 patches and more.

    @JayCanuck @CanuckCoding Facebook
  11. #2471  
    Based on what Rod said earlier I'm not sure how'd you feel about this, but since I somehow half installed a theme via webosqi and the Themer won't run for me; can you help me with removing it 'manually'? A script that would remove the pieces that ARE there?

    The boot logo, unlock, wave bar, wallpaper and the camera and calendar icons are in theme but the phone, IM, mail and laucher icons are not.

    Messaging is a general is a bit jacked up....there is a grey bar in each message that I have no idea of its origin.
  12. rmackay's Avatar
    Posts
    190 Posts
    Global Posts
    192 Global Posts
    #2472  
    Quote Originally Posted by danikat411 View Post
    Based on what Rod said earlier I'm not sure how'd you feel about this, but since I somehow half installed a theme via webosqi and the Themer won't run for me; can you help me with removing it 'manually'? A script that would remove the pieces that ARE there?

    The boot logo, unlock, wave bar, wallpaper and the camera and calendar icons are in theme but the phone, IM, mail and laucher icons are not.

    Messaging is a general is a bit jacked up....there is a grey bar in each message that I have no idea of its origin.
    Supposedly there is a Preware or Prethemer IPK file of the default theme. I do not know if it is WebOS version dependent (1.2.1 vs 1.3.1, etc.), so use at your own risk. Another option is to use WebOS Repair Utility or WebOS Doctor back to a stock 1.3.1.

    When you say themer won't run, what do you mean exactly?
  13. quickrahn's Avatar
    Posts
    28 Posts
    Global Posts
    35 Global Posts
    #2473  
    This may seem unimportant, because I can't find a post on it but will the emoticons in symbols screen be included in quickinstall 2.9.1?
  14. #2474  
    I received an alert yesterday about the new OS auto update and the prompt to install now or later. I selected later and the response stated the install would take place at the next charge. I have replaced WOSQI ver 2.8 with 2.9 with the intent of removing tweaks before the OS update per recommendations in this thread. Will I be able to get into developer mode without the OS updating at the moment of the USB cable connection from PC to Pre?
  15. #2475  
    Quote Originally Posted by rmackay View Post
    Supposedly there is a Preware or Prethemer IPK file of the default theme. I do not know if it is WebOS version dependent (1.2.1 vs 1.3.1, etc.), so use at your own risk. Another option is to use WebOS Repair Utility or WebOS Doctor back to a stock 1.3.1.

    When you say themer won't run, what do you mean exactly?
    I mean that I click on Themer in the drop down menu in webosqi and nothing happens......I've exited and restarted.....I've made sure there's a connection...all to no avail.

    Themer highlights in darker gray but never runs.....
  16. #2476  
    Quote Originally Posted by Jason Robitaille View Post
    One restriction I know of currently is the well-know /var memory limit issue. ipk themes temporarily load into /var before being transferred to their destinations. So if you at the app limit, you may need to uninstall a lot of apps to install an 8mb+ theme


    Currently Rod has a WebOS-Internals script that auto-builds zip themes into the ipks on the PreCentral. It'd probably be easiest to alter the script to split into multiple ipks depending on size, but I'm not sure how Rod made the script (pretty sure it's in python and I'm not familiar with that language). As for integrating ipk building into ThemeBuilder, I'm not sure how to do that cross-platform in java and have no real desire to at the moment given how many other things have higher priority for me (especially given PreThemer and PreCentral Theme Gallery zip uploads are automatically made available in ipk format for Preware anyway).
    I think the theme author just creates two themes, and then the theme builder just allows them to state that one them is dependent on another in the XML. Then the packaging scripts (and WebOS Quick Install) can all use that information to install the dependencies.

    -- Rod
    WebOS Internals and Preware Founder and Developer
    You may wish to donate by Paypal to donations @ webos-internals.org if you find our work useful.
    All donations go back into development.
    www.webos-internals.org twitter.com/webosinternals facebook.com/webosinternals
  17. #2477  
    Hi

    I have just upgraded to 1.3.1 but had this problem before I upgraded, when running WebOS Quick install it cannot find the device & comes up ERROR no device found. I can browse the device no problem using XP via USB, I have tried this in just charge, USB & sync still no joy.

    Any assistance would be great.

    Thanks
  18. #2478  
    Would it be possible to integrate an app store switcher?
    This thread talks about updating the firmware with another app store, and seeing how the new pre gsm 1.3.1 includes a severely crippled app store, it would be nice to have a simple way to go back to the 1.1.3 store cause it was bad enough not having paid apps, loosing a lot of free apps is even worse...
  19. gc916's Avatar
    Posts
    233 Posts
    Global Posts
    294 Global Posts
    #2479  
    Quote Originally Posted by ringfire View Post
    Hi

    I have just upgraded to 1.3.1 but had this problem before I upgraded, when running WebOS Quick install it cannot find the device & comes up ERROR no device found. I can browse the device no problem using XP via USB, I have tried this in just charge, USB & sync still no joy.

    Any assistance would be great.

    Thanks
    Is the phone in developer mode?
  20. #2480  
    Quote Originally Posted by ringfire View Post
    Hi

    I have just upgraded to 1.3.1 but had this problem before I upgraded, when running WebOS Quick install it cannot find the device & comes up ERROR no device found. I can browse the device no problem using XP via USB, I have tried this in just charge, USB & sync still no joy.

    Any assistance would be great.

    Thanks

    i've got the same problem. phone is in devmode. (GSM 1.3.1 Pre)

    thanks!

Tags for this Thread

Posting Permissions