Page 60 of 130 FirstFirst ... 1050555657585960616263646570110 ... LastLast
Results 1,181 to 1,200 of 2596
Like Tree1Likes
  1. #1181  
    Anyone got a copy of 2.03 so i can remove the old tweaks... I saved the new one over it
  2. #1182  
    Quote Originally Posted by Rick99gsx View Post
    Anyone got a copy of 2.03 so i can remove the old tweaks... I saved the new one over it
    Yes. What's your email?
  3. #1183  
    Quote Originally Posted by Rick99gsx View Post
    Anyone got a copy of 2.03 so i can remove the old tweaks... I saved the new one over it
    go back to post 951 on page 48...
    Irish
  4. #1184  
    where can I download from Webos quick install 2.53?????
    I need a link...
  5. #1185  
    Quote Originally Posted by josediaz767 View Post
    where can I download from Webos quick install 2.53?????
    I need a link...

    First page bottom of the first post.
    If you feel that I have given you worthy advice please feel free to show your support. TY

  6. #1186  
    Quote Originally Posted by josediaz767 View Post
    where can I download from Webos quick install 2.53?????
    I need a link...
    not only is it in the first post of this thread, but the link is a few posts above yours.
  7. #1187  
    Quote Originally Posted by josediaz767 View Post
    where can I download from Webos quick install 2.53?????
    I need a link...
    v2.53 is the current version...

    page 1
    post 1
    Irish
  8. kesne's Avatar
    Posts
    471 Posts
    Global Posts
    491 Global Posts
    #1188  
    I'd sum up what you are in a word, but I'd get banned for it, so I hope an implied word will suffice here:



    Quote Originally Posted by clipcarl View Post
    Not sure why you would think that. Just because something is tested doesn't mean there aren't bugs, it just means it is less likely to have the obvious bugs that would be found in testing (such as the one we are discussing).

    What bothers me about this situation is that Mr. Robitaille is not able to test at all because he does not own a Pre. I personally don't believe that a program that modifies system files should be released unless it has been tested first. Because he does not test I have people posting in my thread and starting new threads about how my patch is broken when in fact it is not. I do not like having to spend time diagnosing and fixing other people's mistakes.

    It also bothers me that Mr. Robitaille blamed me for the bug instead of looking at his own untested code. Now that he has finally figured out that it is in fact his own bug he does not say "Sorry for the inconvenience this may have caused you or the users of your patch / my program" but instead he implies that it is still my fault for not supplying him with a version of the patch that runs on the emulator hardware instead of the Pre.

    I don't need the hassle and I don't think it's unreasonable for me to say that I don't want Mr. Robitaille distributing my patch unless he tests that it works properly in his program before distributing it to others. I simply don't feel I should have to deal with users' problems that are a result of his mistakes. I ask that people try to understand that.

    Carl

    PS: I have been in the software development business for about twenty years. Every piece of software, without exception, should be thoroughly tested before being released to the public. That's just my philosophy on it. But I think software such as this that modifies system files on a device that people use for their livelihood and potentially in life and death situations needs to be especially carefully tested before a public release. Sure this time nothing really bad happened to people's phones because of this easily preventable bug but the next one might be worse. Especially given that this program's target demographic seems to be people that aren't comfortable hacking the device themselves from the Linux command line it seems to me to be especially imperative to make sure it just works without causing unecessary problems for people.
  9. #1189  
    Quote Originally Posted by alvin319 View Post
    Try removing it and re-applying it. Many others reported that this fixes the issue.
    Alvin, what do i remove and re-apply?
  10.    #1190  
    Quote Originally Posted by clipcarl View Post
    What bothers me about this situation is that Mr. Robitaille is not able to test at all because he does not own a Pre. I personally don't believe that a program that modifies system files should be released unless it has been tested first. Because he does not test I have people posting in my thread and starting new threads about how my patch is broken when in fact it is not. I do not like having to spend time diagnosing and fixing other people's mistakes.
    That is plain incorrect. I test every patch I apply and put in numerous safeguards. The only one I can't is yours, as it applies specifically to an on-device binary.

    And I have beta testers releases to test the ones I can't. They gave me the go-ahead with v2.53, evidentally not testing the un-applying of your patch (which is the only issue v2.53 has with your script).

    Quote Originally Posted by clipcarl View Post
    It also bothers me that Mr. Robitaille blamed me for the bug instead of looking at his own untested code. Now that he has finally figured out that it is in fact his own bug he does not say "Sorry for the inconvenience this may have caused you or the users of your patch / my program" but instead he implies that it is still my fault for not supplying him with a version of the patch that runs on the emulator hardware instead of the Pre.
    I did admit my mistake on that part and apologize wholeheartedly. I was confident in my code and the specific error information provided to me at the time appearing like standard system output giving an error (which it ended up being). It was a single line oversight I could've sworn was in there, thus I spent my time trying looking in a completely different area. I am not blaming you for the lack of emulator support, I want just trying to point out want that patch hasn't had as much attention as other.

    Quote Originally Posted by clipcarl View Post
    Every piece of software, without exception, should be thoroughly tested before being released to the public. That's just my philosophy on it.
    Interestingly, I remember there 2 versions of your own script going public causing issues with specific websites, which I even had to warn about with a message prompt. Like you I backup all patches before applying and if something can't be applied, it doesn't get applied. The issue at hand was a cosmetic error where a checkbox wasn't unchecking, leading subsequent clicks leaving your app attempting to uninstall something that's already been uninstalled.

    Quote Originally Posted by clipcarl View Post
    I don't need the hassle and I don't think it's unreasonable for me to say that I don't want Mr. Robitaille distributing my patch unless he tests that it works properly in his program before distributing it to others. I simply don't feel I should have to deal with users' problems that are a result of his mistakes. I ask that people try to understand that.
    As I said in my last post, my beta testers have confirmed to me unapplying you script now works


    clipcarl, I've PM'd you my IM information, please contact me asap so we can get things sorted out. V2.54 is ready, but I need things sorted with this before I can release it.
  11. #1191  
    Quote Originally Posted by clipcarl View Post
    The uninstalling of the change-user-agent patch works perfectly and has been thoroughly tested. Only people who have installed it via WebOS Quick Install have had problems so to me this suggests that your program is doing something wrong.

    I am concerned that you are distributing software that makes these kind of changes without thoroughly testing it first (you say above that you don't have a Pre and can't test). In the case of my patch, there is enough error checking and safety built in that it shouldn't mess up anyone's Pre but if it didn't whatever issue your program is having could easily have damaged system files in a hard to recover way. Your program is also doing many other things that could mess up people's Pres if not tested properly. I also do not appreciate people thinking that my code is buggy when it appears to be a problem with your program.

    So until such time as you are able to thoroughly test out all the features of your program before distributing it and putting other people's Pres at risk you may no longer distribute my patch.

    People may get the working patch from the original thread here.

    I apologize in advance if this seems a bit harsh.

    Thanks,
    Carl
    Dude... CHILL THE F^#$!@& OUT!

    When I read your thread, people initially had problems with your patch as well ( remember the Google incident)

    We all know this is beta... we all share the same risk... we all know how to use webdoctor to restore... This is the life of software engineering... Jason has done a nice job providing functionality for everyone for FREE / Optional Donation that Palm left out for whatever reason. WE ALL APPRECIATE WHAT JASON HAS DONE!

    He should be on Palms payroll as I am sure he has saved them many customers related to the Pre's shortcoming.

    CHILL!
  12. #1192  
    Quote Originally Posted by Jason Robitaille View Post
    You need say more than that before I can help. What OS are you on? What specific error are you getting?
    My bad Jason... I should know better. I repeatedly ask the same questions at work...
    I am using XP... pretty much got the same errors presented already in thread.
    All my issues are resolved.
    No worries.
    Thanks!
  13. saxyjaz's Avatar
    Posts
    26 Posts
    Global Posts
    29 Global Posts
    #1193  
    thank you so much... this app is revolutionizing my use of the Pre
  14. #1194  
    Quote Originally Posted by Kyusaku View Post
    Can you possibly add the state view patch to WQI?

    phone/state.patch - modifications in WebOS Internals - Gitorious
    I agree, this is a good tweak to have... not sure why it's not default functionality...
  15. #1195  
    ***Couldn't find my original post, sorry if this is dbl post, I'm just updating the original post***

    Awesome. I think I’ve gone & totally messed up my pre. Or Not.

    Ok. Everything was great, working fine. I had only installed the homebrew apps as of late August. I hadn't run into any problems. I was managing well (and installed many of the tweaks successfully) with webOS QI 2.03 and thought I was keeping a good enough eye out for the update, which came (and I wasn't aware of) and is now at 2.53.

    I had Preware 9.0 installed fine (including GNU patch, and was able to install the VK). I even had 69 apps (which I thought the limit was 60). Nevertheless, I saw the update for the VK, proceeded to update via Preware, which isn't possible until the update to Preware. So I uninstalled it thru webOS qi 203, and then tried to reinstall the updated vk also via webOS qi 203.

    I believe that therein lays my original problem w/ vk, as I began getting error [4]. Then today I found webOS repair utility, ran it, thought it was great, but still got “Patch Installing Error [4].

    Ok, no big deal, I’m currently at removing the tweaks from my Pre from using qi 203. Like post #248, none of the tweaks were checked so I recheck what I had used, then unchecked them. So far so good. If all tweaks are removed w/o a problem, I’ll upgrade to qi 2.53, and see what happens then.
    ===
    update(s)

    **My goal is simply to restore the onscreen virtual keyboard**

    -Finished removing all tweaks using qi 203 (one checkbox by one + reboot), ran webos repair utility, just in case (since all tweaks have been removed). No errors. Proceeding to upgrade to QI 2.53
    -Clicked Disable all mods (restore from backup)
    -Tried yet again to install vk via preware > same error [4]
    -Tried to install vk via qi 2.53 > Appears to be successful; awaiting reboot. Successful.
    vk reinstalled.
    -Proceeding to reenable previous tweaks. (Don’t know when the webOS 1.2 update is coming or not)
    -enabled add/del pages
    -enabled 4 x 4 icons
    -attempted to enable ‘download in browser’ > error > reattempted > same error
    see attached image:


    -enabled reduce min brightness
    -enabled silence phone dialpad
    -enabled hide nascar
    -enabled pdf landscape
    -enabled email landscape
    -enabled call duration log
    -enabled msg fwd
    -enabled msg landscape
    -enabled msg new window / conv
    -enabled msg avatar
    -enabled show timestamp
    -enabled sym+f sym+g

    -enabled batt %
    -enabled iphone spoof agent (rebooted, palm icon flashed weirdly) > browser works, though
    I don’t know what the difference is.

    **I haven’t figured out how to change the themes via webOS 2.53. Am I right to assumeI can copy/paste all my old themes, into the ‘/virtual-keyboard’ folder then modify the ‘theme_config.json’ to include those these also?
    ===
    Alright. Thx if anyone cares to comment or give insight to this.
    Last edited by tihkal; 09/24/2009 at 10:13 PM. Reason: clarity
  16. #1196  
    Quote Originally Posted by tihkal View Post
    ***Couldn't find my original post, sorry if this is dbl post, I'm just updating the original post***

    Awesome. I think I’ve gone & totally messed up my pre. Or Not.
    Ok. Everything was great, working fine. I had only installed the homebrew apps as of late August. I hadn't run into any problems. I was managing well (and installed many of the tweaks successfully) with webOS QI2.03 and thought I was keeping a good enough eye out for the update, which came (and I wasn't aware of) and is now at 2.53. I had Preware 9.0 installed fine (including GNU patch, and was able to install the VK). I even had 69 apps (which I thought the limit was 60). Nevertheless, I saw the update for the VK, proceeded to update via Preware, which isn't possible until the update to Preware. So I uninstalled it thru webOS qi 203, and then tried to reinstall the updated vk also via webOS qi 203. I believe that therein lays my original problem w/ vk, as I began getting error [4]. Then today I found webOS repair utility, ran it, thought it was great, but still got “Patch Installing Error [4]. Ok, no big deal, I’m currently at removing the tweaks from my Pre from using qi 203. Like post #248, none of the tweaks were checked so I recheck what I had used, then unchecked them. So far so good. If all tweaks are removed w/o a problem, I’ll upgrade to qi 2.53, and see what happens then.
    ===
    update(s)

    **My goal is simply to restore the onscreen virtual keyboard**

    -Finished removing all tweaks using qi 203 (one checkbox by one + reboot), ran webos repair utility, just in case (since all tweaks have been removed). No errors. Proceeding to upgrade to QI 2.53
    -Clicked Disable all mods (restore from backup)
    -Tried yet again to install vk via preware > same error [4]
    -Tried to install vk via qi 2.53 > Appears to be successful; awaiting reboot. Successful.
    vk reinstalled.
    -Proceeding to reenable previous tweaks. (Don’t know when the webOS 1.2 update is coming or not)
    -enabled add/del pages
    -enabled 4 x 4 icons
    -attempted to enable ‘download in browser’ > error > reattempted > same error
    see attached image:


    -enabled reduce min brightness -enabled silence phone dialpad
    -enabled hide nascar -enabled pdf landscape
    -enabled email landscape -enabled call duration log

    -enabled msg fwd -enabled msg landscape
    -enabled msg new window / conv -enabled msg avatar
    -enabled show timestamp -enabled sym+f sym+g

    -enabled batt %
    -enabled iphone spoof agent (rebooted, palm icon flashed weirdly) > browser works, though
    I don’t know what the difference is.

    **I haven’t figured out how to change the themes via webOS 2.53. Am I right to assumeI can copy/paste all my old themes, into the ‘/virtual-keyboard’ folder then modify the ‘theme_config.json’ to include those these also?
    ===
    Alright. Thx if anyone cares to comment or give insight to this.
    I am having the exact same problem. Went the the process of Doctoring the PRE tonight. So I can't be more stock. Devmode the PRE and hooked it up and only ran webOSquickinstall. Many of the tweeks worked but the one I really need downloading from the browser is a no go. Same error.

    HELP!!
    Commodore Pet, Commodore 64&128, Amiga 4000, PC-7, Ubuntu, Treo 650. Treo 755p,Sprint Palm Pre Plus 2.2.4,2 Sprint Pre2 2.2.4, TouchPad 32gig.
  17. #1197  
    same here, exactly like the previous two posts, re: Download in browswer.
  18. #1198  
    Quote Originally Posted by Kyusaku View Post
    Can you possibly add the state view patch to WQI?

    phone/state.patch - modifications in WebOS Internals - Gitorious
    +1... I really miss this feature that was on my old clamshell phone.
  19. #1199  
    Quote Originally Posted by mangosauce View Post
    same here, exactly like the previous two posts, re: Download in browswer.
    Yup, Jason, I think your "fix" for Download in Browser in 2.53 borked something else, I'm getting the Java lang error, too :-/ D'oh!
  20. #1200  
    Not a huge deal, but in Tools> Device Management I'm just seeing "Device: <unknown:castle-dvt3>" on my Pre.

    Doesn't really bother me, just something you might want to look into when you have time.

Tags for this Thread

Posting Permissions