PDA

View Full Version : WebOS Quick Install v4.5.0


Pages : [1] 2 3 4 5 6

Jason Robitaille
02/06/2011, 07:23 PM
WebOS Quick Install v4.5.0

This program is intended for use with WebOS applications that are in-testing, which under section 4.2 of the Palm SDK License Agreement allows for such unapproved applications to be installed on Palm devices. Applications installed with WebOS Quick Install have not be tested by Palm and are installed at your own risk.

Donations are appreciated as I'm just one person developing this app during my spare time.
http://www.paypal.com/en_US/i/btn/btn_donate_LG.gif (https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=7G5QLAXMVVSGY)

Enjoy! :-)


Download Here (http://dl.dropbox.com/u/2774158/WebOSQuickInstall-4.5.0.jar)

Source code: https://github.com/JayCanuck/webos-quick-install

Setup Guide/Problem Troubleshooting
If you would like step-by-step directions on how to get things up and running, or are encountering some issues, I highly recommend checking out the official WOSQI Homebrew Guide (http://bit.ly/wosqi-guide).


Requirements

Java 1.6 (http://www.java.com/en/download/manual.jsp)
For Mac OS X, once you've installed Java 1.6, run /Applications/Utilities/Java/Java Preferences. Then click and drag Jave SE 6 to top of both list, and exit the program. This will set Java 1.6 as the default version to use.


Novacom
This will get installed automatically when you run WebOS Quick Install


DevMode enabled
This can be done on your device by typing "upupdowndownleftrightleftrightbastart", opening the DeveloperMode app, and enabling the feature.


Lastly, when you plug in the device, if you want to use WebOS Quick Install, choose the "Just Charge" option on the device.


Running WebOS Quick Install

Simply double-click WebOSQuickInstall.jar and (as long as Java is installed properly) it will launch


Features

Stylish easy-to-use GUI
Cross-platform support (Windows, Mac OS X, Linux)
Supports off-feed .ipk and .patch files
Full-featured feed viewer, with custom feeds allowed
No Linux knowledge required, no root access required.
webOS 3.x-compatible
Full device information section
Send and receive files to and from a webOS device.
Multiple device support
Supports English, French, German, and Simplified Chinese



Screenshots
http://img248.imageshack.us/img248/7373/wosqi.th.png (http://img248.imageshack.us/img248/7373/wosqi.png) http://img11.imageshack.us/img11/2171/wosqi4.th.png (http://img11.imageshack.us/img11/2171/wosqi4.png)


Change Log
v4.5.0 - March 8, 2013
- Fixed the novaxom driver installation issues
- Changed the PreCentral references to webOS Nation
- Minor bugs and code cleanup
- First opensource release

v4.4.0 - January 29, 2012
- Now uses AUSMT for .patch file installation
- Improved feed parsing

v4.3.1 - September 8, 2011
- Fixed an issue with PreCentral feed ipk files not properly downloading

v4.3.0 - September 6, 2011
- Fixed issue with downloading .ipk files on redirected feed urls
- Added support for non-standard Novacom driver locations
- Improved DevMode password detection/support
- Novacom drivers that get installed should now be Lion-compatible
- Fixed an issue where novacom.exe would hang around in the background causing problems
- Fixed issue affecting driver installation on Windows computers

v4.2.3 - July 2, 2011
- Fixed a connection bug that would prevent connection if you disconnect and reconnect the same device in a single session

v4.2.2 - July 2, 2011
- Updated to fix a bug where Novacom reinstall attempts on Windows could fail if novacom.exe was missing

v4.2.1 - July 1, 2011
- Will now install properly Novacom drivers for webOS 3.x
- Logging mode improved for installs/uninstalls
- Now dynamicly determines the webOSDoctor and Linux drivers URLs

v4.2.0 - June 26, 2011
- Auto-detects if a device needs a password to connect
- Prompts for password if needed
- Option to save passwords (encrypted) to avoid needing to re-enter it everytime
- Option on Settings screen to delete all stored passwords
- Option on Settings screen to use device name rather than device model
- Now able to enable/disable feeds on the Settings screen
- Initial no-devices-detected error now has the options to retry and to reinstall novacom
- Fixed .patch applying using the new AUPT script urls
- Packages with invalid source json objects will be omitted from the feed viewer
- Will now be properly notified if file transfers fail
- Improved German translations

v4.1.1 - June 3, 2011
- Added a proper fully-functional Linux Commandline option

v4.1.0 - June 3, 2011
- Changed novacom connection format
- Much stabler; fewer, if any, disconnects
- Faster and more efficient
- Fixed a bug that in rare circumstances would freeze WOSQI
- Novacom driver installation no longer requires webOSDoctor; only downloads driver itself (11mb)
- Full support for future devices (as long as you have a novacom driver that supports it)
- Unavailable patches are now properly hidden
- Clock Theme feed is now added by default
- Fixed a bug that prevented "MinWebOSVersion" and "MaxWebOSVersion" source json values from being recognized

v4.0.4 - February 24, 2011
- Much improved novacom detection; should drastically reduce the number of people who are stuck always being prompted to install novacom drivers
- Fixed issue preventing root fs remounting to read-write

v4.0.3 - February 7, 2011
- Fixed an issue giving .patch files the wrong package name

v4.0.2 - February 7, 2011
- Fixed an issue with Device Management freezing during loading

v4.0.1 - February 7, 2011
- Fixed an issue with incorrect Novacom executable path finding on some Windows systems

v4.0.0 - February 6, 2011
- Underlying code has been 100% redone; only the UI images and layout has been re-used, everything else is new and reworked
- Dynamic dropdown box on main window to easily change between actively connected devices
- No longer requires webOSDoctor (with the exception of temporarily once to install Novacom is it's not installed)
- Immersive feed viewer with tabbed access to all facets of the homebrew community: apps, themes, patches, kernels, etc.
- Feed viewer has all the bells and whistles like categories, screenshots, search, and custom feeds, with full dependency support and following all the latest homebrew package standards
- Full support for French, German, and Simplified Chinese
- Much-improved stability; works on Sun Java SE 6 and OpenJDK
- Many many small bugfixes, UI changes, and stability improvements



Special thanks to Derek Kessler for the splash image, Jake Morrison for the French translation, Tobias Kaller for the German translation, and medigi8 for the Simplified Chinese translation.

Also, thanks to everyone who's helped contribute to the cause: those who donate, those who help test, those who help teach me new things, and those who help out with new users. This app wouldn't be what it is without you guys :)

Garrett92C
02/06/2011, 07:25 PM
Nice! Thanks Jason! I'll be playing around with it later tonight. :D

Sent from my HTC HD2 using Tapatalk

sketch42
02/06/2011, 07:28 PM
Sweet!

-- Sent from my Palm Pre using Forums (http://developer.palm.com/appredirect/?packageid=com.newnessdevelopments.forums)

arkieboy
02/06/2011, 07:32 PM
Thank you. I have been following you on Twitter, and rushed home to download it. Forget the Super Bowl, this is better.

RMB175
02/06/2011, 07:44 PM
Awesome....great work, Jason.

rickys239
02/06/2011, 07:51 PM
Downloading right now, good work as always!

netwrkr9
02/06/2011, 07:56 PM
Awesome, thankyou Jason! Donated ;)

mikeisnowonfire
02/06/2011, 07:56 PM
You're the best Jason!

-- Sent from my Palm Pre using Forums (http://developer.palm.com/appredirect/?packageid=com.newnessdevelopments.forums)

ldudiaz
02/06/2011, 08:07 PM
I installed but is telling me I have to download novacon driver and I did, but still getting same message, any idea?

nimer55
02/06/2011, 08:09 PM
I'm now depressed at the fact that my friend lost my micro usb cable.

ZombieElvis
02/06/2011, 08:24 PM
Sweet! But I can't seem to find Preware on the Homebrew feeds. How do I add feeds?

Jason Robitaille
02/06/2011, 08:28 PM
I installed but is telling me I have to download novacon driver and I did, but still getting same message, any idea?
Private message me your OS and I'll try and help ya out.

Jason Robitaille
02/06/2011, 08:31 PM
Sweet! But I can't seem to find Preware on the Homebrew feeds. How do I add feeds?
Do note: installed apps don't appear in the feeds.

Though for the record, you can add custom feeds in the Settings window

veerar
02/06/2011, 08:37 PM
Thanks for the update!

I am not sure of how its supposed to work, but I installed WebosQI v4.0, opened, connected my pre plus and saw no feeds, no apps, etc. Then I hit the "globe" refresh icon and lo! everything loaded. Even found a solitaire app that I thought webos never had.

( Dont hate me for this ) Since I use the command line for everything, I found ths typo in the first message of this thread: /Application_s_/Utilities/Java/Java Preferences

Thanks,
veerar.

nyczwillz
02/06/2011, 08:39 PM
Great job, perfect timing.

I do have a problem, when I plug my Pre and just charge, it states no device is connected and shuts down.

Jason Robitaille
02/06/2011, 08:40 PM
Thanks for the update!

I am not sure of how its supposed to work, but I installed WebosQI v4.0, opened, connected my pre plus and saw no feeds, no apps, etc. Then I hit the "globe" refresh icon and lo! everything loaded. Even found a solitaire app that I thought webos never had.

( Dont hate me for this ) Since I use the command line for everything, I found ths typo in the first message of this thread: /Application_s_/Utilities/Java/Java Preferences

Thanks,
veerar.
Yea, that's how it works. The main screen is where you can add/remove off-feed .ipk and .patch files. The globe button opens the feed viewer :)

And thanks for the correction. I don't have a Mac and was just going off what I've been told. Updated the first post. :)

Cantaffordit
02/06/2011, 08:40 PM
Everyone that is amazed by Jason's work shold join this FB group and promote it to all of your social networks. Palm needs to hire Jason Robitaille | Facebook (http://www.facebook.com/group.php?gid=133622476652994)

I can't wait to ask the Palm olks about this at the dev event... :)

netwrkr9
02/06/2011, 08:41 PM
Do you have your Pre in developer mode?

Garrett92C
02/06/2011, 08:41 PM
Everyone that is amazed by Jason's work shold join this FB group and promote it to all of your social networks. Palm needs to hire Jason Robitaille | Facebook (http://www.facebook.com/group.php?gid=133622476652994)

I can't wait to ask the Palm olks about this at the dev event... :)

They should also consider donating to him! :D

Sent from my HTC HD2 using Tapatalk

Cantaffordit
02/06/2011, 08:42 PM
Great job, perfect timing.

I do have a problem, when I plug my Pre and just charge, it states no device is connected and shuts down.

Are you in dev mode?

nyczwillz
02/06/2011, 09:03 PM
yep, in dev mode.

teejay69
02/06/2011, 09:51 PM
OK - Thats my pre (no pun intended) Feb 7th SPRINT, and HP 9th fix. I'm ready lets make the wait worth it!

PalmNSH
02/06/2011, 10:07 PM
Amazing! Thanks so much.

shadavis08
02/06/2011, 10:13 PM
UMMMMM where are the tweaks ?? i really would like to have my squarify tweak please ??

Jason Robitaille
02/06/2011, 10:21 PM
UMMMMM where are the tweaks ?? i really would like to have my squarify tweak please ??
Tweaks were removed as nearly all were in the feed viewer already. Squarify is the ones that didn't make it. It'll be added in a future version.

warlord9159
02/06/2011, 10:36 PM
Nice work.
but I can not find a luna restart.
Would be so nice if we had a luna restart on the start page :D

pyrognome
02/06/2011, 11:04 PM
I must be kind of lost. I am not able to find Preware in the applications/patches/kernals/ tabs dialog window. Where could one find it? It used to be easy to find WOSQI3>

Jason Robitaille
02/06/2011, 11:11 PM
I must be kind of lost. I am not able to find Preware in the applications/patches/kernals/ tabs dialog window. Where could one find it?
Preware is in the applications tab. You can even type "preware" in the search box and hit enter to find it. Though keep in mind, if Preware is already installed, it won't show up in the feed viewer

qilu
02/06/2011, 11:18 PM
Great job, perfect timing!

mrreef
02/06/2011, 11:35 PM
Thank You

Editor02
02/06/2011, 11:45 PM
You are a legend for sharing this Jason, thanks.

SonicHyuga
02/06/2011, 11:57 PM
Great job, perfect timing.

I do have a problem, when I plug my Pre and just charge, it states no device is connected and shuts down.

Same here. The older version doesn't work either, and it used to just fine. Trying to figure it out though.

EDIT: Uninstalled then reinstalled Novacomd and it worked afterwards. Not sure why. :P

Achill3s
02/07/2011, 12:45 AM
Hey Jason, I believe 3.14 didn't require your device to be connected to just view WOQI. Did this change with 4.0? Thanks again! :)

Jason Robitaille
02/07/2011, 01:11 AM
Hey Jason, I believe 3.14 didn't require your device to be connected to just view WOQI. Did this change with 4.0? Thanks again! :)
Yea, it was a necessary change in order to get multiple device support working.

nrupesh
02/07/2011, 01:25 AM
I still have to download the Web OS Doctor isnt it? Because when I open the webosQI..its directing me to download the 200mb file

Jason Robitaille
02/07/2011, 01:29 AM
I still have to download the Web OS Doctor isnt it? Because when I open the webosQI..its directing me to download the 200mb file
If you're on Windows or Mac, yes, you'll need to download webOSDoctor at once, to install Novacom drivers. If you already have Novacom drivers installed, then you won't even need to do that :)

CptOx
02/07/2011, 01:31 AM
Congratulations and thank you very much. All of us have begun in this homebrew world with your help and effort. This special week could not have started better. I hope donations go up again as mine as.

In you need a Spanish (from Spain) to translate for future releases of WOSQI, please PM me.

nrupesh
02/07/2011, 01:38 AM
If you're on Windows or Mac, yes, you'll need to download webOSDoctor at once, to install Novacom drivers. If you already have Novacom drivers installed, then you won't even need to do that :)
Thanks a Lot of the software :)

Jason Robitaille
02/07/2011, 01:52 AM
Congratulations and thank you very much. All of us have begun in this homebrew world with your help and effort. This special week could not have started better. I hope donations go up again as mine as.

In you need a Spanish (from Spain) to translate for future releases of WOSQI, please PM me.
Thanks for the compliments :) Heh, I too hope the donations go up. Even with v4.0's release, they've been pretty slow. A special thanks to those who have donated (recently or in the past). The complete overhaul that 4.0 became is dedicated to you guys.

Also, I'll definitely keep you in mind for the spanish translation. I have a guy who said he'd help, but i haven't heard from him recently. If I can't get a hold of him, I'll definitely contact ya :)

jcmarcos
02/07/2011, 02:58 AM
I'd love to take a look at this amazing job, but I con't: Upon starting, it says it needs the novacom driver to be installed, and it's already installed, service running and all. I've had connected to my Pre's console just a minute ago. Did I miss something?

On a second try, I let WebOSQuickInstall setup Novacom by itself, and it says no device is connected.

tklr
02/07/2011, 03:02 AM
AWESOME Jason!
Donated (as it should be self-evident for anyone using WOSQI, if I may say so.)
Toby

SpunJah420
02/07/2011, 03:19 AM
Great job, perfect timing.

I do have a problem, when I plug my Pre and just charge, it states no device is connected and shuts down.

Same here, and I am in dev mode....I'm probably doing something wrong.... help please ;P

MAMISHO
02/07/2011, 04:21 AM
hola jason, yo te podria ayudar con la traducion a espaņol...
si te interesa escribeme a mamisho@hotmail.es

y gracias por que asi la comunidad sigue creciendo y hacemos grande a este sistema operativo, que para mi es el mejor..............

M4rk
02/07/2011, 04:30 AM
Thanks for the update, Jason!

I'm getting a problem in the Device Management window. In the User-Installed Content box, I get the message "Loading list...", but the list never gets filled out. This happens for both Packages and Patches. I'm on Win 7 Pro x64, and my phone is a Sprint Pre with webOS 1.4.5 in DevMode.

pyrognome
02/07/2011, 06:21 AM
Thanks Jason, that would explain why it wasn't showing up. I appreciate the response.

Dude, when are we going to see your Dropbox app?

AD2050
02/07/2011, 07:40 AM
Awesome work, I can't wait to try it.

tomglasser
02/07/2011, 07:52 AM
:thumbsup: I loved the last version and can't wait to start using this one!

PreGP
02/07/2011, 07:58 AM
Thanks Jason. New version works really well. Have donated and hope we can see webOS 2 compatible FileMgr/Internalz coming soon!:)

bevcraw
02/07/2011, 08:04 AM
Thanks, Jason. Can't wait to try it.

And another donation is on its way....

cmahy
02/07/2011, 08:19 AM
Jason -- thanks! Even though I don't use WebOS Quick install as often as PreWare -- it still is a cornerstone of Homebrew/patching & very much appreciated!

Was elimination of the 'Linux Commandline' component deliberate? Admittedly, not a big deal since we have the terminal app on-device, but, just curious.

Donated & I certainly encourage everyone else to show your appreciation to one of the Godfathers of WebOS homebrew.

bakedvaporz
02/07/2011, 08:37 AM
excellent job mate love the new software keep up the great work

AD2050
02/07/2011, 08:38 AM
I get a message that no devices are connected. My phone is in dev mode. Any thoughts.

Gaurav
02/07/2011, 08:45 AM
can't wait to test it out!

cwgtex
02/07/2011, 09:17 AM
Great work Jason. :cheers:

Works wonderfully on LinuxMintDebianEdition, as long as I start novacom manually first (but I have to do that for the sdk also so no surprise, Debian lacks upstart from what I hear).

Just donated, thanks for your hard work. :thumbsup:

loftwyr
02/07/2011, 09:49 AM
I'm running this under Ubuntu (NAtty Alpha 2) and getting the following error messages many times repeated when it tries to poll the installed packages :

java.lang.Exception:
at ca.canucksoftware.novacom.NovacomConnection.runProgram(NovacomConnection.java:59)
at ca.canucksoftware.webos.InstalledEntry.getName(InstalledEntry.java:60)
at ca.canucksoftware.wosqi.DeviceManagement.loadPackages(DeviceManagement.java:139)
at ca.canucksoftware.wosqi.DeviceManagement.access$1300(DeviceManagement.java:26)
at ca.canucksoftware.wosqi.DeviceManagement$DoLoadPackages.run(DeviceManagement.java:626)
at java.util.TimerThread.mainLoop(Timer.java:512)
at java.util.TimerThread.run(Timer.java:462)
Running process: [/usr/local/bin/novacom, -d, 32c9312e0d9ff4bc40642b379f3d67b98046c7af, --, run, file:///bin/grep, \\\"title\\\", /media/cryptofs/apps/usr/palm/applications/net.palmdoc.beeb/appinfo.json]
Unable to get app name from appinfo.json for net.palmdoc.beeb:

In the installed list, I get a bunch of "This is a WebOS application". It works mostly except for that. What am I doing wrong?

swieder
02/07/2011, 09:51 AM
Installed and ran 4.0 with no problems. Thanks for the great update.

alfred86
02/07/2011, 10:21 AM
Same here, and I am in dev mode....I'm probably doing something wrong.... help please ;P

I'm also have the same problem. In developer mode. Still not recognizing my Pre. I uninstalled and reinstall Novacom hoping it would correct. Still no luck. Any idea's?

Edit: I am using Windows XP- fyi

sketch42
02/07/2011, 10:28 AM
Hey Jason, I believe 3.14 didn't require your device to be connected to just view WOQI. Did this change with 4.0? Thanks again! :)

Yea, it was a necessary change in order to get multiple device support working.


i didnt see this in the first post :/ .. hmm checking again

EDIT: Nope not there.. i believe it clear up some confusion

cwgtex
02/07/2011, 10:38 AM
If you are using a Linux desktop and having problems with WOSQI4 and webOS 2.0, check what version your palm-novacom package is. Version 1.0.56 only supports webOS 1.4.5 and earlier.

syntracomp
02/07/2011, 11:12 AM
I have a weird issue. I have downloaded the recent version of quickinstaller. It recognizes my pre and lists everything on it. But when I try to add an app and click install, it doesnt install. I just goes through its transferring/installing little screen then nothing happens. I am able to add patches from an older version of quickinstall and see them in the new version. I just cant get any new apps to successfully install/have quickinstall recognize them or see them on my palm.

azhiker
02/07/2011, 11:24 AM
Nice to see new version. Had used prior version before rebuilding system.
Downloaded new version. Running on Win 7 x64 Ultimate. Have current JRE.
Running QuickInstaller 4, says I need Novacom driver. Have installed via old WebOSDoctor and downloading new 200MB WebOSDoctor. Win7 shows Palm Novacom installed under DeviceMgr. Relaunching QuickInstaller4 says Novacom driver not installed. Again I try successfully to install the driver but QuickInstaller4 still says no devices attached.
Sprint PalmPre 1.4.5 is in developer mode.
Am running Govnah and UberKernel via PreWare if that makes a difference.
Thanks!

Jason Robitaille
02/07/2011, 11:30 AM
Thanks Jason. New version works really well. Have donated and hope we can see webOS 2 compatible FileMgr/Internalz coming soon!:)
As soon as I'm allowed to release them I will. So just be patient :)

Was elimination of the 'Linux Commandline' component deliberate? Admittedly, not a big deal since we have the terminal app on-device, but, just curious.
Yea, it was deliberate. The CommandLine in WOSQI 3.x was very very buggy, and didn't handle interactive commands properly (or any command that required input for that matter). And given that 100% of the code was being rewritten for v4.0, I figured I'd leave it for a future version.

Plus, if you really want commandline access right now, you just need open commandprompt/terminal and type:
novacom -t open tty://

I'm running this under Ubuntu (NAtty Alpha 2) and getting the following error messages many times repeated when it tries to poll the installed packages
In the installed list, I get a bunch of "This is a WebOS application". It works mostly except for that. What am I doing wrong?
That's a side effect of an issue affecting Mac and Linux users specifically, that I've tried to avoid but had no luck. Thankfully, the issue is gonna be gone with webOS 2.x, so you guy hopefully won't have to live with it too long.

I'm also have the same problem. In developer mode. Still not recognizing my Pre. I uninstalled and reinstall Novacom hoping it would correct. Still no luck. Any idea's?

Edit: I am using Windows XP- fyi
A few tips for those with developer mode who can't connect still:
Go StartMenu->Run...->"services.msc" then find "palm novacom" in the list, right click and choose restart. If "palm novacom" isn't found, then it sounds like you really didn't have novacom installed.

Alternatively, you can go to Add/Remove Programs. Look for "Palm Novacom" then uninstall it. Then use WOSQI to reinstall it.

Oh, and you may need to reboot your computer after installing the driver

If you are using a Linux desktop and having problems with WOSQI4, check what version your palm-novacom package is. Version 1.0.56 only supports webOS 1.4.5 and earlier.
Correct. Sorry I forgot to mention it in the first post. But yea, the current public Linux Novacom drivers don't support webOS 2.0, but it's highly likely Palm will release 2.0 drivers eventually.

azhiker
02/07/2011, 12:14 PM
Thanks Jay!
Restarting Palm Novacmd didn't resolve problem.
Used your tip to uninstall Palm Novacmd from the Win7 Programs control panel.
Then used QuickInstall4 and newest WebOSDoctor to reinstall and voila! Now sees Palm Pre correctly.
Thanks!

alfred86
02/07/2011, 12:22 PM
Restarting the driver didn't work in XP either but removing and reinstalling it did.

I did have trouble when pressing the globe it would tell me "ERROR: failed loading feeds." Apparently I hadn't updated my feeds in Preware for a couple days and Quick Install didn't like that. Once I updated them in Preware they loaded just fine.

Thanks a lot!! Works great. Worth a donation everytime. Great work!

katkiller
02/07/2011, 02:08 PM
Thanks!!!!

SvenBe
02/07/2011, 02:57 PM
Restarting the driver didn't work in XP,removing and reinstalling didnīt solve the problem. When starting Quick Install it always asks for installing the driver, after installing again (and again, and again) it doesnīt recognize my pre. (german user).
Thanks for any help.

nightdevil21
02/07/2011, 03:04 PM
Wow Nice Upgrade... I'm on XP and let me try and install something to make sure it works

Jason Robitaille
02/07/2011, 03:39 PM
I did have trouble when pressing the globe it would tell me "ERROR: failed loading feeds." Apparently I hadn't updated my feeds in Preware for a couple days and Quick Install didn't like that. Once I updated them in Preware they loaded just fine.
O.o very odd. WOSQI is in no way connected to Preware and doesn't use the feed update method preware does. Only reason I could think that all feeds would fail to load would be a lack of a working internet connection. Though given that it's back working, I dunno why it originally failed, lol. But at least it's working now :p

forbes256
02/07/2011, 03:42 PM
Thanks for all you do, Jason!

-Frb

alfred86
02/07/2011, 03:49 PM
O.o very odd. WOSQI is in no way connected to Preware and doesn't use the feed update method preware does. Only reason I could think that all feeds would fail to load would be a lack of a working internet connection. Though given that it's back working, I dunno why it originally failed, lol. But at least it's working now :p

I don't know exactly but I'm sure I had a good connection. I even tried adding a custom feed and it wouldn't work either, but once I updated my preware feeds on my device they loaded right up. Now I probably haven't updated the preware feeds for almost two month's because I haven't messed with anything and haven't seen any exciting applicaitons come out. I'm not sure but it seemed to have a connection. Just thought I would add that for people to try if they ran into the same issue.

spudland
02/07/2011, 03:56 PM
Many thanks, Jason....just donated again! :)

Jason Robitaille
02/07/2011, 03:57 PM
Restarting the driver didn't work in XP,removing and reinstalling didnīt solve the problem. When starting Quick Install it always asks for installing the driver, after installing again (and again, and again) it doesnīt recognize my pre. (german user).
Thanks for any help.
Oooo. I might know that cause. I'll be looking into this and get back to ya.

Jason Robitaille
02/07/2011, 04:17 PM
New version out. See post #1 for download.

v4.01 - February 7, 2011
- Fixed an issue with incorrect Novacom executable path finding on some Windows systems

It should fix the novacom detection and device detection issues some users were having (in particular, those on non-English Windows systems).

modified67
02/07/2011, 04:47 PM
Jason,

You TOTALLY rock. Thanks so much for your hard work, perseverance, dedication, and talent!:thumbsup:

bevcraw
02/07/2011, 04:48 PM
New version out. See post #1 for download.

v4.01 - February 7, 2011
- Fixed an issue with incorrect Novacom executable path finding on some Windows systems

It should fix the novacom detection and device detection issues some users were having (in particular, those on non-English Windows systems).

I downloaded 4.01 to my Windows 7 computer. I downloaded Doctor and received a notification that the file (driver?) was installed. I closed WOSQI, attached my Pre Classic (non-Plus) and restarted WOSQI. It tells me that I need to install drivers (again?)

I seem to have the same problem as SvenBe.

Jason Robitaille
02/07/2011, 04:59 PM
I downloaded 4.01 to my Windows 7 computer. I downloaded Doctor and received a notification that the file (driver?) was installed. I closed WOSQI, attached my Pre Classic (non-Plus) and restarted WOSQI. It tells me that I need to install drivers (again?)

I seem to have the same problem as SvenBe.
Tried the earlier suggestions I made, of restarting computer after install, and alternatively uninstalling the driver then reinstalling?

modified67
02/07/2011, 05:03 PM
I installed but is telling me I have to download novacon driver and I did, but still getting same message, any idea?

Jason,

I am on Win7 64-bit

I unistalled the Novacomd driver, rebooted, reinstalled, rebooted, same issue. The device is in developer mode and I selected "just charge" when I plugged it in.

I have restarted the service and still the issue persists.

Thanks!

bevcraw
02/07/2011, 05:32 PM
Tried the earlier suggestions I made, of restarting computer after install, and alternatively uninstalling the driver then reinstalling?

No luck. Rebooted computer. Also uninstalled and reinstalled driver. I receive notification that driver is successfully installed, but does not recognize device. WOSQI tells me to attach device and relaunch WOSQI. I do that and the cycle begins again. WEBQI tells me that I need to install driver....

Believe it or not, I've never had these problems before. I used ver 3.14 just a few weeks ago and did not have any problems.

antondat
02/07/2011, 06:31 PM
Thanks for good job

-----------
Donated

Jason Robitaille
02/07/2011, 07:31 PM
No luck. Rebooted computer. Also uninstalled and reinstalled driver. I receive notification that driver is successfully installed, but does not recognize device. WOSQI tells me to attach device and relaunch WOSQI. I do that and the cycle begins again. WEBQI tells me that I need to install driver....

Believe it or not, I've never had these problems before. I used ver 3.14 just a few weeks ago and did not have any problems.

Hmm... can ya try exploring to search for the novacom drivers location. On windows, it's usually in "C:/Program Files/Palm, Inc./". Perhaps it installed somewhere else on your device.

Jason Robitaille
02/07/2011, 07:39 PM
New release out. Download on post #1

v4.02 - February 7, 2011
- Fixed an issue with Device Management freezing during loading


EDIT: another minor release.

v4.03 - February 7, 2011
- Fixed an issue giving .patch files the wrong package name

bevcraw
02/07/2011, 08:48 PM
Hmm... can ya try exploring to search for the novacom drivers location. On windows, it's usually in "C:/Program Files/Palm, Inc./". Perhaps it installed somewhere else on your device.

The driver seems to be installing in C:/Program Files/Palm, Inc./novacom

killaor112
02/07/2011, 08:50 PM
Sooo, I have my Palm Pixi+ connected to computer in dev mode, and go to use WOSQI 4.03, and I get "No Devices are connected. Connect a device then relaunch WebOS Quick Install." Any ideas what's the matter, or how I can possibly fix this.

WyreNut
02/07/2011, 09:00 PM
Same problem here as the others. Phone (AT&T Pre Plus) in Dev Mode, USB cable attached and Just Charge selected. Running Vista64.

I launch the WebOSQuickInstall-4.03.jar file, I go through the Novacom install routine, let it download the doctor file, it installs, then get the "No devices connected" error. Rinse and repeat. Novacom is in the same directory Bev reported above:

C:/Program Files/Palm, Inc./novacom

When I go to stop the USB hardware, I can see Novacom up and running and is one of the options to stop.

WyreNut

killaor112
02/07/2011, 09:10 PM
There doesn't seem to be a problem, I can go back to WOSQI v3.14 and it sees my device.

Is this a 64 bit, problem? I am currently using Windows 7 Home Premium - 64 bit.

Jason Robitaille
02/07/2011, 09:25 PM
The driver seems to be installing in C:/Program Files/Palm, Inc./novacom
Same problem here as the others. Phone (AT&T Pre Plus) in Dev Mode, USB cable attached and Just Charge selected. Running Vista64.

I launch the WebOSQuickInstall-4.03.jar file, I go through the Novacom install routine, let it download the doctor file, it installs, then get the "No devices connected" error. Rinse and repeat. Novacom is in the same directory Bev reported above:

C:/Program Files/Palm, Inc./novacom

When I go to stop the USB hardware, I can see Novacom up and running and is one of the options to stop.
To both of you, just to confirm, the full path is "C:/Program Files/Palm, Inc/novacom/novacom.exe" ?
Could you please try the following command in command prompt:
C:/Program Files/Palm, Inc/novacom/novacom.exe -V
Then connect your device and do this command:
C:/Program Files/Palm, Inc/novacom/novacom.exe -l
(that's a lowercase L btw)

And please tell me what is outputted.


There doesn't seem to be a problem, I can go back to WOSQI v3.14 and it sees my device.

Is this a 64 bit, problem? I am currently using Windows 7 Home Premium - 64 bit.
not a 64bit issue, as I myself am on Windows 7 Pro 64bit.. Try the above commands and tell me what ya get

killaor112
02/07/2011, 09:38 PM
When I try to execute that, I get "Windows cannot find 'C:/Program'. Make sure you typed the name correctly, and then try again."

WyreNut
02/07/2011, 09:46 PM
Aha! Jason, novacom.exe is not nested into Palm, Inc/novacom. It's existing in C:/Program Files/Palm, Inc/novacom.exe. I do see the novacom subfolder also, but novacom.exe is not in it! :)

Typing the "C:/Program Files/Palm, Inc/novacom/novacom.exe -V" crapped out due to the file is not located there. Typing the correct path produced a "C:/Program is not recognized as an internal or external command..."

I changed my active folder by doing:

CD/
CD C:/Program Files/Palm, Inc
novacom.exe -V

and got "version: 14

Performing the -l command produced this:

50752 09064885d281bc2eb23f799aebefc41513259b92 usb castle-linux

WyreNut

killaor112
02/07/2011, 09:51 PM
I just checked, and I have that same problem. There is a novacom.exe inside amd64, tho.

Jason Robitaille
02/07/2011, 10:01 PM
When I try to execute that, I get "Windows cannot find 'C:/Program'. Make sure you typed the name correctly, and then try again."

Oops, meant to say to use these commands:
"C:/Program Files/Palm, Inc/novacom/novacom.exe" -V
"C:/Program Files/Palm, Inc/novacom/novacom.exe" -l


Aha! Jason, novacom.exe is not nested into Palm, Inc/novacom. It's existing in C:/Program Files/Palm, Inc/novacom.exe. I do see the novacom subfolder also, but novacom.exe is not in it!
Ah, I have that location accounted for already. The current Windows locations for novacom.exe that WOSQI v4 looks for is "C:/Program Files/Palm, Inc/novacom.exe" and "C:/Program Files/Palm, Inc/novacom/novacom.exe". Which is why I'm curious what that the output to the above commands. Could ya try them (with your proper novacom path used) and tell me what is outputted please.

I just checked, and I have that same problem. There is a novacom.exe inside amd64, tho.
Sure that's not novacomd.exe?

WyreNut
02/07/2011, 10:04 PM
Jason, see my edited post above for the outputs.

This is reminding me of the problems I had installing the 1.4.5 emulator from the Dev site.

Two extra steps were necessary to get the Emul to run:

1. Even though the website's #2 step checked my version of Java as "Correct", it misidentified the 32bit version as the right one. I had to download a 64bit version (using IE 64) to grab it.

2. I then had to enter a new System Environment Path to direct windows to the 64 bit folder for Java :

;C:\Program Files\Java\jre6\bin

Finally the Emul opened! Palm's troubleshooting suggestions are comprised of "Uninstall/Reinstall" which I tried twice, but then realized I was defining the topic of "insanity"... Same task, expecting different results? ;)

(Though since I had the emulator working correctly, WOSQI should be working, no?) :(

WyreNut

killaor112
02/07/2011, 10:20 PM
Yes it is, my apologies.

When I use "novacom.exe -V." I get version: 14.

When I use "novacom.exe -l." I get "52050 135182296f75329e86356751edf954c31dc usb pixie-linux."

bevcraw
02/07/2011, 10:25 PM
I checked again and found novacomd.exe in amd64 subdirectory:

C:/Program Files/Palm, Inc/novacom/amd64/novacomd.exe

WyreNut
02/07/2011, 10:28 PM
I checked again and the driver is going into a further subdirectory:

C:/Program Files/Palm, Inc/novacom/amd64/novacomd.exe

That's a slightly different driver Bev - it has a "d" on the end of the name.

Good sleuthing though! ;)

WyreNut

jteply13
02/07/2011, 10:28 PM
Jason, I've downloaded prev installs and they all worked gr8. Gr8 job

Jason Robitaille
02/07/2011, 10:44 PM
Yes it is, my apologies.

When I use "novacom.exe -V." I get version: 14.

When I use "novacom.exe -l." I get "52050 135182296f75329e86356751edf954c31dc usb pixie-linux."
try using the full novacom exe path and tell me if ya get the same results

pastorich1
02/07/2011, 10:53 PM
Great work as usual Jason! Thanks so much!

WyreNut
02/07/2011, 11:06 PM
try using the full novacom exe path and tell me if ya get the same results

Arrgh.

I was not including the double quotes when typing the command....

Typing "C:/Program Files/Palm, Inc/novacom.exe" -V produces

version: 14

WyreNut

modified67
02/07/2011, 11:32 PM
When I use "novacom.exe -V." I get version: 17.

When I use "novacom.exe -l." I get "54596 68473971a3d8dcb508c415a237389118287c6999 usb castle-linux"

Also, there is no novacom folder; there is a novacomd folder.

I tried adding this path to the path statement in cmd prompt, but to no avail. I get the same 'C:/Program is not recognized as an internal or external command, operable program or batch file' message.

spikea4
02/08/2011, 12:20 AM
Jason, Great work! I downloaded 4.0 witch worked fine, minus the continues loading of packages. Just downloaded the newest version and I also am having novacom issues. Every time I open Quick Installer it says that I need to install "Novacom" I select the webdoctor and it states that install was successful. When I hit ok it says that my device is not connected. The 4.0 version still works though, so novacom is installed and working.

endotronic
02/08/2011, 12:27 AM
I tried this today today, and I was also getting frustrated about the same problem everyone else seems to be having. I also got the message about Novacom not being installed every time I launched the program, and after installing, it would never see my Pre.

I looked further into the problem, and I noticed that the 64-bit Novacom was being installed, but Java is 32-bit on my computer. Assuming that Novacom was running in a separate process rather than being loaded by the 32-bit process, I copied the Palm directory from Program Files to Program Files (x86) where Java would see it. Voila! Everything works.

For those of you having trouble, I suggest trying this:
Copy "C:\Program Files\Palm, Inc" to "C:\Program Files (x86)\Palm, Inc" and try again. Hope that helps!

spikea4
02/08/2011, 12:32 AM
I tried this today today, and I was also getting frustrated about the same problem everyone else seems to be having. I also got the message about Novacom not being installed every time I launched the program, and after installing, it would never see my Pre.

I looked further into the problem, and I noticed that the 64-bit Novacom was being installed, but Java is 32-bit on my computer. Assuming that Novacom was running in a separate process rather than being loaded by the 32-bit process, I copied the Palm directory from Program Files to Program Files (x86) where Java would see it. Voila! Everything works.

For those of you having trouble, I suggest trying this:
Copy "C:\Program Files\Palm, Inc" to "C:\Program Files (x86)\Palm, Inc" and try again. Hope that helps!

That appeared to work, it opened. Thank You!

awqqqq
02/08/2011, 02:00 AM
good,good,goodest

spikea4
02/08/2011, 02:06 AM
Is there a way to set boot logos still? I can't find it.

-- Sent from my Palm Pre using Forums (http://developer.palm.com/appredirect/?packageid=com.newnessdevelopments.forums)

LazPL
02/08/2011, 02:07 AM
This is really weird. The old version of QuickInstall works (to some extent) on my Pre2 (win7, 64bit). When I try to use the new version, I am prompted to install the Novacom drivers (of course they're already installed), and then, once that's completed, it says no device is connected (it IS, and it's in dev mode!). Any ideas?
Thanks!

spikea4
02/08/2011, 02:10 AM
This is really weird. The old version of QuickInstall works (to some extent) on my Pre2 (win7, 64bit). When I try to use the new version, I am prompted to install the Novacom drivers (of course they're already installed), and then, once that's completed, it says no device is connected (it IS, and it's in dev mode!). Any ideas?
Thanks!

Read endotronic's post above. It worked for me. Prehaps it will for you.

-- Sent from my Palm Pre using Forums (http://developer.palm.com/appredirect/?packageid=com.newnessdevelopments.forums)

modified67
02/08/2011, 02:24 AM
Thanks endotronic. You rock. Problem solved. I suspected it was a pathing issue.

zmadaric
02/08/2011, 07:34 AM
thnx

pmartin
02/08/2011, 07:37 AM
Hi Jason
i'm a newbie with an unlocked Pre 2 in the UK and am having problems getting WOQI to work. I hope you can help me.
I have followed all the instructions in this thread viz:
- uninstall novacom and reinstall via the option in WOQI (webosdoctor download)
- checked version etc - novacom -l returns 1453 5451019f0978974467c28611668747cf3f4 usb roadrunner-linux and novacom -V gives version 17
- novacom.exe (not novacomd) is in C:\Program Files\Palm, Inc (it's dated Oct 21 2010)
- rebooted the PC after all of this. It's running XP and up to date with service packs etc (corporate machine - i've also run with same results on home machine).

WOQI runs and detects my pre 2 (which is in developer mode). WOQI downloads OK but hangs on installation - just the animated graphic saying installing.......

i've checked that it's not the antivurus or firewall (downloads happen OK and the activity logs are clear).

i'd really like to enjoy the delights of Homebrew etc - hope you can help me!!
regards

zmadaric
02/08/2011, 07:38 AM
I do have 14 posts and I am not able to download this soft. <<deleted by mod>>

WyreNut
02/08/2011, 08:56 AM
Problem solved here too! Great catch endotronic.

WOSQI now opens without any questions about Novacom, etc! Yay! :)

WyreNut

hominyjibjib
02/08/2011, 02:29 PM
Hi there, I hope I can add a few more helpful details to the problem.

I'm in with most of the group up to this point. I'm running win7 64 bit and WOSQI 4.03 loads, asks for novacom driver, installs, says I need to connect a device, wash rinse repeat.

I followed Endotronic's advice with no luck. I have also installed 64bit java and restarted again with no luck.

Afterwards I noticed that when I run "sc query novacomd" in the command line it still is reading from "\Program Files" instead of "\Program Files (x86)"
It also says "stopped" now

Also when I check services.msc and inspect the properties of "palm novacom" it is also in "/Program Files".

Should this be installing into the x86 folder?

SvenBe
02/08/2011, 02:37 PM
Problem solved on my german windows XP too. Just added a new folder "programme (x86)" and copied the "Palm, Inc"-Folder into it. Donīt really understand why, but everything is great now :)

KalChung
02/08/2011, 06:43 PM
I'm having a problem connecting to my pre 2. I'm using Ubuntu 10.10, after setting the phone to dev mode, and running WOQI, it displays a dialog saying no device is connected then terminates.

I have tried removing the old novacom drivers from a previous install, then having it reinstalled through WOQI, but I'm still getting the same message. Any ideas?

lollygags
02/08/2011, 10:09 PM
Jason, thanks for all your hard work, the new version(4.03) is great! Just wanted to let you know that I ran into the same problem several others did with the novacom drivers and was able to resolve the issue with Endotronic's instructions. Thanks Endo! I'm running Vista 64 and would be happy to get you any additional info if you need it. Keep up the great work!

sjamie
02/09/2011, 01:14 AM
For those of you having trouble, I suggest trying this:
Copy "C:\Program Files\Palm, Inc" to "C:\Program Files (x86)\Palm, Inc" and try again. Hope that helps!

Worked for me too! Thanks.

pmartin
02/09/2011, 05:29 AM
Hi Jason
i'm a newbie with an unlocked Pre 2 in the UK and am having problems getting WOQI to work. I hope you can help me.
I have followed all the instructions in this thread viz:
- uninstall novacom and reinstall via the option in WOQI (webosdoctor download)
- checked version etc - novacom -l returns 1453 5451019f0978974467c28611668747cf3f4 usb roadrunner-linux and novacom -V gives version 17
- novacom.exe (not novacomd) is in C:\Program Files\Palm, Inc (it's dated Oct 21 2010)
- rebooted the PC after all of this. It's running XP and up to date with service packs etc (corporate machine - i've also run with same results on home machine).

WOQI runs and detects my pre 2 (which is in developer mode). WOQI downloads OK but hangs on installation - just the animated graphic saying installing.......

i've checked that it's not the antivurus or firewall (downloads happen OK and the activity logs are clear).

i'd really like to enjoy the delights of Homebrew etc - hope you can help me!!
regards
OK i seem to have resolved this now. Since I'm on XP rather than Win 7 it looks a little different from Endotronic's instructions so maybe this will help other XP users.
I have in program files a directory Palm, Inc with subdirectory novacomd which itself has a subdirectory x86. I copied novacom.exe (note: not novacomd.exe) to this x86 directory and WOQI no longer hangs on the installation process.
Now all i have to do is go enjoy what i've installed!
hope this helps

vanngoh
02/09/2011, 06:31 AM
When i click on the glode button, it updates and says: No Packages Found in EVERY PG!

Why is that so? Restarting phone and PC now, hope it"ll resolve this issue... :(

jcmarcos
02/09/2011, 06:58 AM
My Windows Server 2003 computer here is all 32 bit. Could it be that Jason has hardcoded that "(x86)" thing into WOQI, because his computer is 64 bit, and needs to do that for it to access a 32 bit component?

Also, why doesn't WOQI detect if the Novacom service is running? It shouldn't bother about its installation, only about it being running.

vanngoh
02/09/2011, 07:08 AM
Does the ver of Novacom affect everything? My novacom ver is 1.0.1.0 dated: 09/10/2009.
So I suppose the ver is too old isn't it?

Am trying to d/l the new webdoctor for the new novacom now and see how it goes..

vanngoh
02/09/2011, 07:12 AM
Side track abit. I have 1 new laptop and 1 old laptop. WOQI can be opened in my new laptop after i installed java. But the old laptop (also latest java installed), after double clicking WOQI.jar, java says: 'Unable to launch this prog' in the Oracle java box.

Why is this happening?

totalj
02/09/2011, 07:19 AM
Ok so i've been able to download the software without needing 10 posts... that's obviously not my issue.. However, after having the webOSdoctor program not download twice, and then finally getting it to install completely, I had figured, maybe NOW I can get into the goodies.


Nope. I did everything that I was supposed to do step by step to install the webOSinstall program. Though confusing, I continue to leave my phone in the "Just Charge" option, with Dev Mode on, and it constantly tells me that it can't find my device, and that I should reconnect, and reopen webOSinstall. So whats the deal here? Maybe i've got older and lost my knack at these things.. as using my three Treo devices (600, 650, and 700) as well as my beloved Zodiac were a simple to do whatever I wanted to on them. Yes, I know, PalmOS is different than webOS... but come on.. am I missing something?


I really need some of this awesome homebrew. You people even have my donation money! Haha. I currently run on Windows 7, and use a Palm Pre Plus. If that info helps...


This is killing me!

WyreNut
02/09/2011, 09:03 AM
@totalj - have you read any of the previous posts? Did you read endotronic's post yet? Many of us have reported the same issue, and have fixed it.

There are two posts on how to fix it - one from endotronic (who is running a 64bit system), and one recently from pmartin (who is running XP).

WyreNut

marcc
02/09/2011, 09:21 AM
I'm havingthe same problem and yes I am in dev mode

jcmarcos
02/09/2011, 09:57 AM
@totalj - have you read any of the previous posts?

All of them, of course. My gripe is with WOQI4 that is unable to sense that the novacom service is perfectly running in my system. As a service, one can not copy its components on a different location, it's registered at "%PROGRAMFILES%\Palm, Inc", as "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NovacomD\ImagePath" confirms.

Even if I copy it to a new "(x86)" folder, WOQI4 tells me novacom is not installed (?!). I install it with my local WebOS Doctor copy, all done fine, but yet WOQI4 says no device is connected, which of course is. If I start WOQI4 again, it says the same about novacom.

Of course, the previous version of WOQI does work.

Why doesn't WOQI4 see the perfectly running novacom service in my computer, as the previous version did?

critterward
02/09/2011, 12:42 PM
I had this working yesterday and now when i try it keeps telling me "no device is connected connect and relaunch"

Odjs114
02/09/2011, 03:13 PM
:)

drk65
02/09/2011, 04:03 PM
For those of you having trouble, I suggest trying this:Copy "C:\Program Files\Palm, Inc" to "C:\Program Files (x86)\Palm, Inc" and try again. Hope that helps!

I saw that this solution worked for several other posters in the same situation. I'm happy to report that it worked for me, as well (after re-booting). Thanks very much!:thumbsup:

brdl04
02/09/2011, 05:35 PM
I am going mad. Ive tried everything to get my computer to find my pre. Im running windows 7 64.

Ive made sure Ive installed novacom. My pre IS in dev mode. But whenever I start quick install, it askes me if I want to install novacomm driver. When I select the webos doctor file, it says to connect my device.

HELLLP

I have also checked to make sure the services are on

dancin126
02/09/2011, 07:42 PM
I'm getting the same message. I've installed the 'doctor', but it still states that I need to install novacom, but it is apparently not recognizing it. I also get that my computer is not finding my device (my devmode is on). I never had a problem with the older version, but I'm certainly excited to try the update.

WyreNut
02/09/2011, 08:23 PM
Have you read post #101 in this thread?

WyreNut

apollooff320
02/10/2011, 12:07 AM
Webosdoctor will not download completely so I can't even remove preware and the themes. Is there some place else to download it?

habib718
02/10/2011, 12:10 AM
I saw that this solution worked for several other posters in the same situation. I'm happy to report that it worked for me, as well (after re-booting). Thanks very much!:thumbsup:

That worked for me too!! Thanks!!
I've been trying to figure this out for the past 2 hrs

totalj
02/10/2011, 01:59 AM
I tried this today today, and I was also getting frustrated about the same problem everyone else seems to be having. I also got the message about Novacom not being installed every time I launched the program, and after installing, it would never see my Pre.

I looked further into the problem, and I noticed that the 64-bit Novacom was being installed, but Java is 32-bit on my computer. Assuming that Novacom was running in a separate process rather than being loaded by the 32-bit process, I copied the Palm directory from Program Files to Program Files (x86) where Java would see it. Voila! Everything works.

For those of you having trouble, I suggest trying this:
Copy "C:\Program Files\Palm, Inc" to "C:\Program Files (x86)\Palm, Inc" and try again. Hope that helps!


I just worked a long 19 hour shift today and just got home... Thank you for helping me out as this seemed to work. WyreNut, thank you. I was trying to get all of this done in a span of 30 minutes just so I could download preware while at work.. I never got around to this in time... but now I'm happy, and it works.. It works! Hahahahahahahahahahaha it works!


Seriously though.. I miss how much easier my older PalmOS products were. Despite being late into finally adopting the newer Palm tech, I'm glad I own a Palm Pre for two months now. Of course, after hearing about the HP Pre 3, I'm just.. wow. Can't wait. Thank you again.


EDIT: Wow. My grammar is taking quite a hit. This damn combo of sleep deprivation, excitement of finally getting this to work, and this Wild Turkey. Mmmm.

EDIT2: AHHHH THIS IS... AWESOME! Thank you. Donations aaaallll around!...

...


On payday.



Seriously. Keep up the awesome <mod deleted> work. 2010 sucks. My year without technology. Just a downgraded PSP-1000 to keep my geekery up. I'm so happy to own a palm (yeah. PALM) product again. And considering when I bought it online through the AT&T store with a 99.99 dollar discount resulting in.. free... this is the best yet. I paid something around 500 each for my two Treos and 300 for my zodiac. The fact I got this beast for free makes it all much sweeter. I'm not contempt with good enough. I gotta explore every nook and cranny to every device of ANYTHING i've ever owned. I can't help it. Sorry. I'll stop. But again. Thank you. Thank you for the fact that there are people actually supporting this awesome awesome device.

totalj
02/10/2011, 04:55 AM
Ok so I ran into a new problem... But its not a huge one. It's Themes.


Everything works fine. I am able to install from the PC to the Pre with no problems. Then I downloaded Preware to the Pre and can still install various things on there.. However, from the PC, it seems it won't install themes. Likewise, there's no option in Preware to install themes. I'm confused...


EDIT: READING IS AWESOME.


I figured it out.

critterward
02/10/2011, 12:26 PM
I had this working yesterday and now when i try it keeps telling me "no device is connected connect and relaunch"

LNWJ
02/10/2011, 01:21 PM
Having major difficulties on my MBP running OSX 10.6.6 and Java 1.6. Says Novacom isn't installed and no device connected, even after installing.

Just needed to get Preware back on my Pre (I removed it expecting to get webOS 2.x yesterday). Was able to pull it down via OSX Terminal:

Installing Preware from the Commandline: Application:Preware - WebOS Internals (http://www.webos-internals.org/wiki/Application:Preware#Installing_Preware_with_the_Standalone_Installer)

critterward
02/10/2011, 06:00 PM
Anyone have a fix on the no device connected issue? I had this working two days ago.

FesterTreo
02/10/2011, 09:48 PM
Critterward
1) Check that you are in devmode
2) If you are running Windows x64 then you need to do the copy of the Palm, Inc folder in C:\program files over to c:\program files (x86)

Dragone
02/11/2011, 08:36 AM
The new version of QuickInstall does NOT work on my Windows 7 64 bit.
I have both versions of java (32 and 64 bit)

QuickInstall 4.03 correctly detects my Palm Pre 2 WebOs 2.0.1 (I can even see all my installed programs on my device using the proper tool, I tried uninstalling a program using the tool and it works just fine), but when :

1) I select a ipkg to install
2) I press Install
3) QuickInstall GUI shows "Trasferring"
4) The installation close, the "Installing" phase does NOT start

I have this problem using two different computers :
1) Acer Laptop with W7 64bit
2) Desktop with W7 64bit

So this is not a local problem, this is a problem of the new version of QuickInstall.

The old version 3.14 of QuickInstall works just fine on both machines.

carc
02/11/2011, 10:14 AM
First of all, I HAVE read this entire thread up until this point. I did the little trick where you move the location of the palm folder. This solved the issue with novacmd trying to install each time. Now when I run quickInstall on my 64-bit Win7 comp. it doesn't see my Palm Pre Plus (running WebOS 1.4.5 with dev mode enabled).

All help is appreciated .

pmendez
02/11/2011, 10:42 AM
Hello,

When I extract the WebOSQuickInstall-4.03.zip file, downloaded from your DOWNLOAD HERE link, I get no WebOSQuickInstall.exe file. Only extract five folders: ca / com / META-INF / net / org.

Have downloaded the WebOSQuickInstall-4.03.zip file, have correct version of Java, and am in dev mode. Any idea what I'm missing please?

Dragone
02/11/2011, 10:51 AM
You think you downloaded a .zip file, but it is not.
It is a .jar file, that you probably are opening with WinRar/7-zip/WinAce/other clones.

You have to change the association, you have to "Open with" Java Runtime.

pmendez
02/11/2011, 10:59 AM
Spent years as a project manager in software implementation a few years back...and I would fall for something like that.

Your solution was spot-on. Thanx.

onmymarc
02/11/2011, 11:16 AM
I'm getting a "the system is too busy, please try again later" error...
Anyone else?
Nevermind....working now :)

michaelalzipperer0
02/12/2011, 12:06 AM
sweet puting the palm directroy form C:\program files to C:\program files (x86) worked nicely iv got win7 64bit

frankos72
02/12/2011, 01:59 AM
QuickInstall 4.03 correctly detects my Palm Pre 2 WebOs 2.0.1 (I can even see all my installed programs on my device using the proper tool, I tried uninstalling a program using the tool and it works just fine), but when :

1) I select a ipkg to install
2) I press Install
3) QuickInstall GUI shows "Trasferring"
4) The installation close, the "Installing" phase does NOT start

I have this same problem. I believe I only have the 64bit version of Java. I did however try copying the program files folder to program files (x86) and that didn't fix it.




The old version 3.14 of QuickInstall works just fine on both machines.
I actually can't get 3.14 to work correctly either. I'm trying to install preware and I get an error on the post run script.

frankos72
02/12/2011, 02:04 AM
I have this same problem. I believe I only have the 64bit version of Java. I did however try copying the program files folder to program files (x86) and that didn't fix it.




I actually can't get 3.14 to work correctly either. I'm trying to install preware and I get an error on the post run script.

So I just tried to install org.webosinternals.preware_1.5.0_arm.ipk using palm-install from the developer kit and that worked. Preware seems to be working now.

ceceinha
02/12/2011, 02:12 AM
thanks for the update!!

teitell10
02/12/2011, 02:29 AM
Jason,

I have used WebOs quickinstall before but it has been awhile. Since then I have had my pre replaced. I downloaded the new version of webos quickinstall great and easy. It recognized my phone as I have turned Dev Mode on...The problem is when I click on the globe it loads great and i click on the patches or apps I want and it says connecting...downloading...transferring. Which seems normal. I then exit out that screen back to the main one and there is noting to install...and the previous parts have not been installed. I have reset my phone several time turned Dev mode on and off..and reinstall novacom. What do you recommend, am I doing something wrong?
thanks

fdm006
02/12/2011, 09:37 AM
Hey Jason,
I was using WebOSQuickInstall-4.03 on a brand new Pre 2 from Mac OSX and WinXP without issue. Now it will no longer connect to the Mac and on WinXP the device is "roadrunner-linux" instead of Pre 2. Inside Device Management the device is Unknown Device and OS is webOS ?.?.?. I've installed a couple of packages and patches, but without getting into those have you seen this issue?

Thanks,

Dan

fdm006
02/12/2011, 09:46 AM
Interesting. I removed Enable Virtual Keyboard and now WebOSQuickInstall-4.03 now sees the device as a Palm Pre-2.

Shadowhawk
02/12/2011, 08:29 PM
I have a weird issue. I have downloaded the recent version of quickinstaller. It recognizes my pre and lists everything on it. But when I try to add an app and click install, it doesnt install. I just goes through its transferring/installing little screen then nothing happens. I am able to add patches from an older version of quickinstall and see them in the new version. I just cant get any new apps to successfully install/have quickinstall recognize them or see them on my palm.

I'm on Windows 7 64-bit and a Sprint Palm Pre. I've downloaded WebOS QI, and, at first, I had the problem with WebOS QI asking to install Novacom drivers each time. I solved that with the trick of copying the Palm, Inc folder from the \Program Files directory to the \Program Files (86) directory.

After doing that, I've now run into the problem reported by syntracomp above--that when I try to install things (Preware, for instance), I get the transferring files to the Pre dialog box and what appears to be a successful installation, but on looking on the Pre (and even after rebooting the Pre), I don't see Preware on-device.

What can I try next?

rastoginitin
02/13/2011, 02:35 AM
Hi. I am a first timer on these forums and it is also my first time using WebOS QI for any version. I installed v4.03 and when i open the program, and hit on the globe icon, I get a message saying "No Packages Found" in all the tabs except for themes. What am I doing wrong?

Thanks a lot in advance for all your help.

Eggshell
02/13/2011, 07:09 AM
let me see. how to work it.

why i can't connect the site?

I want to download it. but it show error when i click the link. what's the problem?

Jason Robitaille
02/13/2011, 08:34 AM
to rastoginitin and Eggshell:

The feeds are down because WebOS-Internals' server is unde maintenance. Should be back online in a few hours hopefully (though that's just my guess).

dspear60
02/13/2011, 09:54 AM
Hi Jason and others, yes, I am attempting download this morning and getting themes only. So the server must be down. Will wait (patiently).

Jason, thanks for all your help and support. I made a small donation this morning. Keep up the great work!

poppeye
02/13/2011, 09:59 AM
PSA: Feeds are back up

mmccan02
02/13/2011, 10:31 AM
I searched for preware and nothing is returned. Poppeye, have you been able to find preware in the feeds? Or is that still down?

Running webosqi 4.03 on Ubuntu 10.04, Pre+ 1.4.5

dspear60
02/13/2011, 11:08 AM
Yes, Preware in feeds...under Applications. Verified server back up, working well

headgamer
02/13/2011, 12:37 PM
I'm on Windows 7 64-bit and a Sprint Palm Pre. I've downloaded WebOS QI, and, at first, I had the problem with WebOS QI asking to install Novacom drivers each time. I solved that with the trick of copying the Palm, Inc folder from the \Program Files directory to the \Program Files (86) directory.

After doing that, I've now run into the problem reported by syntracomp above--that when I try to install things (Preware, for instance), I get the transferring files to the Pre dialog box and what appears to be a successful installation, but on looking on the Pre (and even after rebooting the Pre), I don't see Preware on-device.

What can I try next?

I'm having the same issue. Says it installs Preware but never does. Anyone got a solution to this? Been a frustrating morning...

Shadowhawk
02/13/2011, 02:37 PM
I'm on Windows 7 64-bit and a Sprint Palm Pre. I've downloaded WebOS QI, and, at first, I had the problem with WebOS QI asking to install Novacom drivers each time. I solved that with the trick of copying the Palm, Inc folder from the \Program Files directory to the \Program Files (86) directory.

After doing that, I've now run into the problem reported by syntracomp above--that when I try to install things (Preware, for instance), I get the transferring files to the Pre dialog box and what appears to be a successful installation, but on looking on the Pre (and even after rebooting the Pre), I don't see Preware on-device.

What can I try next?

As an update, I found a workaround that helped me move forward with what I needed to do. That workaround was to use webOS QI v 3.14. It successfully installed what I needed.

radicalRWer
02/13/2011, 04:00 PM
I have MSB Pro 10.6.6 Snow Lep OS X. I have followed the directions for getting started. Got to the point where I downloaded Doctor and it ran the Installer. The Installer went thru the unpacking and installing and at the end of the process it said it failed. I went to relaunch QuickInstall and it came up saying I needed the Nova driver and then it also wanted to re-download Doctor again. What did I do wrong!?

Note: I am using my pre's mobile hotspot for internet connection if that makes any difference.

Thanks for your help.

I should also note i am not very computer savvy when it comes to the command lines etc. you all talk about in this thread. I did locate 4 novacom thinga-ma-bobs in my Finder.

Is this what I need? I really am clueless.

trickyhero
02/13/2011, 05:39 PM
Thanks, for your hard work. :)

foxtome
02/13/2011, 07:42 PM
good software good designer!!!

ding!!!
thanks!!!

Spade
02/13/2011, 10:18 PM
First try at v4.03 and it didnt work for me. I opened the .jar file and started trying to get a patch onto the PrePlus. I found the patches tab, but only one patch was listed under it. Not sure whats going on. Seems like it isnt loading patches from the feeds.

LazPL
02/14/2011, 09:09 AM
Read endotronic's post above. It worked for me. Prehaps it will for you.

-- Sent from my Palm Pre using Forums (http://developer.palm.com/appredirect/?packageid=com.newnessdevelopments.forums)

That was very noob of me.... Not reading the post above... ! Thanks!

DJeremyC
02/15/2011, 04:19 PM
Well, attempted to install on my win7 x64 machine to no avail again. I download webOS QI, plug in my pre, prompts to install novacom and download the doctor. Then it states no device is plugged in. Next time i reinstalled all of it, QI keeps prompting to reinstall novacom.

Not sure what is wrong. I have tried putting the Palm Inc folder in the Program Files (x86) folder, and nothing worked. Tried using back USB ports instead of hub ports. I even tried using an older webOS doctor file i had and nothing still.

Any suggestions?

JakeBworth
02/15/2011, 08:57 PM
Hey thank you so must for the new quick install (it is so much easier to use). I do have one question. What is the easiest way to install custom boot logos with WOSQI 4/

sartorius54
02/16/2011, 12:27 AM
I am new to homebrew and quickinstall, but so far I have been able to get some apps and patches installed successfully, even though all the guides online don't apply to this new version. Unfortunately, I have been unable to get a theme installed. I click install in the themes tab, it says it has installed, but it never shows up on my phone. I also can't find where I would uninstall or restore my theme to default. Any help would be much appreciated. Thanks.

rwhitby
02/16/2011, 02:03 AM
I'm having the same issue. Says it installs Preware but never does. Anyone got a solution to this? Been a frustrating morning...

I've helped a couple of people with this issue in the last couple of days. We could not work out why it is occurring, so I advised them to alert Jason to the problem, then install the Palm SDK and use the palm-install program to install the ipkg file from http://get.preware.org/

-- Rod

schreibman
02/16/2011, 10:18 AM
for those of you having trouble, i suggest trying this:
Copy "c:\program files\palm, inc" to "c:\program files (x86)\palm, inc" and try again. Hope that helps!

thanks
thanksss
thanksssss

palm_str
02/16/2011, 12:04 PM
OK i seem to have resolved this now. Since I'm on XP rather than Win 7 it looks a little different from Endotronic's instructions so maybe this will help other XP users.
I have in program files a directory Palm, Inc with subdirectory novacomd which itself has a subdirectory x86. I copied novacom.exe (note: not novacomd.exe) to this x86 directory and WOQI no longer hangs on the installation process.
Now all i have to do is go enjoy what i've installed!
hope this helps

--> Im having the same issue:

In plain english, after i copy the novacom.exe to (x86 folder), it still prompts me to install novacom as soon as i open WOQI. as tho i never installed.

Not to mention, my XP computer is Not recognizing my pixi.
..AND... when i plug my device into the USB port(FYI - tried all different ports) it recognizes my device as a "Generic Serial" and "Reduced...R-(ACM)" not as a Pixi???

ANY ideas why i cant Get my pc to even find my device?

NOTE:I recently flashed my pixi to another carrier and im kinda afraid to use webOSDoctor for fear of bricking my pixi.

Oh and did i mention, when i plug my device in via USB plug, it doesnt even give me an option to "Sync", or "JustCharge"??

beancode1810
02/16/2011, 02:50 PM
Help! I had this when it was version 3.0 and it ran perfectly but now it keeps saying that the novacom driver needs to be installed and when i install it (I am in dev mode) It says that there isent a device connected! Please help!

deejayrunt
02/16/2011, 09:33 PM
it didnt work for me, i downloaded it AND got the doctor program, when i open it , it wont work and it reinstalls every time i open it

schreibman
02/17/2011, 04:01 PM
Is there an alternative application for 'themer' and linux commandline that no longer appears on the tools menu of 4.03

DJ Nativus
02/17/2011, 04:04 PM
Will this allow me to remove BS Sprint applications, such as NASCAR and Football? I wanted to use Internalz and remove fluff from my phone.

malpha
02/17/2011, 05:19 PM
I have a question. I've been trying to install some patches, but every time I do I get this error:

Unable to contact webOS-Internal's Servers.
Cannot download AUPT scripts for the patch.

(Also, this just started. I installed some partches an hour ago and it worked fine)

spudland
02/18/2011, 12:48 AM
Hey thank you so must for the new quick install (it is so much easier to use). I do have one question. What is the easiest way to install custom boot logos with WOSQI 4/

Use Internalz! (get from Preware or WOSQI if you don't already have it). Just copy the pics to your Pre, name them palm-logo.png and palm-bright-logo.png (that's the glow one) and move them from the /media/internals/ folder to /usr/palm/sysmgr/images/ then do a luna reboot...

totalj
02/18/2011, 06:56 AM
Ok so dumb*** me bricked my phone. After getting it all setup, and running again (damn me for not thinking the 1ghz kernel wasn't good enough... just had to try the 1.2ghz kernel.. Luckily, it just wouldn't boot my phone..) I have a question..


I'm too tired to get preware up. I've spent 11 hours trying to just download the damn correct webOSdoctor (it kept timing out, or just finishing too early, to where I just downloaded 2mbs at a time, paused, resumed, downloaded 2 more mbs.. rinse, wash, repeat).. But enough of that.. my point...


Will any webOSdoctor program work for preware? Or do I need to use the one that webOS Quick Install downloaded? Because I deleted that one in frustration when it wouldn't reboot my phone..


(I live in the middle of nowhere, and rely on a Virgin Mobile MiFi Hotspot with no cap, runs at between 75kbs/sec to 600kbs/sec in my area for my broadband internet. My other two choices are dial-up, and thats both too slow, and won't let me on XBL or my PSP, or Satellite "Broadband", which after looking up, has daily bandwidth caps of 75mbs, and monthly caps at around 10gbs.. Which I would just obliterate. And has usual speeds of 700bytes/sec to 5kbs/sec. So downloading something on my option alone can be time consuming.. Man I miss the city...)

rwhitby
02/18/2011, 07:12 AM
Ok so dumb*** me bricked my phone. After getting it all setup, and running again (damn me for not thinking the 1ghz kernel wasn't good enough... just had to try the 1.2ghz kernel.. Luckily, it just wouldn't boot my phone..) I have a question..


I'm too tired to get preware up. I've spent 11 hours trying to just download the damn correct webOSdoctor (it kept timing out, or just finishing too early, to where I just downloaded 2mbs at a time, paused, resumed, downloaded 2 more mbs.. rinse, wash, repeat).. But enough of that.. my point...


Will any webOSdoctor program work for preware? Or do I need to use the one that webOS Quick Install downloaded? Because I deleted that one in frustration when it wouldn't reboot my phone..


(I live in the middle of nowhere, and rely on a Virgin Mobile MiFi Hotspot with no cap, runs at between 75kbs/sec to 600kbs/sec in my area for my broadband internet. My other two choices are dial-up, and thats both too slow, and won't let me on XBL or my PSP, or Satellite "Broadband", which after looking up, has daily bandwidth caps of 75mbs, and monthly caps at around 10gbs.. Which I would just obliterate. And has usual speeds of 700bytes/sec to 5kbs/sec. So downloading something on my option alone can be time consuming.. Man I miss the city...)

This is a classic example of the conditions under which you should *NOT* test experimental kernels.

If you were reading the experimental testing threads as all alpha testers are required to do, you would have seen the memboot instructions to recover from this situation.
-- Rod

totalj
02/18/2011, 07:19 AM
I did. And tried to figure them out.


I'm not that computer savvy... But hey, I regularly backup everything and my phone is just fine now. In all honesty, it was much easier to do.


You know.. we all live and learn.

rwhitby
02/18/2011, 07:20 AM
I did. And tried to figure them out.


I'm not that computer savvy... But hey, I regularly backup everything and my phone is just fine now. In all honesty, it was much easier to do.


You know.. we all live and learn.

Glad you're back up and running.

Perhaps stick to UberKernel now ;)

-- Rod

totalj
02/18/2011, 07:28 AM
Keeping to it. I had nothing but awesome things to say about it. Of course, surprisingly enough I've been able to keep it at a decent temp while at 1ghz. Of course, I like my house really cold, and usually see low temp ratings...

http://a8.sphotos.ak.fbcdn.net/hphotos-ak-snc6/182701_10150112906788249_512803248_6189931_8182971_n.jpg


That's after playing VBA.


Anywhos.. Best keep this back on topic...


Instead of making a brand new post about it and cluttering up the boards... I've noticed that my phone has run much smoother, and I'm actually able to sucessfully install preware that once wouldn't install before my webOSdoctor-ing. Tether is awesome. Oh. My. God.

dankilla
02/18/2011, 03:13 PM
Thanks! :)

texrunner77
02/19/2011, 06:35 AM
when i try to download webos quick install 4, it says i need to temporarily install doctor. i click ok but it always says download failed. it also says it cannot connect or find my device. can anyone help? i have pre 2 with 2.0.1.. thanks!

mmm5288
02/19/2011, 11:04 AM
For those of you having trouble, I suggest trying this:
Copy "C:\Program Files\Palm, Inc" to "C:\Program Files (x86)\Palm, Inc" and try again. Hope that helps!

Thanks for this tip endotronic. Worked like a charm. :D Now I just need to get device manager list to load up.

Tibman
02/19/2011, 11:49 AM
I spent over an hour trying to get this to work using windows 7 x64 but my video driver kept crashing for some reason (ati 5770) and then it would say I had no device connected.


Tried the same process under ubuntu 10.10 x64 and it finished in about 2 minutes.

Thanks for the great app! :-)

texrunner77
02/21/2011, 04:16 PM
my computer will still not recognize my device. always tries to make me re download novacom and the DR. whats up with that, any advice?

craigau
02/21/2011, 04:39 PM
Thanks! Appreciate for the great work!

PinkPink
02/21/2011, 07:50 PM
I tried this today today, and I was also getting frustrated about the same problem everyone else seems to be having. I also got the message about Novacom not being installed every time I launched the program, and after installing, it would never see my Pre.

I looked further into the problem, and I noticed that the 64-bit Novacom was being installed, but Java is 32-bit on my computer. Assuming that Novacom was running in a separate process rather than being loaded by the 32-bit process, I copied the Palm directory from Program Files to Program Files (x86) where Java would see it. Voila! Everything works.

For those of you having trouble, I suggest trying this:
Copy "C:\Program Files\Palm, Inc" to "C:\Program Files (x86)\Palm, Inc" and try again. Hope that helps!
I think I tried EVERY suggestion on EVERY forum. Nothing got WebOsQuickInstall to work for my Pre 2

Untill...

I did what you told me... Copied folder into x86.....

T H A N K S

Mercury+fly
02/21/2011, 08:05 PM
That's great on the x86 folder, thanks for the help!

Chrissmithey
02/22/2011, 02:54 AM
Is there anywhere I can manually install the Novacom driver for Mac OS X? Every time I try through QuickInstall it says that the download fails.

joemarzi
02/22/2011, 08:08 AM
Great program!!:D

lil_tom22
02/22/2011, 10:29 AM
can you please give me a link for novacom its not installing properly on my mac

jjrausch
02/22/2011, 12:06 PM
Great job on the new version! Maybe I am missing something stupid, but where is the squarify your screen setting? Used to be under tweaks on the older version?

teh_epic_spanky
02/22/2011, 05:08 PM
whats the diffrence between the quickinstall versions?

FenrirWolf
02/22/2011, 05:40 PM
For those of you having trouble, I suggest trying this:
Copy "C:\Program Files\Palm, Inc" to "C:\Program Files (x86)\Palm, Inc" and try again. Hope that helps!

That did the trick. Thanks man!

DaveyBoy
02/23/2011, 07:10 PM
I'm having problems too though slightly different. I couldn't get quickinstall to start at first, but copying all the files to x86 folder made it suddenly spring into life. However, while it seems to go through the motions of installing nothing actually ends up on the phone.

Any ideas? I've tried installing lots of apps: rebooting, restarting services, in and out of dev mode and not a one appeared in launcher.

just for info: I recently doctored my O2 pre plus to webos 2.1 (it's quite nice but I am kinda regretting it)

luxdelux007
02/23/2011, 11:45 PM
thx

thxxx

thxxxxxx

thxxxxxxxxxxxxxxxxxxa lot

awesome

cool

thxxxxxxxxxxxxxxxxxxxxxxxxxxx

Awesome!!!

cool!!!!

Thxxx a lot man

cthetford
02/24/2011, 08:42 AM
[QUOTE=neobaptist;2851608]Restarting the driver didn't work in XP either but removing and reinstalling it did.

I did have trouble when pressing the globe it would tell me "ERROR: failed loading feeds." QUOTE]


I'm having the same issue. I had to get my PRE Replaced by AT&T. When I logged in to my profile, the phone did a pretty amazing job of restoring the state of my phone over the air, but now I'm trying to get my homebrew stuff re-installed.

Downlaoded 4.03 of the quick install. When I hit the button to read the feeds, I see messages that say "Downloading and parsing:" on a bunch of packages, but then it just gets to a point where it throws this message. Any ideas why this might be happening?

cthetford
02/24/2011, 08:52 AM
[QUOTE=neobaptist;2851608]Restarting the driver didn't work in XP either but removing and reinstalling it did.

I did have trouble when pressing the globe it would tell me "ERROR: failed loading feeds." QUOTE]


I'm having the same issue. I had to get my PRE Replaced by AT&T. When I logged in to my profile, the phone did a pretty amazing job of restoring the state of my phone over the air, but now I'm trying to get my homebrew stuff re-installed.

Downlaoded 4.03 of the quick install. When I hit the button to read the feeds, I see messages that say "Downloading and parsing:" on a bunch of packages, but then it just gets to a point where it throws this message. Any ideas why this might be happening?

Then again, the WebOS internals web site seems to be down at the moment as well.. maybe that has something to do with it?

Jason Robitaille
02/24/2011, 09:40 AM
First off, yes, the feeds not loading is due to issues on WebOS-Internals' site. Chances are it'll return soon. :)


Also, I've v4.04 is here!

v4.04 - February 24, 2011
- Much improved novacom detection; should drastically reduce the number of people who are stuck always being prompted to install novacom drivers
- Fixed issue preventing root fs remounting to read-write

No more having to copy to x86 folder :)

YankBoy
02/24/2011, 10:00 AM
First off, yes, the feeds not loading is due to issues on WebOS-Internals' site. Chances are it'll return soon. :)


Also, I've v4.04 is here!

v4.04 - February 24, 2011
- Much improved novacom detection; should drastically reduce the number of people who are stuck always being prompted to install novacom drivers
- Fixed issue preventing root fs remounting to read-write

No more having to copy to x86 folder :)

Is this why nothing is showing up in any of the tabs except themes? I was able to use it to change my carrier string, but when I click on any of the tabs they all say "no packages found", except for themes which has a ton of themes to choose from.

Jason Robitaille
02/24/2011, 10:13 AM
Is this why nothing is showing up in any of the tabs except themes? I was able to use it to change my carrier string, but when I click on any of the tabs they all say "no packages found", except for themes which has a ton of themes to choose from.
Correct. All feeds that relayed via WebOS-Internals are offline

YankBoy
02/24/2011, 10:32 AM
First off, yes, the feeds not loading is due to issues on WebOS-Internals' site. Chances are it'll return soon. :)


Also, I've v4.04 is here!

v4.04 - February 24, 2011
- Much improved novacom detection; should drastically reduce the number of people who are stuck always being prompted to install novacom drivers
- Fixed issue preventing root fs remounting to read-write

No more having to copy to x86 folder :)

Correct. All feeds that relayed via WebOS-Internals are offline

Thanks for all the great work!

frantid
02/24/2011, 10:52 AM
Jason,

I seem to be having issues with the latest versions not retrieving the complete file when doing a retrieve from the emulator -- from the newest sdk, win7 64. The older version works consistently. The file is about 390k. Any logs i can check?

Jason Robitaille
02/24/2011, 11:18 AM
Jason,

I seem to be having issues with the latest versions not retrieving the complete file when doing a retrieve from the emulator -- from the newest sdk, win7 64. The older version works consistently. The file is about 390k. Any logs i can check?
Launch webosquicinstall will the "-log" parameter.

For example, java -jar WebOSQuickInstall.jar -log and errors will be redirected to the a log file.

frantid
02/24/2011, 12:10 PM
only thing in the log file:

Feb 24, 2011 6:03:29 PM org.jdesktop.application.SessionStorage restoreTree
WARNING: No saved state for javax.swing.JTable[installTable,0,0,483x164,alignmentX=0.0,alignmentY=0.0,border=,flags=251658568,maximumSize=java.awt. Dimension[width=2147483647,height=2147483647],minimumSize=java.awt.Dimension[width=45,height=45],preferredSize=,autoCreateColumnsFromModel=true,autoResizeMode=AUTO_RESIZE_SUBSEQUENT_COLUMNS,cellSe lectionEnabled=false,editingColumn=-1,editingRow=-1,gridColor=java.awt.Color[r=0,g=255,b=255],preferredViewportSize=java.awt.Dimension[width=450,height=400],rowHeight=20,rowMargin=1,rowSelectionAllowed=true,selectionBackground=javax.swing.plaf.ColorUIResou rce[r=51,g=153,b=255],selectionForeground=javax.swing.plaf.ColorUIResource[r=255,g=255,b=255],showHorizontalLines=true,showVerticalLines=true]


statements from the cmd box:
d:\temp\webos>java -jar WebOSQuickInstall-4.04.jar -log
Running process: [novacom, -d, a378bd7726cf53ba33d85a771dffd27a7f962931, --, run, file:///bin/cat, /etc/palm-build-info]
Running process: [novacom, -d, a378bd7726cf53ba33d85a771dffd27a7f962931, --, get, file:///opt/src/patches/ubercalendar2_1_284-1.patch]
Running process: [novacom, -d, a378bd7726cf53ba33d85a771dffd27a7f962931, --, get, file:///opt/src/patches/ubercalendar2_1_284-1.patch]
Running process: [novacom, -d, a378bd7726cf53ba33d85a771dffd27a7f962931, --, get, file:///usr/palm/applications/com.palm.app.calendar/s
tylesheets/day.css]

Dragone
02/24/2011, 01:21 PM
I still can't use the newer version 4.03 or 4.04 to install any software on my palm pre 2

this is the log :

Feb 24, 2011 8:18:41 PM org.jdesktop.application.SessionStorage restoreTree
WARNING: No saved state for javax.swing.JTable[installTable,0,0,483x164,alignmentX=0.0,alignmentY=0.0,border=,flags=251658568,maximumSize=java.awt. Dimension[width=2147483647,height=2147483647],minimumSize=java.awt.Dimension[width=45,height=45],preferredSize=,autoCreateColumnsFromModel=true,autoResizeMode=AUTO_RESIZE_SUBSEQUENT_COLUMNS,cellSe lectionEnabled=false,editingColumn=-1,editingRow=-1,gridColor=java.awt.Color[r=0,g=255,b=255],preferredViewportSize=java.awt.Dimension[width=450,height=400],rowHeight=20,rowMargin=1,rowSelectionAllowed=true,selectionBackground=javax.swing.plaf.ColorUIResou rce[r=51,g=153,b=255],selectionForeground=javax.swing.plaf.ColorUIResource[r=255,g=255,b=255],showHorizontalLines=true,showVerticalLines=true]
Feb 24, 2011 8:19:01 PM org.jdesktop.application.SessionStorage restoreTree
WARNING: No saved state for javax.swing.JTable[installTable,0,0,483x164,alignmentX=0.0,alignmentY=0.0,border=,flags=251658568,maximumSize=java.awt. Dimension[width=2147483647,height=2147483647],minimumSize=java.awt.Dimension[width=45,height=45],preferredSize=,autoCreateColumnsFromModel=true,autoResizeMode=AUTO_RESIZE_SUBSEQUENT_COLUMNS,cellSe lectionEnabled=false,editingColumn=-1,editingRow=-1,gridColor=java.awt.Color[r=0,g=255,b=255],preferredViewportSize=java.awt.Dimension[width=450,height=400],rowHeight=20,rowMargin=1,rowSelectionAllowed=true,selectionBackground=javax.swing.plaf.ColorUIResou rce[r=51,g=153,b=255],selectionForeground=javax.swing.plaf.ColorUIResource[r=255,g=255,b=255],showHorizontalLines=true,showVerticalLines=true]
ERROR: Unable to copy appid.sh to device

brianedwards80
02/24/2011, 05:10 PM
I have a Sprint Palm pre and when I run the quick installer it says i dont have a device connected then when i click ok, the whole program turns off. any suggestions?

sethyC123
02/24/2011, 10:56 PM
Hi. When trying to flash a patch to my 2.1 Sprint Pre - I get an error

ERROR: An error occurred while attempting to apply all.patch

Unable to connect to WebOS-Internals' servers.
Cannot download AUPT scripts for the patch.novacom: unexpected EOF error from server


I've seen one other person reported this error in the thread but nobody replied.

Thank you very much (for the help and your amazing work Jason, I've been using webOS QuickInstall from the beginning (launch day Pre represent!))

spudland
02/24/2011, 11:19 PM
Hi. When trying to flash a patch to my 2.1 Sprint Pre - I get an error




I've seen one other person reported this error in the thread but nobody replied.

Thank you very much (for the help and your amazing work Jason, I've been using webOS QuickInstall from the beginning (launch day Pre represent!))

Jason already answered this a couple posts back...webOS-Internals server is down...

stu5797
02/25/2011, 10:18 AM
Weird. On Ubuntu Webosqi 4.04 ( actually all versions of wosqi) recognizes my sprint pre perfectly. But, it does NOT recognize my Sprint Pre 2. It says no devices are connected. Both my devices have developer mode ON.
Thanks for any suggestions and all your hard work is greatly appreciated!

yaiba
02/25/2011, 11:44 AM
Awesome, thankyou Jason!

nethan
02/25/2011, 03:58 PM
The new loading screen looks NICE!

I'm having a bit or a problem though.

Just updated my Sprint Pre- to 2.X and have it masked as 1.4.5

It connects to WOSQI no problem (I can browse the device).

I can connect to the feeds, select a feed and click install (namely, Preware).

It pops up a window that says Connecting, Downloading, then Transferring.

And that's it. No new package on my phone. No nothing. I tried restarting thinking maybe it needed a luna restart, but that didn't do anything.

I'm guessing I'm missing something really basic but I'm at a loss to figure out what it is.

Any help?

EDIT: I was able to get Preware installed using the stand alone installer, so it works now, but I'm still wondering why I can't get WOSQI to install stuff.

malpha
02/25/2011, 05:56 PM
WebOS internals server is not down currently (nor was it down when I posted the post about the AUPT error) and I get this error almost every time I install a patch. Is it really necessary to apply the AUPT scripts to it, especially if it's a test patch? Or can the timeoff for not getting a message back be increased? Idk, just wondering...

92palm
02/25/2011, 09:06 PM
I can't down.Why?

Badcard
02/26/2011, 10:14 AM
Well, It doesn't seem to work for me.
I get the "No devices are connected..." error and WOSQI closes immediately.
Dev Mode is on, Novacom drivers are installed, but no joy.
I have a Pre 2 with WOS 2.01 on it.
Is there anything else I can try or that I might have missed?

UPDATE:
I flushed the novacom drivers and re-installed them with the latest WebOS Doctor image.
All ok now. :-)

jrjeffrey
02/26/2011, 01:57 PM
I am having trouble installing the WebOS Quick Install on my Mac.

I keep trying to download the webdoctor and the novacom driver, but always receive the message that installation failed.

I'm using the following:
Mac OS X 10.6.6
Sprint Palm Pre
WebOS 1.4.5 with dev mode enabled

I'll admit that I'm new to this, so I might be missing something obvius. Any help is appreciate. Thanks!

FetusSoup
02/27/2011, 12:42 PM
Doesn't work for me. Just freezes at the loading screen.

frantid
02/27/2011, 12:42 PM
Hi Jason, more logs hope it helps. QI 404, win7 64, emulator -- trying to install locally downloaded preware 154. After the first error I ran "touch /media/cryptofs/apps/usr/lib/ipkg/status", but still did not succeed.

java.lang.Exception: grep: /media/cryptofs/apps/usr/lib/ipkg/status: No such file or directory
novacom: unexpected EOF from server
at ca.canucksoftware.novacom.NovacomConnection.runProgram(NovacomConnection.java:59)
at ca.canucksoftware.webos.WebOSConnection.listInstalled(WebOSConnection.java:119)
at ca.canucksoftware.webos.Patcher.<init>(Patcher.java:23)
at ca.canucksoftware.wosqi.Installer.processList(Installer.java:64)
at ca.canucksoftware.wosqi.Installer.access$300(Installer.java:21)
at ca.canucksoftware.wosqi.Installer$DoTransfer.run(Installer.java:241)
at java.util.TimerThread.mainLoop(Unknown Source)
at java.util.TimerThread.run(Unknown Source)
ERROR: Unable to copy appid.sh to device
java.lang.Exception: novacom: unexpected EOF from server
at ca.canucksoftware.novacom.NovacomConnection.runProgram(NovacomConnection.java:59)
at ca.canucksoftware.webos.WebOSConnection.listInstalled(WebOSConnection.java:119)
at ca.canucksoftware.webos.Patcher.<init>(Patcher.java:23)
at ca.canucksoftware.wosqi.Installer.processList(Installer.java:64)
at ca.canucksoftware.wosqi.Installer.access$300(Installer.java:21)
at ca.canucksoftware.wosqi.Installer$DoTransfer.run(Installer.java:241)
at java.util.TimerThread.mainLoop(Unknown Source)
at java.util.TimerThread.run(Unknown Source)
ERROR: Unable to copy appid.sh to device

Dragone
02/27/2011, 06:44 PM
ERROR: Unable to copy appid.sh to device

That's the same error of mine.

enrconc
02/28/2011, 08:12 PM
I downloaded it today - And made a donation too.
I'm using webOS 2.1 in ATT PRe+ since yesterday.
The software has improved a lot, now it is faster and easier to use.
I like it so much.
Good work Jason.

mrtonk
03/01/2011, 01:15 PM
This is making me insane. I am running 32 bit Windows 7 and WOSQI will not recognize my Pre Plus.

I have removed and reinstalled novacom.

I have updated my Java.

I have copied the Palm, Inc folder into the x86 folder (even though these instructions do not apply to me).

I have updated to 4.04.

I am in Developer Mode.

I cannot get WOSQI to recognize my Pre Plus. Anyone else having these problems? I am normally very good at searching the forums for what I need, but I'm not finding my answers today. I really should doctor my phone because:

- my Palm Backup isn't working anymore, and it would be nice if it did
- Since my Palm Backup isn't working anymore and my profile has been deleted and the new Uberkernel has been released, I have no reason not to try to do the 2.1-on-a-Pre-Plus game.

BUT...if I doctor my phone or have to erase or whatever, I will not be able to reinstall Preware or do whatever (including the 2.1 magic).

Also, I have seen suggestions regarding running Ubuntu from a livecd or something like that. I don't even know what they're talking about.

tawmt
03/01/2011, 01:49 PM
I am unable to install the WebOS Quick Install. I am running Java version 1.6.0_24 and I see errors when I attempt to install this file. I think it's the third file that tries to run that has issues, but the cmd prompt closes prior to me being able to see what the error is. Any help would be greatly appreciated guys. Thank you

ben_dov
03/02/2011, 03:11 AM
i just update to newer webosQInstall and what ever i'm trying to install it always says system busy? i just update my pre- to 2.1, maybe thats the reson?

nickyboy
03/02/2011, 04:00 AM
thx!

pcworld
03/02/2011, 10:43 AM
Would be nice if I could install patch files when I'm offline, too.
I get an error message if I am offline:
Unable to connect to webOS Internals' servers.
Cannot download AUPT scripts for the patch.

Buddy1969
03/02/2011, 11:29 AM
Hi there!

I am not exactly new here, but since TreoCentral I was merely a "voyeur" :-)

WQI is a brilliant tool and I used it alot with my Pre Plus on WebOS 1.4.5.
Yesterday I updated my Pre Plus zu WebOS 2.1, which went smoothly

Therefore I downloaded WQIs new Version 4.04.
Sadly, the software doesn't start. The splashscreen is displayed shortly and then nothing else happens.
When run on cmd.exe the errormessage is as follows:
02.03.2011 17:42:15 org.jdesktop.application.Application$1 run
SCHWERWIEGEND: Application class ca.canucksoftware.wosqi.WebOSQuickInstallApp failed to launch
java.lang.NullPointerException
at ca.canucksoftware.wosqi.MainView.loadList(MainView.java:102)
at ca.canucksoftware.wosqi.MainView.<init>(MainView.java:81)
at ca.canucksoftware.wosqi.WebOSQuickInstallApp.startup(WebOSQuickInstallApp.java:33)
at org.jdesktop.application.Application$1.run(Application.java:171)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
Exception in thread "AWT-EventQueue-0" java.lang.Error: Application class ca.canucksoftware.wosqi.WebOSQuickInstallApp failed to launch
at org.jdesktop.application.Application$1.run(Application.java:177)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
Caused by: java.lang.NullPointerException
at ca.canucksoftware.wosqi.MainView.loadList(MainView.java:102)
at ca.canucksoftware.wosqi.MainView.<init>(MainView.java:81)
at ca.canucksoftware.wosqi.WebOSQuickInstallApp.startup(WebOSQuickInstallApp.java:33)
at org.jdesktop.application.Application$1.run(Application.java:171)
... 8 more

"SCHWERWIEGEND" is german for "grave" or "serious" ...
I use a Win7/64bit system with Java 6.21-64bit. All the other java apps work fine, including the Doctor.

I would appreciate any hints...
Oh yes, and I am on the way to the donation site ;-)

cya
Harry

swieder
03/02/2011, 12:53 PM
I missed the Linux command line feature of WOSQI.

I can use "novacom -t open tty://" but its not as fun.

rwhitby
03/02/2011, 03:04 PM
Would be nice if I could install patch files when I'm offline, too.
I get an error message if I am offline:

Since WOSQI is not open source, it cannot include the open source AUPT scripts and must download them separately.

-- Rod

huladaddy
03/02/2011, 03:16 PM
Well, It doesn't seem to work for me.
I get the "No devices are connected..." error and WOSQI closes immediately.
Dev Mode is on, Novacom drivers are installed, but no joy.
I have a Pre 2 with WOS 2.01 on it.
Is there anything else I can try or that I might have missed?

UPDATE:
I flushed the novacom drivers and re-installed them with the latest WebOS Doctor image.
All ok now. :-)

How do you flush the novacom drivers?

jlewis0509
03/02/2011, 09:47 PM
I have a mac 10.5.8 edition. It has the current java on it. I also went through and downloaded all the quick install and webos doctor and preware info. I tried to download the novacom but to no yield. All of them were the most current .jar files I could find but when i open them on my computer (all except doctor which works fine), they open up like they are starting and then stay for a couple seconds with no window popping up. Then they just shut themselves down. Can anyone help me?!?! oh and I have a palm pre plus through verizon on palm webOS 1.4.5

pcworld
03/03/2011, 08:26 AM
Since WOSQI is not open source, it cannot include the open source AUPT scripts and must download them separately.

-- Rod
I think it could download the scripts and save them somewhere on the computer. If no internet connection is available, it could use the downloaded files.

By the way: Why is Quick Install not Open Source? I don't think you could make money with it, so why not open source it?
That would be really great. I would like to add some features and rewrite some of the existing features/code.

I thought of developing something like Quick Install myself (and publish it under GPL), but I think it would be too much work to get at a level like Quick Install.

pcworld
03/03/2011, 08:29 AM
I have a mac 10.5.8 edition. It has the current java on it. I also went through and downloaded all the quick install and webos doctor and preware info. I tried to download the novacom but to no yield. All of them were the most current .jar files I could find but when i open them on my computer (all except doctor which works fine), they open up like they are starting and then stay for a couple seconds with no window popping up. Then they just shut themselves down. Can anyone help me?!?! oh and I have a palm pre plus through verizon on palm webOS 1.4.5
Try starting WOSQI from the command line with "java -jar WebOSQuickInstall-4.04.jar" and post error messages if there are any.

rwhitby
03/03/2011, 02:26 PM
I think it could download the scripts and save them somewhere on the computer. If no internet connection is available, it could use the downloaded files.

By the way: Why is Quick Install not Open Source? I don't think you could make money with it, so why not open source it?
That would be really great. I would like to add some features and rewrite some of the existing features/code.

I thought of developing something like Quick Install myself (and publish it under GPL), but I think it would be too much work to get at a level like Quick Install.

The choice of licensing is up to the author (Jason in this case).

-- Rod

Jason Robitaille
03/03/2011, 02:53 PM
Since WOSQI is not open source, it cannot include the open source AUPT scripts and must download them separately.

-- Rod
Point of clarification. That's not the main reason for that. As as agreed by both myself and Rod, the script should be downloaded on-demand so patches get installed with the most up-to-date version of the AUPT scripts. Anything less would risk future issues.

rwhitby
03/03/2011, 02:58 PM
Point of clarification. That's not the main reason for that. As as agreed by both myself and Rod, the script should be downloaded on-demand so patches get installed with the most up-to-date version of the AUPT scripts. Anything less would risk future issues.

Yep, that is a good reason too.

The caching idea someone had would still comply with the open source licensing of the scripts.

Only using the cached version if the server could not be reached of course.

-- Rod

anhhq
03/03/2011, 04:40 PM
Well, attempted to install on my win7 x64 machine to no avail again. I download webOS QI, plug in my pre, prompts to install novacom and download the doctor. Then it states no device is plugged in. Next time i reinstalled all of it, QI keeps prompting to reinstall novacom.

Not sure what is wrong. I have tried putting the Palm Inc folder in the Program Files (x86) folder, and nothing worked. Tried using back USB ports instead of hub ports. I even tried using an older webOS doctor file i had and nothing still.

Any suggestions?

first go to "C:\Program Files\Palm, Inc" then rename folder "novacomd" to "novacom"
ok now right click "Computer" in desktop >> Manage >> Services and Applications >> Services
find for "Palm Novacom" >> right click and Start it.

Re-run you WOQI, *** this problem !!!.

dzee206
03/04/2011, 09:41 AM
works great.

Buddy1969
03/04/2011, 11:52 AM
Still don't work on my main PC. Tried it at work on XP, there it works.

I just checked the novacom driver and the eventlog ... everything seems ok...

Thats a bit frustrating...

ps: deinstalled novacom driver completely. Downloaded WQI again.

no avail

kkirby
03/04/2011, 11:19 PM
thx

ego2001
03/05/2011, 11:03 AM
I saw that this solution worked for several other posters in the same situation. I'm happy to report that it worked for me, as well (after re-booting). Thanks very much!:thumbsup:

Same here.

EDIT:

Spoke too soon. It still acts funky after it loads from the doctor.

I am going to remove and reinstall the drivers again. (The location thing definitely is needed, however - Windows XP Pro)

EDIT:
Disable and re-enable Developer Mode!
Unplug and re-plug phone!

darkzone
03/05/2011, 12:18 PM
Guys, 1st time with homebrew i installed Quick Install on my machine and i wanted to install Uber Kernal. I dunno what i did wrong but im getting the following message(Attached). Not sure what to do now.

graffix31
03/05/2011, 05:08 PM
i just doctored to 2.1 and enabled developer mode right off the bat. i cannot connect to 4.0.4 at all. just says detected. i see others with this issue. anybody figure it out yet?

scratch that. disabled and reenabled dev mode and im working.

pcworld
03/06/2011, 04:21 PM
Guys, 1st time with homebrew i installed Quick Install on my machine and i wanted to install Uber Kernal. I dunno what i did wrong but im getting the following message(Attached). Not sure what to do now.
Rod said that kernels should only be installed via Preware.

rwhitby
03/06/2011, 04:43 PM
Rod said that kernels should only be installed via Preware.

Preware will give the same error in that circumstance.

The original poster should first confirm that they are installing the correct kernel for their version of webOS. Often getting the testing kernel feed name incorrect will stop the automatic version update code from working.

If that is not the cause, they should install the Palm Recovery Kernel, and then try again.

-- Rod

darkzone
03/06/2011, 05:50 PM
My apologies i will check out the kernel again. I should have made my intentions clear this is my 1st time using homebrew and im still on older version 1.4 im trying to make my phone faster. I followed the instructions which brought me to this thread.

rwhitby
03/06/2011, 05:58 PM
My apologies i will check out the kernel again. I should have made my intentions clear this is my 1st time using homebrew and im still on older version 1.4 im trying to make my phone faster. I followed the instructions which brought me to this thread.

You should use Preware, as it shows only those kernels which are compatible with your webOS version. You should never install a random kernel from an ipk file and expect it to be compatible.

-- Rod