Results 1 to 14 of 14
  1.    #1  
    Hi,

    Yesterday, I quickly tried Squeeze Control XL with my Touch. My Touch was running the internal TinySBS server, version 7.5.4.
    The app did start properly. It did not find automatically my server, so I had to point to it by giving its IP address, and ask it to connect explicitly. After connecting, the main menu of the Touch came up, as well as the current playlist on the Touch, and things seemed all right.
    Then, I selected the "My Music" menu item, and I got an error message. At this point, the main menu disappeared and the whole application became unusable.

    I'm currently upgrading to 7.6.1. More info later.

    Jean
  2.    #2  
    Hi,

    Same deal with 7.6.1. I quickly saw the "My Music" menu getting populated before I got the error message.
    The error message says : "Error [object Event] OK".

    Regards,

    Jean
  3. #3  
    Hi, thank you for your purchase.

    I'm sorry that the app isn't working correctly for you, but I specifically mentioned in the app description that I have not tested the app with the server on the Touch. I don't own a Touch so there really isn't anyway for me to fix this.

    Auto server discovery has never been a feature of Squeeze Control XL, a fact that I also mentioned in the app description. The initial firmware of the Touchpad had a limitation that made server discovery impossible. This is something that I was going to eventually add, but due to the recent announcements of HP any major development on the app has been suspended until I get a clearer picture of webOS's future. I will however fix bugs that crop up.

    Finally, since you are trying to use this app with a setup that's beyond what I said it would support, I would appreciate it if you would remove your 1-star review.
    --------------------
    Apps for webOS
    http://www.angrygoatapps.com
    Twitter: angrygoatapps
  4. #4  
    What happens when you click on Internet Radio or Settings?
    --------------------
    Apps for webOS
    http://www.angrygoatapps.com
    Twitter: angrygoatapps
  5. #5  
    Hmm... I've been reading up on TinySBS and I realized that since it doesn't have a web interface, the problem maybe the icons on the My Music menu. Those icons are pulled from the server with a url, but if the TinySBS doesn't have a web server, the image load would fail and I don't think I accounted for that in that part of the app.

    I encountered a similar problem with Rhapsody where some album art had errors and the image load would fail and kill the app. I fixed that problem but it was in a different part of the app.

    Now I just have to find a place with a lenient return policy where I can buy a Touch to test my theory.
    --------------------
    Apps for webOS
    http://www.angrygoatapps.com
    Twitter: angrygoatapps
  6.    #6  
    Quote Originally Posted by wayne@angrygoat View Post
    Hi, thank you for your purchase.
    Yes, I guess somebody had to try it out...

    Quote Originally Posted by wayne@angrygoat View Post
    I'm sorry that the app isn't working correctly for you, but I specifically mentioned in the app description that I have not tested the app with the server on the Touch.
    Well, I don't want to get into a fight with you, but I would personally argue that it was worded in a more ambiguous way in the app description :

    Code:
    it might work with the SqueezeBox Touch as the server - not tested
    Quote Originally Posted by wayne@angrygoat View Post
    I don't own a Touch so there really isn't anyway for me to fix this.
    I'm willing to help, I'm quite savy when it comes to Linux.

    Quote Originally Posted by wayne@angrygoat View Post
    Finally, since you are trying to use this app with a setup that's beyond what I said it would support, I would appreciate it if you would remove your 1-star review.
    I think my review is factual and properly detailed, and I feel it's a totally legitimate use of the review system. People are not stupid and should be able to see if the review apply to them or not. Also, I fail to see the downside to you as there is no competition ;-)

    But I understand, it's hard to make oneself a reputation...

    Quote Originally Posted by wayne@angrygoat View Post
    What happens when you click on Internet Radio or Settings?
    "Setting" and "Setting->Advanced" do work properly
    "Internet" radio works properly.
    "My Apps" fails (I have TuneIn and Pandora)
    "App Galery" and its submenus works
    "Favorites" works
    "Pandora" works
    "TuneIn" works

    Quote Originally Posted by wayne@angrygoat View Post
    Hmm... I've been reading up on TinySBS and I realized that since it doesn't have a web interface, the problem maybe the icons on the My Music menu.
    Yes, the TinySBS does not have the regular web interface. Note that with the 7.6 code base, it's possible to disable the web server, so it's possible to some NAS and Plug computer decide to run in similar fashion.

    The squeezeserver is run this way on the Touch :

    Code:
    slimserver.pl --charset utf8 --noweb --notranscoding --nosb1slimp3sync --nostatistics --noinfolog --nodebuglog
    In theory, by running a 7.6.X with those command line options, your server should behave exactly as a Touch. Which platform are you running your SBS on ?

    Quote Originally Posted by wayne@angrygoat View Post
    Those icons are pulled from the server with a url, but if the TinySBS doesn't have a web server, the image load would fail and I don't think I accounted for that in that part of the app.
    Possible. Please note that all the icons are properly shown in the "Playlist" and the "Now Playing" screens.

    Quote Originally Posted by wayne@angrygoat View Post
    I encountered a similar problem with Rhapsody where some album art had errors and the image load would fail and kill the app. I fixed that problem but it was in a different part of the app.
    I have not used Rhapsody.

    Quote Originally Posted by wayne@angrygoat View Post
    Now I just have to find a place with a lenient return policy where I can buy a Touch to test my theory.
    First, I'm willing to help. By any chance, are you in the Silicon Valley ? Second, I believe that with the right command line options you should be able to emulate a Touch with the full SBS. That would seem easier to try than dealing with Amazon...

    Have fun...

    Jean
  7. #7  
    I'm running my SBS on a Win7 machine. I'll try to run a SBS on another machine with the TinySBS command line options.

    If the icons are showing up for the playlists, the problem may be something else.

    I was actually thinking about getting one from Fry's but they don't carry it. I'm in Los Angeles.
    --------------------
    Apps for webOS
    http://www.angrygoatapps.com
    Twitter: angrygoatapps
  8. #8  
    Ok I got SBS running with the TinySBS command line and connected a SqueezePlay player to it. SqzCtrl XL disconnects immediately after connecting to the server. I guess I'll be busy for the next couple of days.
    --------------------
    Apps for webOS
    http://www.angrygoatapps.com
    Twitter: angrygoatapps
  9. #9  
    Alright I know what the problem is. I was partially right, it is a problem with loading icons, but it's not the fact that TinySBS can't server icons. It turns out that only certain icons are broken. I'm running 7.6.1 and on the the main menu the MyApps and App Gallery icons are broken. In the My Music menu, only the Random Mix icon is broken, every other icon shows up correctly.

    The strange thing is, this only happens when I run the server with the TinySBS command line. If I run the server with no command switches, the all the icons show up fine. So I guess technically it's a bug with TinySBS, but it's a bug that I should have accounted for.

    Do you know how to manually install an app on the Touchpad? PM me.
    --------------------
    Apps for webOS
    http://www.angrygoatapps.com
    Twitter: angrygoatapps
  10. #10  
    Ok here's something else strange. After I've run the server normally and connected to it, the missing icons now show up when I run it as TinySBS again.

    I guess those icons must be generated when a controller first connects and when running as TinySBS some of those icons aren't generated correctly. However if the icons already exist, TinySBS will serve them up fine.
    --------------------
    Apps for webOS
    http://www.angrygoatapps.com
    Twitter: angrygoatapps
  11.    #11  
    Quote Originally Posted by wayne@angrygoat View Post
    Alright I know what the problem is. I was partially right, it is a problem with loading icons, but it's not the fact that TinySBS can't server icons. It turns out that only certain icons are broken. I'm running 7.6.1 and on the the main menu the MyApps and App Gallery icons are broken. In the My Music menu, only the Random Mix icon is broken, every other icon shows up correctly.

    The strange thing is, this only happens when I run the server with the TinySBS command line. If I run the server with no command switches, the all the icons show up fine. So I guess technically it's a bug with TinySBS, but it's a bug that I should have accounted for.
    Thanks a lot looking into it. Just so that that you know, my Touch display (i.e. SqueezePlay on the Touch) is also missing some icons.

    By the way, I've searched a bit and I found what I think is the relevant bug :

    Bug 15723 – wrong Icons showing up for my Apps and Apps gallery and more

    What worries me is that, from the bug description, the icon problem seems to be new to 7.6.X, whereas I tried earlier with 7.5.4 and had issues.

    Quote Originally Posted by wayne@angrygoat View Post
    Do you know how to manually install an app on the Touchpad? PM me.
    I did not, but I've just installed the sdk, got on console on the TouchPad via novaterm, and verified that I have palm-install on my Linux machine.

    Quote Originally Posted by wayne@angrygoat View Post
    Ok here's something else strange. After I've run the server normally and connected to it, the missing icons now show up when I run it as TinySBS again.

    I guess those icons must be generated when a controller first connects and when running as TinySBS some of those icons aren't generated correctly. However if the icons already exist, TinySBS will serve them up fine.
    Thanks a lot for your time figuring those details ! Unfortunately, I don't really have that option.

    Jean
  12. #12  
    I've just bought SqueezeControl for my TouchPad, and I'm having the same problem.

    I'm running Squeezebox Server 7.6.1 on Ubuntu, controlling a Boom, a Classic and a Radio.

    I start Squeeze Control, it connects to the server, I briefly see what's currently playing, and then I get a small dialog popping up with the message Error [object Event] and an OK button. On clicking OK, Squeeze Control is blank.

    Any ideas?
  13. #13  
    Most likely the same problem with the icons. I'll do an update soon with a fix. There's already an update in the app review process right that fixes something else. The fix for this problem will be the update after that.
    --------------------
    Apps for webOS
    http://www.angrygoatapps.com
    Twitter: angrygoatapps
  14.    #14  
    Quote Originally Posted by wayne@angrygoat View Post
    Most likely the same problem with the icons. I'll do an update soon with a fix.
    The fix you have pending for 1.0.7 work perfect, the application is fully usable with TinySBS 7.6.1 (bearing in ming that TinySBS is slow). Thanks a lot for the quick and excellent support, and I'm glad I was able to help.

    Have fun...

    Jean

Posting Permissions