Page 7 of 11 FirstFirst ... 234567891011 LastLast
Results 121 to 140 of 207
Like Tree111Likes
  1.    #121  
    Quote Originally Posted by PANDA_roken View Post
    I am a Chinese,sorry,my English isn't good.I want to konw,when will you give us the android card for pre2?
    Thanks all you did for webOS
    Quote Originally Posted by joshua764 View Post
    will android for pre2? say that if!

    Enviado desde la chingada, hasta allá!!
    OK, I've built package and kernel for pre2, but there are big chances that it will not work(kernel is a mix of very old pre android sources and pre2 webos sources). So, please enable logging(#22,#24) and test kernel by membooting before any installation actions.
    com.nizovn.androidchroot_1.0.0_pre2.ipk
    uImage.pre2
    Quote Originally Posted by Palmiga
    I got problems to connect to any wifi-hotspot if im using Androidchroot.

    When im connected to a wifi-hospot and start Android&Client, everything works fine.
    But when im not connected to a wifi-hotspot, start Android&Client and using it for a while i couldnt connect to any wifi-hotspot. WebOS found no wifi anymore, but there are many hotspot around.

    BTW: Any solution for using BT, GPS or camera?
    I confirm the problem, will see it later. No BT, GPS and camera in reasonable time.
    Proximity likes this.
  2. #122  
    I am very willing to try. thanks for the hard work.

    Enviado desde la chingada, hasta allá!!
  3. #123  
    Someone there knows his installation video tutorial about this post?

    Enviado desde mi MB860 usando Tapatalk 2
  4. #124  
    Thank you very much, Nikolay! Android is working wonderfully on my Pre³. But there is no sound. Any chance to get sound output working?

    One of the reasons to get android on my Pre3 is audible's missing webOS support.The audible android app works nicely on the Pre³. But without sound it doesn't make a lot of sense...
  5. #125  
    Goodwill someone teach me how to install in pre2 Apple
    I'm bad at this

    -- Sent from my Palm Pre using Forums
    Last edited by joshua764; 03/17/2014 at 07:58 PM.
  6.    #126  
    Quote Originally Posted by ZehHa View Post
    Thank you very much, Nikolay! Android is working wonderfully on my Pre³. But there is no sound. Any chance to get sound output working?

    One of the reasons to get android on my Pre3 is audible's missing webOS support.The audible android app works nicely on the Pre³. But without sound it doesn't make a lot of sense...
    I found what I need to do, but first attempt to enable sound failed. I will try to see it again at weekend.
    Quote Originally Posted by joshua764
    Goodwill someone teach me how to install in pre2 Apple
    I'm bad at this
    What exactly installation step do you have problem with? What error message did you get?
  7. #127  
    all steps. I suck in linux. if I can help with a step by step would help me a lot. I am very least. please

    Enviado desde la chingada, hasta allá!!
  8. #128  
    Quote Originally Posted by NIN_ru View Post
    OK, I've built package and kernel for pre2, but there are big chances that it will not work(kernel is a mix of very old pre android sources and pre2 webos sources). So, please enable logging(#22,#24) and test kernel by membooting before any installation actions.
    com.nizovn.androidchroot_1.0.0_pre2.ipk
    uImage.pre2

    I confirm the problem, will see it later. No BT, GPS and camera in reasonable time.
    I try to use the novacom in recovery mode make my pre2 use the uimage.pre2 ,but when my phone restart the androidchroot also can't work.When I start android,it show me a colorful card with no text on it,then my pre2 restart again.How can I do?
  9. #129  
    Quote Originally Posted by NIN_ru View Post
    The Back gesture corresponds to pressing the back button, the Forward gesture to the home button.
    OK. Working. But I'm not aware of any equivalence to the menu button. Any idea how to access the android menus?

    BTW: Donation on the way...
    Last edited by ZehHa; 03/22/2014 at 12:07 PM.
  10. #130  
    Quote Originally Posted by ananimus View Post
    Oh... actually everywhere the script issues a mount command, there is this error:

    Code:
    mount: [path]/out/system.ext3 is not a block device (maybe try `-o loop'?)
    EDIT: That did it! Added '-o loop' option to all mount commands in the script. I'm now looking at Android!

    Oh man, this is bizarre. Any chance of adding the keyboard driver...?
    i didnt get it could you please tell me what you did to fix the black screen issue ?

    im starting the android client so a card pops and then nothing happens it goes away
  11. Jonny.A's Avatar
    Posts
    28 Posts
    Global Posts
    53 Global Posts
    #131  
    Hi,

    I tried this at last this weekend - it works! Thanks

    Just a note to anyone doing this without a Linux box - the gapps zip wasn't supported by the gunzip or unzip versions on the phone, so I unzipped it on MacOS, copied over the uncompressed files and modified the script to skip the unzip and look in my previously created dir for the various libs/apks required.

    I'll try and play around a bit more next weekend, but thanks to all who have worked on it so far, really fun to play with!

    I tried BubbleUpnp but it didn't see the devices on my home network, so I want to look into why - is there some proxy NAT device? Anyone else had luck with connecting to other wifi devices?

    Jonny
  12.    #132  
    Sorry for the late reply.
    Quote Originally Posted by ZehHa View Post
    OK. Working. But I'm not aware of any equivalence to the menu button. Any idea how to access the android menus?
    You can enable tablet UI by replacing system.ext3/framework/framework-res.apk with framework-res.apk and system.ext3/app/SystemUI.apk with SystemUI.apk.

    Also you can return status bar to top or manage keys in tablet tweaks settings.
    No sound yet, it seems I need to make clean build of cm7, this is very long.
    Quote Originally Posted by joshua764
    all steps. I suck in linux. if I can help with a step by step would help me a lot. I am very least. please
    Sorry, this guide is the best that I can write in english. You can install AndroidChroot without linux computer, but I see that it doesn't work on pre2 now.
    Quote Originally Posted by PANDA_roken
    I try to use the novacom in recovery mode make my pre2 use the uimage.pre2 ,but when my phone restart the androidchroot also can't work.When I start android,it show me a colorful card with no text on it,then my pre2 restart again.How can I do?
    I need your logcat.txt and maybe dmesg output to investigate problem. You should enable logging by replacing init.rc in root.ext(see post #22, post #24)
    Quote Originally Posted by abdulcraze
    i didnt get it could you please tell me what you did to fix the black screen issue ?

    im starting the android client so a card pops and then nothing happens it goes away
    files.sh in first post already has this fix. Make sure you have no error during creating ext3 files and you have successfully booted android kernel.
    Attached Images Attached Images
  13. #133  
    What is the best way to copy those files for tablet mode, SU app does not seem to work and root not enabled when try to copy while running android with ROM toolbox pro. Does it need a script to mount the system.ext3 and copy them, while still in webOS?
  14. #134  
    Quote Originally Posted by Firepower View Post
    What is the best way to copy those files for tablet mode, SU app does not seem to work and root not enabled when try to copy while running android with ROM toolbox pro. Does it need a script to mount the system.ext3 and copy them, while still in webOS?
    Don't know about best way. My way is using wTerm to mount the system.ext3 file:
    Code:
    su
    Password: <Enter password>
    cd /
    mkdir android
    cd android
    mkdir system
    mount /media/internal/AndroidChroot/system.ext3 /android/system
    And using Internalz to rename the old and copy the new files afterwards into the specific folders.

    These steps can obviously be done via terminal commands as well.

    I'm leaving the wTerm window card open and do this afterwards:
    Code:
    umount /android/system
    You can delete these folders as well, if you want to.

    Su password has to be set via the wTerm Setup menu option before using su.

    The webOS filesystem cannot easily be reached from within AndroidChroot. The file system has to be mounted, just as it is necessary vice versa. But considering the lags and the instability of AndroidChroot on the Pre3 (due to the hardware limitations), I think my way is safer.
    Last edited by ZehHa; 03/27/2014 at 03:18 AM.
    Firepower likes this.
  15. #135  
    Quote Originally Posted by NIN_ru View Post
    Sorry for the late reply.
    I have been waiting for such a long time to get android on my Pre3... You came just at the right time!
    Quote Originally Posted by NIN_ru View Post
    You can enable tablet UI by replacing system.ext3/framework/framework-res.apk with framework-res.apk and system.ext3/app/SystemUI.apk with SystemUI.apk.
    Can confirm it works! Thanks a lot!

    And you can completly switch off the lock screen. Nice!
    Last edited by ZehHa; 03/26/2014 at 04:28 PM.
  16. #136  
    Quote Originally Posted by NIN_ru View Post
    Sorry for the late reply.

    You can enable tablet UI by replacing system.ext3/framework/framework-res.apk with framework-res.apk and system.ext3/app/SystemUI.apk with SystemUI.apk.
    [URL= to view quoted image
    [/URL]
    Also you can return status bar to top or manage keys in tablet tweaks settings.
    No sound yet, it seems I need to make clean build of cm7, this is very long.

    Sorry, this guide is the best that I can write in english. You can install AndroidChroot without linux computer, but I see that it doesn't work on pre2 now.

    I need your logcat.txt and maybe dmesg output to investigate problem. You should enable logging by replacing init.rc in root.ext(see post #22, post #24)

    files.sh in first post already has this fix. Make sure you have no error during creating ext3 files and you have successfully booted android kernel.
    I enable logging ,but there is no text in logcat.txt,it's 0kb.
    I think maybe the kernel doesn't work please check the file uImage.pre2
  17.    #137  
    Quote Originally Posted by ZehHa View Post
    The webOS filesystem cannot easily be reached from within AndroidChroot. The file system has to be mounted, just as it is necessary vice versa. But considering the lags and the instability of AndroidChroot on the Pre3 (due to the hardware limitations), I think my way is safer.
    My way was almost same as your. Not sure what you meant, but webOS and android have "shared" directory(/media/internal/AndroidChroot/sdcard in webOS and /mnt/sdcard in android). This directory(fake sdcard) is necessary for some android apps.
    Quote Originally Posted by PANDA_roken
    I enable logging ,but there is no text in logcat.txt,it's 0kb.
    I think maybe the kernel doesn't work please check the file uImage.pre2
    Yes, I also think it's kernel issue, but I can't test it myself because I don't have pre2. I see your pre2 reboots, so please provide klog output(just after reboot).


    UPD: Just found how to solve su issue. You need mount system.ext3 and under xbin directory run:
    Code:
    chown root:root ./*
    chmod 6755 ./*
    Now you will be able to install root apps, e.g. button saviour app(if you don't like gingerbread tablet UI).
    Also disabling animations under Spare Parts app cause better feelings.
    Last edited by NIN_ru; 03/28/2014 at 10:21 AM.
  18. #138  
    Quote Originally Posted by NIN_ru View Post
    My way was almost same as your. Not sure what you meant, but webOS and android have "shared" directory(/media/internal/AndroidChroot/sdcard in webOS and /mnt/sdcard in android). This directory(fake sdcard) is necessary for some android apps.

    Yes, I also think it's kernel issue, but I can't test it myself because I don't have pre2. I see your pre2 reboots, so please provide klog output(just after reboot).
    How can I get the klog?Sorry I am not very good at linux.Please tell me ,then I can try my best to help you make the android on pre2
  19.    #139  
    Quote Originally Posted by PANDA_roken View Post
    How can I get the klog?Sorry I am not very good at linux.Please tell me ,then I can try my best to help you make the android on pre2
    In terminal(novaterm or WOSQI on pc) under root execute:
    Code:
    klog > /media/internal/klog.txt
  20. #140  
    Quote Originally Posted by NIN_ru View Post
    In terminal(novaterm or WOSQI on pc) under root execute:
    Code:
    klog > /media/internal/klog.txt
    klog.txt
    I just change the kernel name to "nova-installer-image-roadrunner.uImage",because when it was named "uImage.pre2" it return bad or error response from other side: 'err -1 bad command string'
    Is it effect the all things?
    If the klog.txt is wrong,please tell me ,I will do again
Page 7 of 11 FirstFirst ... 234567891011 LastLast

Similar Threads

  1. Replies: 14
    Last Post: 02/20/2013, 05:19 PM
  2. Replies: 3
    Last Post: 12/16/2011, 04:03 PM
  3. If Amazon Buys webOS, They Could Make it Run Android Apps
    By deesugar in forum webOS Discussion Lounge
    Replies: 0
    Last Post: 09/30/2011, 06:39 PM
  4. Run iOS and Android apps on webOS.
    By sherard in forum webOS Discussion Lounge
    Replies: 2
    Last Post: 03/30/2011, 06:46 PM
  5. Will we be able to run Android Apps on webOS?
    By JED-WEB-OS in forum Other OS's and Devices
    Replies: 1
    Last Post: 01/15/2011, 02:28 PM

Tags for this Thread

Posting Permissions