Page 5 of 11 FirstFirst 12345678910 ... LastLast
Results 81 to 100 of 207
Like Tree111Likes
  1. #81  
    saw the video..impressive.. to run Android - not smooth but that is a hardware memory problem.....now if we can get it running properly 100% ..and get from Beta to Public release v1, we can probably try running it on a Touchpad :P
  2. #82  
    Quote Originally Posted by vgg View Post
    I think the only difference would be in terms of speed. Obviously the linux box(virtual or otherwise) will be quicker than running the scripts on the pre3. Good luck anyway. I've just uninstalled as I'm missing uberkernel so will reinstall the new UK friendly uImage and recreate the updated ext3 files to see how that works out...

    -- Sent from my Palm Pre3 using Forums
    vgg's got it. You can do it either way. The gapps script modifies the data in the ext3 filesystem files. That initial big zip unpacking is the slowest part though, especially for the big filesystems.

    So if you do it on the computer before loading, it's quicker. If it's already unpacked on the device, then moving the file you're changing over, then mounting, changing and unmounting to revise some file might be quicker.

    That's how other revisions to the filesystem mentioned later in the thread (not yet updated?) are described. Move file over, mount, change files inside the ext3 file, unmount.

    That includes the mods to init.rc and the keymap file to get keyboard working. That I did on device since the original ext3 files were already there. It's a short operation compared to unpacking the whole filesystem, so it's quick. So you move the files over and use the code mentioned to modify the files in the ext3 filesystem files (did that make sense? ) instead of changing them on the computer and transferring. But you could do it either way.

    The gapps script is the first example of this here though. There's some unpacking, but it's not as big as the main part.

    Anyway... YES, you should just do the gapps stuff before transferring that first time.
    Last edited by ananimus; 02/20/2014 at 02:36 AM.
  3. eKeith's Avatar
    Posts
    759 Posts
    Global Posts
    779 Global Posts
    #83  
    Great stuff! Thanks for elaborating. It's starting to make sense to me :-)
    Current Phones: Unlocked AT&T Pre3; Samsung Galaxy Nexus i9250; HTC Desire A8181
    Current Tablets: Lenovo ThinkPad Tablet 183825U; HP TouchPad 32GB w/ACL
    Previous Devices: Unlocked UK Pre3; HTC Touch Diamond; Palm Unlocked GSM Treo 680; PalmOne Unlocked GSM 650; Palm Tungsten T3 w/PalmOne WiFi Card, PowerToGo and ASUS WL-330g; 3Com Palm III; Sony Clie N760C
  4. #84  
    Kind of a noob when when it comes to all the technical stuff on here; I'm simply a fan of webOS.

    However, I'm so impressed and appreciative of your effort, Ninru! Same goes for everyone else that is working on ironing out the bugs!

    Here is to continued progress!!!
    eKeith likes this.
  5. #85  
    Quote Originally Posted by monday206am View Post
    Kind of a noob when when it comes to all the technical stuff on here; I'm simply a fan of webOS.

    However, I'm so impressed and appreciative of your effort, Ninru! Same goes for everyone else that is working on ironing out the bugs!

    Here is to continued progress!!!
    Ditto what Monday206am said. Thanks!
  6. vgg
    vgg is offline
    vgg's Avatar
    Posts
    83 Posts
    #86  
    Well after installing uberkernel I've installed the new Uberkernel friendly uImage.Android and am pleased to say it's working well. The only thing is that my hw keyboard doesn't seem to be working (I commented out line 29 of init.rc and replaced the qwerty.kcm.bin file as described in #58 above). Also I noticed that after I shutdown androidchroot, and am back in webos, pdk games (in my case sparkle) dont display correctly and are resized and tiled, i.e when sparkle starts up you normally have the introductory image displayed as the game loads, but in this case the image was shrunk and being presented 4 times as tiles. However if I restart the pre3 and select webos at the bootr stage, sparkle starts up as normal. Has anyone noticed if this is the case for the standard uImage or is this peculiar to the Uberkernel version?

    cheers

    Vito
  7.    #87  
    Quote Originally Posted by vgg View Post
    The only thing is that my hw keyboard doesn't seem to be working (I commented out line 29 of init.rc and replaced the qwerty.kcm.bin file as described in #58 above).
    I can only guess. Maybe you didn't restart android after editing, make sure you have /media/internal/AndroidChroot/root/dev/input/event1 while working android(Also that line should be already be commented out in 1 post link root.ext3)
    Quote Originally Posted by vgg View Post
    Also I noticed that after I shutdown androidchroot, and am back in webos, pdk games (in my case sparkle) dont display correctly and are resized and tiled, i.e when sparkle starts up you normally have the introductory image displayed as the game loads, but in this case the image was shrunk and being presented 4 times as tiles. However if I restart the pre3 and select webos at the bootr stage, sparkle starts up as normal. Has anyone noticed if this is the case for the standard uImage or is this peculiar to the Uberkernel version?
    I can't reproduce it because I don't have sparkle. Please, post the result of the command:
    Code:
    fbset -i -fb /dev/fb1
    and try this command:
    Code:
    fbset -fb /dev/fb1 -g 480 800 480 2400 32
    before launching sparkle.
    Quote Originally Posted by vgg View Post
    Well after installing uberkernel I've installed the new Uberkernel friendly uImage.Android and am pleased to say it's working well.
    Yes, I think with uberkernel and performace options it can be called to be usable(for small apps). Also, this is a result of antutu benchmark:
    Attached Images Attached Images
  8. vgg
    vgg is offline
    vgg's Avatar
    Posts
    83 Posts
    #88  
    Quote Originally Posted by NIN_ru View Post
    I can only guess. Maybe you didn't restart android after editing, make sure you have /media/internal/AndroidChroot/root/dev/input/event1 while working android(Also that line should be already be commented out in 1 post link root.ext3)

    I can't reproduce it because I don't have sparkle. Please, post the result of the command:
    Code:
    fbset -i -fb /dev/fb1
    and try this command:
    Code:
    fbset -fb /dev/fb1 -g 480 800 480 2400 32
    before launching sparkle.

    Yes, I think with uberkernel and performace options it can be called to be usable(for small apps). Also, this is a result of antutu benchmark:
    Click to view quoted image
    Thanks NIN_ru

    will try this tonight and report back...cheers

    vito
  9. vgg
    vgg is offline
    vgg's Avatar
    Posts
    83 Posts
    #89  
    Quote Originally Posted by NIN_ru View Post
    I can only guess. Maybe you didn't restart android after editing, make sure you have /media/internal/AndroidChroot/root/dev/input/event1 while working android(Also that line should be already be commented out in 1 post link root.ext3)

    I can't reproduce it because I don't have sparkle. Please, post the result of the command:
    Code:
    fbset -i -fb /dev/fb1
    and try this command:
    Code:
    fbset -fb /dev/fb1 -g 480 800 480 2400 32
    before launching sparkle.
    OK when I try the fbset -i command the message I get is:

    fopen /etc/fb.modes: No such file or directory

    when I try the fbset -fb command no message is output.

    I tried the commands with the android image installed and without (i.e booting into webos, without the ability to run AndroidChroot, and with the ability to launch AndroidChroot). I also tried the commands before and after launching androidchroot. I also tried these variation both from novaterm and from the pre3 itself using Xterm via xecutah (not that this should have made a difference).

    Also the scaling problem doesn't occur prior to launching android in the card itself, by this i mean prior to launching androidchroot everything is fine. Once I launch androidchroot everything is still fine and scaling is ok. Once I "start android && start client" the scaling error occurs....


    any ideas??


    I've still not being able to sort out my keyboard issue yet but will investigate further tomorrow - probably rebuild everything again...

    chrz

    Vito
  10. Palmiga's Avatar
    Posts
    96 Posts
    Global Posts
    110 Global Posts
    #90  
    Geronimo!
    HW-Keyboard and Uberkernel-UImage works great!

    I tried to install Lightning Launcher, a great Laucher for small systems. I works great before I install the language-package. Now it only use a square (size maybe B320xH640) top/middle of the screen. Couldnt change it in the settings. Any idea?

    Often Android freeze for a longer time and then shows a message 'system' or 'app' didnt answer and I could choose 'force to close' or 'wait' for it. Is there a way to end this annoying messages?
  11.    #91  
    Quote Originally Posted by vgg View Post
    any ideas??
    Honestly, I don't know what to do with it.

    ananimus: when pressing "0" on virtual keyboard, appears symbol "@". Do you know why and possible way to solve?
    Quote Originally Posted by Palmiga
    I tried to install Lightning Launcher, a great Laucher for small systems. I works great before I install the language-package. Now it only use a square (size maybe B320xH640) top/middle of the screen. Couldnt change it in the settings. Any idea?
    I just tried lightning launcher and android refused to work after reboot. So, I can't help you, let me call "lightening launcher" to be unsupported.
    Quote Originally Posted by Palmiga
    Often Android freeze for a longer time and then shows a message 'system' or 'app' didnt answer and I could choose 'force to close' or 'wait' for it. Is there a way to end this annoying messages?
    This message appears when android don't have enough ram or cpu to run app. It's pre3 hardware problem and I think it's unsolvable.
  12. #92  
    Quote Originally Posted by NIN_ru View Post
    ananimus: when pressing "0" on virtual keyboard, appears symbol "@". Do you know why and possible way to solve?
    Oh. Oops! Thanks for the heads up.

    I'll have to check. That may be because of the sloppy way I fixed the hardware keyboard. I didn't know the hardware/software input methods were connected to the same keychars!

    Anyways yes. I might be able to fix it.
  13. #93  
    Quote Originally Posted by ananimus View Post
    Oh. Oops! Thanks for the heads up.

    I'll have to check. That may be because of the sloppy way I fixed the hardware keyboard. I didn't know the hardware/software input methods were connected to the same keychars!

    Anyways yes. I might be able to fix it.
    Yes, I was going to state the obvious and say that this is indeed correct in relation to the H/W keyboard, but does your virtual keyboard have that - whatever it's called - "coloured square shift" button to type numbers etc.? EDIT: It's the 'Option' button. And how do you mimic the symbol key?

    And off topic, how do you type TAB in webOS? That's always bothered me! The system seems to recognize the character, but I never worked out how to input it.
    Last edited by Preemptive; 02/23/2014 at 11:34 AM.
    ananimus likes this.
  14. #94  
    Quote Originally Posted by Preemptive View Post
    Yes, I was going to state the obvious and say that this is indeed correct in relation to the H/W keyboard, but does your virtual keyboard have that - whatever it's called - "coloured square shift" button to type numbers etc.? And how do you mimic the symbol key?

    And off topic, how do you type TAB in webOS? That's always bothered me! The system seems to recognize the character, but I never worked out how to input it.
    Keen! I don't think the tab is standard on any mobile OS actually, and that's always bothered the hell out of me. As for the symbol key, it's generally equivalent to ALT. Other HW keyboards have that, as does Android standards. And it is part of how I botched the keymap not realizing the file I skirted changing was tied to the software keyboard. I'll try to really fix it romorrrow for inclusion in the version NIN has posted.
  15. #95  
    To elaborate, there are two files in Android in particular (and probably Linux in general): one that relates what hardware number code maps to which base symbol. Then a second explains what to do with that base symbol and any modifier, depending on what's expected based on what's painted on the physical buttons (or display.).

    Assuming the two files I was editing were tied only to the physical keyboard (cuz I'm a physicist and not a programmer/dev), I just changed the second of the two. The original keymap was interpreting a Pre 3's keypress on @ as 0. I didn't change that. I told it in the higher level to print @ when a 0 is entered with no modifier (because I was mostly trying to fix the other 26 incorrect alt chars) not realizing the same first level file would tell the software keyboard to do the same thing. The result is when any keyboard says "unmodified 0," it prints @.

    So whoops! There's a reason for standards and knowing what they are instead of guessing or bein lazy for a quick fix.
    Last edited by ananimus; 02/23/2014 at 03:18 AM.
  16. #96  
    Quote Originally Posted by ananimus View Post
    Keen! I don't think the tab is standard on any mobile OS actually, and that's always bothered the hell out of me. As for the symbol key, it's generally equivalent to ALT. Other HW keyboards have that, as does Android standards. And it is part of how I botched the keymap not realizing the file I skirted changing was tied to the software keyboard. I'll try to really fix it romorrrow for inclusion in the version NIN has posted.
    I pulled out the instruction leaflet and reminded myself that the button on the left is called 'Option' and I assume this is what functions as ALT.

    I presume virtual keyboards generate the same character codes as hardware keyboards for common use across systems.

    But yes, the Symbol ('Sym') key brings up a table of possible characters in the manner of a virtual keyboard, so I was curious as to how this is handled. Or is it a standard approach? If Android includes this as part of it's virtual keyboard, I guess it must be straightforward to connect it rather than having to replicate the entire table. Or maybe it's simple to port the webOS code in Android?
  17. #97  
    Y'know, I hadn't thought much about the Sym key. It didn't do anything obvious in Android, so I didn't look into it much. I'll check.
  18. #98  
    I dont have a linux system to use for install, so am using my Pre3 but i can't get gapps.sh to run, when i try it gives error
    Archive: zip flags 1 and 8 are not supported

    I am confused about where to actually put the gapps files on the pre as you say place in archive folder , i have placed them in the same "out".
  19. Palmiga's Avatar
    Posts
    96 Posts
    Global Posts
    110 Global Posts
    #99  
    Quote Originally Posted by Firepower View Post
    I dont have a linux system to use for install, so am using my Pre3 but i can't get gapps.sh to run, when i try it gives error
    Archive: zip flags 1 and 8 are not supported

    I am confused about where to actually put the gapps files on the pre as you say place in archive folder , i have placed them in the same "out".
    Before it works (for me) I need to give it the execute-bit (like files.sh)

    Try
    sudo chmod +x gapps.sh
    ./gapps.sh
  20. #100  
    Quote Originally Posted by Palmiga View Post
    Before it works (for me) I need to give it the execute-bit (like files.sh)

    Try
    sudo chmod +x gapps.sh
    ./gapps.sh
    i tried (no sudo command)

    chmod+x gapps.sh
    ./gapps.sh

    I get same error
Page 5 of 11 FirstFirst 12345678910 ... LastLast

Similar Threads

  1. Replies: 14
    Last Post: 02/20/2013, 04:19 PM
  2. Replies: 3
    Last Post: 12/16/2011, 03:03 PM
  3. If Amazon Buys webOS, They Could Make it Run Android Apps
    By deesugar in forum webOS Discussion Lounge
    Replies: 0
    Last Post: 09/30/2011, 05:39 PM
  4. Run iOS and Android apps on webOS.
    By sherard in forum webOS Discussion Lounge
    Replies: 2
    Last Post: 03/30/2011, 05:46 PM
  5. Will we be able to run Android Apps on webOS?
    By JED-WEB-OS in forum Other OS's and Devices
    Replies: 1
    Last Post: 01/15/2011, 01:28 PM

Tags for this Thread

Posting Permissions