I keep getting a "package not signed correctly" error. Any ideas? Anyone experiencing the same thing?