webOS Nation Forums >  Other OS's and Devices >  Android on webOS > Android on 4G TouchPad
Android on 4G TouchPad
  Reply
Like Tree66Likes

 
Thread Tools Display Modes
Old 10/27/2012, 07:14 PM   #121 (permalink)
Member
 
Posts: 141

New releases of CyanogenMod for the HP TouchPad 4G are available for testing.

See the second post in this thread or here: CyanogenMod 9 and 10 - TouchPad 4G Releases

John
NewbyJE is offline   Reply With Quote
Liked by renater, tabletrus, stangri and 1 others like this.
Old 10/27/2012, 08:19 PM   #122 (permalink)
Member
 
Posts: 85
thanks, will try it when i get home and report back. im excited.
ceejayr is offline   Reply With Quote
Old 10/28/2012, 01:15 AM   #123 (permalink)
Member
 
Posts: 33
I am running the 4g_alpha3 build. I have a number of programs installed, but the only ones usually running would be the basic ones - the Nova Launcher, Mail, Chrome, and the Kindle app. I'll fire up RealCalc and a periodic table program when I'm working, but beyond that I don't run much regularly. I do have FriendCaster running sometimes, but the other poster (stangri) mentioned Nova Prime as a possible culprit. I do use that every time. I was getting reboots with alpha2 and alpha3 before I installed the Nova launcher, but it's possible I'm getting more now.

I installed wake-lock powermanager and set it to "Partial_Wake_Lock" a few days ago. I've only had one reboot since, and I have no idea why. It might have happened when I pulled the TP off the TS charger, but the tablet was on and running when I picked it up (with the cover replaced before I grabbed it). When I was in England, the tablet would often reboot when I unplugged it, but not every time.

I've only had one weird experience with programs not working. That was a few days ago. Settings wouldn't work. Neither would the Kindle app or another app I was trying to use (I forget which one). After the reboot a few days ago, everything seems to be fine.

Thanks for the beta build! I don't have time to play with it now; when I re-installed CM9 the last time, it took me a good chunk of the day and several install/wipe cycles to get it to take. That was my fault, but I hope I know better now. I want to leave enough time to get it installed properly if I have further trouble. I'll keep an eye out and see if anything changes with the reboots.
krotech is offline   Reply With Quote
Old 10/28/2012, 04:19 PM   #124 (permalink)
Member
 
Posts: 85
Did a system wipe, installed beta0 and gapps 0429... 0 reboots or crashes, ive already reinstalled my apps, i saw one error very quickly, not sure where it came from... i really cant remember it as it went away quick, it said something like revcom blah blah.... cellular and data is working like a charm, not sure if wireless N link goes beyond 65Mbps, I do not get any of the wakelock issues some have been reporting. I have yet to check on battery drain and GPS.

so far so good.
ceejayr is offline   Reply With Quote
Old 10/29/2012, 01:50 PM   #125 (permalink)
Member
 
Posts: 67
Also installed beta0 and sounds good so far. Just waiting for camera for skype and i am all set for couple of years
tabletrus is offline   Reply With Quote
Old 10/29/2012, 09:27 PM   #126 (permalink)
Member
 
Posts: 10
Cleaned cache and dalvik cache, installed beta0 and was still having reboots. Went into recovery, cleaned up caches again and now it works (knock on wood) no problem.

Many thanks to NewbyJE!
stangri is offline   Reply With Quote
Old 10/31/2012, 06:20 PM   #127 (permalink)
Member
 
Posts: 85
Antutu Benchmark results:
stock clock (1.5 GHz): 6483

cant seem to get it to complete antutu when overclocked... antutu stays at 0% (will fiddle with it a bit more)
ceejayr is offline   Reply With Quote
Old 10/31/2012, 06:21 PM   #128 (permalink)
Member
 
Posts: 85
Apparently i was impatient....

Antutu Benchmark results:
overclocked (1.78 GHz): 7639

screenie
http://i.imgur.com/Ykzlx.png

Last edited by ceejayr; 10/31/2012 at 08:10 PM. Reason: screenie
ceejayr is offline   Reply With Quote
Old 11/05/2012, 06:07 PM   #129 (permalink)
Member
 
Posts: 84
Cool.

Just following up. I wonder if you can add me to the list of alpha testers for the Sierra build when you release it.

Thanks.

Quote:
Originally Posted by NewbyJE View Post
Hi sd_matto:

No to first question. Yes to the second. I have been splitting my limited time between the beta for the Ericsson f5521gw module and an early alpha for the Sierra MC7700 module. TTB has been waiting very patiently for a Sierra build to test.

John
sd_matto is offline   Reply With Quote
Old 11/06/2012, 12:02 AM   #130 (permalink)
Member
 
Posts: 141
Quote:
Originally Posted by sd_matto View Post
I wonder if you can add me to the list of alpha testers for the Sierra build when you release it.
Thanks.
Hi sd_matto:

You're on the list. I'm slowly making progress (baby steps); no ETA. It's an interesting project -- yet to see if it is really worth all the effort. Jury is still out on voice support.

Curious if you have already installed a Sierra MC7700 module in your TP 4G? When I release an alpha for testing, I will also provide some instructions on how to install and use the module (thanks to TTB).

John
NewbyJE is offline   Reply With Quote
Thanked By: sd_matto
Old 11/06/2012, 12:31 AM   #131 (permalink)
Member
 
Posts: 141
I am curious if anyone has experienced AT timeouts with the recent pre-release builds. When this happens, you loose cellular connection and have to reboot to get it back.

The issue happens a lot at my home location for some reason. Turning off NITZ (network time reporting) functionality in the RIL prevents the AT timeouts from happening. We have not been able to track down the specific cause and fix it. Therefore, NITZ reporting was turned off in the 4G_alpha3 release. No one indicated any problems with their TP 4G keeping the correct time.

I left NITZ turned on for testing the MBM Beta pre-release builds. These builds still cause my TP to experience AT timeouts occasionally. Future builds will include a system property that can be used to enable or disable NITZ functionality. I am not sure if the default should be enabled or disabled. Your experience and feedback will help make the decision.

Any other issues to report?

John
NewbyJE is offline   Reply With Quote
Old 11/06/2012, 05:25 PM   #132 (permalink)
Member
 
Posts: 84
Quote:
Originally Posted by NewbyJE View Post
Hi sd_matto:

Curious if you have already installed a Sierra MC7700 module in your TP 4G? When I release an alpha for testing, I will also provide some instructions on how to install and use the module (thanks to TTB).

John
I have not yet done the install; I have been crazy busy doing other projects, and I wanted to make sure there would be a working Android build before I took the plunge and swapped out wireless modules. Having said that, I do have the Sierra modules purchased and ready to swap in.

I do have speaker cracks on both TP 4Gs for which I was going to do the module swap, so I am not sure if I will do the swap myself (in which case I need to get my hands on a replacement back case) or just ship it off to TTB (who will do it for a fee). I think it will depend on how much time I have on my hands at the time of the Android release.

Thanks again for your hard work, John. Much appreciated!
sd_matto is offline   Reply With Quote
Old 11/09/2012, 11:24 PM   #133 (permalink)
Member
 
TopTongueBarry's Avatar
 
Posts: 1,837
sd_matto,

The alpha John is working on is ohhh so close. Few minor bugs but as of now, data works, however I have not ventured into the city to verify LTE data connection speeds yet.

Direct SMS/MMS works (as Twack's eyes perk up .....).

Direct voice calling "may" also be possible. It's on John's list below other bug fixes. We don't know if the TP 4G will support it even with a voice enabled OS, modem, and sim installed, it's never been done before. What offers hope is that I've seen a video of someone in China with a Sierra inside their Touchpad GO using it to make and receive cals directly through the Sierra. Gotta keep in mind the Touchpad GO and the Touchpad 4G are two different devices even if they both use the MSM8660.

I'm using a voice enabled smartphone sim for testing that hasn't been LTE enabled yet. The dialer contacts the network and successfully pulls voicemail, call forwarding and call waiting settings, AT&T even sent me a text message AND an email after I tested the build with it congratulating me on my purchase of a new LTE enabled smartphone, and of course offering me an upgrade to a LTE data plan so it could take advantage of the LTE data network. Unfortunately, incoming and outgoing calls don't work. Incoming calls go direct to voice mail right now.

RE: "need to get my hands on a replacement back case"
Didn't I send you a brand new uncracked white back case a few months ago?

TTB
__________________
----------------------------------------------------------------------------------------------------
I am an AT&T employee and the postings on this site are my own and donít necessarily represent AT&Tís positions, strategies or opinions.

Last edited by TopTongueBarry; 11/10/2012 at 12:25 AM.
TopTongueBarry is offline   Reply With Quote
Thanked By: brizmontay
Old 11/10/2012, 11:27 PM   #134 (permalink)
Member
 
Posts: 84
Quote:
Originally Posted by TopTongueBarry View Post
sd_matto,

The alpha John is working on is ohhh so close. Few minor bugs but as of now, data works, however I have not ventured into the city to verify LTE data connection speeds yet.
Very good news. Let me know if you want a second beta tester for LTE, as I have LTE at my house (East Bay, San Francisco area, with working LTE from iPad 3, which I am keeping merely to maintain grandfathered unlimited data plan (which, per ATT Communication program on WebOS, is actually capped at 2000 GBs - ).

Quote:
Originally Posted by TopTongueBarry View Post
RE: "need to get my hands on a replacement back case"
Didn't I send you a brand new uncracked white back case a few months ago?

TTB
Nope, I didn't buy a white one from you. May be curious to do the white (though I understand that there are cracking issues with it). But, I have two backs that need replacing, and am interested in either 2 blacks, or 1 black + 1 white. PM your price, and let's see if we can make a deal!

Thanks again for testing, and for sharing test results. Voice on this would be pretty awesome, but I am just excited to get LTE data - YAY!!
sd_matto is offline   Reply With Quote
Old 11/11/2012, 04:42 PM   #135 (permalink)
Member
 
Posts: 85
next CM10 alpha for TP4G will be worth a try.... jcsullins had released his 3rd CM10 preview, released 11/08, it's kinda stable and now has sound. now we'll have to wait for john's hard work as he is currently the android TP4g saviour.
ceejayr is offline   Reply With Quote
Old 11/11/2012, 07:36 PM   #136 (permalink)
Member
 
Posts: 141
Quote:
Originally Posted by sd_matto View Post
I do have speaker cracks on both TP 4Gs for which I was going to do the module swap, so I am not sure if I will do the swap myself (in which case I need to get my hands on a replacement back case) or just ship it off to TTB (who will do it for a fee). I think it will depend on how much time I have on my hands at the time of the Android release
sd_matto:

I just posted some things I learned from opening the TouchPad 4G case here: 4G TouchPad Owners Lounge

John
NewbyJE is offline   Reply With Quote
Old 11/11/2012, 08:01 PM   #137 (permalink)
Member
 
TopTongueBarry's Avatar
 
Posts: 1,837
Quote:
Originally Posted by ceejayr View Post
next CM10 alpha for TP4G will be worth a try.... jcsullins had released his 3rd CM10 preview, released 11/08, it's kinda stable and now has sound. now we'll have to wait for john's hard work as he is currently the android TP4g saviour.
He's still working on the pre-release beta of CM 9 for the TP 4G and a pre-release alpha of CM 9 for the TP 4G with a Sierra LTE module installed.

I suspect CM 10 for the TP 4G will come along after that.

I motion that John is allowed to get away for a short spell or to take a vacation soon.

We certainly don't want him to burn out on us!
__________________
----------------------------------------------------------------------------------------------------
I am an AT&T employee and the postings on this site are my own and donít necessarily represent AT&Tís positions, strategies or opinions.
TopTongueBarry is offline   Reply With Quote
Old 11/11/2012, 08:45 PM   #138 (permalink)
Member
 
Posts: 85
ahh, "2 weeks" then. im happy with my CM9 4G beta
ceejayr is offline   Reply With Quote
Old 11/14/2012, 12:41 AM   #139 (permalink)
Member
 
Posts: 141
TTB, sd_matto:

Please check your PMs.

John
NewbyJE is offline   Reply With Quote
Thanked By: dinlaca
Old 11/17/2012, 12:24 PM   #140 (permalink)
Member
 
TopTongueBarry's Avatar
 
Posts: 1,837
Encouraging news to share regarding direct voice calling on the TP 4G with a Sierra MC7700 / 7710 MBM installed.

I'm testing an alpha for the 4G with a sierra MBM and voice calling seems to work, with bugs,

Tablet successfully connects to numbers dialed on its dialpad, and rings on incoming calls, but the other party can't hear me and I can't hear them. Tried with both the tablet mic/speaker and a wired headset.

Enabling voice calling on the MBM seems to have induced additional hw GPS bugs.

John is working through these issues as well as the CM10 build for the Touchpad 4G. I've started calling him Santa!

Stay tuned,

TTB
__________________
----------------------------------------------------------------------------------------------------
I am an AT&T employee and the postings on this site are my own and donít necessarily represent AT&Tís positions, strategies or opinions.
TopTongueBarry is offline   Reply With Quote
Liked by renater and kayphoonstar like this.
Thanked By: yellowhammer
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0