Page 5 of 26 FirstFirst 1234567891015 ... LastLast
Results 81 to 100 of 504
Like Tree95Likes
  1. #81  
    I am also having spontaneous reboot issues. I could not last a day without resets.

    Could it be a googapps issue? Do i need to reinstall gappps?

    -- Sent from my 4G Touchpad using Communities
  2. #82  
    Quote Originally Posted by NewbyJE View Post
    Hi machbaba: Sorry to hear about your reboot issue. On 9 Sept. you reported having no reboots for a full day when you first installed 4g_alpha3. Did this just start to happen? Did anything else change?

    I will look at the code and see if it could be related to China Unicom's manual network setting mode and somehow related to the 'No Service' / SIM issues you were having. Also, you might send me new radio logs. I might be able to see some differences from the 4g_alpha2 logs you sent previously that would help figure out why this could be happening.

    I think this problem may be specific to China Unicom. If anyone else is having a similar problem on another network, please let me know.

    John
    On 9 Sept., the system is running without SIM. Very stable and smooth. The reboot issue occurs after i put in a SIM.
    One thing to make is that the system is working fine with China Telecom's HSPA+ network and shows the correct sign. 1 of my SIM shows H+, one doesn't is because the limitation from Unicom. But both will cause spontaneous reboot in Alpha 3. In Alpha 2 it seems fine. Btw, the No Service display issue still remains.

    Log attached.
    John, really appreciate your effort looking into this.
    Attached Files Attached Files
  3. #83  
    Quote Originally Posted by bulls96 View Post
    I am also having spontaneous reboot issues. I could not last a day without resets. Could it be a googapps issue? Do i need to reinstall gappps?
    I think machbaba's reboot problems could be tied to the SIM routines in the MBM modules, but this is a special case with the way the MBM module handles the China Unicom SIM. I have had minimal reboots with 4g_alpha3 over the last couple of weeks.

    Some people have occasional reboot problems with the standard CM9 releases. Sometimes these clear up after a few reboots or upon reflashing the ROM and wiping the cache. If you can access Play Store, gapps is probably not the problem. But, it probably would not hurt to use CWM or TWRP to re-install 4g_alpha3 and gapps, wipe cache and Dalvik, and then reboot.

    John
  4. #84  
    Quote Originally Posted by machbaba View Post
    One thing to make is that the system is working fine with China Telecom's HSPA+ network and shows the correct sign. 1 of my SIM shows H+, one doesn't is because the limitation from Unicom. But both will cause spontaneous reboot in Alpha 3. In Alpha 2 it seems fine. Btw, the No Service display issue still remains. Log attached.
    Thanks for the logs, they are helpful. I now see where the 'No Service' problem occurs. It does have to do with the way the MBM module interprets the China Unicom SIM and there may be other issues that could be the cause of your reboots. Although I could force 'China Unicom' to appear, this really does not fix the underlying problem. I will need to delve into the code to better understand what the MBM module is doing with all the information taken off the SIM and why there is no problem with the AT&T SIM, but a problem with the China Unicom SIM. Will keep you posted.

    John
  5. #85  
    i was a moron for not visiting this thread, i kept looking at jcsullins goo.im page for any release but apparently it was right underneath my nose from this thread. upgrading to the newer build.
  6. #86  
    upgrade went well, so far so good, battery consumption on sleep has dropped to as low as -60, the lowest ive ever seen on my 4G TP. thats a bit above 1% per hour.
  7. #87  
    Quote Originally Posted by bulls96 View Post
    I am also having spontaneous reboot issues. I could not last a day without resets.

    Could it be a googapps issue? Do i need to reinstall gappps?

    -- Sent from my 4G Touchpad using Communities
    Ok resets have dropped down quite a bit. Went a whole day without resets which is progress :-)

    - Sent from my Samsung Galaxy SIII using Tapatalk
  8. #88  
    I have had no issues so far with alpha 3. working beautifully.
  9. #89  
    Quote Originally Posted by machbaba View Post
    Btw, the No Service display issue still remains.
    machbaba: Please check for a PM.

    John
  10. #90  
    Quote Originally Posted by NewbyJE View Post
    machbaba: Please check for a PM.

    John
    John,

    the patched version is awesome, gladly report no reboot since install.

    Rock solid!!!
  11. #91  
    machbaba:

    Please check for another PM.

    John
  12. twack's Avatar
    Posts
    634 Posts
    Global Posts
    638 Global Posts
       #92  
    Good Morning Android 4G'rs,

    Do we have a build with Mic and Camera working? IF so, please point me the way to the load instructions.

    Thank you,
    Twack
  13. #93  
    Quote Originally Posted by twack View Post
    Good Morning Android 4G'rs,

    Do we have a build with Mic and Camera working? IF so, please point me the way to the load instructions.

    Thank you,
    Twack
    Mic works, no camera yet (some progress is being made on getting the camera to work, but still rough).

    See second post in this thread for links and instructions.

    John
  14. #94  
    camera already work partially.
  15. #95  
    So I recently purchased a 4G that the previous owner had done the hard work of getting a dual boot WebOS / Android environment set up.

    It was the standard build from awhile ago and did not have a gapps installed when I got it. It worked well enough.

    I was able to get the alpha 3 build and the 4.29 gapps onto the device last week and I am seeing periodic reboots on the Android side.

    I have added the 4G to a Palm Profile that had a TP on it already and it got most of the things installed from the profile. I have not activated the SIM yet. The WebOS side reminds me every so often that activation is required on the SIM but it does not reboot the WebOS side.

    Do you think the non-activated SIM is causing the reboots on the Android side when it reminds me to activate?


    -- Sent from my Palm Pre using Forums
    Handspring Visor -> Treo 650 -> Centro -> Pre Plus -> Developer Day Pre 2
    32Gb Touchpad, 32Gb Touchpad 4G w/ CM10 onboard
    Pre 3 waiting in the wings for a good reason to switch
  16. #96  
    Quote Originally Posted by jbates View Post
    Do you think the non-activated SIM is causing the reboots on the Android side when it reminds me to activate?
    Theoretically not, but it is possible that is the case. Reboots are an elusive issue.

    I am testing a pre-release of the MBM HAL Beta version (current 4g builds use the Alpha version) that has many issues fixed, including some related to the SIM and reboots. It supports both CM9 and CM10. A new release incorporating the MBM HAL Beta will be posted within two weeks

    John
    kayphoonstar likes this.
  17. sd_matto's Avatar
    Posts
    85 Posts
    Global Posts
    190 Global Posts
    #97  
    I am finally surfacing for air after a crazy month.

    Curious if the MBM HAL Beta version that you reference below includes support for the Sierra Wireless LTE module. If not, any thoughts on whether the Sierra Wireless LTE module will ever be able to be made to work on Android with our TP 4G?

    Thanks in advance for your thoughts, and thank you so much for all the hard work you have put in.

    Quote Originally Posted by NewbyJE View Post
    I am testing a pre-release of the MBM HAL Beta version (current 4g builds use the Alpha version) that has many issues fixed, including some related to the SIM and reboots. It supports both CM9 and CM10. A new release incorporating the MBM HAL Beta will be posted within two weeks

    John
    Quote Originally Posted by NewbyJE View Post
    Hi TTB:

    Traveling this weekend and away from my development machine. The MBM HAL in the CM9 for 4G uses Ericsson specific commands, so I am not surprised it does not work. The hardware drivers you found for Sierra are already in the kernel and should be working. If not, it is pretty easy to get them turned on. The problem is the HAL needs to be specific for Sierra. I have not been able to get the right contact at Sierra and even then I have heard that you have to beg and sign a NDA to get the RIL and GPS HAL code.

    You might be able to use the RIL HAL version available here: https://github.com/aferre/sierra-ril if you compile your own version of CM9. Let me know if you want to try and I will try to help.

    John
  18. #98  
    For those interested in the beta MBM HAL can find a precompiled CM9 build here. I've had less frequent reboots with the new beta HAL.
    Devices:
    HP TouchPad WiFi 32 GB - webOS 3.0.5 + CyanogenMod 10.2 Kernel 3.0
    HP TouchPad 4G 32 GB - webOS 3.0.5 + CyanogenMod 10.1 MBM Beta
    HTC One (T-Mobile)
    Amazon Kindle Fire HD 7" 2012
    Apple iPhone 4 (Verizon)
  19. #99  
    Quote Originally Posted by gamer765 View Post
    I've had less frequent reboots with the new beta HAL.
    gamer765:

    I presume you built this using my git repo of the pre-release MBM HAL 4.0.0.0 BETA. I would prefer that builds using this code not be released for general use until it is debugged and required modifications to CM are included with the documentation. I have been very fortunate to have the developers of the MBM HAL dedicate significant time helping debug the code specifically for the TouchPad 4G. They gave me permission to make the repo publicly available so it could be used by other TP users assisting with development and debugging. If you would like to help, please send me a PM.

    Users, please be aware that the pre-release MBM HAL 4.0.0.0 BETA code has several issues that are still being worked on. Also, the beta was written for and is being tested using newer versions of the cdc, ncm, and usb kernel drivers that have not been comitted to the CM9 tenderloin kernel. In addition, there are other patches to the kernel, frameworks/base, etc. required for full functionality. When the MBM HAL 4.0.0.0 BETA is debugged, it will be 'officially' released on the SorceForge site and I will post clean CM9 and CM10 builds for the TouchPad 4G in this thread. These "official" versions will have links in the second post.

    The build posted by gamer765 should work reasonably well, but the RIL may hangup or crash occasionally. I strongly suggest patience until the debugged beta version is available. It should not be too much longer and will provide an even better experience.

    John
    Last edited by NewbyJE; 10/06/2012 at 02:28 AM. Reason: Clarity and civility
    ilikecl likes this.
  20. #100  
    Quote Originally Posted by sd_matto View Post
    Curious if the MBM HAL Beta version that you reference below includes support for the Sierra Wireless LTE module. If not, any thoughts on whether the Sierra Wireless LTE module will ever be able to be made to work on Android with our TP 4G?
    Hi sd_matto:

    No to first question. Yes to the second. I have been splitting my limited time between the beta for the Ericsson f5521gw module and an early alpha for the Sierra MC7700 module. TTB has been waiting very patiently for a Sierra build to test.

    John
    Last edited by NewbyJE; 10/06/2012 at 02:51 AM.
Page 5 of 26 FirstFirst 1234567891015 ... LastLast

Posting Permissions