webOS Nation Forums >  Other OS's and Devices >  Android on webOS > Android on 4G TouchPad
Android on 4G TouchPad
  Reply
Like Tree66Likes

 
Thread Tools Display Modes
Old 01/28/2013, 11:35 PM   #221 (permalink)
Member
 
Posts: 141
Quote:
Originally Posted by marknyack View Post
hi - I am presently running CM9 on my ATT 4G without problems (actually don't use it much since WebOS does most of what I need). I appreciate all the hard work that's gone into developing both CM 9 and CM10. The question I have is - What benefit(s) does CM10 really bring over CM9 for an occasional user? I have read through this thread and I haven't seen a big reason other than it is getting more stable - camera works, etc. With each update.
Not a lot of difference. The interface is faster and smoother. Even looks nicer, but that is subject to personal preference.

Not much development is going into CM9 but it still is going on for CM10 and CM10.1, so other fixes and additions in the future may not get back-ported to CM9. I will probably only do one more release of CM9 when the MBM HAL beta is finalized, then concentrate only on newer versions.

One advantage to CM9 is that Flash was supported by Adobe for ICS, but is not for Jellybean (CM10).
NewbyJE is offline   Reply With Quote
Thanked By: marknyack
Old 01/28/2013, 11:44 PM   #222 (permalink)
Member
 
Posts: 67
Quote:
Originally Posted by NewbyJE View Post
tabletrus:

Yep, corrupted files would do it. Should be able to start over if you can get the correct files into cminstall. Or, try my suggestion to boot into CWM and go from there.
Thank you John! You are awesome! I was able to get to get to follow your instruction and did an uninstall and redoing install again. I downloaded all the files in my office and i did not bother to check the install size. Now downloaded all files at home and it is booting as I write to JellyBEAN!!!
tabletrus is offline   Reply With Quote
Old 01/29/2013, 01:37 AM   #223 (permalink)
Member
 
Posts: 85
@marknyack - there isn't a giant reason to really jump from cm9 to cm10 for an occasional user. The changes are subtle to an occasional user, but it should be big for us rom freaks. I would suggest to stay where you are, as CM9 is super stable compared to CM10, given that you frequent webOS over android.
ceejayr is offline   Reply With Quote
Thanked By: marknyack
Old 01/29/2013, 03:23 AM   #224 (permalink)
Member
 
Posts: 207
Quote:
Originally Posted by ceejayr View Post
my battery drain on idle with these main settings:

governor: conservative
airplane mode: on (wifi off, data off, cellular off)
brightness: rockbottom

averages on the -80mAh using battery monitor widget to check

could someone check on your unit for comparison? thanks!
Hi ceejay
Same settings, using battery monitor widget too, I am getting -424mA

How did you get -80mAh? Could it be a calibration issue?
This is the first time I use this widget (https://play.google.com/store/apps/d...cc71.bmw&hl=en) and I just made the switch to CM10 today.

What should I look out for?

Thx

JP
pepebuho is offline   Reply With Quote
Old 01/29/2013, 05:20 AM   #225 (permalink)
Member
 
Posts: 85
Maybe i wasn't too clear with my post JP, i meant that to be the sleep drain, non-4G models get sleep drain of about -30mah during sleep. -80 is the best my touchpad is currently doing with CM10.
ceejayr is offline   Reply With Quote
Old 01/29/2013, 02:49 PM   #226 (permalink)
Member
 
marknyack's Avatar
 
Posts: 22
Quote:
Originally Posted by NewbyJE View Post
Not a lot of difference. The interface is faster and smoother. Even looks nicer, but that is subject to personal preference.

Not much development is going into CM9 but it still is going on for CM10 and CM10.1, so other fixes and additions in the future may not get back-ported to CM9. I will probably only do one more release of CM9 when the MBM HAL beta is finalized, then concentrate only on newer versions.

One advantage to CM9 is that Flash was supported by Adobe for ICS, but is not for Jellybean (CM10).
appreciate the responses (and ceejayr) and I will stick with CM9 for now. WebOS flash works fairly well for me. Like my 4G a lot - still seeing some NIB 4G's out there on ebay wondering/wishing they had gotten more out so developers could have done more
marknyack is offline   Reply With Quote
Old 01/30/2013, 12:42 PM   #227 (permalink)
Member
 
Posts: 67
Android - Android 4.1, Jelly Bean gives all of the new features. Voice search and playback is awesome for me on Touchpad. JB is very stable so far after 1 day of use. Project Butter is the theme for JB.
tabletrus is offline   Reply With Quote
Old 02/08/2013, 04:21 AM   #228 (permalink)
Member
 
Mutoidi's Avatar
 
Posts: 1,583
Hi,
I already have CM9 & CM10 installed on my Wifi only 32Gb TP.
I am soon upgrading to a 4G Model and wish to install CM10 whilst retaining settings and Apps etc from the Wifi only machine.

HOW best to do this please?

Use PC, Palm, Inc/Novacom/Installer3 etc to install an 'update-backup-etc' of existing Wifi-only CM10 and then 'upgrade' on top of that to 4G CM10 MBM Beta version?
Or install fresh 4G CM10 MBM Beta version and trust some Google 'Profile' or other to backup/install my original settings & Apps etc for me?

Also not clear whether Wifi only CM10 will refuse to initially install on a 4G machine.. and yet wanting to retain data, settings & Apps etc.

I hope this is clear..Thank you..


Last edited by Mutoidi; 02/08/2013 at 04:45 AM.
Mutoidi is offline   Reply With Quote
Old 02/08/2013, 08:04 AM   #229 (permalink)
Member
 
Posts: 141
Quote:
Originally Posted by Mutoidi View Post
Hi,
I already have CM9 & CM10 installed on my Wifi only 32Gb TP.
I am soon upgrading to a 4G Model and wish to install CM10 whilst retaining settings and Apps etc from the Wifi only machine.

HOW best to do this please?

Mutoidi:

Here is what I think will work best:
  1. Install CWM6 and moboot_038 on your WiFi TP (if you do not already have them installed).
  2. Make a backup of CM10 on your WiFi TP using CWM6.
  3. Use ACMEInstaller3 to install the same version of CM10 you are using on the WiFi TP, along with CWM6 and moboot_038, on the new 4G TP.
  4. Verify that you have a good install.
  5. Copy the CWM backup from the clockworkmod/backup/2013-xx-xx directory on your WiFi TP to the same directory you create on the new 4G TP and restore it using CWM6 to get all your settings, etc. back.
  6. Install the latest 4G build of CM10 on the 4G TP using CWM6.
John
NewbyJE is offline   Reply With Quote
Old 02/08/2013, 10:24 AM   #230 (permalink)
Member
 
Mutoidi's Avatar
 
Posts: 1,583
Quote:
Originally Posted by NewbyJE View Post
Mutoidi:

Here is what I think will work best:
  1. Install CWM6 and moboot_038 on your WiFi TP (if you do not already have them installed).
  2. Make a backup of CM10 on your WiFi TP using CWM6.
  3. Use ACMEInstaller3 to install the same version of CM10 you are using on the WiFi TP, along with CWM6 and moboot_038, on the new 4G TP.
  4. Verify that you have a good install.
  5. Copy the CWM backup from the clockworkmod/backup/2013-xx-xx directory on your WiFi TP to the same directory you create on the new 4G TP and restore it using CWM6 to get all your settings, etc. back.
  6. Install the latest 4G build of CM10 on the 4G TP using CWM6.
John
John:

Thank You.. I had hoped as much.

1). Already installed.. and good!

2). Done.

3). OK. Same Version.. but 'fresh' - no data/Apps?

4). This will be the question!

5). Good. ie. '/media/internal/cminstall/' for example?

6). And then go '4G specific' in Android: eg. CM10 V.MBM Beta?

Will report back after the 'occaision'.



Mutoidi.

Last edited by Mutoidi; 02/08/2013 at 12:03 PM.
Mutoidi is offline   Reply With Quote
Old 02/10/2013, 01:13 PM   #231 (permalink)
Member
 
bulls96's Avatar
 
Posts: 2,101
Installed the latest update on mine. It went rhough fine but all the Google apps are having errors (like Google Play, Music) popups always appear that say they have stopped working.



is this a gapps file issue? which is the latest most compatible gapps zip file?



thanks.

Sent from my Windows 8 device using Board Express Pro
bulls96 is offline   Reply With Quote
Old 02/10/2013, 01:43 PM   #232 (permalink)
Member
 
Posts: 141
Quote:
Originally Posted by bulls96 View Post
Installed the latest update on mine. It went rhough fine but all the Google apps are having errors (like Google Play, Music) popups always appear that say they have stopped working.
Sometimes the app's data files get messed up. Try going into settings, apps, find the problem application and "clear data". Then restart the app and see if it fixes the problem. If, so fix all the ones you are having problems with and make a clean backup.

Hope this helps.

John
NewbyJE is offline   Reply With Quote
Old 02/10/2013, 11:39 PM   #233 (permalink)
Member
 
Posts: 121
Quote:
Originally Posted by bulls96 View Post
Installed the latest update on mine. It went rhough fine but all the Google apps are having errors (like Google Play, Music) popups always appear that say they have stopped working.



is this a gapps file issue? which is the latest most compatible gapps zip file?
Are you by any chance using CM10 with the latest jb gapps? If so, that might be the reason since the latest jb gapps are incompatible with JB 4.1. The latest gapps is gapps-jb-20121212-signed.zip which is for 4.2 only. The last 4.1 compatible gapps is gapps-jb-20121011-signed.zip.
__________________
Devices:
HP TouchPad WiFi 32 GB - webOS 3.0.5 + CyanogenMod 10.2 Kernel 3.0
HP TouchPad 4G 32 GB - webOS 3.0.5 + CyanogenMod 10.1 MBM Beta
HTC One (T-Mobile)
Amazon Kindle Fire HD 7" 2012
Apple iPhone 4 (Verizon)
gamer765 is offline   Reply With Quote
Old 02/12/2013, 12:32 PM   #234 (permalink)
Member
 
Mutoidi's Avatar
 
Posts: 1,583
Quote:
Originally Posted by NewbyJE View Post
Mutoidi:

Here is what I think will work best:
  1. Install CWM6 and moboot_038 on your WiFi TP (if you do not already have them installed).
  2. Make a backup of CM10 on your WiFi TP using CWM6.
  3. Use ACMEInstaller3 to install the same version of CM10 you are using on the WiFi TP, along with CWM6 and moboot_038, on the new 4G TP.
  4. Verify that you have a good install.
  5. Copy the CWM backup from the clockworkmod/backup/2013-xx-xx directory on your WiFi TP to the same directory you create on the new 4G TP and restore it using CWM6 to get all your settings, etc. back.
  6. Install the latest 4G build of CM10 on the 4G TP using CWM6.
John
That all went really smoothly John.. thanks!

Fresh install was good and I chose to activate and make a backup of that and then place the already 'Backed-up backup + data Wifi-CM10' etc in the resultant 'clockworkmod/backup' directory and CWM-install the zip from there.

Latest 4G CM10 build then installed without issue and after setting APN in Networks to 'default' was soon Telstra-3G-on-line (+ all Apps. etc).




Last edited by Mutoidi; 02/12/2013 at 01:34 PM.
Mutoidi is offline   Reply With Quote
Old 02/12/2013, 10:31 PM   #235 (permalink)
Member
 
Posts: 141
Quote:
Originally Posted by Mutoidi View Post
That all went really smoothly John.. thanks!
Welcome to the TP 4G world...

John
NewbyJE is offline   Reply With Quote
Old 02/13/2013, 01:02 AM   #236 (permalink)
Member
 
Mutoidi's Avatar
 
Posts: 1,583
Quote:
Originally Posted by NewbyJE View Post
Welcome to the TP 4G world...

John
A pleasure to have made the 'transition'!

Can anyone recommend which Mapping/GPS Apps. perform well together?
Also a reliable 4G Toggle Widget? (CM10)

Thank you.


Last edited by Mutoidi; 02/14/2013 at 11:38 AM.
Mutoidi is offline   Reply With Quote
Old 02/17/2013, 11:43 AM   #237 (permalink)
Member
 
jazzdoc's Avatar
 
Posts: 137
Thanks to all of you who have made this work! I have a touchpad with an IMEI that ATT sees as only a smartphone. I bought a go phone chip as my family plan already has 5 phones, and the touchpad doesn't show up as a tablet. I am able to do SMS from the touchpad, but not data on CM10 or Webos. My Veer does data with the same gophone SIM. Is there a way inside of Android to make my tablet act more like a feature phone as far as ATT is concerned, or is this a database at ATT using my IMEI. Would unlocking help? I would be okay with a Data share plan as well if ATT would see this as a tablet...(The ATT rep at the store couldn't get that to happen...)
__________________
Casio BOSS->Palm Pilot Professional->Palm M500->Treo 600-> Treo 680->Treo Pro (TP) ->HP Veer<->HP TP<->Pre3<>HP TP 4G
Conn 6H-> Bach 36->Bach 16L (high Bb plays really flat?(fixed thanks to **** Akright))-> New York Bach 6viii
Scalpel->Scope->Aesop->Hermes->Sidne->Davinci S>Davinci Si
jazzdoc is offline   Reply With Quote
Old 02/17/2013, 01:42 PM   #238 (permalink)
Member
 
Posts: 141
jazzdoc:

Have you tried setting 'broadband' as the APN?

TTB reported that the Go Phone SIM works for 3G data speeds only. See the SIM Information on the CM 4G doc: CyanogenMod 9 and 10 - TouchPad 4G Releases

John
NewbyJE is offline   Reply With Quote
Old 02/17/2013, 07:29 PM   #239 (permalink)
Member
 
jazzdoc's Avatar
 
Posts: 137
Quote:
Originally Posted by NewbyJE View Post
jazzdoc:

Have you tried setting 'broadband' as the APN?

TTB reported that the Go Phone SIM works for 3G data speeds only. See the SIM Information on the CM 4G doc: CyanogenMod 9 and 10 - TouchPad 4G Releases

John
Thanks for the response. Tried changing the settings in the Webos settings found in the phone app, no luck, says "Unable to Set Up Internet APN". Found a description of changing the APN for Android and put in the same settings but with wap.cingular as the "APN". This got me a 3G icon next to my bars, and the "no internet connection" warning went away. Still not able to use the browser as it says to check my internet connection. However, I am able to get the News and Weather app to refresh. Very wierd.....Maybe I'll try putting wap.cingular and the APN name on the WebOS side....
__________________
Casio BOSS->Palm Pilot Professional->Palm M500->Treo 600-> Treo 680->Treo Pro (TP) ->HP Veer<->HP TP<->Pre3<>HP TP 4G
Conn 6H-> Bach 36->Bach 16L (high Bb plays really flat?(fixed thanks to **** Akright))-> New York Bach 6viii
Scalpel->Scope->Aesop->Hermes->Sidne->Davinci S>Davinci Si
jazzdoc is offline   Reply With Quote
Old 02/17/2013, 08:42 PM   #240 (permalink)
Member
 
jazzdoc's Avatar
 
Posts: 137
If I change the APN name on the Touchpad to wap.cingular on the WebOS side I am able to use my regular SIM from my Pre3. The tablet saw the gophone SIM and acted like it was working, but wouldn't load any web pages. Putting the gophone SIM in my pre3 shows an internet connection but fails to load internet pages as well. I guess my touchpad thinks it is a smartphone. I am hoping I can talk ATT into recognizing the IMEI as a tablet so I can get it onto a Datashare plan for $10 a month, not $35. I'm not planning to use it on ATT's network often, but having a connection without the reboot of the pre3 with freetether would be nice.
__________________
Casio BOSS->Palm Pilot Professional->Palm M500->Treo 600-> Treo 680->Treo Pro (TP) ->HP Veer<->HP TP<->Pre3<>HP TP 4G
Conn 6H-> Bach 36->Bach 16L (high Bb plays really flat?(fixed thanks to **** Akright))-> New York Bach 6viii
Scalpel->Scope->Aesop->Hermes->Sidne->Davinci S>Davinci Si
jazzdoc is offline   Reply With Quote
Reply

 

Thread Tools
Display Modes



 


Content Relevant URLs by vBSEO 3.6.0