Page 1 of 2 12 LastLast
Results 1 to 20 of 26
Like Tree1Likes
  1.    #1  
    Just wanted to make a quick note here about an important fix. The only showstopper bug I've run into on the touchpad running android is the "sleep of death". Basically, the pad goes to sleep and refuses to wake up, requiring a hard reboot (holding home/power for a long time etc).

    The problem seems to stem from cpu scaling. It appears this alpha build is having trouble kicking itself in the pants when it scales down to 192mhz during sleep. Picking up cpu master from the app catalog lets you kick up the minimum scaling speed a few hundred megahertz. Putting it at 384 minimum seems to solve the issue.

    It's not perfect obviously, since it'll drain a hair more power running at 384mhz, but it gets me past the only real showstopper bug I've encountered in android thus-far.
    New to webOS? Here's my definitive Get Started guide: http://forums.webosnation.com/hp-tou...ted-guide.html

    Want to dual boot Android on your Touchpad? Here's my guide: http://forums.webosnation.com/androi...ted-guide.html
    dignitary likes this.
  2. #2  
    smart thinking I know that older pre's had this issue in the past also
    In a world of droid, Pre does it better.

    Shouldn't we treat this world like the Garden of Eden and avoid the apple at all costs?
  3. #3  
    It's not the only problem

    The touchscreen unresponsive after sleep is also a problem. You have to triple tap the power button after the screen falls asleep to get it back.
  4. #4  
    tried this but still went into a coma.
  5. #5  
    The problem bugging me the most is my media always disappearing after a restart. CPU Boost was one of the first things I installed and I set the minimum at 245mhz, so no noticed the sleep problem yet.
  6. DeadVim's Avatar
    Posts
    184 Posts
    Global Posts
    268 Global Posts
    #6  
    Quote Originally Posted by DemonHighwayman View Post
    The problem bugging me the most is my media always disappearing after a restart. CPU Boost was one of the first things I installed and I set the minimum at 245mhz, so no noticed the sleep problem yet.
    I believe this is issue 69 (insert joke) on the issues list (marked as Accepted and Critical):
    Issue 69 - cmtouchpad - Folder deletion on reboot to android - Android port for HP Touchpad - Google Project Hosting

    There is a potential workaround referenced there, worth trying?
  7. #7  
    Fortunately, I have not had the media disappearing issue as I have gone back and forth between the OS's many times.
    I am however experiencing sleep of death even with setcpu set to 384mhz minimum. I will have to bump it up a bit and retry.
  8. Tedcas's Avatar
    Posts
    271 Posts
    Global Posts
    281 Global Posts
    #8  
    I have Setcpu to 432Mhz, and it works much better than when set to 384. I still had the SOD happen pretty often on the lower setting.
    My Palm history.
    Sony Clie', Treo 650, Treo700p, Centro, Treo 800w, Palm Pre, Touchpad
  9. #9  
    486 seems to be doing it for me.
  10. #10  
    245mhz still gave me SOD, so I will try 384mhz next and if that fails then I'll keep stepping it up until it's gone. However 486 is approaching nearly 50% of the standard full clock speed, I don't think it's going to help the battery issues any
  11. #11  
    changing the minimum speed hasnt really done anything for me. i still experience sleep death constantly. in fact, its happened even more often since i started changing the speeds.
  12. #12  
    This issue alone (don't want to keep bumping up the cpu speed as that'll drain the battery at a faster rate) along with the wifi and slow browser (perhaps due to wifi issue?) is keeping me from trying this. My fingers are itching like h3ll though..
  13.    #13  
    Mines been working comfortably at 384 for a few days now, no Sleep Of Death.

    YMMV of course - I'm sure this little bug will be ironed out soon.

    As for the battery woes, touchpad android already has some issues with power management when the device sleeps - they are working on fixing that. Means you wont see much of a difference between 192 or 400 minimums (I certainly havent). I just shut the pad down if I'm not going to use it for awhile, either by "reboot into webos" or by shutting it down entirely. It only takes about 20 seconds to get into android, so it's not too bad .
    New to webOS? Here's my definitive Get Started guide: http://forums.webosnation.com/hp-tou...ted-guide.html

    Want to dual boot Android on your Touchpad? Here's my guide: http://forums.webosnation.com/androi...ted-guide.html
  14. mrmars#CB's Avatar
    Posts
    19 Posts
    Global Posts
    35 Global Posts
    #14  
    This solved my SOD issues
  15. mrmars#CB's Avatar
    Posts
    19 Posts
    Global Posts
    35 Global Posts
    #15  
    Well that and turning off the lock screen
  16. #16  
    Quote Originally Posted by DemonHighwayman View Post
    The problem bugging me the most is my media always disappearing after a restart. CPU Boost was one of the first things I installed and I set the minimum at 245mhz, so no noticed the sleep problem yet.
    You need to put your media in a subfolder either from a native WebOS or Android folder. I had put my folders in the top level and they kept disappearing from storage. I then dropped them into the DCIM folder on the Touchpad side with subfolders and they now appear on both Android and WebOS after a reboot.

    Again, don't put anything important on the top level of the drive. Put it inside of a native subfolder.
  17. midas69's Avatar
    Posts
    134 Posts
    Global Posts
    151 Global Posts
    #17  
    I seem to be having good luck with SOD by turning off WiFi before I let it sleep. I've been doing it manually so far. Next I'll try setting it to turn off automatically when the screen goes off. But for now I've gone about 24 hours, in and out of sleep at least 20 times, and it hasn't hung yet.
  18. midas69's Avatar
    Posts
    134 Posts
    Global Posts
    151 Global Posts
    #18  
    Well I forgot to turn off the WiFi and sure enough, locked right up on me. Haven't had an issue though if I remember to turn it off.
  19. grifter77's Avatar
    Posts
    17 Posts
    Global Posts
    23 Global Posts
    #19  
    it has happened every time i use the unit the past few days. wifi on or off. cpu amped up or not getting sorta frustrating
  20. #20  
    I had my first SOD today. Thanks for the tip.
    I installed a Wi-Fi switch on the home screen. I'll post if it works.
Page 1 of 2 12 LastLast

Posting Permissions